blackrack

[WIP][1.2.2&1.3] Scatterer-atmospheric scattering (v0.0320-0.320b - 06/07/2017) water refraction

6526 posts in this topic

I just uploaded the new version for 1.2.2 and 1.3, enjoy.

27 people like this

Share this post


Link to post
Share on other sites
2 hours ago, blackheart612 said:

Well, stuff happened, partially due to playing other games, I'll likely update things on my own thread so to keep it on topic, got to play ArmA for a bit and beauty struck me, craved for heat haze from turbine exhausts. Immediately thought of implementing it, realizes it's post process and requires a plug-in, so I asked here. :P 

It doesn't HAVE to be post process. You could do it as normal mapped particles. You might have to do your own shader for that but it wouldn't require a plugin and would be less work

Share this post


Link to post
Share on other sites
2 minutes ago, blackrack said:

I just uploaded the new version for 1.2.2 and 1.3, enjoy.

Thanks!

Share this post


Link to post
Share on other sites

Posted (edited)

Looks like I can release the next version of Spectra then! :D

Edited by Avera9eJoe
4 people like this

Share this post


Link to post
Share on other sites

Thanks for the update!!

5 people like this

Share this post


Link to post
Share on other sites

Away from my gaming PC for a few days but really looking forward to trying out the update for this.
Always in awe of guys who give of their own time to make quality mods for others to enjoy - so genuine thanks for that!

Haven't seen confirmation in the thread or changelog - does this new update solve the sinking physics problem too?

Pure selfish on my part - I hate turning off your ocean effects when I know I have a 'splash down' mission.

Well done again - your work improves my Kerbal gaming experience immensely!

regards

Share this post


Link to post
Share on other sites

Posted (edited)

7 hours ago, evileye.x said:

I remember BahamutoD's video with engine heat haze

Yeah this one; 

[Edit] I'm not sure if you could contact Bahamutod (Paolo Encarnacion) in some other fashion, or if they'd be willing to part-with/donate what they had for that though, hopefully?

Edited by NoMrBond
1 person likes this

Share this post


Link to post
Share on other sites
12 minutes ago, NoMrBond said:

Yeah this one; 

[Edit] I'm not sure if you could contact Bahamutod (Paolo Encarnacion) in some other fashion, or if they'd be willing to part-with/donate what they had for that though, hopefully?

I remember he said there were issues with it, a version might be able to be done with Real Plume

Share this post


Link to post
Share on other sites
11 minutes ago, selfish_meme said:

I remember he said there were issues with it, a version might be able to be done with Real Plume

The passgrab filter grabpass shader was not working with the terrain but that was because something was getting accidentally zeroed in the shader and he'd managed to fix it (according to their last post anyway).

If KSP got updated to Unity 5.6.x its new particle system includes support for it (particles with normals etc), Roverdude and JPLRepo have been obliquely hinting at 5.6.x but until that happens, hopefuly Bahamutod and Blackrack can work something out (and it still works)?

Share this post


Link to post
Share on other sites

I just updated to new version (scatterer-0.0320b) and my sky turned very, very blue. Is there some way to tone this down? It's never been so bright in previous versions. Also, the ocean seems to be gone entirely. I'm running with RSSVE/RSS in case that makes a difference. Thank you.

Share this post


Link to post
Share on other sites

Posted (edited)

3 minutes ago, Observe said:

I just updated to new version (scatterer-0.0320b) and my sky turned very, very blue. Is there some way to tone this down? It's never been so bright in previous versions. Also, the ocean seems to be gone entirely. I'm running with RSSVE/RSS in case that makes a difference. Thank you.

The cfgs for RSSVE will need to be tweaked. The structure of the cfgs has changed. It's not an issue with scatterer, but not updated cfgs. You will probably have to wait for RSSVE to update

Edited by Galileo

Share this post


Link to post
Share on other sites
7 minutes ago, Galileo said:

The cfgs for RSSVE will need to be tweaked. The structure of the cfgs has changed. It's not an issue with scatterer, but not updated cfgs. You will probably have to wait for RSSVE to update

I see. Thank you for letting me know. I guess I'll revert to the older version with the "floating tile" issue. I might mess around with the RSSVE configs to see if anything looks obvious to my untrained eye.

Share this post


Link to post
Share on other sites

I'm getting some strange artifacting when sunlight reflects off of water below a craft. You'll have to view the image full-size to see it.

aStQ8pq.png

Share this post


Link to post
Share on other sites

I just released v0.7 of Spectra, adding a new scatterer feature that Blackrack added with this version - non-atmospheric glow compatibility. :) Thank you so much Blackrack!

3 people like this

Share this post


Link to post
Share on other sites
3 hours ago, Avera9eJoe said:

I just released v0.7 of Spectra, adding a new scatterer feature that Blackrack added with this version - non-atmospheric glow compatibility. :) Thank you so much Blackrack!

Wait, non-atmospheric glow compatibility? DOWNLOADING!

2 people like this

Share this post


Link to post
Share on other sites

Any hints as to what settings to mess with to fix this? Using the new scatterer with SVE 1.2.4.1 on mac. Or better to just wait for an SVE update @Galileo? (also, no idea what's up with the sun flare, looks like a dds-not-working-on-mac thing still)

Ctbai6w.png

Also in map view:

http://i.imgur.com/HZLiSGh.png

1 person likes this

Share this post


Link to post
Share on other sites

@Starwaster I did try with a unity glass shader. It looked like the pic I had shown there. With moduleenginesFX, it didn't work ingame, which is why I referred to scatterer's refraction here. Do you know any way to make that work?

Share this post


Link to post
Share on other sites
1 hour ago, Rodger said:

Any hints as to what settings to mess with to fix this? Using the new scatterer with SVE 1.2.4.1 on mac. Or better to just wait for an SVE update @Galileo? (also, no idea what's up with the sun flare, looks like a dds-not-working-on-mac thing still)

Ctbai6w.png

Also in map view:

http://i.imgur.com/HZLiSGh.png

Flip the alternate sqrt switch in the main menu settings.

2 people like this

Share this post


Link to post
Share on other sites

Thank you @blackrack for your hard and astonishing work on Scatterer. I can't play KSP without it any longer. It's the most essential eye-candy mod I can think of. Looking forward to start a 1.3 career in the near future. Now with Scatterer! Thanks again!

Share this post


Link to post
Share on other sites

Posted (edited)

To be honest, this is the first time that I can add scatterer and still have passable fps ...

Thank you.

 

Edit:

Does it have a reason that the lightning flashes are kinda dark blue?

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
2 hours ago, Gordon Dry said:

Does it have a reason that the lightning flashes are kinda dark blue?

Lightning flashes?

1 person likes this

Share this post


Link to post
Share on other sites

It's very difficult to catch a lightning with a screenshot, but here is one, to the right :
tP97bqa.png

Share this post


Link to post
Share on other sites
5 minutes ago, Gordon Dry said:

It's very difficult to catch a lightning with a screenshot, but here is one, to the right :
tP97bqa.png

I don't know what this but I don't do lightning flashes.

Share this post


Link to post
Share on other sites

Posted (edited)

btw I found exceptions with scatterer, perhaps something with

NullReferenceException: Object reference not set to an instance of an object
  at scatterer.RefractionCamera.OnPreCull () [0x00000] in <filename unknown>:0 

or

[Scatterer] Volumetric clouds error on planet: KerbinSystem.NullReferenceException: Object reference not set to an instance of an object
  at scatterer.SkyNode.mapEVEvolumetrics () [0x00000] in <filename unknown>:0 

Are these serious or just to be ignored?

 

Edit:

are these the lightnings? :D

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
2 hours ago, Galileo said:

Lightning flashes?

@Gordon Dry might mean this sort of thing. It's more a rapid change of brightness experienced with the EVE clouds. That example is from KSP 1.1.3, and I can see how these might get coloured with the current Scatterer and EVE cloud integration. Or it might be from PlanetShine if that's installed.

And the current water effects are just gorgeous! I could go swimming in that all day.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now