astecarmyman

Wat's your worst Ksp 1.0 glitch?

73 posts in this topic

Everytime I EVA a Kerbal from the Mk2 lander can and and let go of the hatch, game crashes. Every time.

Share this post


Link to post
Share on other sites

Launch Clamps like me. To the point of breaking physics and teleporting to me in an attempt to stay with me. And one time, they teleported right into the center of my ship. Which destroyed said ship.

Since then, I have never used launch clamps.

Share this post


Link to post
Share on other sites
I am the only person I think who actually plays completely vanilla stock KSP.

Nope there's me lol.

Share this post


Link to post
Share on other sites

Well half of my scene changes crash the game now. At least it loads faster in 1.0x. :P

Share this post


Link to post
Share on other sites

well... at last they resolved that bug of wings spontaneously exploding when coming back to KSC from a deep space/high orbital trip...

Share this post


Link to post
Share on other sites
here's mine

http://i.imgur.com/0C3NnMF.png

there was actually four solar systems at one point on screen. It was scary.

http://i.imgur.com/jPcYWJ6.png

Oh my! I think you may have a possible haunting on your hands, that looks like a ghost to me! :D

The only bug I have really had to struggle with, is the memory leak. I am now using DMagic's temperature gauge killer mod though, so it's not as bad.

Share this post


Link to post
Share on other sites

The most annoying one? I'd say it's when parts "steal" attachment nodes from one another in VAB/SPH and you have to delete and reassemble the whole section of the ship.

Share this post


Link to post
Share on other sites

The memory leaks from terrain that are still around.....

Share this post


Link to post
Share on other sites

The catastrophic results of trying to fit a science junior into a 2.5m service bay. Had a multi-module Duna ship disassemble itself because of this, stranding its crew in solar orbit. I have yet to retrieve them.

Share this post


Link to post
Share on other sites

0C3NnMF.png

N-Body physics confirmed

Share this post


Link to post
Share on other sites

My most hated glitch is that glitch that makes your ground bases spring up into the air and rip themselves apart when you switch to them. It happens when you use KAS pipes to attach all the different modules of your base together but I'm sure it can be replicated with stock parts. I haven't tried to make a ground base in 1.0 yet but I'm 99% sure the problem is still there, because when I docked my refuelling rover to my interplanetary ship, it sprung up a few centimetres.

I just wanna make cool ground bases, man.

Share this post


Link to post
Share on other sites

Before version 1.0 i hardly had any kraken encounters. But now. ... my ships freeze and lock up after i get out of time warp all the time. They won't turn and won't change in velocity when i fire up the engines, although the engines are spitting fire like trogdor the burninator. . It happens Like every 5-10 minutes flying in space (it's not a power issue ) . A restart "solves" the problem temporarily. Doing a grand tour was a great challenge before 1.0, but now it's even more challenging: the game is testing my patience skills while i restart the game.. XP

Share this post


Link to post
Share on other sites

My game constantly crashes on 1.0.2. Also my rockets flip. I should make a video on that

Share this post


Link to post
Share on other sites
My game constantly crashes on 1.0.2. Also my rockets flip. I should make a video on that

You should. I bet if I could see you launching a ship I could tell you why it's flipping.

The crashing, not so much. But if you upload a post-crash output_log.txt somewhere and post on the modded or unmodded (depending on how you play) help boards someone may be able to tell you why. I'm assuming you know about the heat gui memory leak and are not using it.

Share this post


Link to post
Share on other sites

On landings when climbing down the ladder, if I let go of the ladder close to the ground, sometimes my Kerbal ends up falling through the ground, disappearing, and dying. It's happened on Kerbin, Mun, and Minmus.

Share this post


Link to post
Share on other sites

The worst so far for me was when I was landing on laythe.

Somehow 3 of the 6 parachutes on my ship, all attached with symmetry, were inside the utility bay and refused to deploy. I had to open the service bay and manually deploy them.

Share this post


Link to post
Share on other sites

my payload just fell trough the fairings

Share this post


Link to post
Share on other sites

Early Game, two person rocket, Landed on Kerbin and I take Val and the other Kerbal out to do eva science stuff.

Recover the other Kerbal and leave Val and the Rocket to be recovered, except as I enter tracking, I can't find Val.

Recover the Rocket and check the Astronaut building and she is listed as K.I.A., uhm, I have "missing, not killed" on in this game.

In the save file, at the end of her mission log, she has the stuff from the mission, but it ends with # killed and then she entered another glitch mission, where she was killed too, the game really wanted her dead.

Share this post


Link to post
Share on other sites

[hc ipad] Just blew up th mun with a 10t landing stage?

Share this post


Link to post
Share on other sites

I would say my worst bug would be a type of kraken, suddenly while I'm in space the ship goes nuts and hits a planet and explodes.

Share this post


Link to post
Share on other sites

Crashes and memory leaks. It's absurd if compared to 0.90. I love THIS GAME. But SOMETIMES the development of the game is like 10 steps forward and 7 steps back.

Edited by includao

Share this post


Link to post
Share on other sites

this one is easy,

I cannot consistently launch a rocket into orbit.

even when I get one into orbit if I change the payload, fuel ect ect the drag/atmosphere effects makes it uncontrollable forcing me to custom design every rocket to every payload.

Share this post


Link to post
Share on other sites
#1 Constant Crashes from memory leaks :(. Had a plane saved in orbit that needed to be landed... (the last of my crew was on it) on re-entry game would fall on its face every single time :T

#2 Imaginary Terrain landing on Bop (or maybe it was Pol?) ... was approaching the ground, a couple KM from the ground WHAM Ship explodes in mid air from a collision with invisible terrain. Reloaded from an F5, WhAM roughly the same place. 3rd try, descended REALLY slow and managed to land.

#3 VAB went bonkers. Designed a fancy dancy rocket (quite a lot of time in it) did some undo/redo combination... couldnt click on parts properly... hit save on the ship - all buttons greyed out :( Closed KSP, loaded my ship and it was buggy as hell(wouldnt let me click anything, shows all parts out of the staging on the right (even though they were solid in the VAB), had to start from scratch again.

Ran into so many more glitches, unbalances etc... been playing KSP since almost the very start, never seen it this buggy... I hope squad has a good vacation and comes back going bonkers on polishing the game for a month or 3....

I haven't had memory related crashes, but I play on linux and things are more stable here memory wise. I did had #3 happen to me in a 0.90 save, I had to revert to an older save as I was having many different glitches occurring after the inital borking.

Share this post


Link to post
Share on other sites

Probably the two worst bugs I've encountered are nullrefs in the VAB, and one weird bug I've never encountered before. Sometimes, without rhyme or reason, certain parts will become fixed points in space. I first discovered this with my Ike biome hopper. Whenever I timewarped, the probe core would become locked in place relative to the surface (while still somehow showing non-zero surface velocity??). Unfortunately, I still had a contract to complete, so I spent close to an hour in non-timewarped suborbital hops. Really makes you appreciate how long spaceflight takes.

Share this post


Link to post
Share on other sites

I was playing in 1.0.2 and trying to dock, when suddenly when switching out of map view, most of my ship suddenly exploded. I couldn't see kerbin anymore. I wasn't moving either. After switching back to map view, I realized the solar system no longer existed. There were some random parts nearby floating in space (that it didn't say was debree in the map view) that I haven't even unlocked with science with (ex. gigantor solar panel, the big ladders, etc)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now