JPLRepo

[1.3] AmpYear Main & Reserve Power Manager (v1.4.9.0) 21st June 2017

447 posts in this topic

Quote

Could be done, but the trick here is, is it supposed to take into account current EC production (Solar panels, etc). If so, that's a little difficult to predict given it will change depending on the vessel situation.
Or it could just show you a time to empty based on no EC production.

just time to empty based on current inputs would be best. that way, in the VAB, the result of adding/removing solar panels etc can be monitored easily, and in orbit, a rough estimation of current capacity would be available.

Quote

Is this calculation based on parameters you enter? such as altitude and velocity? Or is to to assume a rough circular orbit velocity based on altitude that you enter?

a simple circular orbit estimation would be really useful for figuring out how many batteries to load onto satellites.

Share this post


Link to post
Share on other sites
3 hours ago, speedwaystar said:

just time to empty based on current inputs would be best. that way, in the VAB, the result of adding/removing solar panels etc can be monitored easily, and in orbit, a rough estimation of current capacity would be available.

a simple circular orbit estimation would be really useful for figuring out how many batteries to load onto satellites.

I have a dev version that I am currently testing with some changes in line with this.

I have added radio buttons against the PartsList that allows you to include (button on) or exclude (button off) each part from power calculations in the VAB. This way you can customise the readouts for power production and consumption in the VAB. Although these are also available in flight, they don't do anything. In flight the readouts show you ACTUAL power production and consumption.

I have also added a Dark-Side Transit GUI window that allows you to:-

Select a celestial body (works with stock planets as well as any planet mod like Kopernicus, etc), then you enter an orbit (assumes this is roughly circular) in Kms and it will show you the dark-side transit time and amount of EC required to complete the transit. This EC calc also takes into account what parts you have included/excluded in the PartsList in the VAB. This window is also available in flight but it uses the ACTUAL power consumption. This EC calc does NOT factor in any parts that PRODUCE EC. But I am thinking of just adding a tweak to that to include anything that produces EC but exclude Solar Panels (because you will be on the dark-side). 

What do people think?

Share this post


Link to post
Share on other sites
8 hours ago, JPLRepo said:

What do people think?

sounds fantastic.

oh, and as for the timewarp issue when on reserve power, i've confirmed that it kicks in whenever timewarp rises to 50x and reserve power is active. so, hit 50x, get warning, timewarp drops to 1x, rises back to 50x (because warp to destination is still active), another warning, drops back to 1x, rinse repeat.

the 18 power draw for the Mk1-2 cockpit in the VAB seems to be based on average of XYZ torgue = 15 x ElectricCharge 1.2/sec. since this is a worst-case scenario i'd be inclined to either ignore it (since reaction wheels aren't usually running), or multiply it by some notional percentage, say 0.05 or less.

Edited by speedwaystar

Share this post


Link to post
Share on other sites
1 hour ago, speedwaystar said:

sounds fantastic.

oh, and as for the timewarp issue when on reserve power, i've confirmed that it kicks in whenever timewarp rises to 50x and reserve power is active. so, hit 50x, get warning, timewarp drops to 1x, rises back to 50x (because warp to destination is still active), another warning, drops back to 1x, rinse repeat.

the 18 power draw for the Mk1-2 cockpit in the VAB seems to be based on average of XYZ torgue = 15 x ElectricCharge 1.2/sec. since this is a worst-case scenario i'd be inclined to either ignore it (since reaction wheels aren't usually running), or multiply it by some notional percentage, say 0.05 or less.

Oh ok, I forgot, when you are on reserve power yes anything above 50x forces you out of timewarp. I can deactivate that piece of code. Given you get the warning when you drop below x% mains anyway.

Yes - with the new changes I have ready you can just de-select the cockpit or turn off the reaction wheels in the VAB and it will not include this figure.

Spoiler Pics:

Spoiler

Z9Wm9xk.png

7W7E6Qb.png

 

 

Edited by JPLRepo

Share this post


Link to post
Share on other sites

Right I'm just going to release what I have got tonight once I finish my dinner (next couple of hours). It working well far as I can tell. Stay tuned.

1 person likes this

Share this post


Link to post
Share on other sites

Ok V1.1.0.0 is out. See the OP for links and details. I'll do new Imgur library updates tomorrow when I have more time.
Enjoy!

 

Edited by JPLRepo
1 person likes this

Share this post


Link to post
Share on other sites

excellent work. this is really an invaluable piece of kit--i wouldn't leave kerbin without it!

two things i've noticed. first, blizzy's toolbar integration seems to have stopped working since the update. also, ModuleScienceLab parts aren't counted in power drain either when running or at design stage in the VAB.

again, great job with the update.

Share this post


Link to post
Share on other sites
48 minutes ago, speedwaystar said:

excellent work. this is really an invaluable piece of kit--i wouldn't leave kerbin without it!

two things i've noticed. first, blizzy's toolbar integration seems to have stopped working since the update. also, ModuleScienceLab parts aren't counted in power drain either when running or at design stage in the VAB.

again, great job with the update.

Thanks I'll check it out and report back.

 

EDIT: Blizzy toolbar works fine for me. If you switch between stock applauncher and blizzy you should restart KSP.
Exactly what issue are you seeing?
As for the ModuleScienceLab - yep there is a bug there. I'll fix that in the next point release.

Edited by JPLRepo

Share this post


Link to post
Share on other sites
7 hours ago, JPLRepo said:

EDIT: Blizzy toolbar works fine for me. If you switch between stock applauncher and blizzy you should restart KSP.
Exactly what issue are you seeing?

Blizzy's Toolbar->Configure Visible Buttons->AmpYear isn't in the list anymore.

Share this post


Link to post
Share on other sites
1 hour ago, speedwaystar said:

Blizzy's Toolbar->Configure Visible Buttons->AmpYear isn't in the list anymore.

It is working fine for me.
In the AmpYear settings menu do you have "Use Application Launcher" button OFF? Once it is OFF go back to the load game menu and re-load you game. You should be able to add the AY button to blizzy toolbar. If this doesn't work I'll need a log to help determine your problem.

iAucbJ0.png

 

Edited by JPLRepo

Share this post


Link to post
Share on other sites

 

9 hours ago, JPLRepo said:

In the AmpYear settings menu do you have "Use Application Launcher" button OFF?

okay, i completely forgot about the space center-only settings menu. d'oh! all good now.

Share this post


Link to post
Share on other sites
14 minutes ago, speedwaystar said:

 

okay, i completely forgot about the space center-only settings menu. d'oh! all good now.

No problem.
I've identified a work-around fix for the Mobile Processing Lab (it's buggy as ... in stock) to know what EC it is using and when. 
So I have it correctly identifying when you are running research (turning data into science) and when you are processing science reports into data in flight.
But it's one of those parts where in the VAB, it's just the max amount.

Edited by JPLRepo

Share this post


Link to post
Share on other sites

bug fix version 1.1.1 released to Fix to Mobile Process Lab EC monitoring. Now correctly identifies when science is being sent to the lab to be converted into data (which uses EC) and when data is being converted into science (which uses EC). See OP for links.

1 person likes this

Share this post


Link to post
Share on other sites

I just started using this mod and the "reserve" power has saved my  bacon already, is there an audible or visual alert that shows me where my power is at?  For example can , the "AY" be green / yellow / red , etc.

Share this post


Link to post
Share on other sites

Well, me again - I think, I came across a bug?  I don't have a screen show or anything, but I had a ship that was in and our of electrical charge and I was passing the energy around between reserve and main.  When red text appeared and said that the Reserve Power was depleted, when in fact all the reserves were recharged.

I was unable to utilize the reserves after that.

Edited by gamerscircle

Share this post


Link to post
Share on other sites
2 hours ago, gamerscircle said:

Well, me again - I think, I came across a bug?  I don't have a screen show or anything, but I had a ship that was in and our of electrical charge and I was passing the energy around between reserve and main.  When red text appeared and said that the Reserve Power was depleted, when in fact all the reserves were recharged.

I was unable to utilize the reserves after that.

"Reserve Power Depleted" will be displayed when vessel has no Reserve power.
This is updated every frame of the game - so it would be very accurate.

Not sure exactly what you mean by "I was unable to utilize the reserves after that."? do you mean that you couldn't transfer reserve into main power? That reserve wouldn't re-charge? Unable to use the reserve power indicates to me that some other unexpected error has occurred. But without a log file, there is not a lot I can do in the way of support.

As per the OP:
For support please ensure you are following these instructions.
NO LOG = NO SUPPORT.
I do not support 64bit Windows and OSX work-arounds.

21 hours ago, gamerscircle said:

I just started using this mod and the "reserve" power has saved my  bacon already, is there an audible or visual alert that shows me where my power is at?  For example can , the "AY" be green / yellow / red , etc.

The only current indication is to have the AmpYear GUI open which indicates power levels and is colour coded.
It is not possible to do this with the stock application launcher (buttons top right). It can be done if using Blizzy Toolbar (but currently AmpYear does not do this).
 

Edited by JPLRepo

Share this post


Link to post
Share on other sites

The ship was fully charge and I was attempting to transfer main to reserve and it would not allow it.  If I come across another bug, I will make sure to get a screen shot and support logs.

As for "indicators" another mod that I liked and used was Fusebox and it was a nice convince to see a color coded indicator.  I do really like the idea of 'reserve power', thank you for the reply.

Share this post


Link to post
Share on other sites
20 hours ago, gamerscircle said:

Well, me again - I think, I came across a bug?  I don't have a screen show or anything, but I had a ship that was in and our of electrical charge and I was passing the energy around between reserve and main.  When red text appeared and said that the Reserve Power was depleted, when in fact all the reserves were recharged.

I was unable to utilize the reserves after that.

"Reserve Power Depleted" will be displayed when vessel has no Reserve power.
This is updated every frame of the game - so it would be very accurate.

Given you then said you could not utilize reserves after that - what do you mean? that you couldn't transfer them into main power? That to me indicates some other unexpected error has occurred. But without a log file, there is not a lot I can do in the way of support.

As per the OP:

12 hours ago, gamerscircle said:

The ship was fully charge and I was attempting to transfer main to reserve and it would not allow it.  If I come across another bug, I will make sure to get a screen shot and support logs.

As for "indicators" another mod that I liked and used was Fusebox and it was a nice convince to see a color coded indicator.  I do really like the idea of 'reserve power', thank you for the reply.

Thanks. Not had this issue reported before. Would need a log to track any potential bug down.

Yes, as I had indicated before this is possible using Blizzy's Toolbar but not the stock app launcher buttons Actually this can be done, I will investigate. AmpYear doesn't do this as the small GUI (which can be kept open) is colour coded and there is a warning pop-up window when the critical low EC amount is reached.

Edited by JPLRepo

Share this post


Link to post
Share on other sites

Hello, and thank you for an awesome mod! I LOVE IT! Can`t live without it, and the KabinKraziness is hilarious. 

You said in the text that if I had any other mods that I use and would like this to work with I could drop you a line... Well here is the line:

I would love if AmpYear could calculate EC produced by "KSP Interstellar Extended " nuclear rockets and fusion generators. I`m using the "WB-MF Micro Fusion" Reactor and the "Closed Cycle Gas Core Engine" on my current mission. I got 3 screenshots (I think, I`ve never used DropBox sharing before) (IMG1), (IMG2), (IMG3 ) to show you my problem.

On another note, When I`m in the VAB doing dark-side calculations AmpYear does not refresh. I have to add the part and exit/enter VAB to get the numbers.

Share this post


Link to post
Share on other sites

it is indeed a tremendously useful mod. there are couple of power sources it doesn't take into account, including (from memory) nuclear engines with always on generators, and some others which i've come across. i'll make a note to report them as they show up in future.

EDIT: here's one.

392lncQ.png

the FC-1 Monop Fuel Cell (from RLA Stockalike) is generating power (Power %: on the right is actually ticking up), but Power Prod: shows 0.000 and the Fuel Cell isn't listed in the AmpYear Parts List.

Edited by speedwaystar

Share this post


Link to post
Share on other sites

 

On 19/01/2016 at 0:26 AM, wadena said:

Hello, and thank you for an awesome mod! I LOVE IT! Can`t live without it, and the KabinKraziness is hilarious. 

You said in the text that if I had any other mods that I use and would like this to work with I could drop you a line... Well here is the line:

I would love if AmpYear could calculate EC produced by "KSP Interstellar Extended " nuclear rockets and fusion generators. I`m using the "WB-MF Micro Fusion" Reactor and the "Closed Cycle Gas Core Engine" on my current mission. I got 3 screenshots (I think, I`ve never used DropBox sharing before) (IMG1), (IMG2), (IMG3 ) to show you my problem.

On another note, When I`m in the VAB doing dark-side calculations AmpYear does not refresh. I have to add the part and exit/enter VAB to get the numbers.

Thanks, glad people are finding it as useful as I do.
I used to support KSP Interstellar before it stopped being updated by Fractal then I dropped it. But given there is now Interstellar Extended I will look into adding support again.
As for your dark-side calcs in the VAB. Works fine for me. To note: Dark-side calc only takes into account power consumption parts (not any power production parts) which is a conservative approach I know. I might get around to changing that so it includes them all except solar panels. 
EG (pics)

Spoiler

dark-side calc with dish antenna not selected.. (and when I add it the calc updates as well)

fNBKoXJ.png

when I select the dish antenna the dark-side calc updates, and when I remove it, etc.

xER4DTl.png

 

So if you are still having this issue, can you check you are using the latest version and the above. I would need a log and what parts you are adding that are not updating the calcs.

Edited by JPLRepo

Share this post


Link to post
Share on other sites
2 hours ago, speedwaystar said:


It is indeed a tremendously useful mod. there are couple of power sources it doesn't take into account, including (from memory) nuclear engines with always on generators, and some others which i've come across. i'll make a note to report them as they show up in future.

EDIT: here's one.

392lncQ.png

the FC-1 Monop Fuel Cell (from RLA Stockalike) is generating power (Power %: on the right is actually ticking up), but Power Prod: shows 0.000 and the Fuel Cell isn't listed in the AmpYear Parts List.

Hmmm, I assume this pic is from flight mode?
Strange thing is - It's working just fine for me. In the VAB it is correctly showing "Power Prod" and in flight it correctly does it as well.. Once you Turn it on.... See previous post pics of it in the editor. And here is one in flight mode.
 

Spoiler

VQq8VU4.png


You have got it turned on? As this part is using ModuleResourceConverter AmpYear handles any part using that module, but of course the module has an on/off switch which AmpYear looks at as well.

On 19/01/2016 at 0:26 AM, wadena said:

 

Share this post


Link to post
Share on other sites
15 hours ago, JPLRepo said:

 

Thanks, glad people are finding it as useful as I do.
I used to support KSP Interstellar before it stopped being updated by Fractal then I dropped it. But given there is now Interstellar Extended I will look into adding support again.
As for your dark-side calcs in the VAB. Works fine for me. To note: Dark-side calc only takes into account power consumption parts (not any power production parts) which is a conservative approach I know. I might get around to changing that so it includes them all except solar panels. 
EG (pics)

  Hide contents

dark-side calc with dish antenna not selected.. (and when I add it the calc updates as well)

fNBKoXJ.png

when I select the dish antenna the dark-side calc updates, and when I remove it, etc.

xER4DTl.png

 

 

So if you are still having this issue, can you check you are using the latest version and the above. I would need a log and what parts you are adding that are not updating the calcs.

:-) I hope you add support for Interstellar Extended. AmYear is extremely useful for both long and short trips, and it adds a whole new level of realism (with KabinKraraziness it got even better). to add parts to see how many or how big of a fuel cell is needed for the numbers to change from red to white :-)

 

Share this post


Link to post
Share on other sites

Update; 

Something happened to the text in my previous post..

Point was, don`t sweat it, it works good enough, but if you someday get around to add calculations for producing parts that would be awesome. It would make it a lot easier to add parts and just keep and eye on the red numbers until they change to white.

1 person likes this

Share this post


Link to post
Share on other sites
21 hours ago, wadena said:

Update; 

Something happened to the text in my previous post..

Point was, don`t sweat it, it works good enough, but if you someday get around to add calculations for producing parts that would be awesome. It would make it a lot easier to add parts and just keep and eye on the red numbers until they change to white.

@wadena - If you want to give me a list of the Interstellar Extended parts you want supported that would be good. There are just so many parts in that mod.
Also, Unlikely I can support any parts in that mod that use MegaJoules instead of ElectricCharge (AmpYear only supports ElectricCharge and ReservePower resources).
Megajoules just makes it way more complicated.

Also for the Dark-Side calcs - I'm working on something like this:
7DJZJPI.png

So now in the Dark-Side calcs window it shows EC required for Dark-Side Transit = Power Consumer Parts that you have selected in the Parts List
EC produced for Dark-Side Transit = Power Production Parts you have selected in the Parts List (will also include solar panels unless you de-select them, I'm thinking I could automatically de-select Solar Panels if you have the Dark-Side Window Open, or you have to do it manually :- Looking for people's thoughts here
The Last line will show Surplus or Deficit EC required for the Dark-Side Transit depending on the difference between your producer parts and consumer parts you have selected.

@speedwaystar - Is your RLA stockalike fuel cell working? Seems to work for me?

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now