Shadowmage

[WIP][1.3] SSTULabs - Low Part Count Solutions (Orbiters, Landers, Lifters) - Dev Thread [02-05-17]

6576 posts in this topic

Back from Italy, and looking forward to mess around with SSTU again!

Reading over the past several pages, things are looking good, indeed, great (sorry about wheel hell).

The comment above about a parachute model has one possible utility I can see, and that would be a part to add atmospheric capability to some sorts of landers in a way that doesn't look as "kerbal" as many solutions. Past that, there's not a lot of utility for it. Adding an SSTU part for use with stock parts seems sorta pointless to me, I'm at the point I practically don't use stock parts---they are so profoundly inferior in every way to SSTU.

Share this post


Link to post
Share on other sites

@Shadowmage Just FYI, from the 1.1.3 changelog, because I know we discussed this:

* Fixed UI_ChooseOption - onFieldChanged being called even when the field value hasn't changed.

Not that you will actually be able to remove much code because of it, but I think it's always nice to be able to clean up these things.

2 people like this

Share this post


Link to post
Share on other sites

I will -try- and get an updated build pushed out tomorrow for 1.1.3 (if needed; testing shortly).

Sadly I had a bit of misfortune today with my vehicle deciding to... take an unscheduled break.  So has been a bit stressful (and busy) trying to sort out getting it to the shop and locating interim transportation.  Looking like tomorrow will be another busy/hectic day getting the rest of it sorted out and (hopefully) getting my car back.

Also, will be going out of town on a camping trip this weekend (thurs-sun), so will be unavailable during that time.  Yeah, excellent timing with the car breaking down right before a trip... meh.  Suppose that is better than -during- the trip.

 

So anyhow, I will -try- and get an updated SSTU build available if I can before I leave; else it will have to wait until sun/monday after I return.

Share this post


Link to post
Share on other sites

Well, so far, so good.  The plugin doesn't seem to be broken much/at all from the 1.1.3 update; so it looks like I might not have to do any updating/etc.  At least, everything that I've tested seems to work so far, including loading my career save up that uses SSTU parts; nothing broke or exploded.... the only thing missing seemed to be MechJeb (which seems to have disabled itself/not loaded at all; unsurprising considering it is the 1.1.2 version...)

If anyone runs into anything that seems to be broken by this update, please let me know and I'll work on getting a fix in place before I leave if possible.

6 people like this

Share this post


Link to post
Share on other sites

So if I set the interstage to auto decouple, it is supposed to do that after all fuel in the solid motors has burned out right?  For me it seems to decouple while there is still at least a tiny bit of fuel left, causing it to jet forward and crash into the stage above it :(

Edited by Agathorn

Share this post


Link to post
Share on other sites
6 minutes ago, Agathorn said:

So if I set the interstage to auto decouple, it is supposed to do that after all fuel in the solid motors has burned out right?  For me it seems to decouple while there is still at least a tiny bit of fuel left, causing it to jet forward and crash into the stage above it :(

That seems to be specific to the RO configs.  I haven't had time to investigate, but my best guess is that something changes it to use one of the RO solid thrust profiles, and the code deciding when to detach isn't aware that thrust could vary over the course of the burn.  Probably, the ejection delay just needs to be increased.  There's a similar issue with the launch abort systems where they will detach immediately but not gain enough thrust to actually separate for a couple of seconds.  Not sure what the solution to that one is, other than just removing the thrust curve.

Share this post


Link to post
Share on other sites
13 minutes ago, blowfish said:

That seems to be specific to the RO configs.  I haven't had time to investigate, but my best guess is that something changes it to use one of the RO solid thrust profiles, and the code deciding when to detach isn't aware that thrust could vary over the course of the burn.  Probably, the ejection delay just needs to be increased.  There's a similar issue with the launch abort systems where they will detach immediately but not gain enough thrust to actually separate for a couple of seconds.  Not sure what the solution to that one is, other than just removing the thrust curve.

Ah ok fair enough.  I didn't even consider that our configs could be causing that, as I just assumed the code released when it detected no fuel but I guess it is more time based.

For now I can decouple manually.  I'll chat with you more in IRC.  Thanks!

Share this post


Link to post
Share on other sites
9 hours ago, blowfish said:

That seems to be specific to the RO configs.  I haven't had time to investigate, but my best guess is that something changes it to use one of the RO solid thrust profiles, and the code deciding when to detach isn't aware that thrust could vary over the course of the burn.  Probably, the ejection delay just needs to be increased.  There's a similar issue with the launch abort systems where they will detach immediately but not gain enough thrust to actually separate for a couple of seconds.  Not sure what the solution to that one is, other than just removing the thrust curve.

I remember leaving these with their stock fuel specifically to avoid problems...

Share this post


Link to post
Share on other sites

So far, I haven't ran into any immediate problems with the current version of SSTU on 1.1.3. Seems like the plug-in coding is rock solid. That's with 60 mods running and not all of them are up to date, yet. 

But, as I have the floor. I would like to pose some questions about some requests I'd like some answers to, if possible.

1. The new truss parts: Is there any way to make them solid, without the fairings or a lot of heavy duty work to get them that way?

2. Truss part ends: I've been piecing together vehicles comprised of these truss parts and had a startling revelation that there is no way to connect two separate for anything bigger than 2.5 meters. Luckily, the IXS warpship mod does come with 3.75 meter docking port and Space-Y has 3.75 to 5 meter docking ports (I think KW has one too at 3.75 meters). Which work okay, but since we are going for lower part count, how difficult would it be to incorporate a docking/connector port on the ends of these, like the fuel tanks can add mounts and noses to the tank ends?  

 

1 person likes this

Share this post


Link to post
Share on other sites

Wondering where this is coming from, in VAB/SPH I'm getting parts which have no icon, no object when placed loads of them (will take a screen shot in a bit) all starting with SSTU and having a long description??

Share this post


Link to post
Share on other sites

Does this mod replace the Stock nuclear engine? If so, can you remove that function? It's breaking many of my old craft.

Share this post


Link to post
Share on other sites
2 hours ago, Brainpop14 said:

Does this mod replace the Stock nuclear engine? If so, can you remove that function? It's breaking many of my old craft.

There's a patches folder where you can delete that patch. go to GameData > SSTU > Patches and delete "StockParts.cfg"

Edited by StickyScissors
1 person likes this

Share this post


Link to post
Share on other sites

@Shadowmage Just wanted to drop by and say thanks for making this mod.  I've been messing with it in my RO install, and its resulted in me making a few launchers/stages where I've kinda just stood back and admired how they look.  The functionality is awesome and this was clearly very well thought out.  Thanks! 

Share this post


Link to post
Share on other sites

Hope your camping trip went well. Where'd you go?

1 person likes this

Share this post


Link to post
Share on other sites

Quick something i noticed today about the Soyuz crew pods; both the ascent and descent pods have a crew capacity of 2 in this mod, but in real life they can both carry 3.

If this is intentional, please ignore :)

Share this post


Link to post
Share on other sites

Right now SSTU Soyuz use stock mk2 iva. So you can edit its config to have 3. Shadowmage made it 2 for balance purpose. Note that some soyuz version are limited to to IRL as well.

Share this post


Link to post
Share on other sites
On Sunday, June 26, 2016 at 9:41 PM, Brainpop14 said:

Does this mod replace the Stock nuclear engine? If so, can you remove that function? It's breaking many of my old craft.

Yes;  however, you bring up a good point.  I will change the patch to 'hide' the stock engine rather than delete it entirely; in this manner old craft files/existing vessels will still load with the stock NRV engines, but they will be unaccessible from the editor (being replaced by the clusterable version).

 

13 hours ago, jdub3350 said:

@Shadowmage Just wanted to drop by and say thanks for making this mod.  I've been messing with it in my RO install, and its resulted in me making a few launchers/stages where I've kinda just stood back and admired how they look.  The functionality is awesome and this was clearly very well thought out.  Thanks! 

You're welcome, glad you are enjoying it :)

 

11 hours ago, tater said:

Hope your camping trip went well. Where'd you go?

Indeed, aside from the car breaking down right beforehand.  Hyalite Canyon, in Bozeman MT, was the destination.  Little camp-site at the top of the mountain we've been working on for about 12 years now, slowly fixing it up.  We like to bring chainsaws and other tools, and have been building outdoors wood-log furniture for it for awhile; tables, benches.. more tables...  Beautiful place, though gets a bit chilly at night even in the middle of the summer; think we say about 20f one of the nights we were up there (thankfully that was only in the late night, early morning).  Ohh.. and bears.  There are bears up here... big ones, and not too-far-away.  Gotta be careful with your foodstuffs so as to not attract them, and gotta keep your bear mace and/or large caliber weapons handy.

Overall it was a good trip; lots of good food was eaten, lots of beer/drinks were consumed, only a few minor injuries incurred, and only got rained on for a few hours out of the 3 days being up there.  I'll see if I have any pictures from last year (didn't take any this time), as it really is a very beautiful place.

 

3 hours ago, Qwarkk said:

Quick something i noticed today about the Soyuz crew pods; both the ascent and descent pods have a crew capacity of 2 in this mod, but in real life they can both carry 3.

If this is intentional, please ignore :)

 

37 minutes ago, RedParadize said:

Right now SSTU Soyuz use stock mk2 iva. So you can edit its config to have 3. Shadowmage made it 2 for balance purpose. Note that some soyuz version are limited to to IRL as well.

Indeed.  It is mostly limited to two crew due to size; there is no way three giant kerbal heads would fit in those things (they barely would fit through the extra-large hatch as-is).  It also makes a nice 2-crew early-career mode pod system; as in shortly after you have the tech/skills to make it to orbit with some slapped-together-stock-stuff, the SC-A stuff should unlock and give you something less... cludgy... to take to orbit.

 

On Friday, June 24, 2016 at 9:54 AM, blowfish said:

That seems to be specific to the RO configs.  I haven't had time to investigate, but my best guess is that something changes it to use one of the RO solid thrust profiles, and the code deciding when to detach isn't aware that thrust could vary over the course of the burn.  Probably, the ejection delay just needs to be increased.  There's a similar issue with the launch abort systems where they will detach immediately but not gain enough thrust to actually separate for a couple of seconds.  Not sure what the solution to that one is, other than just removing the thrust curve.

 

On Friday, June 24, 2016 at 7:21 PM, JoseEduardo said:

I remember leaving these with their stock fuel specifically to avoid problems...

Hmm... likely the plugin is coded specifically to look for 'SolidFuel'.  I'll take a look at it and expose that to config (if it isn't already... lots of things are config'd but merely undocumented unless you read through the code).  Should be solvable either way with minimal changes.

 

 

On Saturday, June 25, 2016 at 0:06 AM, ComatoseJedi said:

So far, I haven't ran into any immediate problems with the current version of SSTU on 1.1.3. Seems like the plug-in coding is rock solid. That's with 60 mods running and not all of them are up to date, yet. 

But, as I have the floor. I would like to pose some questions about some requests I'd like some answers to, if possible.

1. The new truss parts: Is there any way to make them solid, without the fairings or a lot of heavy duty work to get them that way?

2. Truss part ends: I've been piecing together vehicles comprised of these truss parts and had a startling revelation that there is no way to connect two separate for anything bigger than 2.5 meters. Luckily, the IXS warpship mod does come with 3.75 meter docking port and Space-Y has 3.75 to 5 meter docking ports (I think KW has one too at 3.75 meters). Which work okay, but since we are going for lower part count, how difficult would it be to incorporate a docking/connector port on the ends of these, like the fuel tanks can add mounts and noses to the tank ends?  

 

1.) Are you referring to solid cargo bays, or a full wrap-around truss part?

The saddle-trusses are the first of the 'cargo bay' parts, -not- structural parts.  As such, a full-wrap-around-variant would not fit/work as a cargo bay.  I have _not_ started working on any structural parts yet; those are still quite a ways off.  Solid-sided cargo bays are also planned, but are also a ways out.  How far?  No clue, gotta finish the wheel stuff first.


2.) Sorry, but no.  Docking ports require MODULEs in order to function.  Stock code does not support MODULE switching at runtime, so this is not something that I can do.  Adapters/end-caps/simple structural bits, sure.  Anything that requires a MODULE to function... nope (hmm... maybe I should start bugging NK about this now, try and get such things supported in 1.2....).

I -do- have a resizable 'welding' docking port planned (and the plugin-code 3/4 written and already working for it)... but alas, as with structural parts and other station parts... gotta finish up that wheel stuff first.

 

2 people like this

Share this post


Link to post
Share on other sites
22 minutes ago, Shadowmage said:

Beautiful place, though gets a bit chilly at night even in the middle of the summer; think we say about 20f one of the nights we were up there

how? how do you guys handle this b...nonsense? we're freezing here with +16°C (60°F)

Share this post


Link to post
Share on other sites
15 minutes ago, JoseEduardo said:

how? how do you guys handle this b...nonsense? we're freezing here with +16°C (60°F)

:)  A big fire, thick coats, lots of blankets and 0f/good sleeping bags.

It gets down to -25f during the winter here; so comparatively, 20f is a nice warm day (during the winter).  Basically... you just come prepared for it; we know it gets cold up there at night.  It does warm up during the day (60-80f depending on cloud cover), and generally doesn't get too cold until fairly late in the evening... so you are in bed/asleep for the worst of the cold.  Really you only feel it if you need to get up/go out in the middle of the night for anything... in which case you do it fast and get back into your bedroll ASAP.

3 people like this

Share this post


Link to post
Share on other sites
1 hour ago, Shadowmage said:

1.) Are you referring to solid cargo bays, or a full wrap-around truss part?

The saddle-trusses are the first of the 'cargo bay' parts, -not- structural parts.  As such, a full-wrap-around-variant would not fit/work as a cargo bay.  I have _not_ started working on any structural parts yet; those are still quite a ways off.  Solid-sided cargo bays are also planned, but are also a ways out.  How far?  No clue, gotta finish the wheel stuff first.


2.) Sorry, but no.  Docking ports require MODULEs in order to function.  Stock code does not support MODULE switching at runtime, so this is not something that I can do.  Adapters/end-caps/simple structural bits, sure.  Anything that requires a MODULE to function... nope (hmm... maybe I should start bugging NK about this now, try and get such things supported in 1.2....).

I -do- have a resizable 'welding' docking port planned (and the plugin-code 3/4 written and already working for it)... but alas, as with structural parts and other station parts... gotta finish up that wheel stuff first.

1. Yes, I was referring to making a structural part for space stations. SXT mod has a truss similar to this, but unfortunately it doesn't stretch to any length and without tweakscale, you can't resize it. A solid one of these "cargo truss" would be excellent building material for space stations. And if you've already addressed this as part of the station parts on the Git that you plan on making, forgive my ignorance on this matter and proceed to "These are not the droids you are looking for". 

2. That sucks, but it's totally understandable why that is. But, there are plenty of docking/connector ports that I can work with to accomplish this, thanks for the input on that. I do remember you were working on such code, but those wheels come first, by all means. This was just an observation that I noticed and was looking through the eyes of a mod user who wouldn't be using other mods, other than yours, to utilize the cargo truss. 

3. Glad to have you back and I hope you enjoyed your camping trip. I, too, enjoy the great outdoors as often as I can get around to doing so. But, since it's summer here in Georgia and the eastern diamondback rattlesnake is prolific in these parts, I will have to wait until the end of fall/beginning of winter to hit the ole campsite. In anycase, I hope you are rested and doing well. I did, however, go to Kennedy Space Center for my birthday/father's day present. That truly was better than any camping trip.... almost :wink:  

Share this post


Link to post
Share on other sites

Sounds awesome---black or brown bears? We only have black bears here in NM, and in Colorado where we go sometimes, and they're scary enough (black bears mean I only take trash outside the morning they come to take it away, lol).

Edited by tater

Share this post


Link to post
Share on other sites
27 minutes ago, tater said:

Sounds awesome---black or brown bears? We only have black bears here in NM, and in Colorado where we go sometimes, and they're scary enough (black bears mean I only take trash outside the morning they come to take it away, lol).

Supposedly both; though I have only seen black, and never within a mile or two of our campsite.  But they are out there, not too far up the trail/mountain.  The FWP / forest-rangers always stop by our camp at least once and remind us while we are up there (as if all of the signs aren't enough), and there are pretty large fines/etc if you don't take the proper precautions (e.g. don't leave your food or trash out overnight...).

Share this post


Link to post
Share on other sites

This has probably already been asked so I apologize in advance for duplication.  There is a ships and sub-assemblies folder install file but they are empty.  I tried going to the craft repository and downloaded every ship in there but not a single one loads!  They say they are missing parts???

What is it that I am missing?  I loaded the sstu, and sstu-textures packages from github and all the craft files from the craft file repository link.  Are those just for the 1.0.5 version of sstu?  Are there any craft files for the latest 1.1.3 version?  With other mods installed it's really hard to sort out the sstu stuff from other stuff and build anything useful.  A couple pre-built examples would really be helpful.

 

Thanks,

RM

Edited by ctbram

Share this post


Link to post
Share on other sites
1 minute ago, ctbram said:

This has probably already been asked so I apologize in advance for duplication.  There is a ships and sub-assemblies folder install file but they are empty.  I tried going to the craft repository and downloaded ever ship in there but not a single one loads!  They say they are missing parts???

What is it that I am missing?  I loaded the sstu, and sstu-textures packages from github and all the craft files from the craft file repository link.  Are those just for the 1.0.5 version of sstu?  Are there any craft files for the latest 1.1.3 version?  With other mods installed it's really hard to sort out the sstu stuff from other stuff and build anything useful.  A couple pre-built examples would really be helpful.

 

Thanks,

RM

No, there is nothing wrong with the ships. They are just made for 1.0.5. Also, many parts have undergone changes in the name and in the part itself. There won't be any ships until SSTU is in full release.

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now