TheEpicSquared

Through Hardships to the Stars [Chapter 32 - Something Big II]

383 posts in this topic

One thing to say about the ITS launch: YAHOO! WE DID IT, TEAM!

Just JAI. SpaceY was because SpaceX is going to make the real ITS :) 

I was thinking the EL mod so that we could build crafts on Duna, but if you don't want it, that's OK. 

Got it. Hopefully the 0.625-meter MOLE is compatible with the Clamp-O-Tron Junior. 

Share this post


Link to post
Share on other sites
1 hour ago, KAL 9000 said:

One thing to say about the ITS launch: YAHOO! WE DID IT, TEAM!

WOOHOOOO!

1 hour ago, KAL 9000 said:

Just JAI. SpaceY was because SpaceX is going to make the real ITS :) 

Alright, thanks

1 hour ago, KAL 9000 said:

I was thinking the EL mod so that we could build crafts on Duna, but if you don't want it, that's OK. 

Yeah, too many gameplay mechanics going on as it is. Thanks for understanding :) 

1 hour ago, KAL 9000 said:

Got it. Hopefully the 0.625-meter MOLE is compatible with the Clamp-O-Tron Junior. 

Pretty sure they are, but if they aren't, I can make an adapter for them no problem. :)

2 people like this

Share this post


Link to post
Share on other sites

Posted (edited)

Duna Station Craft Files 

Habitat goes on the core's TOP node. 

Fuel depots go on the FRONT and BACK nodes. 

There are two Solar Trusses. They go on the LEFT and RIGHT nodes. 

The BOTTOM node connects to SpaceLab via an adapter on the SpaceLab Tug.

Every station part except the Core needs a tug to move it into place. 

The Tug already has a probe core. 

Mods: Near Future Mods

Edited by KAL 9000

Share this post


Link to post
Share on other sites

nice reusable rocket!, how will you get teh capsule back on the booster ? 

Share this post


Link to post
Share on other sites

@TheEpicSquared

  • Location: 00110011001101110010111000110010001100100011100100110010001101100011100000101100001000000010110100110001001100010011010100101110001101110011100100110011001101110011000100110101

Clever...

Nevada is a cool place

Share this post


Link to post
Share on other sites

Posted (edited)

EpicSquared, you stole that design from Blue Origin, hmm, well I guess Green Origin since you are on Kerbin, still.  

Edited by Alpha 360
"Kouston, we have several problems, but that doesn't matter so we want to continue on with the mission."

Share this post


Link to post
Share on other sites

Alright, some bad news everybody. 

I was backing up my 1.2.2 install in advance of the 1.2.9 prerelease coming out, so I copied everything to another location, updated all the mods, loaded up the game, and...

The save won't open.

The game itself loads normally, all the way through the main screen. Then I click "Resume Saved", as usual, and then the save for this mission report.

Then, the screen goes to the black loading screen with the word "loading" and the circling planets at the bottom, as usual.

The problem is that it gets stuck there. I left my computer on for over 6 hours to make sure that it wasn't just slow loading, but no luck. :( 

I'll try to fix it the next time I can play (probably Friday), but I'm at a loss as to what I can do to fix it. Does anyone have any ideas?

 

Oh, and on another note, @The Raging Sandwich, I tried installing Kerbinside on a stock install the way I've been saying, and it worked perfectly. Download Kerbal Konstructs from Ger_space's thread, and then download Kerbinside Complete from the outdated Kerbinside thread. I'm not sure what's going on, maybe you installed it wrong? Anyway, here's a photo of my GameData folder, in case that helps.HHONp32.jpg

 

3 people like this

Share this post


Link to post
Share on other sites

Posted (edited)

No idea, dude :( 

Edited by KAL 9000

Share this post


Link to post
Share on other sites

R I P  I N  P E P P E R O N I

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

Is it getting stuck in ksp 1.2.2? If so, post your logs and maybe I can see where it is getting stuck. If you updated Kopernicus recently, that might be why you are seeing a blank screen. I had a similar problem on my career game.

Edited by Angel-125
2 people like this

Share this post


Link to post
Share on other sites

Posted (edited)

13 hours ago, Angel-125 said:

Is it getting stuck in ksp 1.2.2? If so, post your logs and maybe I can see where it is getting stuck. If you updated Kopernicus recently, that might be why you are seeing a blank screen. I had a similar problem on my career game.

Yup, 1.2.2. I think I updated kopernicus along with all the other mods, so that might be the cause. At any rate, I'll see if I can post the logs during the weekend. :) 

 

Edited by TheEpicSquared
1 person likes this

Share this post


Link to post
Share on other sites

@TheEpicSquared I really hope that works out for you

1 person likes this

Share this post


Link to post
Share on other sites

I made a logo for the Duna program! 

RNzSK0b.jpg

And the mission patch version: 

PvD12yZ.jpg

2 people like this

Share this post


Link to post
Share on other sites

@KAL 9000 ummm... it's a beautiful patch, but why is it male? Why isn't it female, or any of the other 70 genders? 

 

I know that probably wasn't intended, but there are certain things implied by putting that in there

Share this post


Link to post
Share on other sites

The male symbol is also the symbol for Mars. Duna = Kerbal Mars

1 person likes this

Share this post


Link to post
Share on other sites
On 3/23/2017 at 0:06 AM, Kosmonaut said:

@TheEpicSquared I really hope that works out for you

Thanks. I hope so too. 

18 hours ago, KAL 9000 said:

I made a logo for the Duna program! 

RNzSK0b.jpg

And the mission patch version: 

PvD12yZ.jpg

That is awesome! Thanks! :) 

@Angel-125, I should have some free time after school today, so I can probably post the logs today. Do you need the KSP.log, or the output log, or both? Thanks :) 

Share this post


Link to post
Share on other sites
12 hours ago, KAL 9000 said:

The male symbol is also the symbol for Mars. Duna = Kerbal Mars

OOOOHHHHHHHHHHH...

Ok, wonderful, thanks

Share this post


Link to post
Share on other sites
2 hours ago, Kosmonaut said:

OOOOHHHHHHHHHHH...

Ok, wonderful, thanks

The female symbol is also the symbol for Venus. If we were going to Eve, that symbol would be used.

1 person likes this

Share this post


Link to post
Share on other sites
On 3/19/2017 at 3:28 PM, TheEpicSquared said:

Oh, and on another note, @The Raging Sandwich, I tried installing Kerbinside on a stock install the way I've been saying, and it worked perfectly. Download Kerbal Konstructs from Ger_space's thread, and then download Kerbinside Complete from the outdated Kerbinside thread. I'm not sure what's going on, maybe you installed it wrong? Anyway, here's a photo of my GameData folder, in case that helps.

Wait so...... You're saying that with your way of installing this, you would have all... like 20-ish bases?

Share this post


Link to post
Share on other sites

And here's the flag for the entire program: 

MvTrOOT.jpg

3 people like this

Share this post


Link to post
Share on other sites
3 hours ago, DarkOwl57 said:

Wait so...... You're saying that with your way of installing this, you would have all... like 20-ish bases?

Yup. Worked for me...

Also, @Angel-125, here are the logs you asked for:

KSP.log

output_log.txt

Hope we can solve this :) 

1 person likes this

Share this post


Link to post
Share on other sites
8 hours ago, TheEpicSquared said:

Thanks. I hope so too. 

That is awesome! Thanks! :) 

@Angel-125, I should have some free time after school today, so I can probably post the logs today. Do you need the KSP.log, or the output log, or both? Thanks :) 

Just the logs. I'm pretty certain you ran into the same problem with Kopernicus that I did. Don't know how to fix it though..

1 person likes this

Share this post


Link to post
Share on other sites

@TheEpicSquared Yup, it's definitely Kopernicus causing the error:

[LOG 17:22:58.266] Load(Assembly): Kopernicus/Plugins/Kopernicus.Components
[LOG 17:22:58.267] AssemblyLoader: Loading assembly at C:\Users\Ronak\Desktop\KSP 1.2.2\GameData\Kopernicus\Plugins\Kopernicus.Components.dll
[LOG 17:22:58.270] AssemblyLoader: KSPAssembly 'Kopernicus.Components' V1.0


[EXC 17:33:59.225] NullReferenceException: Object reference not set to an instance of an object
	Kopernicus.RuntimeUtility.UpdateMenu ()
	Kopernicus.RuntimeUtility.Start ()

[EXC 17:33:59.297] IndexOutOfRangeException: Array index is out of range.
	Kopernicus.Components.KopernicusStar.Start ()

[EXC 17:33:59.366] NullReferenceException: Object reference not set to an instance of an object
	Kopernicus.Components.KopernicusStar.LateUpdate ()
[ERR 17:33:59.825] Exception handling event onNewGameLevelLoadRequestWasSanctionedAndActioned in class <>c:System.NullReferenceException: Object reference not set to an instance of an object
  at Kopernicus.StarLightSwitcher+<>c.<Start>b__2_1 (GameScenes scene) [0x00000] in <filename unknown>:0 
  at EventData`1[GameScenes].Fire (GameScenes data) [0x00000] in <filename unknown>:0 

[EXC 17:33:59.832] NullReferenceException: Object reference not set to an instance of an object
	Kopernicus.StarLightSwitcher+<>c.<Start>b__2_1 (GameScenes scene)
	EventData`1[GameScenes].Fire (GameScenes data)
	UnityEngine.Debug:LogException(Exception)
	EventData`1:Fire(GameScenes)
	<FireLoadedEvent>c__Iterator68:MoveNext()
	UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
[ERR 17:33:59.895] Exception handling event onNewGameLevelLoadRequestWasSanctionedAndActioned in class RuntimeUtility:System.NullReferenceException: Object reference not set to an instance of an object
  at Kopernicus.RuntimeUtility.UpdateMenu () [0x00000] in <filename unknown>:0 
  at Kopernicus.RuntimeUtility.<Awake>b__1_0 (GameScenes scene) [0x00000] in <filename unknown>:0 
  at EventData`1[GameScenes].Fire (GameScenes data) [0x00000] in <filename unknown>:0 

[EXC 17:33:59.898] NullReferenceException: Object reference not set to an instance of an object
	Kopernicus.RuntimeUtility.UpdateMenu ()
	Kopernicus.RuntimeUtility.<Awake>b__1_0 (GameScenes scene)
	EventData`1[GameScenes].Fire (GameScenes data)
	UnityEngine.Debug:LogException(Exception)
	EventData`1:Fire(GameScenes)
	<FireLoadedEvent>c__Iterator68:MoveNext()
	UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
      
      and a whole lot of these..
      
[EXC 17:34:00.848] NullReferenceException: Object reference not set to an instance of an object
	Kopernicus.Components.KopernicusStar.LateUpdate ()

I think you're going to need to talk to @Galileo about this, and be sure to specify the exact version of Kopernicus you're using.

2 people like this

Share this post


Link to post
Share on other sites

rip this series

 

I'm really enjoying it and I hope it doesn't go down the crapper...

1 person likes this

Share this post


Link to post
Share on other sites
On 3/25/2017 at 1:15 AM, Kosmonaut said:

rip this series

 

I'm really enjoying it and I hope it doesn't go down the crapper...

*triumphant voice* HAHAHAHAAAAA!!! :D 

This hasn't gone down the crapper! 

The issue has been fixed!

Missions have been launched!

Screenshots have been taken!

Ideas have been formed!

Spoiler

It seems just installing the previous version of Kopernicus fixed the problem. However, I will take steps to try to fix the problem with the current version of Kopernicus, but for now, we're back in business! :cool: 

 

2 people like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now