JPLRepo

[1.3] TAC - Life Support v0.13.2 - Release 29th May 2017

636 posts in this topic

On ‎7‎/‎9‎/‎2017 at 11:47 PM, ItchyBrother said:

I am sure the mod developer is working on it.    Hope that helps you and keep the faith.  The fix is coming, it just take some time.

Agree, great mod, great developer, just needs a tweak to make it right.  Thanks all for everything you do.  

Share this post


Link to post
Share on other sites

I'm sorry everything has been waiting for me to fix the EC problem for some weeks.
I shall endeavor to get to it this weekend.

2 people like this

Share this post


Link to post
Share on other sites
27 minutes ago, JPLRepo said:

I'm sorry everything has been waiting for me to fix the EC problem for some weeks.
I shall endeavor to get to it this weekend.

Oh, no. The person who makes these things for us for free might have other things on as well in life.

But in all seriousness, many thanks for the awesome mod will look forward to updates.

1 person likes this

Share this post


Link to post
Share on other sites
3 hours ago, JPLRepo said:

I'm sorry everything has been waiting for me to fix the EC problem for some weeks.
I shall endeavor to get to it this weekend.

You SERIOUSLY needn't apologize. Rather please accept our thanks for maintaining and improving the mod!

1 person likes this

Share this post


Link to post
Share on other sites

I've started testing a fix for the EC issues... IF it looks good tomorrow I will publish a dev build if some people can help me out with testing.

3 people like this

Share this post


Link to post
Share on other sites
2 minutes ago, JPLRepo said:

I've started testing a fix for the EC issues... IF it looks good tomorrow I will publish a dev build if some people can help me out with testing.

Always!

1 person likes this

Share this post


Link to post
Share on other sites

Is there a way to delete the tracked vessel data from a savegame?

In my careergame i have a whole lot of Vessels still in the LIfesupport tracker, despite the fact the have all been recovered. I dont think this is a bug with TAC_LS itself, since this did not happen in a new game i just started to see if this happens there aswell.  Probably just a byproduct of installing-deleting-reinstalling mods mid game.

Share this post


Link to post
Share on other sites
17 minutes ago, Filigan said:

Is there a way to delete the tracked vessel data from a savegame?

In my careergame i have a whole lot of Vessels still in the LIfesupport tracker, despite the fact the have all been recovered. I dont think this is a bug with TAC_LS itself, since this did not happen in a new game i just started to see if this happens there aswell.  Probably just a byproduct of installing-deleting-reinstalling mods mid game.

You sure can. Manually. Edit the persistent.sfs file for your save.
Look for this section:
 

Spoiler

SCENARIO
    {
        name = TacLifeSupport
        scene = 5, 6, 7, 8
        SavedGameSettings
        {
            IsNewSave = False
            CrewMemberInfo
            {
                name = Jebediah Kerman
                lastUpdate = 118844.26156259399
                lastFood = 118844.26156259399
                lastWater = 118844.26156259399
                vesselName = Ship 1
                vesselId = 0370352a-b19f-432e-b717-9e931b897878
                vesselIsPreLaunch = False
                hibernating = False
                DFFrozen = False
                recoverykerbal = False
                crewType = Crew
            }
            VesselInfo
            {
                vesselName = Ship 1
                vesselType = Ship
                vesselSituation = ORBITING
                vesselIsPreLaunch = False
                numCrew = 1
                numFrozenCrew = 0
                numOccupiedParts = 1
                lastUpdate = 118844.26156259399
                lastFood = 118844.26156259399
                lastWater = 118844.26156259399
                lastOxygen = 118844.26156259399
                lastElectricity = 118844.26156259399
                remainingFood = 112.29229199793099
                remainingWater = 314.19997366156696
                remainingOxygen = 11561.632965386367
                remainingElectricity = 2300
                remainingCO2 = 14.084055831744053
                remainingWaste = 0.10000000000000001
                remainingWasteWater = 0.92400000000000004
                maxFood = 114.297
                maxWater = 315.52499999999998
                maxOxygen = 11577.938
                maxElectricity = 2300
                estimatedElectricityConsumptionRate = 0.035416666666666999
                hibernating = False
                recoveryvessel = False
                windowOpen = False
                Guid = 0370352a-b19f-432e-b717-9e931b897878
            }
        }

There will be sections called CrewMemberInfo and sections called  VesselInfo.
As long as you delete the enclosed blocks for the ones you want remove it will be fine.
Backup your save file first.

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

Apparently i managed to delete this entries without causing even more problems =D

 

TY

Edited by Filigan

Share this post


Link to post
Share on other sites

Hello

I dont know about this awesome Space Simulation until 1 Month ago.

I have a question about this mod:

Is it possible to build a independently Life support System? Something like a Space-Greenhouse, that becomes carbondioxide/wastewater/waste for the plants.

The plants then produce food and oxigen, wastewater will be cleaned from the soil in the Greenhouse and waste will give nutritions for the plants. 

I want to build a system like this to prevent that my KSS dont run out of food when i'm Time warping in another mission. 

Another question is:

What happens when the waste Container is full? Will be Cleaners stop working then.

And why i cannot dispose waste into space

Share this post


Link to post
Share on other sites
51 minutes ago, SwissSpace93 said:

Hello

I dont know about this awesome Space Simulation until 1 Month ago.

I have a question about this mod:

Is it possible to build a independently Life support System? Something like a Space-Greenhouse, that becomes carbondioxide/wastewater/waste for the plants.

The plants then produce food and oxigen, wastewater will be cleaned from the soil in the Greenhouse and waste will give nutritions for the plants. 

I want to build a system like this to prevent that my KSS dont run out of food when i'm Time warping in another mission. 

There are other mods that add greenhouses. Off the top of my head: SETI Greenhouse, USI Kolonization, Planetary Base Inc, Pathfinder, Airline Kuisine

54 minutes ago, SwissSpace93 said:

Another question is:

What happens when the waste Container is full? Will be Cleaners stop working then.

As far as I remember the excess just disappears.

56 minutes ago, SwissSpace93 said:

And why i cannot dispose waste into space

I suggest using the mod Ship Manifest which allows you to dump the contents of any tank whenever you want. (There are other mods for dumping resources but this has the best mix of features in my opinion)

Share this post


Link to post
Share on other sites

Hi all,

Thanks for your patience and understanding.
Here is a link to a test/develop Build for TAC LS to hopefully resolve the EC issue for unloaded vessels at high time warp.
Anyone who has the time to help me out and test it would be terrific.
Let me know good or bad if this solves the problem or not.
If it does not I'd appreciate logs and save files and a description of the problem.
Prefer no other mods if that can be avoided thanks, Just makes it quicker for me to look at the problems and figure out a fix that works for everyone if I don't have to spend an hour downloading and installing mods to look at each report. In fact usually I don't, because I don't have the time to do that.
Thanks!


https://github.com/KSP-RO/TacLifeSupport/releases/tag/v0.13.4dev
 

Share this post


Link to post
Share on other sites

Posted (edited)

@JPLRepo

It's half fixed. The EC now starts updating itself properly when the craft is reloaded (no more kerbals dying of no EC when you have a full battery after a scene switch), but the EC is still not replenishing on unloaded vessels.

Easiest way to reproduce is to use this craft file and cheat it into orbit - https://www.dropbox.com/s/hx5mammupteos6a/Untitled Space Craft.craft?dl=0

Switch back to Space Centre, and open the TAC window - timewarp until EC has been depleted. At this point, one of two things happens:

1) If you switch back to the craft before the 2hr "death window" has expired, the EC will start updating itself again, and if the craft is still in sunlight, the panels will start to charge the battery and your kerbal will be saved.

2) If you don't, the kerbal will die of air toxicity when you switch to it.

So TL:DR - TAC is depleting the EC when unloaded, but not replenishing it again. I'm going to try with Unloaded Vessel Processing turned off now.

Log: https://www.dropbox.com/s/ivrtklna104p7ty/output_log.txt?dl=0

Save: https://www.dropbox.com/s/lfevver4k9ltbeo/persistent.sfs?dl=0

Edit: With Unloaded Processing turned off it makes no difference. Symptoms are exactly the same.

Edit 2: Minor thing, but even if you catch it in time, and the EC goes back into the green, the toolbar icon stays red.

Edited by severedsolo
1 person likes this

Share this post


Link to post
Share on other sites
29 minutes ago, severedsolo said:

@JPLRepo

It's half fixed. The EC now starts updating itself properly when the craft is reloaded (no more kerbals dying of no EC when you have a full battery after a scene switch), but the EC is still not replenishing on unloaded vessels.

Easiest way to reproduce is to use this craft file and cheat it into orbit - https://www.dropbox.com/s/hx5mammupteos6a/Untitled Space Craft.craft?dl=0

Switch back to Space Centre, and open the TAC window - timewarp until EC has been depleted. At this point, one of two things happens:

1) If you switch back to the craft before the 2hr "death window" has expired, the EC will start updating itself again, and if the craft is still in sunlight, the panels will start to charge the battery and your kerbal will be saved.

2) If you don't, the kerbal will die of air toxicity when you switch to it.

So TL:DR - TAC is depleting the EC when unloaded, but not replenishing it again. I'm going to try with Unloaded Vessel Processing turned off now.

Log: https://www.dropbox.com/s/ivrtklna104p7ty/output_log.txt?dl=0

Save: https://www.dropbox.com/s/lfevver4k9ltbeo/persistent.sfs?dl=0

Edit: With Unloaded Processing turned off it makes no difference. Symptoms are exactly the same.

Edit 2: Minor thing, but even if you catch it in time, and the EC goes back into the green, the toolbar icon stays red.

Well that is most strange.... Because that's not what I see....
I launched your vessel. put it in orbit.. went to the KSC.
Open TAC window and timewarp.maximum.. few seconds later (cause it's got very little food or water)... and it doesn't run out of EC? ever..
It runs out of Food and Water before it runs out of EC.
 

Spoiler

[Edit] - I don't not believe you.. I see it in the log...
But I don't understand why your results are different to mine.

Share this post


Link to post
Share on other sites

Posted (edited)

19 minutes ago, JPLRepo said:

 

[Edit] - I don't not believe you.. I see it in the log...
But I don't understand why your results are different to mine.

That craft should have had 2 days worth of food, and about 4 hours of EC (Default settings, fresh install of KSP 1.3).

Is there anything else I can do to help you test it? I can reproduce it consistently at my end, but obviously that doesn't help you.

Edited by severedsolo
1 person likes this

Share this post


Link to post
Share on other sites
44 minutes ago, severedsolo said:

That craft should have had 2 days worth of food, and about 4 hours of EC (Default settings, fresh install of KSP 1.3).

Is there anything else I can do to help you test it? I can reproduce it consistently at my end, but obviously that doesn't help you.

I got it to happen if I continue to speed up time more... So yeah, something isn't right. Because it should be putting the EC in and compensating (overflow) for timewarp.
I'll have to have a closer look when I get a bit of time during the week.
Thanks for your input.

1 person likes this

Share this post


Link to post
Share on other sites

I have no clue in regards to modding (just using them) but I hope this info will help.

I had a savegame with TAC_Life_Support-v0.13.2 installed and upgraded to 13.4.

In the savegame I had a vessel that reported electricity depleting but Kerbals did not die as long as there was actually EC on board.

After upgrading to 13.4 they died when I returned to the vessel.

I fixed this by looking in the savefile and searching for 'taclife' and looked at the lines there.

I noticed that under 'vesselInfo' there was lines with 'lastUpdate', 'lastFood', 'lastWater', 'lastOxygen' and 'lastElectricity'.

They all had the same long number after them except for 'lastElectricity' so I changed that to match the others, saved the file and loaded that and now my Kerbals survive when I return to the vessel.

Regards,

Mikey

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

Is there any easy way to disable kerbal ec consumption for now? (there's seem to be setting for ec per day for one kerbin, but I can lower it only to 100) Are that settings written in persistent file so I can edit them here? Will TAC tolerate 0 or 1 as minimal value?

Because TAC just killed my crew in transit in middle of other launch despite I set "hibernate, not kill" in settings. :(

UPD. Also there is also value for "base ec consumption per day". Is it somehow related with ec consumption for one kerbal?

Edited by demiare
added question

Share this post


Link to post
Share on other sites
1 hour ago, Mikey_B1974 said:

I have no clue in regards to modding (just using them) but I hope this info will help.

I had a savegame with TAC_Life_Support-v0.13.2 installed and upgraded to 13.4.

In the savegame I had a vessel that reported electricity depleting but Kerbals did not die as long as there was actually EC on board.

After upgrading to 13.4 they died when I returned to the vessel.

I fixed this by looking in the savefile and searching for 'taclife' and looked at the lines there.

I noticed that under 'vesselInfo' there was lines with 'lastUpdate', 'lastFood', 'lastWater', 'lastOxygen' and 'lastElectricity'.

They all had the same long number after them except for 'lastElectricity' so I changed that to match the others, saved the file and loaded that and now my Kerbals survive when I return to the vessel.

Regards,

Mikey

Thanks, That is a clue. IT is a bug. But it's not the main one.
I took another look. I've fixed this one, but in the process of fixing it, I've found the real problem.
I'll work on a fix tomorrow.

55 minutes ago, demiare said:

Is there any easy way to disable kerbal ec consumption for now? (there's seem to be setting for ec per day for one kerbin, but I can lower it only to 100) Are that settings written in persistent file so I can edit them here? Will TAC tolerate 0 or 1 as minimal value?

Because TAC just killed my crew in transit in middle of other launch despite I set "hibernate, not kill" in settings. :(

UPD. Also there is also value for "base ec consumption per day". Is it somehow related with ec consumption for one kerbal?

Nope.

Yeah that's unfortunate...  TAC LS will kill kerbals if O2 or EC runs out... there's no hibernate. Hibernate is only if they run out of food or water. Not sure when and how that got changed.. but that's what the code does. 
[edit]
I think it's always done it that way since Taranis wrote it.
Because EC and O2 calculations are done by vessel. Not by kerbal. Whereas Food and Water calculations are done by kerbal.
Can look to change that, but after I fix the EC first. I'm working on it.

[edit2] BaseElectricityRate is part of the calculations for EC. There is a base EC rate per crewed part.
The formula is:(EC rate per kerbal x #ofkerbals) + (baseECRate * #ofoccupiedPods)

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

Hey. Came here to report EC bug, but you are already working on it. Thanks for working on such an awesome mod!

if it helps any, it seems that all the ships get the EC bug at the same time? I could be wrong but it seems like its not just 1 ship that gets it but all of them at once.

It also seems like visiting them (or maybe restarting KSP?) can 'fix' them? Not 100% sure what does it but they do seem to get 'fixed'

Edited by BlackMoons

Share this post


Link to post
Share on other sites

Hopefully I am helping more than confusing, but I noticed precisely when this bug seems to manifest: during timewarp, you can accelerate up to 50x and everything seems to function normally concerning EC with TACLS.  Once you accelerate beyond 50x, at 100x and above, the bug manifests and time till dead batteries begins to decrease despite full resources/charge.  You do not have to be focused on the vessel in question when this occurs either.  I have absolutely no idea how to provide logs/code that could possibly demonstrate this phenomenon, but if the developer believes this symptom is indeed related and not a residual issue, I can try to provide as much information as I can.  And indeed,thank you for maintaining a great mod and furthering a great game and community!

Share this post


Link to post
Share on other sites

Posted (edited)

1 hour ago, JPLRepo said:

@severedsolo and anyone else that has tried the latest test build in the last 24-48 hours.
I think I've finally fixed it.

If anyone can try to download the test build again and test for me and confirm that would be terrific.
It is the same Link as before:
https://github.com/KSP-RO/TacLifeSupport/releases/edit/v0.13.4dev

This URL just drops me back to githubs main page after making me sign in?

Edited by BlackMoons

Share this post


Link to post
Share on other sites

Very nice, installing now. Will I have to switch back to vessels to 'fix' them one last time or should it all be good?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now