UomoCapra

Kerbal Space Program 1.2.1 is live!

201 posts in this topic

Looks good so far. I gave it a try on a clone of my heavily modded 1.2 save and apart from a wall of AVC compatibility warnings on loading (which I expected) everything looks fine. One mod was throwing exceptions into the log for OnGameSettingsApplied events but it didn't appear to affect the functionality of its parts or UI.

1 hour ago, UomoCapra said:

* Fix UI Flickering in Editor when lots of parts loaded.
* Fix UI Flickering in MC when lots of Contracts listed.

Seems to have worked. Spent a bit of time in the VAB and where before the parts list flickered regularly and the App buttons were permanently glitched, I saw no problems with the new version.

1 hour ago, UomoCapra said:

Fix for Mapnode text not updating when controls locked.

Thank you! Thank you! Thank you! Not being able to adjust manoeuvre nodes easily with window based editors was really frustrating - now it works like it used to.

Share this post


Link to post
Share on other sites

I appreciate your efforts!

1 hour ago, UomoCapra said:

* Add Reset All Settings option to settings.

I'd been waiting for this button since the creation of the universe.

Share this post


Link to post
Share on other sites
37 minutes ago, Neroziat said:

i was forced the update by steam and cant go back to 1.2.0 now my mods are mega broken. what can i do to revert so i can play the game

@Neroziat you can use the Betas menu in Steam to access older versions. There is a "previous_1.0.5" and a "previous_1.1.3" to go back to those versions. Make sure you back up your save games and craft files etc beforehand.

 

Share this post


Link to post
Share on other sites
1 hour ago, UomoCapra said:

Hello everyone!

Kerbal Space Program 1.2.1 is live! 

Here's the changelog for this patch:


=================================== v1.2.1 ============================================================
+++ Bug Fixes
* Fix Maneuver Nodes not showing dV when target changes.
* Fix highlighter chewing memory every frame.
* Fix CBs being in different places in 1.2 by adjusting GeeASL.
* Fix engine glow not originating from engine thrust location.
* Fix for non-resettable experiments listing a reset cost.
* Fix KSPedia inaccuracy about reentry friction.
* Fix for drills shutting down when you approach.
* Fix "Mammoth" collider pushing away parts on stage.
* Fix for MysteryGoo container having collider too large.
* Fix for ModuleRCSFX KSPField.
* Fix for contract weights getting messed up in save files.
* Fix for Gas bursts on decouplers being in the wrong place.
* Fix for EVA orientation on lab hatches.
* Removed duplicate "Lowlands" biomes from Mun.
* Fix for revert deleting Messages.
* Removed writing from Mk3->Mk2 adapter.
* Fix for text overflow, etc for flag plaque.
* Miscellaneous KSPedia text tweaks.
* Fix for Subassembly DropZone tooltip not closing.
* Fix for StackGraph not following links across decouplers if one of the decouplers is a root part (Fuel crossfeed issue).
* Fix for ladder slide on Mk1 Inline.
* Fix for ScientistBonus in ModuleScienceConverter being broken.
* Fix loop using wrong iterator in GetModulesImplementingInterface.

+++UI Fixes
* Fix UI Flickering in Editor when lots of parts loaded.
* Fix UI Flickering in MC when lots of Contracts listed.
* Fix for Mapnode text not updating when controls locked.
* Fix for UIScaling applying incorrectly to the AppLancher and apps.
* Fix for asteroid KB Info text wrapping.
* Fix for text missing against some Action Menu items for wheel actions.

+++Miscellaneous Stuff
* Update to Biome Maps for Bop, Gilly and Pol.
* Adjust minimum FoV for enhanced mode on Roverbody and NDS to allow more zoom when landed.
* Add Reset All Settings option to settings.
* Add customizable binding for Editor Scroll Modifier for Zoom - default to left-command for OSX instead of left-shift.
* Add new default binding for precision control of "Return" for OSX instead of capslock.
* Change default camera reset binding to not clash with Abort Action group.
* Change default eva light binding to not clash with translate left.
* Allow mods to circumvent contract weight limits

 

Cheers!

* Change default eva light binding to not clash with translate left.

Thank you. I gave up on not having to do this myself like 3 years ago :)



Share this post


Link to post
Share on other sites

Thanks guys! I do really hope you can fix the claw the next patch though (resource transfer is disabled since 1.2).

And the audio system still has a problem with custom sound and for example doesn't play the sound of your own ion engine. I've made the same bug report multiple times since 1.1.

1 hour ago, UomoCapra said:

* Fix CBs being in different places in 1.2 by adjusting GeeASL.

What does this mean by the way?

Edited by Azimech

Share this post


Link to post
Share on other sites

>just updated all of my mods the night before last
>this

Welp, I guess I should be studying calculus anyways. 

2 people like this

Share this post


Link to post
Share on other sites
1 hour ago, Kerbart said:

Damn! Just when all my mods were working... Back to square 0?

Shouldnt be - although if you use AVC or CKAN and the files are set for 1.2.0 then you'll get warnings galore

 

23 minutes ago, Azimech said:

...What does this mean by the way?

The Celestial Bodies have a GeeASL value that was based on the value of gee for before 1.2, in 1.2 these changed which meant things like the geostationary orbit heights, etc all moved a bit, and things were in slightly diffn places in the sky. This put them back at the right place with the right values.

 

1 hour ago, swjr-swis said:

I had the same thought. A little cutesy personal touch killed. Oh well.

Yet meanwhile, much more annoying and outright confusing/unhelpful texture errors remain (like the Mk1-2/Mk2 Inline/Mk3 cockpit asymmetric fake RCS ports, misaligned arrows on decouplers, 90 degree misaligned texture on the Mk0 LF tank, etc). You'd think those would've merited an edit by now more urgently than a touch of humour.

 

Anyway. At least they finally did something about the Mammoth collider. Yay!

Cutesy to some, but offensive to others, so yeah it got a quick brush, if you can point me to the bug nums for the other ones I can see where they are in the list

1 person likes this

Share this post


Link to post
Share on other sites
1 hour ago, Neroziat said:

i was forced the update by steam and cant go back to 1.2.0 now my mods are mega broken. what can i do to revert so i can play the game

Are you sure they are broken? You will get errors when loading, but that doesn't really mean anything aside from the version number has changed. Granted some mods may be broken, but with a small bugfix patch I'd guess most will be ok.

1 person likes this

Share this post


Link to post
Share on other sites

Nice!   Good to see squad polishing up the game so aggressively.  

Share this post


Link to post
Share on other sites

Well, Squad, thanks for the "heads up",... NOT!

Share this post


Link to post
Share on other sites
1 hour ago, Neroziat said:

i was forced the update by steam and cant go back to 1.2.0 now my mods are mega broken. what can i do to revert so i can play the game

Yes - Please advise...Steam only allows you to rollback to 1.0.5 and 1.1.3

Share this post


Link to post
Share on other sites
28 minutes ago, TriggerAu said:

Shouldnt be - although if you use AVC or CKAN and the files are set for 1.2.0 then you'll get warnings galore

You have to admit that's a bit of an understatement. I'd say it's more "up the wazoo"

What's really aggravating with AVC is that it's informing you that "you're not using the latest version. use 1.2"

I wish whoever wrote it would check for newer or equal, not just equal.

Share this post


Link to post
Share on other sites
2 minutes ago, Kerbart said:

You have to admit that's a bit of an understatement. I'd say it's more "up the wazoo"

LOL the AVC warning list was taller than my screen and checking the summary window in the top left almost everything was yellow with only a handful of green entries.

Would have been alarming if I wasn't expecting it.

Share this post


Link to post
Share on other sites
13 minutes ago, Kerbart said:

I wish whoever wrote it would check for newer or equal, not just equal.

To some degree that would defeat the purpose. Those mod versions haven't been tested on 1.2.1 and AVC is rightfully telling the player that, without stopping them from playing if the mod works.

2 people like this

Share this post


Link to post
Share on other sites
8 minutes ago, Kerbart said:

You have to admit that's a bit of an understatement. I'd say it's more "up the wazoo"

What's really aggravating with AVC is that it's informing you that "you're not using the latest version. use 1.2"

I wish whoever wrote it would check for newer or equal, not just equal.

you aint wrong - testing that UI flicker was a mind bending clicking of yes I do wanna do that.

3 people like this

Share this post


Link to post
Share on other sites
47 minutes ago, Aelfhe1m said:

LOL the AVC warning list was taller than my screen and checking the summary window in the top left almost everything was yellow with only a handful of green entries.

Would have been alarming if I wasn't expecting it.

I was not expecting it and I was quite alarmed at first. 

Share this post


Link to post
Share on other sites
1 hour ago, TriggerAu said:

you aint wrong - testing that UI flicker was a mind bending clicking of yes I do wanna do that.

I sure appreciate it was fixed.  I literally got heavy migraines from it and either had to deal with the pain after or play stock only. So thank you!! VERY MUCH!

5 people like this

Share this post


Link to post
Share on other sites

Hey, Squad, can you ask Steam to launch the 64 bit version of KSP on Linux?

Share this post


Link to post
Share on other sites

Just trying out 1.2.1 and have an issue with science experiments and action groups. 

  • Create a vessel with science experiments
  • Assign experiments to run on an action group
  • Launch
  • Trigger the action group - all experiments run as expected
  • Reset all experiments from the results dialogs
  • Trigger action group again - only some experiments run, others do not.

Now this is a modded install (MJ, MM, KAC and a few others) - and I've not seen updates for them yet. Is it a general problem, or something broken by mods?

Seems to be the 'simple' experiments - temperature, pressure, gravity, etc that fail - mystery goo, science jr and crew reports do repeat as expected. Also, I can still manually click on each experiment run it from it's menu, it's only the action group that's failing.

Spoiler

 

Test setup:

science-action-group.pngscience-action-group-test.jpg

 

 

Share this post


Link to post
Share on other sites
11 minutes ago, jonatkins said:

Now this is a modded install (MJ, MM, KAC and a few others) - and I've not seen updates for them yet. Is it a general problem, or something broken by mods?

If it occur in a "no modded" situation, it might be issues of KSP substance. and you can post it to bug tracker.

You have got opportunity to check it. Good luck with you.

Share this post


Link to post
Share on other sites
5 hours ago, UomoCapra said:

* Removed writing from Mk3->Mk2 adapter. 

Wow. Pre-order cancelled. 

1 person likes this

Share this post


Link to post
Share on other sites

Good patch. Not the biggest one we ever had, but it fixes a whole bunch of things that really annoyed me!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now