Galileo

[v1.2.3] Galileo's Planet Pack: Official Release [KSP 1.2.2]

3848 posts in this topic

3 hours ago, erik84 said:

Is this version  really compatible with the version of KSP 1.3? Why he continues to tell me to use a version compatible with KSP 1.2.2

There is no 1.3 version yet. We're really close but to use GPP you'll need to stay in 1.2.2 for the time being

Share this post


Link to post
Share on other sites

Posted (edited)

You are using the dev version? I'm not providing support for that just yet and there are some things that need balancing, like strategia. If you are going to use the dev version, which is against the devs wishes, you are kind of on your own until we actually update. Our latest release is for 1.2.2

Edited by Galileo

Share this post


Link to post
Share on other sites

Whoah, @Galileo check your post... it came out a bit... odd... :0.0:

postception... we can go deeper...

2 people like this

Share this post


Link to post
Share on other sites
6 minutes ago, CatastrophicFailure said:

Whoah, @Galileo check your post... it came out a bit... odd... :0.0:

postception... we can go deeper...

Galileo has revealed that he wields secret martial arts. This one being the FIVE FINGER SEND PUNCH. :ph34r: 

3 people like this

Share this post


Link to post
Share on other sites
1 hour ago, Galileo said:

You are using the dev version? I'm not providing support for that just yet and there are some things that need balancing, like strategia. If you are going to use the dev version, which is against the devs wishes, you are kind of on your own until we actually update. Our latest release is for 1.2.2

Oh sorry for that, I will just remove the effect for myself from the config and play on...

1 person likes this

Share this post


Link to post
Share on other sites

Sorry for the heavy finger on my post.. 

 

Share this post


Link to post
Share on other sites

Was to understand, I no longer have version 1.2.2, steam me alone the game updated to 1.3 will say that I will wait, thank you

Share this post


Link to post
Share on other sites
1 hour ago, erik84 said:

Was to understand, I no longer have version 1.2.2, steam me alone the game updated to 1.3 will say that I will wait, thank you

You can roll ksp back to 1.2.2 through steam...

Share this post


Link to post
Share on other sites
On 7/2/2017 at 2:29 AM, woland said:

Just wondering if the private industry strategy configured by this mod in Strategia gives a bit too much science a bit too easily? The following only with the level 1 commitment. Using CTT (but hiding unused tech nodes) and the near future parts naturally increases the payouts due to the unresearched techs multiplier, but still it feels a bit out of line with everything else. 

I think this was mentioned here a few pages ago, or maybe it was over on the Strategia thread?  Anyway it seems that the Private Industry strat is meant to be a kind of Science Boost Mode.  GPP is meant to be a bit barren of science on the homeworld and home moons, to force the player to go interplanetary early on (stock KSP has so much science at home that many players never even bother).  But if that doesn't fit your playstyle - pick Private Industry and get a huge science boost so you can max out your tech tree and cruise interplanetary in style.

1 person likes this

Share this post


Link to post
Share on other sites

Hi - This is not related to the GPP pack but comes as one of the suggested additions - I think it is part of MKS (but not 100% certain) - the various pulse drill heads with "interchangeable" drill heads? How do you change them?  Within the VAB you can change them from Dirt - Ore etc.....  However when you get onto a surface and right click to change them - there is no option to do so and it only sems to drill dirt?   I had to revert to the "default" stock mining drill to extract my 2800 cubits of Ore to deliver back to Gael - but it would be nice to work out how to use the array of "automatic pulse drills" that I have unlocked?

In other exciting news I have 3 willing volunteers currently cryogenically frozen on a manned mission to Thalia to dock with the Lab, the habitation extension and the life support extension all also on their way.. Docked with my interplanetery spaceplane and being dragged along is "hopefully" enough fuel to get them home again!!

My latest Icarus attempt is on its way and has 3K more d/v so hoping this time I can get into orbit and not get yet another flyby.  I now have more than the d/v map tells me I need so here's hoping :) 

I love the look of Thalia - the scarred surface of "facelift" biome is amazing and even managed to land before my probe melted....  You guys rock the socks of me!!

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

@Pinchy MKS tech support should be requested in MKS's thread. But I bet you may be missing something small like only an EVA kerbal can change the drill heads. I assume the craft is unmanned. MKS puts a heavy emphasis on EVA.

As for the exciting news, heck yeah. Make sure to bring back some screenshots. :wink: 

Edited by JadeOfMaar
1 person likes this

Share this post


Link to post
Share on other sites
5 minutes ago, JadeOfMaar said:

@Pinchy MKS tech support should be requested in MKS's thread. But I bet you may be missing something small like only an EVA kerbal can change the drill heads. I assume the craft is unmanned. MKS puts a heavy emphasis on EVA.

As for the exciting news, heck yeah. Make sure to bring back some screenshots. :wink: 

haha - yeah for sure...  Will post some screenies on the adventure :)

Yeah I found this @JadeOfMaar from the inbuilt wiki - but I can't work out how I get the specialised parts or materials kits on board - or where they are from within the parts tree.....

Swapping the separators for the drills can be done after they deploy but requires the following resources

Drill SpecializedParts MaterialKits ElectricCharge
MEU-100 Pulse Drill 1 5 5
MEU-500 Pulse Drill 3 15 15
Industrial Strip Miner 8 40 40

Share this post


Link to post
Share on other sites

@Pinchy Once you start unlocking parts in the Logistics category (nearly everything there is kontainers) you'll be able to attach a kontainer and switch it to hold MaterialKits and SpecializedParts. 

Yeah... everything there is a kontainer. :P 

jBDLNo0.jpg

1 person likes this

Share this post


Link to post
Share on other sites
4 minutes ago, Pinchy said:

haha - yeah for sure...  Will post some screenies on the adventure :)

Yeah I found this @JadeOfMaar from the inbuilt wiki - but I can't work out how I get the specialised parts or materials kits on board - or where they are from within the parts tree.....

Swapping the separators for the drills can be done after they deploy but requires the following resources

Drill SpecializedParts MaterialKits ElectricCharge
MEU-100 Pulse Drill 1 5 5
MEU-500 Pulse Drill 3 15 15
Industrial Strip Miner 8 40 40

Ok looking through this and looks like the parts and kits need to be assembled in parts - clearly need to spend some time understanding this in detail

2 minutes ago, JadeOfMaar said:

@Pinchy Once you start unlocking parts in the Logistics category (nearly everything there is kontainers) you'll be able to attach a kontainer and switch it to hold MaterialKits and SpecializedParts. 

Yeah... everything there is a kontainer. :P 

jBDLNo0.jpg

Thanks for this - I admit totally that I have not really spent anytime looking in logistics or experimenting with Kontainers, but this I didn't know so will have a play with this on the launchpad and see if I can work it out now you have given me this guidance.. Thanks once again for your help.

1 person likes this

Share this post


Link to post
Share on other sites

I posted a question about performance with bases on bodies where if I have more than 3 crafts landed and in the same vicinity (not even linked) but within a few hundred metres - there is massive lag - despite me having a pretty good rig.

 

The answer back is

I believe extreme base lag is a Kopernicus problem (as in just having Kopernicus is enough to cause surface bases to chug like a steam train, part-heavy or not).

 

Is this a known problem as part of GPP and if there is likely to be a resolution with the updated version of Kopernicus and the GPP update?

Share this post


Link to post
Share on other sites

@Pinchy Nothing can be done to GPP to cure this problem. It's a Kopernicus problem and is well known for plaguing players when in Mun's SOI. GPP had a few code errors that provoked a similar problem but those were largely fixed before Grannus existed.

Share this post


Link to post
Share on other sites

@JadeOfMaar - Thanks - when you say within Mun's SOI - does this mean that the problem would only be unique to the moons within Gael's planetary SOI (ie IOTA and CETI) - and if I go interplanetery with Ground Bases the problem will not be there?

I read from @Galileo that Kopernicus had been upgraded with the latest version of KSP and thats what has so far plagued him with updates to the latest version of GPP - so my question was really aimed at asking if Kopernicus had been updated to address this known problem and therefore by default fixing this in GPP.

Share this post


Link to post
Share on other sites

Players have had problems once their craft were in Mun orbit or landed on Mun. This does not automatically mean it happens to crafts in Iota or Ceti SOI. About going interplanetary, the only answer is to find out for yourself. :/ But the Kopernicus devs should know very well about it, and only a portion of players experience this.

The part with Galileo is that Kopernicus changes resources and syntax concerning planet-making: that means a steep learning curve and a lot of troubleshooting to ensure that GPP (as simply a collection of planets) loads at all, loads properly and the issues or oversights that non-modders discover later on are as few as possible.

Share this post


Link to post
Share on other sites
3 minutes ago, JadeOfMaar said:

Players have had problems once their craft were in Mun orbit or landed on Mun. This does not automatically mean it happens to crafts in Iota or Ceti SOI. About going interplanetary, the only answer is to find out for yourself. :/ But the Kopernicus devs should know very well about it, and only a portion of players experience this.

The part with Galileo is that Kopernicus changes resources and syntax concerning planet-making: that means a steep learning curve and a lot of troubleshooting to ensure that GPP (as simply a collection of planets) loads at all, loads properly and the issues or oversights that non-modders discover later on are as few as possible.

Ok thanks - Yeah I don't seem to have had any isues building and assembling orbital bases in Ceti or Iota - only experienced when I put a mining operation on both planets that consisted of an initial landing probe (pathfinder) and then an automated mining ship, a manned lander power station and habitat/supplies. 

I won't try to make Thalia as my first interplanetary ground base :o 

Share this post


Link to post
Share on other sites
11 hours ago, JadeOfMaar said:

Players have had problems once their craft were in Mun orbit or landed on Mun

This is why I looked for an excuse to replace the Mun in my own mod :wink::P

 

1 person likes this

Share this post


Link to post
Share on other sites
2 minutes ago, Gameslinx said:

This is why I looked for an excuse to replace the Mun in my own mod :wink::P

If the Mun problem indeed happens with Iota then something is very wrong. Iota does not use Mun's template and should have no chance to "inherit" the problem. I take it your excuse paid off well. :) 

1 person likes this

Share this post


Link to post
Share on other sites

Just some quick videos I made now that I finally installed camera tools. Time to make some videos. :)

2 people like this

Share this post


Link to post
Share on other sites

@Galileo So I got the sunflare working except for sunFlare.png and sunSpikes.png, when I place them in, the game reverts to the original stock sunflare. Without them, the ghosting pics work. I'm using Andromeda's btw. Any suggestions?

On 6/27/2017 at 0:14 AM, JadeOfMaar said:

@fourfa @Pinchy Here you go. I've added Grannus and raised the upgrade detection range to about 2x Grannus' apoapsis.

Grannus for ResearchBodies

And speaking of Grannus, I upgraded my personal sunflare for it and Ciro. @Galileo you like? :P All the elements are yours except the rim ghost from the Eden sunflare.

q0vGOls.jpg

Pt78QlJ.jpg 

qdXOTzg.jpg

What sunflare is that? I'd love to use it

I should avoid this forum before it makes me feel to restart KSP lol, just got a career going

Share this post


Link to post
Share on other sites

Posted (edited)

10 hours ago, The-Doctor said:

@Galileo So I got the sunflare working except for sunFlare.png and sunSpikes.png, when I place them in, the game reverts to the original stock sunflare. Without them, the ghosting pics work. I'm using Andromeda's btw. Any suggestions?

What sunflare is that? I'd love to use it

I should avoid this forum before it makes me feel to restart KSP lol, just got a career going

Does Andromeda's package contain a Ghost3.png? If not then you're getting null spam along with the reversion to stock flare. Just insert anything named Ghost3.png and it should behave. Also, its config file may be obsolete. Scatter config structures have been changing.

Those sunflares are a WIP and my creation. They're not release ready.

Edited by JadeOfMaar

Share this post


Link to post
Share on other sites
1 hour ago, JadeOfMaar said:

Does Andromeda's package contain a Ghost3.png? If not then you're getting null spam along with the reversion to stock flare. Just insert anything named Ghost3.png and it should behave. Also, its config file may be obsolete. Scatter config structures have been changing.

Those sunflares are a WIP and my creation. They're not release ready.

Yes Andromeda's has a Ghost3, the Ghost pics are not the problem, they are working, I installed these ghosts from this mod and it works fine, it's the sunflare and sunspikes that aren't working

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.