politas

CKAN (The Comprehensive Kerbal Archive Network); v1.22.3 - Mahia

393 posts in this topic

Hi guys,

 

In these past weeks I had a error trying to access CKAN.

This is the error:

 

CKAN.ModuleNotFoundKraken: Tipo de excepção 'CKAN.ModuleNotFoundKraken' accionado.
   em CKAN.Registry.AllAvailable(String module)
   em CKAN.MainAllModVersions.set_SelectedModule(GUIMod value)
   em CKAN.MainModInfo.set_SelectedModule(GUIMod value)
   em CKAN.Main.ModList_SelectedIndexChanged(Object sender, EventArgs e)
   em System.Windows.Forms.DataGridView.OnSelectionChanged(EventArgs e)
   em System.Windows.Forms.DataGridView.FlushSelectionChanged()
   em System.Windows.Forms.DataGridView.ClearSelection(Int32 columnIndexException, Int32 rowIndexException, Boolean selectExceptionElement)
   em System.Windows.Forms.DataGridView.SetAndSelectCurrentCellAddress(Int32 columnIndex, Int32 rowIndex, Boolean setAnchorCellAddress, Boolean validateCurrentCell, Boolean throughMouseClick, Boolean clearSelection, Boolean forceCurrentCellSelection)
   em System.Windows.Forms.DataGridView.MakeFirstDisplayedCellCurrentCell(Boolean includeNewRow)
   em System.Windows.Forms.DataGridView.OnRowCollectionChanged_PostNotification(Boolean recreateNewRow, Boolean allowSettingCurrentCell, CollectionChangeAction cca, DataGridViewRow dataGridViewRow, Int32 rowIndex)
   em System.Windows.Forms.DataGridViewRowCollection.OnCollectionChanged_PostNotification(CollectionChangeAction cca, Int32 rowIndex, Int32 rowCount, DataGridViewRow dataGridViewRow, Boolean changeIsDeletion, Boolean changeIsInsertion, Boolean recreateNewRow, Point newCurrentCell)
   em System.Windows.Forms.DataGridViewRowCollection.OnCollectionChanged(CollectionChangeEventArgs e, Int32 rowIndex, Int32 rowCount)
   em System.Windows.Forms.DataGridViewRowCollection.AddRange(DataGridViewRow[] dataGridViewRows)
   em CKAN.Main._UpdateFilters()
   em CKAN.Util.Invoke[T](T obj, Action action)
   em CKAN.Main._UpdateModsList(Boolean repo_updated)
   em CKAN.Util.Invoke[T](T obj, Action action)
   em CKAN.Main.CurrentInstanceUpdated()
   em CKAN.Main.OnLoad(EventArgs e)
   em System.Windows.Forms.Form.OnCreateControl()
   em System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
   em System.Windows.Forms.Control.CreateControl()
   em System.Windows.Forms.Control.WmShowWindow(Message& m)
   em System.Windows.Forms.Control.WndProc(Message& m)
   em System.Windows.Forms.Form.WmShowWindow(Message& m)
   em System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Assemblagens carregadas **************
mscorlib
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
ckan
    Versão da assemblagem: 0.0.0.0
    Versão Win32: 0.0.0.0
    CodeBase: file:///D:/SteamLibrary/steamapps/common/Kerbal%20Space%20Program/ckan.exe
----------------------------------------
System.Configuration
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Windows.Forms
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Transactions
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_64/System.Transactions/v4.0_4.0.0.0__b77a5c561934e089/System.Transactions.dll
----------------------------------------
System.Windows.Forms.resources
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms.resources/v4.0_4.0.0.0_pt_b77a5c561934e089/System.Windows.Forms.resources.dll
----------------------------------------
mscorlib.resources
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/mscorlib.resources/v4.0_4.0.0.0_pt_b77a5c561934e089/mscorlib.resources.dll
----------------------------------------
Microsoft.GeneratedCode
    Versão da assemblagem: 1.0.0.0
    Versão Win32: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Numerics
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll
----------------------------------------
System.Runtime.Serialization
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Serialization/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Serialization.dll
----------------------------------------
System.Xml.Linq
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll
----------------------------------------
System.Data
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1636.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
Anonymously Hosted DynamicMethods Assembly
    Versão da assemblagem: 0.0.0.0
    Versão Win32: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_64/mscorlib/v4.0_4.0.0.0__b77a5c561934e089/mscorlib.dll
----------------------------------------
Microsoft.CSharp
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.CSharp/v4.0_4.0.0.0__b03f5f7f11d50a3a/Microsoft.CSharp.dll
----------------------------------------
System.Dynamic
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Dynamic/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Dynamic.dll
----------------------------------------
Microsoft.CSharp.resources
    Versão da assemblagem: 4.0.0.0
    Versão Win32: 4.6.1586.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.CSharp.resources/v4.0_4.0.0.0_pt_b03f5f7f11d50a3a/Microsoft.CSharp.resources.dll
----------------------------------------

 

 

Any idea how to work this out?

 

Thanks

Share this post


Link to post
Share on other sites

Is there a place to post requests for CKAN features? I'd like to see a 'last updated' field for the mod list. That would be awesome.

Jamie

Share this post


Link to post
Share on other sites

Can someone please check why Stock Visual Terrain is still on 2.0 under CKAN. The girhub for 2.0.1 was updated several days ago.

Share this post


Link to post
Share on other sites

I notice CKAN has a "Versions" tab for mods, but it doesn't seem to do anything? The latest scatterer mod (v0.0300) isn't working for me, and I'm trying to install the previous version (v0.0256), which I can see in CKAN, but I can't figure out any way to tell it to install that version instead of the latest. Am I just missing something? I tried googling around a bunch, and looking through the CKAN documentation, but I can't find anything.

Share this post


Link to post
Share on other sites
17 hours ago, lewisd said:

I notice CKAN has a "Versions" tab for mods, but it doesn't seem to do anything? The latest scatterer mod (v0.0300) isn't working for me, and I'm trying to install the previous version (v0.0256), which I can see in CKAN, but I can't figure out any way to tell it to install that version instead of the latest. Am I just missing something? I tried googling around a bunch, and looking through the CKAN documentation, but I can't find anything.

Up!

This feature is missing from CKAN.

Versions KSP compatible is only for mods outdated, but functional.

 

Also, mods should be installed with their version dependencies.

Ex: Install Mod X > Dependency: Mod Y, version Z.

There should be a parameter specifying the version, and this is updated only by the primary mod author.

Edited by Phoenyx

Share this post


Link to post
Share on other sites

Update needed - still shows as 1.1.3, 1.2+ available for some time now - just updated again. Also the entry for it points to the old thread, which was one of the o0nes some Squad moderator permanently deleted.  Here is the addon and new thread.

 

and also its dependency

https://github.com/Angel-125/WildBlueTools/tree/master/GameData/WildBlueIndustries/000WildBlueTools

Share this post


Link to post
Share on other sites

We've said it before, and I'll say it again - There is no way to add "last updated" date for mods without completely rewriting the way we find mod updates automatically. It's not going to happen. We're talking replacing most of our infrastructure code.

1 person likes this

Share this post


Link to post
Share on other sites

2 parts of Stock Visual Enhancements need a netkan update cause a release file name changed from "SVE.Scatterer.cfgs.zip" to "SVE_Scatterer.zip".
This is a little bit important, cause the actual situation (old scatterer config files with new scatterer) breaks KSP for the people that install SVE via CKAN.
The two netkan files that need to be changed (if I see this right): File1 File2.
I've checked the old and the new and the folders that are used by the netkans are inside, so it seems that only the filename change listed above must be included to the netkan files. A second look to verify this would be good, still.

@linuxgurugamer

May I ping you here?

Edited by Jebs_SY

Share this post


Link to post
Share on other sites
1 hour ago, Jebs_SY said:

2 parts of Stock Visual Enhancements need a netkan update cause a release file name changed from "SVE.Scatterer.cfgs.zip" to "SVE_Scatterer.zip".
This is a little bit important, cause the actual situation (old scatterer config files with new scatterer) breaks KSP for the people that install SVE via CKAN.
The two netkan files that need to be changed (if I see this right): File1 File2.
I've checked the old and the new and the folders that are used by the netkans are inside, so it seems that only the filename change listed above must be included to the netkan files. A second look to verify this would be good, still.

@linuxgurugamer

May I ping you here?

No file names are listed in the NetKan files.  I'm not an expert, but I wonder if all that's needed is to reindex.

How would I be able to tell if an old config is installed with the new scatterer?

 

Edit:  I looked at the local registry.json, and indeed, it is still referring to the old file:

"download": "https://github.com/Galileo88/StockVisualEnhancements/releases/download/1.1.4/SVE.Scatterer.cfgs.zip",

 

Oh, it's a version change.  Ok, I'll see what I can do

Edited by linuxgurugamer
1 person likes this

Share this post


Link to post
Share on other sites
7 minutes ago, linuxgurugamer said:

No file names are listed in the NetKan files.  I'm not an expert, but I wonder if all that's needed is to reindex.

How would I be able to tell if an old config is installed with the new scatterer?

Thx for looking into this.

Not this?:   "$kref" : "#/ckan/github/Galileo88/StockVisualEnhancements/asset_match/SVE.Scatterer.cfgs.zip" ?

At least CKAN picked up the change to 1.1.6 for the other SVE packages, but not for the two above. They are still on 1.1.4.

Check scatterer\config\planetlist.cfg. A scatterer v0.300 compatible config must now have a "mainSunCelestialBody = ..." in each item{...} listed there. If that's missing, scatterer memleaks KSP fast until the system dies by swapping. At least for me.

Edited by Jebs_SY

Share this post


Link to post
Share on other sites

There were 3 files which needed to be updated:

  • SVE-HighResolution.netkan
  • SVE-MediumResolution.netkan
  • SVE-LowResolution.netkan

These three have the version hard-coded in the netkan file.  I've done the update, will need to have someone else confirm and merge

 

1 person likes this

Share this post


Link to post
Share on other sites
14 minutes ago, linuxgurugamer said:

Oh, it's a version change.  Ok, I'll see what I can do

A version change AND a download / download-for-index file name change.

Share this post


Link to post
Share on other sites

When it updates, it redoes the index file

1 person likes this

Share this post


Link to post
Share on other sites
30 minutes ago, linuxgurugamer said:

There were 3 files which needed to be updated:

  • SVE-HighResolution.netkan
  • SVE-MediumResolution.netkan
  • SVE-LowResolution.netkan

These three have the version hard-coded in the netkan file.  I've done the update, will need to have someone else confirm and merge

Are you sure? These three packages are listed correct for 1.1.6 (actual) in my CKAN. Just SVE-sunflare and SVE-Scatterer-Config are on the old 1.1.4, cause the CKAN system cannot find the 1.1.6 ".version" file of these 2 packages, cause it searches the ".version" files at the wrong place (SVE.Scatterer.cfgs.zip up to v1.1.4), cause the "github download filenames" have changed to SVE_Scatterer.zip (from v1.1.5 on).

I think CKAN missed the update of SVE-sunflare and SVE-Scatterer-Config cause it doesn't find the 1.1.6 ".version" files for these 2 packages, cause it does not know about the new release location (SVE_Scatterer.zip).

And I expected this netkan line must be changed for SVE-sunflare and SVE-Scatterer-Config, but I am not sure:

"$kref" : "#/ckan/github/Galileo88/StockVisualEnhancements/asset_match/SVE.Scatterer.cfgs.zip"

I assume when CKAN finds the actual 1.1.6 ".version" files for  SVE-sunflare and SVE-Scatterer-Config in SVE_Scatterer.zip on Github it will make the version jump for the SVE-sunflare and SVE-Scatterer-Config packages.

 

EDIT: @linuxgurugamer Thx for your work, anyway. I assume the kref line in the netkan for SVE-sunflare and SVE-Scatterer-Config must be changed (release filename change here from 1.1.4 to 1.1.5/6). So maybe ping @politas here? 

Edited by Jebs_SY

Share this post


Link to post
Share on other sites

If it's something else, it's beyond what I can do

1 person likes this

Share this post


Link to post
Share on other sites

Good point, I'll see if I can fix that

Fixed by @dbent in a pattern-match, so this won't happen again

 

Edited by linuxgurugamer
1 person likes this

Share this post


Link to post
Share on other sites
On 1/27/2017 at 11:44 AM, Kiro said:

Can someone please check why Stock Visual Terrain is still on 2.0 under CKAN. The girhub for 2.0.1 was updated several days ago.

Bumping this, SVT is now on 2.0.2 and CKAN only has up to 2.0.0.  I think the mods file structure changed as when I checked the game data folder I didn't see the SVT root folder that the current .zip has now.

Share this post


Link to post
Share on other sites
58 minutes ago, Amechwarrior said:

Bumping this, SVT is now on 2.0.2 and CKAN only has up to 2.0.0.  I think the mods file structure changed as when I checked the game data folder I didn't see the SVT root folder that the current .zip has now.

This is the same problem as in SVE, the "release download filename on github" changed, so CKAN doesn't find the new updates...
And the LR version is gone and now there is one version only for PC and one version for Mac/Linux.
I wonder if CKAN can differentiate between Win and Mac/Linux?!

At the moment the Netkan indexer matches to THIS. ("SVT.High.*.zip" for SVT-HighResolution and "SVT.Low.*.zip" for SVT-LowResolution)

Old filenames were:
SVT.High.Resolution.v2.0.zip
SVT.Low.Resolution.v2.0.zip

Version 201 filenames were:
SVT.LR.v2.0.1.zip
SVT.v2.0.1.zip

Version 202 filenames are:
SVT.v2.0.2.Mac.Linux.zip
SVT.v2.0.2.zip

@Galileo
Do you know if the new 2.0.2 naming convention will stick for a while? So it would make sense, that the CKAN guys can adopt to that? LR version is gone and the normal version is splitted into Win and Mac/Linux?
Maybe use "SVT.v2.0.2.Win.zip" for the Win version to make it perfectly clear?

Share this post


Link to post
Share on other sites

Yes it will continue like that from now on. I will change the name to make it more clear in a little bit.

1 person likes this

Share this post


Link to post
Share on other sites

I found that in 1.2.x, save files now has information about what mods installed(and used when last play) savegame in loaderinfo tab. Can we use it like .ckan file and install that mods?

it's be useful when we move savefiles or like.

 

Spoiler

 
    LoaderInfo
    {
        KerbalEngineer v1.1.2.0 = False
        KerbalEngineer.Unity v1.0.0.0 = True
        MiniAVC v1.0.3.2 = False
        MiniAVC v1.0.3.0 = False
        PlanetShine v1.0.6121.34655 = True
        KerbalEngineer = True
        PlanetShine = True
        ModuleManager.2.7.5 v2.7.5.0 = True
        USITools v1.0.0.0 = True
        BetterBurnTime v1.0.0.0 = True
        CCK v1.2.1.0 = True
        ContractConfigurator v1.0.0.0 / v1.22.2 = True
        DistantObject v1.8.1.12781 = True
        ContractParser v1.0.5.0 / vv5.0 = True
        ProgressParser v1.0.6.0 / vv6.0 = True
        CapCom v1.0.2.5 / vv2.5 = True
        EasyVesselSwitch v1.2.0.0 / v1.2.0 for KSP v1.2 = True
        KSPDev_Utils.0.19.0 v0.19.0.0 / v0.19.0 for KSP v1.2 = True
        Atmosphere v1.5.6131.22338 / v1.0.0.0 = True
        CelestialShadows v1.5.6131.22338 / v1.0.0.0 = True
        EVEManager v1.5.6131.22338 / v1.0.0.0 = True
        PartFX v1.5.6131.22338 / v1.0.0.0 = True
        PQSManager v1.5.6131.22338 / v1.0.0.0 = True
        ShaderLoader v1.5.6131.22337 / v1.0.0.0 = True
        Terrain v1.5.6131.22338 / v1.0.0.0 = True
        TextureConfig v1.5.6131.22338 / v1.0.0.0 = True
        Utils v1.5.6131.22337 / v1.0.0.0 = True
        _BuildManager v1.5.6131.22338 / v1.0.0.0 = True
        Firespitter v7.3.6212.36331 = True
        GravityTurn v1.7.6.32456 = True
        HideEmptyTechTreeNodes v0.7.4.0 = True
        IndicatorLights v1.0.0.0 = True
        KAS v0.6.2.0 / v0.6.2 for KSP 1.2 = True
        KerbalEngineer v1.1.2.8 = True
        KIS v1.4.2.0 / v1.4.2 for KSP 1.2 = True
        KSPDev_Utils.0.20.0 v0.20.0.0 / v0.20.0 for KSP v1.2 = True
        MechJeb2 v2.5.1.0 / v / v2.6.0.0 = True
        ModularFlightIntegrator v1.0.0.0 / v1.2.3.0 = True
        NavBallDockingAlignmentIndicatorCE v1.0.1.1 / v1.0.0.0 = True
        PlanetarySurfaceStructures v1.3.11.4 = True
        PortraitStats v1.0.13.0 = True
        SafeChute v2.1.6.0 / v2.1.6 = True
        SCANsat v1.6.0.11 / vv16.11 = True
        scatterer v1.0.6231.33139 = True
        ScienceRelay v1.0.3.1 / vv3.1 = True
        KerbalAlarmClock v3.8.4.0 = True
        Konstruction v0.0.0.0 = True
        WaypointManager v1.0.0.0 / v2.6.2 = True
        ZeroMiniAVC v1.0.4.32363 = True
        [x] Science! v5.4.6185.40021 = True
        000_USITools = True
        BetterBurnTime = True
        BoulderCo = True
        CommunityCategoryKit = True
        CommunityResourcePack = True
        CommunityTechTree = True
        ContractConfigurator = True
        ContractPacks = True
        DistantObject = True
        DMagicUtilities = True
        EasyVesselSwitch = True
        EnvironmentalVisualEnhancements = True
        Firespitter = True
        GravityTurn = True
        HideEmptyTechTreeNodes = True
        IndicatorLights = True
        IndicatorLightsCommunityExtensions = True
        KAS = True
        KIS = True
        MechJeb2 = True
        ModularFlightIntegrator = True
        NavBallDockingAlignmentIndicatorCE = True
        PartOverhauls = True
        PlanetaryBaseInc = True
        PortraitStats = True
        SafeChute = True
        SCANsat = True
        scatterer = True
        ScienceRelay = True
        TriggerTech = True
        UmbraSpaceIndustries = True
        UniversalStorage = True
        WaypointManager = True
        ZeroMiniAVC = True
        [x] Science! = True
        deltav.ksp = True
        MechJebAndEngineerForAll.cfg = True
        ModuleManager.2.7.5.dll = True
        ModuleManager.ConfigCache = True
        ModuleManager.ConfigSHA = True
        ModuleManager.Physics = True
        ModuleManager.TechTree = True
    }
    ROSTER
    {
        KERBAL
        {

         ...

 

 

Share this post


Link to post
Share on other sites
9 hours ago, omelaw said:

I found that in 1.2.x, save files now has information about what mods installed(and used when last play) savegame in loaderinfo tab. Can we use it like .ckan file and install that mods?

it's be useful when we move savefiles or like.

 

  Reveal hidden contents

 
    LoaderInfo
    {
        KerbalEngineer v1.1.2.0 = False
        KerbalEngineer.Unity v1.0.0.0 = True
        MiniAVC v1.0.3.2 = False
        MiniAVC v1.0.3.0 = False
        PlanetShine v1.0.6121.34655 = True
        KerbalEngineer = True
        PlanetShine = True
        ModuleManager.2.7.5 v2.7.5.0 = True
        USITools v1.0.0.0 = True
        BetterBurnTime v1.0.0.0 = True
        CCK v1.2.1.0 = True
        ContractConfigurator v1.0.0.0 / v1.22.2 = True
        DistantObject v1.8.1.12781 = True
        ContractParser v1.0.5.0 / vv5.0 = True
        ProgressParser v1.0.6.0 / vv6.0 = True
        CapCom v1.0.2.5 / vv2.5 = True
        EasyVesselSwitch v1.2.0.0 / v1.2.0 for KSP v1.2 = True
        KSPDev_Utils.0.19.0 v0.19.0.0 / v0.19.0 for KSP v1.2 = True
        Atmosphere v1.5.6131.22338 / v1.0.0.0 = True
        CelestialShadows v1.5.6131.22338 / v1.0.0.0 = True
        EVEManager v1.5.6131.22338 / v1.0.0.0 = True
        PartFX v1.5.6131.22338 / v1.0.0.0 = True
        PQSManager v1.5.6131.22338 / v1.0.0.0 = True
        ShaderLoader v1.5.6131.22337 / v1.0.0.0 = True
        Terrain v1.5.6131.22338 / v1.0.0.0 = True
        TextureConfig v1.5.6131.22338 / v1.0.0.0 = True
        Utils v1.5.6131.22337 / v1.0.0.0 = True
        _BuildManager v1.5.6131.22338 / v1.0.0.0 = True
        Firespitter v7.3.6212.36331 = True
        GravityTurn v1.7.6.32456 = True
        HideEmptyTechTreeNodes v0.7.4.0 = True
        IndicatorLights v1.0.0.0 = True
        KAS v0.6.2.0 / v0.6.2 for KSP 1.2 = True
        KerbalEngineer v1.1.2.8 = True
        KIS v1.4.2.0 / v1.4.2 for KSP 1.2 = True
        KSPDev_Utils.0.20.0 v0.20.0.0 / v0.20.0 for KSP v1.2 = True
        MechJeb2 v2.5.1.0 / v / v2.6.0.0 = True
        ModularFlightIntegrator v1.0.0.0 / v1.2.3.0 = True
        NavBallDockingAlignmentIndicatorCE v1.0.1.1 / v1.0.0.0 = True
        PlanetarySurfaceStructures v1.3.11.4 = True
        PortraitStats v1.0.13.0 = True
        SafeChute v2.1.6.0 / v2.1.6 = True
        SCANsat v1.6.0.11 / vv16.11 = True
        scatterer v1.0.6231.33139 = True
        ScienceRelay v1.0.3.1 / vv3.1 = True
        KerbalAlarmClock v3.8.4.0 = True
        Konstruction v0.0.0.0 = True
        WaypointManager v1.0.0.0 / v2.6.2 = True
        ZeroMiniAVC v1.0.4.32363 = True
        [x] Science! v5.4.6185.40021 = True
        000_USITools = True
        BetterBurnTime = True
        BoulderCo = True
        CommunityCategoryKit = True
        CommunityResourcePack = True
        CommunityTechTree = True
        ContractConfigurator = True
        ContractPacks = True
        DistantObject = True
        DMagicUtilities = True
        EasyVesselSwitch = True
        EnvironmentalVisualEnhancements = True
        Firespitter = True
        GravityTurn = True
        HideEmptyTechTreeNodes = True
        IndicatorLights = True
        IndicatorLightsCommunityExtensions = True
        KAS = True
        KIS = True
        MechJeb2 = True
        ModularFlightIntegrator = True
        NavBallDockingAlignmentIndicatorCE = True
        PartOverhauls = True
        PlanetaryBaseInc = True
        PortraitStats = True
        SafeChute = True
        SCANsat = True
        scatterer = True
        ScienceRelay = True
        TriggerTech = True
        UmbraSpaceIndustries = True
        UniversalStorage = True
        WaypointManager = True
        ZeroMiniAVC = True
        [x] Science! = True
        deltav.ksp = True
        MechJebAndEngineerForAll.cfg = True
        ModuleManager.2.7.5.dll = True
        ModuleManager.ConfigCache = True
        ModuleManager.ConfigSHA = True
        ModuleManager.Physics = True
        ModuleManager.TechTree = True
    }
    ROSTER
    {
        KERBAL
        {

         ...

 

 

No, you will have to install them, CKAN can't read that file

Share this post


Link to post
Share on other sites
22 hours ago, Galileo said:

Yes it will continue like that from now on. I will change the name to make it more clear in a little bit.

 

23 hours ago, Jebs_SY said:

This is the same problem as in SVE, the "release download filename on github" changed, so CKAN doesn't find the new updates...
And the LR version is gone and now there is one version only for PC and one version for Mac/Linux.
I wonder if CKAN can differentiate between Win and Mac/Linux?!

At the moment the Netkan indexer matches to THIS. ("SVT.High.*.zip" for SVT-HighResolution and "SVT.Low.*.zip" for SVT-LowResolution)

Old filenames were:
SVT.High.Resolution.v2.0.zip
SVT.Low.Resolution.v2.0.zip

Version 201 filenames were:
SVT.LR.v2.0.1.zip
SVT.v2.0.1.zip

Version 202 filenames are:
SVT.v2.0.2.Mac.Linux.zip
SVT.v2.0.2.zip

@Galileo
Do you know if the new 2.0.2 naming convention will stick for a while? So it would make sense, that the CKAN guys can adopt to that? LR version is gone and the normal version is splitted into Win and Mac/Linux?
Maybe use "SVT.v2.0.2.Win.zip" for the Win version to make it perfectly clear?

Being fixed now

23 hours ago, Galileo said:

Yes it will continue like that from now on. I will change the name to make it more clear in a little bit.

CKAN is being updated with the new file names.  Since right now CKAN doesn't have the ability to select an install file based on OS, there are two entries, one for Windows and one for MacLinux

2 people like this

Share this post


Link to post
Share on other sites
On 03/02/2017 at 9:13 AM, Galileo said:

Yes it will continue like that from now on. I will change the name to make it more clear in a little bit.

Sorry, which of those statements is correct? They are contradictory. When you change the zip names, you break CKAN updates.

Share this post


Link to post
Share on other sites
45 minutes ago, politas said:

Sorry, which of those statements is correct? They are contradictory. When you change the zip names, you break CKAN updates.

Disregard that. I was going to rename it to match earlier versions to fix it for CKAN but you guys beat me to it. I no longer need to rename it. 

Share this post


Link to post
Share on other sites

Hello,

I am new to the community. Whenever I try and use CKAN to update my mods CKAN always tells me that it needs to quit due to a parsing error in stacks or something close to that.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now