politas

CKAN (The Comprehensive Kerbal Archive Network); v1.22.3 - Mahia

450 posts in this topic

Hi, 

Could someone take a look at Stock Visual Enhancements please, 3 versions have come out in the last 2 weeks which ckan isn't picking up. @Galileo has made some changes to the format of the mod so guessing that's probably why ckan isn't updating automatically?

Thanks

Share this post


Link to post
Share on other sites
1 minute ago, Torih said:

Hi, 

Could someone take a look at Stock Visual Enhancements please, 3 versions have come out in the last 2 weeks which ckan isn't picking up. @Galileo has made some changes to the format of the mod so guessing that's probably why ckan isn't updating automatically?

Thanks

We're working on it. 

1 person likes this

Share this post


Link to post
Share on other sites
2 minutes ago, linuxgurugamer said:

First one is difficult, I've started, but asked for help

2nd one (new reaction wheels) is done

I'll look into why the UpgradeGUI isn't there yet

Why don't you merge the two NK-33 mods into one? Doesn't make sense to have a single part in a mod.  What I'd do is have a single directory (for now, call it MadScientist) as follows:

GameData/MadScientist/Parts/NK33

GameData/MadScientist/Parts/NK33_125

Last one (antenna progression), I've asked the author for permission.

 

Hey linuxgurugamer,

Thank you very much!! :wink:

 

And the NK-33 mods aren't mine, they were made by Mad Rocket Scientist .

 

I just want to help with CKAN. :wink:

 

1 person likes this

Share this post


Link to post
Share on other sites
Just now, N3N said:

 

Hey linuxgurugamer,

Thank you very much!! :wink:

 

And the NK-33 mods aren't mine, they were made by Mad Rocket Scientist .

 

I just want to help with CKAN. :wink:

 

I understand, but you really should ask for permission from the author before this sort of request.

Share this post


Link to post
Share on other sites
Just now, linuxgurugamer said:

I understand, but you really should ask for permission from the author before this sort of request.

 

Oh, sorry, I didn't want to do the wrong thing, I listed it, because I read it in his post, that he wanted to add it to CKAN and thought he might want help with it.

I didn't want to make a request without his permission. Sorry! :(

Share this post


Link to post
Share on other sites
20 minutes ago, N3N said:

 

Oh, sorry, I didn't want to do the wrong thing, I listed it, because I read it in his post, that he wanted to add it to CKAN and thought he might want help with it.

I didn't want to make a request without his permission. Sorry! :(

Not a problem, I've already asked

1 person likes this

Share this post


Link to post
Share on other sites
5 hours ago, linuxgurugamer said:

@Olympic1

I make the following as a start for the KPBStoMKS, but it's going to need some work.

specifically, it needs to have at least one of the following mods installed:

MKS, Konstruction, USI-LS, or OSE Workshops

So I'm wondering if you could help:


{
  "spec_version": "v1.4",
  "install": [
    {
      "install_to": "GameData",
      "find": "KPBStoMKS"
    }
  ],
  "depends": [
    { "name": "ModuleManager" },
    { "name": "KerbalPlanetaryBaseSystems" },
    { "name": "FirespitterCore" }
  ],
  "$vref": "#/ckan/ksp-avc",
  "$kref": "#/ckan/github/DanStaal/KPBStoMKS",
  "x_via": "Automated Linuxgurugamer CKAN script",
  "identifier": "KPBStoMKS",
  "license": "MIT"
}

 

It's a bit of an annoying one but after looking into it, it needs KPBS (obviously) and MM. Because it is mostly made for MKS, I should depend on UKS and recommend/suggest USI-LS, Workshop, ExtraPlanetaryLaunchpads and ConnectedLivingSpace.

Share this post


Link to post
Share on other sites

Posted (edited)

2 hours ago, Olympic1 said:

It's a bit of an annoying one but after looking into it, it needs KPBS (obviously) and MM. Because it is mostly made for MKS, I should depend on UKS and recommend/suggest USI-LS, Workshop, ExtraPlanetaryLaunchpads and ConnectedLivingSpace.

It definitely shouldn't reccomend EL because RoverDude has dropped EL in favor of GroundConstruction (which is now a required and bundled dependency). Also don't know why you'd suggest CLS because while both KPBS and MKS have compatibility patches, I wouldn't call it a recommended mod. 

Edited by TheRagingIrishman

Share this post


Link to post
Share on other sites

CLS should probably be Suggested, not Recommended, IMHO. You can throw an explicit dependency to GC Core if you don't want to depend on the one bundled with USI/MKS. Similar goes for CC core (Alista's configurable containers).

Share this post


Link to post
Share on other sites
On 2017-4-19 at 0:51 PM, politas said:

We're working on it. 

Hi, ckan is now trying to update SVE, I've double checked Github and it appears the work has been done.

However it's trying to install version 1.0 and not 1.2.2, it's also only attempting the textures, the configs are not showing the update:

https://www.dropbox.com/s/osa18rpgaj7ynmz/Screenshot 2017-04-21 02.24.24.png?dl=0

Apologies if its still being worked on :)

Share this post


Link to post
Share on other sites
10 hours ago, Torih said:

Hi, ckan is now trying to update SVE, I've double checked Github and it appears the work has been done.

However it's trying to install version 1.0 and not 1.2.2, it's also only attempting the textures, the configs are not showing the update:

https://www.dropbox.com/s/osa18rpgaj7ynmz/Screenshot 2017-04-21 02.24.24.png?dl=0

Apologies if its still being worked on :)

Yes, as is often the case with SVE updates, the packaging method is all different. You will now need to install "Stock Visual Enhancements", which requires you to install one of the three texture options. The texture packs can thus remain far more stable, and version 1.0 is the correct version number for them (It's actually version 3:1.0 in CKAN) It will probably be easier if you uninstall the existing SVE version and install the new one de novo rather than trying to upgrade.

2 people like this

Share this post


Link to post
Share on other sites

@politas Thanks, it works just right after the old version is removed. 

Share this post


Link to post
Share on other sites

Posted (edited)

Hi, Mac user here, and whenever I try to run ckan, whether through the command line or the new ckan.app, terminal tells me it can't find my ksp version in my readme.txt. The readme is still there and displays the correct version number, so I'm not sure what's going on.

 

Edited by Deus Zed Machina

Share this post


Link to post
Share on other sites
17 hours ago, Deus Zed Machina said:

Hi, Mac user here, and whenever I try to run ckan, whether through the command line or the new ckan.app, terminal tells me it can't find my ksp version in my readme.txt. The readme is still there and displays the correct version number, so I'm not sure what's going on.

 

Do you have a buildID.txt file there as well? That is the primary source of version number. What does it say?

Share this post


Link to post
Share on other sites

@politas My buildID.txt says the following:

build id = 01622
2016-12-06_08-18-38
Branch: master

 

Share this post


Link to post
Share on other sites

Posted (edited)

Getting a lot of unhandled exceptions trying to select mods to install - e.g. configurable containers or a lot of linuxguru's mods like Fusebox continued or Crew R&R. Happens when I click the little tickbox before installing, and the "apply changes" button remains greyed out so I can't install.

Exception looks like this:

Spoiler

Exception of type 'CKAN.ModuleNotFoundKraken' was thrown.



See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
CKAN.ModuleNotFoundKraken: Exception of type 'CKAN.ModuleNotFoundKraken' was thrown.
   at CKAN.Registry.LatestAvailable(String module, KspVersionCriteria ksp_version, RelationshipDescriptor relationship_descriptor)
   at CKAN.CkanModule.FromIDandVersion(IRegistryQuerier registry, String mod, KspVersionCriteria ksp_version)
   at CKAN.RelationshipResolver.<RelationshipResolver>c__AnonStorey0.<>m__0(String name)
   at System.Linq.Enumerable.WhereSelectListIterator`2.MoveNext()
   at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
   at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
   at CKAN.RelationshipResolver..ctor(IEnumerable`1 module_names, RelationshipResolverOptions options, IRegistryQuerier registry, KspVersionCriteria kspversion)
   at CKAN.MainModList.ComputeConflictsFromModList(IRegistryQuerier registry, IEnumerable`1 change_set, KspVersionCriteria ksp_version)
   at CKAN.Main.<UpdateChangeSetAndConflicts>c__async1.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at CKAN.Main.<ModList_CellValueChanged>c__async0.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.CompilerServices.AsyncMethodBuilderCore.<>c.<ThrowAsync>b__6_0(Object state)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1637.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
----------------------------------------
ckan
    Assembly Version: 0.0.0.0
    Win32 Version: 0.0.0.0
    CodeBase: file:///C:/Users/Archie/Downloads/Gaming/KSP/Utilities/ckan.exe
----------------------------------------
System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1637.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1638.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
----------------------------------------
System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Transactions
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_64/System.Transactions/v4.0_4.0.0.0__b77a5c561934e089/System.Transactions.dll
----------------------------------------
Microsoft.GeneratedCode
    Assembly Version: 1.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Numerics
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll
----------------------------------------
System.Runtime.Serialization
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1637.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Serialization/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Serialization.dll
----------------------------------------
System.Xml.Linq
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll
----------------------------------------
System.Data
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1636.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
----------------------------------------
Anonymously Hosted DynamicMethods Assembly
    Assembly Version: 0.0.0.0
    Win32 Version: 4.6.1637.0 built by: NETFXREL3STAGE
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_64/mscorlib/v4.0_4.0.0.0__b77a5c561934e089/mscorlib.dll
----------------------------------------
Microsoft.CSharp
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Microsoft.CSharp/v4.0_4.0.0.0__b03f5f7f11d50a3a/Microsoft.CSharp.dll
----------------------------------------
System.Dynamic
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Dynamic/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Dynamic.dll
----------------------------------------
System.EnterpriseServices
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_64/System.EnterpriseServices/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.EnterpriseServices.dll
----------------------------------------
Accessibility
    Assembly Version: 4.0.0.0
    Win32 Version: 4.6.1586.0 built by: NETFXREL2
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

 

EDIT: Uhh...Seems to have fixed itself already? If somebody's responsible for that, thanks!

Edited by baldamundo

Share this post


Link to post
Share on other sites

Posted (edited)

On 25/04/2017 at 2:05 AM, Deus Zed Machina said:

@politas My buildID.txt says the following:


build id = 01622
2016-12-06_08-18-38
Branch: master

 

Ok, that looks fine. Can you run this at a terminal/command prompt?

mono ckan.exe ksp list

That should list your ksp install. If it doesn't, you may need to add it with 

mono ckan.exe ksp add <name> /absolute/path/to/ksp/directory/

 

Edited by politas

Share this post


Link to post
Share on other sites
3 hours ago, politas said:

Ok, that looks fine. Can you run this at a terminal/command prompt?


mono ckan.exe ksp list

That should list your ksp install. If it doesn't, you may need to add it with 


mono ckan.exe ksp add <name> /absolute/path/to/ksp/directory/

 

My install directory is listed correctly and set as the default install, but, unfortunately, it still doesn't work. Is there anything else I could do to fix this? Here's the full error log if that helps:

2313 [1] ERROR CKAN.KSP (null) - Could not find KSP version
CKAN.NotKSPDirKraken: Could not find KSP version in readme.txt
  at CKAN.KSP.DetectVersion (System.String directory) [0x00048] in <db7f644cef3d44268a3a52ddab219b4b>:0 
  at CKAN.KSP.Version () [0x00026] in <db7f644cef3d44268a3a52ddab219b4b>:0 
  at CKAN.Main.<CurrentInstanceUpdated>m__B () [0x00012] in <db7f644cef3d44268a3a52ddab219b4b>:0 
  at CKAN.Util.Invoke[T] (T obj, System.Action action) [0x00035] in <db7f644cef3d44268a3a52ddab219b4b>:0 
  at CKAN.Main.CurrentInstanceUpdated () [0x00001] in <db7f644cef3d44268a3a52ddab219b4b>:0 
  at CKAN.Main.OnLoad (System.EventArgs e) [0x00248] in <db7f644cef3d44268a3a52ddab219b4b>:0 
  at System.Windows.Forms.Form.OnLoadInternal (System.EventArgs e) [0x00029] in <b4e6df1a5a1f4b78af726adaf5fd3ede>:0 

 

Share this post


Link to post
Share on other sites

Posted (edited)

35 minutes ago, Deus Zed Machina said:

My install directory is listed correctly and set as the default install, but, unfortunately, it still doesn't work. Is there anything else I could do to fix this? Here's the full error log if that helps:


2313 [1] ERROR CKAN.KSP (null) - Could not find KSP version
CKAN.NotKSPDirKraken: Could not find KSP version in readme.txt
  at CKAN.KSP.DetectVersion (System.String directory) [0x00048] in <db7f644cef3d44268a3a52ddab219b4b>:0 
  at CKAN.KSP.Version () [0x00026] in <db7f644cef3d44268a3a52ddab219b4b>:0 
  at CKAN.Main.<CurrentInstanceUpdated>m__B () [0x00012] in <db7f644cef3d44268a3a52ddab219b4b>:0 
  at CKAN.Util.Invoke[T] (T obj, System.Action action) [0x00035] in <db7f644cef3d44268a3a52ddab219b4b>:0 
  at CKAN.Main.CurrentInstanceUpdated () [0x00001] in <db7f644cef3d44268a3a52ddab219b4b>:0 
  at CKAN.Main.OnLoad (System.EventArgs e) [0x00248] in <db7f644cef3d44268a3a52ddab219b4b>:0 
  at System.Windows.Forms.Form.OnLoadInternal (System.EventArgs e) [0x00029] in <b4e6df1a5a1f4b78af726adaf5fd3ede>:0 

 

OK, double and triple-check the path that it's reporting. Copy the text from the path listing and

ls -l /the/actual/path

 

Edited by politas

Share this post


Link to post
Share on other sites

 

7 minutes ago, politas said:

OK, double and triple-check the path that it's reporting. Copy the text from the path listing and `ls -l /the/actual/path`

Yeah, turns out I was wrong :S every time I try to add a new path though, it shows the list of commands and doesn't add the new path as far as I can tell

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

egS9xCA.jpg%E2%80%8B%E2%80%8B%E2%80%8B%ETl3k11a.jpg

I am having trouble with getting the correct version of certain mods to load.

CKAN is reporting Auto Detect on final frontier mod but KSP AVC is reporting I'm not on the correct version.  I have manually deleted the FInal Frontier directory and recopied them to game data but this has not solved the problem. I am not sure how I should fix this.

 

Edited by Lucky Spacer
get ckan image in post

Share this post


Link to post
Share on other sites

Posted (edited)

3 hours ago, Lucky Spacer said:

I am having trouble with getting the correct version of certain mods to load.

CKAN is reporting Auto Detect on final frontier mod but KSP AVC is reporting I'm not on the correct version.  I have manually deleted the FInal Frontier directory and recopied them to game data but this has not solved the problem. I am not sure how I should fix this.

 

Try closing CKAN, deleting the mod manually from the GameData folder and then re-opening CKAN.  Download and reinstall Final Frontier from the Compatible list.

I'm not sure if there is a file in the FF directory that you need to keep to preserve your current game awards.  Check that out first but it's likely that these are stored in the persistent.sfs file (under the HallofFameScenario).

Edited by Brigadier
Added warning
2 people like this

Share this post


Link to post
Share on other sites
3 hours ago, Lucky Spacer said:

egS9xCA.jpg%E2%80%8B%E2%80%8B%E2%80%8B%ETl3k11a.jpg

I am having trouble with getting the correct version of certain mods to load.

CKAN is reporting Auto Detect on final frontier mod but KSP AVC is reporting I'm not on the correct version.  I have manually deleted the FInal Frontier directory and recopied them to game data but this has not solved the problem. I am not sure how I should fix this.

 

Note that under "Installed" it says "AD".  That means you installed it manually, CKAN will not touch it.  Thus it will not update it even though it's out of date.  Uninstall manually, then install with CKAN.

2 people like this

Share this post


Link to post
Share on other sites
9 hours ago, Deus Zed Machina said:

 

Yeah, turns out I was wrong :S every time I try to add a new path though, it shows the list of commands and doesn't add the new path as far as I can tell

Are there any spaces in the path to your ksp install, or other characters that might be messing with the ckan command?

Share this post


Link to post
Share on other sites
On 4/27/2017 at 6:37 PM, Loren Pechtel said:

Note that under "Installed" it says "AD".  That means you installed it manually, CKAN will not touch it.  Thus it will not update it even though it's out of date.  Uninstall manually, then install with CKAN.

 

On 4/27/2017 at 6:31 PM, Brigadier said:

Try closing CKAN, deleting the mod manually from the GameData folder and then re-opening CKAN.  Download and reinstall Final Frontier from the Compatible list.

I'm not sure if there is a file in the FF directory that you need to keep to preserve your current game awards.  Check that out first but it's likely that these are stored in the persistent.sfs file (under the HallofFameScenario).

This worked.  I had missed one of the manual FInal Frontier installs I had done.  Thank you very much.

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now