DoctorDavinci

[1.3] BDArmory Continued v0.2.1.1 [5/28/2017] + Vessel Mover, Camera Tools, BDMk22, Destruction Effects, Burn Together

820 posts in this topic

1 hour ago, toric5 said:

is there any bd armooury pack that foucuses on space based weapons platforms? railguns, coilguns, realistic lasers, or space optimized missiles?

You play CoaDE? 

Share this post


Link to post
Share on other sites
Just now, Svm420 said:

You play CoaDE? 

yup! or i did, now im waiting for a linux release!

1 person likes this

Share this post


Link to post
Share on other sites
7 hours ago, SpannerMonkey(smce) said:

Fair enough, a valid point I s'pose, I'll think on it a bit

Hey, look those photo.I meet a big BUG

 

On 2017/1/29 at 2:54 PM, BF2_Pilot said:

Is it all right?

m4QgS4t.png

zWnYIuH.png

C5MqgoR.png

Lm3XffT.png

And could you tell me what is wrong with it?

jg1ms6G.jpg

6EQlRfQ.jpg

 

 @SpannerMonkey(smce)  

 

Share this post


Link to post
Share on other sites
5 hours ago, BF2_Pilot said:

Hey, look those photo.I meet a big BUG

 

 

We have a known issue regarding the particles effects. I also suggest to disable the Aero FX when playing BDArmory to avoid a huge performance hit while using missiles.

2 people like this

Share this post


Link to post
Share on other sites
19 hours ago, Svm420 said:

You play CoaDE? 

oh boy

I like smashing two toilet paper tubes together.

Share this post


Link to post
Share on other sites
On 2017/1/30 at 10:33 PM, jrodriguez said:

We have a known issue regarding the particles effects. I also suggest to disable the Aero FX when playing BDArmory to avoid a huge performance hit while using missiles.

Ok.I hope you will fix the bug soon.

Share this post


Link to post
Share on other sites

So Red Vs Blue got updated/continued recently by @TMasterson5. However the bomb bays don't open when it is set in guard mode. How would I go about making the bays open when in guard mode?

Share this post


Link to post
Share on other sites
1 hour ago, War Eagle 1 said:

So Red Vs Blue got updated/continued recently by @TMasterson5. However the bomb bays don't open when it is set in guard mode. How would I go about making the bays open when in guard mode?

By me figuring out how to make cargo bays according to the stock cfg way of id'ing something as a cargo bay. 

Share this post


Link to post
Share on other sites
2 hours ago, War Eagle 1 said:

So Red Vs Blue got updated/continued recently by @TMasterson5. However the bomb bays don't open when it is set in guard mode. How would I go about making the bays open when in guard mode?

Even though you received an answer, might I suggest when inquiring about a mod that you take it to that mods thread

 

1 person likes this

Share this post


Link to post
Share on other sites
2 hours ago, DoctorDavinci said:

Even though you received an answer, might I suggest when inquiring about a mod that you take it to that mods thread

 

I appreciate the thought but I know this guy personally it's all good person whose name I won't mention! :wink:  

 

And also i so I think he was asking for general advice outside of just me, which I'm open to hearing also as I have zero idea how to make cargo behaves behave properly......

1 person likes this

Share this post


Link to post
Share on other sites

One little thing to ask. In the changelog i noticed that a new penetration feature is added. Could you explain more about it?(The old thread with detailed changelog is gone ;(

Share this post


Link to post
Share on other sites
15 hours ago, TMasterson5 said:

I appreciate the thought but I know this guy personally it's all good person whose name I won't mention! :wink:  

 

And also i so I think he was asking for general advice outside of just me, which I'm open to hearing also as I have zero idea how to make cargo behaves behave properly......

My advice would be to first take a look at the part configs for all the stock bays as BDAc checks for if missiles are in cargo bays (selected in the SPH/VAB through a missiles right click menu)

If you model your part configs after the stock cargo bay configs (look for what settings are common between them) you should be able to get those bays playing nicely with BDAc since it doesn't change how the stock cargo bays work (just hooks into the stock system)

 

1 person likes this

Share this post


Link to post
Share on other sites
2 minutes ago, DoctorDavinci said:

My advice would be to first take a look at the part configs for all the stock bays as BDAc checks for if missiles are in cargo bays (selected in the SPH/VAB through a missiles right click menu)

If you model your part configs after the stock cargo bay configs (look for what settings are common between them) you should be able to get those bays playing nicely with BDAc since it doesn't change how the stock cargo bays work (just hooks into the stock system)

 

Yeah Im fairly certain I have a general idea how to get them working, just havent had the time to actually test my theory yet. soon.....

Share this post


Link to post
Share on other sites
11 minutes ago, TMasterson5 said:

Yeah Im fairly certain I have a general idea how to get them working, just havent had the time to actually test my theory yet. soon.....

Keep us posted ... If your idea doesn't work then it may involve a bit of code diving to dig up specifically how BDAc is hooking into that part of the KSP system

1 person likes this

Share this post


Link to post
Share on other sites

This is just a quick question from me: Is it possible that BDAc is quite unstable with 1.2.2? I'm having a lot of crashes if I use BDAc, I also use other mods but they are stable enough so that it doesn't crash all the time. I don't know where it comes from, just that it happens. If asked I will put up all my mods for a compatibility check or something( if there is one).

thanks in advance

edit: I've done some checking myself and it seems that either the series of "the wildblueindustries" or BDAc causes the other to crash. can't say for sure since i have had problems with both.

Edited by WhiteSagettarius
adding information

Share this post


Link to post
Share on other sites
7 hours ago, WhiteSagettarius said:

This is just a quick question from me: Is it possible that BDAc is quite unstable with 1.2.2? I'm having a lot of crashes if I use BDAc, I also use other mods but they are stable enough so that it doesn't crash all the time. I don't know where it comes from, just that it happens. If asked I will put up all my mods for a compatibility check or something( if there is one).

thanks in advance

edit: I've done some checking myself and it seems that either the series of "the wildblueindustries" or BDAc causes the other to crash. can't say for sure since i have had problems with both.

If you provided your crash logs and whether or not it's 64 or 32 bit, it would help. 

I personally don't know what to look for in them, apart from an out of memory error, but I imagine the guys working on BDAc definitely know what to look for.

Also, make a post in the NASA MSEV forum topic (with the crash log and ksp bit version as well).

My advice is to take all your mods and put them in a different folder (IE in the desktop in a folder), and re-add them one by one to find which mod causes the crash.
It's time consuming, yeah, but it'll definitely find your problem mod. (Well, that's been my experience anyways)


P.S. If you can provide steps for reproducing the crash that would help too.

1 person likes this

Share this post


Link to post
Share on other sites
14 hours ago, WhiteSagettarius said:

This is just a quick question from me: Is it possible that BDAc is quite unstable with 1.2.2? I'm having a lot of crashes if I use BDAc, I also use other mods but they are stable enough so that it doesn't crash all the time. I don't know where it comes from, just that it happens. If asked I will put up all my mods for a compatibility check or something( if there is one).

thanks in advance

edit: I've done some checking myself and it seems that either the series of "the wildblueindustries" or BDAc causes the other to crash. can't say for sure since i have had problems with both.

A5eeK0s.jpg

A log is better than bad, it's good :wink:

Spoiler

 

All joking aside, I refer you to the following post where you will discover how to help us help you 

 

Edited by DoctorDavinci

Share this post


Link to post
Share on other sites
1 hour ago, DoctorDavinci said:

A5eeK0s.jpg

A log is better than bad, it's good :wink:

  Reveal hidden contents

 

All joking aside, I refer you to the following post where you will discover how to help us help you 

 

thnx I followed this list and apparently it's indeed a problem with the 32 bit ksp not being able to handle the list of mods. 64 bit should work fine. Tested it with multiple times with a vehicle that crashed the 32 bit multiple times and haven't had a single crash with the 64 bit yet

2 people like this

Share this post


Link to post
Share on other sites

I've just returned to KSP after a long hiatus and couldn't find thid mod, was worried it had been discontinued. So a bunch of threads in the Addons section were deleted?

 

EDIT: My god this thread is difficult to find. Searching "BDArmory" in google just yields a bunch of addons for BDA. Took me 10 minutes of searching until i realised I could see my posting history.

Edited by Hoddd9000

Share this post


Link to post
Share on other sites
8 minutes ago, Hoddd9000 said:

I've just returned to KSP after a long hiatus and couldn't find thid mod, was worried it had been discontinued. So a bunch of threads in the Addons section were deleted?

Yes the software glitched and every thread on the first page of Addin Releases was permanently removed. Squad tried to bring them back but the backup system the forum uses only allows for full restores not partial ones. 

Edited by TheRagingIrishman
typo

Share this post


Link to post
Share on other sites

So I just got back to playing KSP after a few months, and the mod you posted the link to is very buggy for me.

When I load up the game the parts are all there,  but all the pictures and logos are white.

It also doesnt seem to detect that the weapon manager is on the craft.

Is anyone else getting this problem?

Share this post


Link to post
Share on other sites
1 hour ago, DYo12234 said:

So I just got back to playing KSP after a few months, and the mod you posted the link to is very buggy for me.

When I load up the game the parts are all there,  but all the pictures and logos are white.

It also doesnt seem to detect that the weapon manager is on the craft.

Is anyone else getting this problem?

I refer you to the following thread:

However, from what you describe it sounds like you are using the wrong version of the mod for the version of KSP you are running

I recommend updating KSP to v1.2.2 and using the latest version of BDAc

Please note that versions prior to BDAc v0.11.1.6 are no longer supported ... This means that only the most recent version of BDAc is supported as of the date of this post

 

1 person likes this

Share this post


Link to post
Share on other sites

Good evening all,

I have been having the same problem as DYo12234, and and am seeking advice.  I have done four hard resets and as far as i can tell this is an issue with the mod itself and not an conflict with another mod. 

Vs. 1.2.2 / 64bit

Prob. Bdarmory weapon manager is non functional, and only some of the weapons work[ mainly missiles, though most only give a jettison option] as well, toolbar button is white and non functional.

MDs/Ins.  BDArmory Vs. 0.11.1.6

*Not sure how to give a log, or link steam screenshots of issue in question.

 

Progressively,

TheAshenHat

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now