DoctorDavinci

[1.3] BDArmory Continued v0.2.1.1 [5/28/2017] + Vessel Mover, Camera Tools, BDMk22, Destruction Effects, Burn Together

591 posts in this topic

hi, i have 1.2.2 and i been trying to get your really cool mod to work. but its not working for me. iv been watching videos how to use this mod. the weapon module is not working for me , for some reason. i did what the people in the videos iv watched but it doesn't seem to work i used the BDArmory and BDArmory continued both of them do the same. what do i do. 

thanks for your time.

Share this post


Link to post
Share on other sites

Install only one of them (the continued one) and provide logs.

2 people like this

Share this post


Link to post
Share on other sites

 And also please use the Github issues section for this.

1 person likes this

Share this post


Link to post
Share on other sites

Not asking when the update is coming out. 

Just wondering how things are going. Like if anything new and exciting is happing on the teams end.

If not its cool. Just curious is all

Share this post


Link to post
Share on other sites
26 minutes ago, War Eagle 1 said:

Not asking when the update is coming out. 

soon

26 minutes ago, War Eagle 1 said:

Like if anything new and exciting is happening on the teams end.

Its is

26 minutes ago, War Eagle 1 said:

Just curious is all

Curiosity is allowed :)

 

2 people like this

Share this post


Link to post
Share on other sites
8 minutes ago, SpannerMonkey(smce) said:

soon

Its is

Curiosity is allowed :)

 

may we have any sneak peaks or sneaky leaks about the new stuff?:wink:

Edited by WhiteSagettarius

Share this post


Link to post
Share on other sites

Good evening all,

I have been having the same problem as DYo12234, and and am seeking advice.  I have done four hard resets and as far as i can tell this is an issue with the mod itself and not an conflict with another mod. 

Vs. 1.2.2 / 64bit

Prob. Bdarmory weapon manager is non functional, and only some of the weapons work[ mainly missiles, though most only give a jettison option] as well, toolbar button is white and non functional.

MDs/Ins.  BDArmory Vs. 0.11.1.6

Log's.https://www.dropbox.com/s/fuxayhl4i7ykjsa/output_log.txt?dl=0

Ksplog. https://www.dropbox.com/s/czekx3drhl2puxr/KSP.log?dl=0

Screenshot. JwKPE3h.jpg

 

Sorry for taking so much of your time.

\By the way, the "How to get support [read first] " , give's me this " NOTE: These logs are not the same as KSP.log, which lacks valuable data. Do not upload KSP.log; do upload output_log.txt / Player.log "

I assumed from that, that you needed the output, not the ksp.log\

Progressively,

TheAshenHat

Edited by TheAshenHat
Adding more log's.

Share this post


Link to post
Share on other sites
1 hour ago, SpannerMonkey(smce) said:

soon

Its is

Curiosity is allowed :)

 

cheeky but I laughed. Thanks 

Share this post


Link to post
Share on other sites
2 hours ago, TheAshenHat said:

Good evening all,

I have been having the same problem as DYo12234, and and am seeking advice.  I have done four hard resets and as far as i can tell this is an issue with the mod itself and not an conflict with another mod. 

Vs. 1.2.2 / 64bit

Prob. Bdarmory weapon manager is non functional, and only some of the weapons work[ mainly missiles, though most only give a jettison option] as well, toolbar button is white and non functional.

MDs/Ins.  BDArmory Vs. 0.11.1.6

Log's.https://www.dropbox.com/s/fuxayhl4i7ykjsa/output_log.txt?dl=0

KSP.log please ... I refer you to the following thread where it describes in detail everything that is required for us to help you:

 

9 hours ago, toxic reaper said:

hi, i have 1.2.2 and i been trying to get your really cool mod to work. but its not working for me. iv been watching videos how to use this mod. the weapon module is not working for me , for some reason. i did what the people in the videos iv watched but it doesn't seem to work i used the BDArmory and BDArmory continued both of them do the same. what do i do. 

thanks for your time.

I refer you to the following thread where it describes in detail everything that is required for us to help you:

Share this post


Link to post
Share on other sites

@TheAshenHat - You have installed BDAc incorrectly ... I have amended the OP to provide an explanation on how to correctly install BDAc

First download the latest release (not the source download) and then extract the BDArmory folder contained within the zip file and place it into your KSP/Gamedata folder ... Do not, I repeat, do not place the Gamedata folder contained within the BDAc zip into your Gamedata folder as this will cause umpteen million conflicts to arise as the BahaTurret pickle looks for textures, configs and whatnot in specific places

3 people like this

Share this post


Link to post
Share on other sites

I googled and cound find a thread for it, so can I suggest different AI modes for vehicles, vtols and types of planes?

 

I imagine some would be easier to implement than others.

 

 

For example, I imagine making a jet that does Boom and zoom instead of turn fighting is just the changing of a few things.

Share this post


Link to post
Share on other sites

Hi @USB4, welcome to the forums

The ideas that you have suggested are all great and some have been discussed before in the lost thread ... the missile that shall not be named is buried somewhere in that thread too :wink:

Might I suggest jumping over to the BDAc issues page on Github and opening an enhancement request detailing your ideas :) 

The BDAc team uses the Github issues tracker for these types of things which greatly assists the team with keeping track of bugs and all the great suggestions and ideas that the community comes up with

Here's the link: https://github.com/PapaJoesSoup/BDArmory/issues

Edited by DoctorDavinci

Share this post


Link to post
Share on other sites

Hi,

Just downloaded the latest release, and the .version file says it's only good up to 1.2.1

I was working on CKAN issues and found this.

So, would it be possible to get the .version updated (no need to change the actual version, just update the KSP version max) and back on Github?  If not, would it be ok if I patched the CKAN info to force 1.2.2 compatibility?

There is at least one (maybe more) other mods which are waiting for this.

Thanks

Share this post


Link to post
Share on other sites
16 minutes ago, linuxgurugamer said:

Hi,

Just downloaded the latest release, and the .version file says it's only good up to 1.2.1

I was working on CKAN issues and found this.

So, would it be possible to get the .version updated (no need to change the actual version, just update the KSP version max) and back on Github?  If not, would it be ok if I patched the CKAN info to force 1.2.2 compatibility?

There is at least one (maybe more) other mods which are waiting for this.

Thanks

Thanks for bringing that to our attention ... I have opened a Github issue to address this and it should be fixed for the next release of BDAc

In the meantime you can ignore the warning as BDAc is working in 1.2.2

Share this post


Link to post
Share on other sites
Just now, DoctorDavinci said:

Thanks for bringing that to our attention ... I have opened a Github issue to address this and it should be fixed for the next release of BDAc

In the meantime you can ignore the warning as BDAc is working in 1.2.2

It's not a warning, it that CKAN can't index it for 1.2.2 right now.

So with your permission, I'll patch the CKAN info to allow 1.2.2

Share this post


Link to post
Share on other sites
47 minutes ago, linuxgurugamer said:

It's not a warning, it that CKAN can't index it for 1.2.2 right now.

So with your permission, I'll patch the CKAN info to allow 1.2.2

It is our policy not to provide support for CKAN as we have no control over the process beyond listing when deploying to SpaceDock.

However, feel free to make the changes and submit a PR on Github

Share this post


Link to post
Share on other sites
Just now, DoctorDavinci said:

It is our policy not to provide support for CKAN as we have no control over the process beyond listing when deploying to SpaceDock.

However, feel free to make the changes and submit a PR on Github

I understand that, and appreciate your feedback

Share this post


Link to post
Share on other sites

I see this thread is active, is there any new release? I missed my working bomb reticles..

Share this post


Link to post
Share on other sites
3 minutes ago, jrodriguez said:

The last release is from November

https://github.com/PapaJoesSoup/BDArmory/releases

Nope, i use this but doesnt fix the issue.

I have seen few people having same issue but need to confirm, does everyone have same issue? bomb reticle showing under plane not where it should hit if plane is higher than 250m or so?  (i also seen they found way to solve issue in github around december but there is no release yet.)

Edited by qromodynmc

Share this post


Link to post
Share on other sites
16 minutes ago, qromodynmc said:

Nope, i use this but doesnt fix the issue.

I have seen few people having same issue but need to confirm, does everyone have same issue? bomb reticle showing under plane not where it should hit if plane is higher than 250m or so?  (i also seen they found way to solve issue in github around december but there is no release yet.)

Ok, then it will be released soon :)

Share this post


Link to post
Share on other sites
41 minutes ago, jrodriguez said:

Ok, then it will be released soon :)

Are you speaking for the team, or just hopeful?
I'm asking because if it will be within a day or so, I won't bother updating CKAN with a patch to fix the bad .version file

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
43 minutes ago, linuxgurugamer said:

Are you speaking for the team, or just hopeful?
I'm asking because if it will be within a day or so, I won't bother updating CKAN with a patch to fix the bad .version file

You are better off updating CKAN (thanks for that). "Soon" has a different meaning for each person. In my case, "soon" is something between 2 weeks and  1 month "hopefully." I'm speaking as a BDArmory developer.

Edited by jrodriguez
1 person likes this

Share this post


Link to post
Share on other sites

Ok, thanks

Share this post


Link to post
Share on other sites
3 hours ago, qromodynmc said:

Nope, i use this but doesnt fix the issue.

I have seen few people having same issue but need to confirm, does everyone have same issue? bomb reticle showing under plane not where it should hit if plane is higher than 250m or so?  (i also seen they found way to solve issue in github around december but there is no release yet.)

As was stated by one of our esteemed team members a few weeks ago in response to your asking of the same question, this issue has been fixed and will be included in the next release

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now