DoctorDavinci

[1.3] BDArmory Continued v0.2.1.1 [5/28/2017] + Vessel Mover, Camera Tools, BDMk22, Destruction Effects, Burn Together

593 posts in this topic

Posted (edited)

@DoctorDavinci 

I wont speak directly for @Nertea, but IIRC, it was he that I recently asked about the box collider errs... Its not just his mods throwing them, but many others...

IIRC, his response was that its caused by parts that were modelled in Unity 4.x, and the errs appear when played with an updated KSP version after it updated to Unity 5...

So, IIRC, nothing to be done, other than to re-model the parts in Unity 5...

THAT being said, IIRC, his MkIV mod had recent discussion about collider issues, especially with the cargo bay parts, that I think were unrelated to this err... ???

Edited by Stone Blue

Share this post


Link to post
Share on other sites
2 hours ago, DoctorDavinci said:

@Djohaal - I took a look at your logs and I see errors being thrown by the MarkIVSytems mod which seems to be screwing with the colliders of the parts you are using on your craft

This is a sample of what I am talking about:

  1. [WRN 15:20:54.106] BoxColliders does not support negative scale or size.
  2. The effective box size has been forced positive and is likely to give unexpected collision geometry.

This is one of the parts that generate the error:

Scene hierarchy path "mk4cargo-2/model/MarkIVSystem/Parts/Fuselage/mk4cargo-2(Clone)/Mk4CargoMedium/ColliderFloor003"

I will do some tests when I get home with a stock install to determine if this is a mod interaction issue

I still haven't managed to home on faulty colliders as the cause, but it -seems- from my gameplay experience some specific parts seem to trigger the bug while other vessels behave normally. I've not done systematic testing to prove it though.

Share this post


Link to post
Share on other sites

I might be blind but how do I download it? XD

Share this post


Link to post
Share on other sites

Posted (edited)

Still works great in 1.2.9 beta!

DxQY71m.png

Just need to recompile is all (it was crashing otherwise on game load).

Not sure if its just mne, but 1.2.9 seems to perform a bit better, it normally lags a tad when you have 4 vs 4 dogfights, not that bad in 1.2.9...

Edited by panzer1b
3 people like this

Share this post


Link to post
Share on other sites
On 17/03/2017 at 2:04 AM, Stone Blue said:

@DoctorDavinci 

I wont speak directly for @Nertea, but IIRC, it was he that I recently asked about the box collider errs... Its not just his mods throwing them, but many others...

IIRC, his response was that its caused by parts that were modelled in Unity 4.x, and the errs appear when played with an updated KSP version after it updated to Unity 5...

So, IIRC, nothing to be done, other than to re-model the parts in Unity 5...

THAT being said, IIRC, his MkIV mod had recent discussion about collider issues, especially with the cargo bay parts, that I think were unrelated to this err... ???

Hiya, Re the negative scale box colliders. This has absolutely nothing to do with being modeled in U4 compared to U5, It is caused by one thing and one thing only, simply that there are indeed negative scale box colliders, a negative scale box collider is created when adjusting the size of a box collider in unity, 

The problem only usually occurs on small thin colliders. It is all to easy when adjusting a   collider to be,  for example  1 x 1 x 0.01 for that tiny 0.01 to flip to - 0.01.  It's quite an insidious error as in scene unless you actually note the values, there is no visible difference between a pos scale box collider and a negative scale version

There is nothing else I've found that will cause it except this, and I have had a load of them to fix. The fix is quick but needs access to the scene, usually it can be fixed by simply deleting the minus sign in front of the relative scale value. ( there may be another way to fix it though,  as this value is recorded in the mu but that requires investigation)

I do grant however that prior versions of unity did not report this as an error , which explains why so many mods and parts including stock ones are producing this similar error, there's a good chance that many parts in many parts mods have actually been around for many unity versions without  problems, which has been great for mod makers all around, but now a lot of old parts will need a revisit. For my part I simply redid every single one that shows up, Being a hoarder of unity projects means I have access to everything I've ever done, some of the projects have gone from U3 to U5 in upgrades

The hardest part of the whole job for a mod maker will be finding the damn scene the part is in after so long .

 

 

 

 

2 people like this

Share this post


Link to post
Share on other sites

@SpannerMonkey(smce) ,

Thank you for that answer. Thats the most informative I've found in my searches for this err.
Again, I stated, "IIRC", as to the information I got, possibly from Nertea... I know we had a short discussion, as I've had with some others, so theres a good chance I didnt remember exactly where that response came from... Unfortunately, I have a REALLY bad memory... :P

I've been digging around some old mod parts, and many have this err, so I'll be happy to see if this fix fixes them...

Thank You

Share this post


Link to post
Share on other sites
22 minutes ago, Andrew Hei said:

Huh it didn't work yesterday :huh:

Here is the link to BDAc v0.11.1.6 https://github.com/PapaJoesSoup/BDArmory/releases

Be advised that it is ONLY for KSP version 1.2.2 .... this means if you are trying to use it on the 1.2.9 pre-release then your out of luck for the time being

The team has been working feverishly to bring new features and squash bugs over the past few months, however the likelihood of a release before KSP v1.3 is released is unlikely at this time (subject to change at our discretion)

2 people like this

Share this post


Link to post
Share on other sites

Nah im on 1.2.2 I don't usually play unstable and there are pretty much no mods at the time.

Share this post


Link to post
Share on other sites
21 minutes ago, Andrew Hei said:

Nah im on 1.2.2 I don't usually play unstable and there are pretty much no mods at the time.

In that case did you install it correctly,?  it's difficult to tell from your awesome bug report . See first post for bug reporting details

1 person likes this

Share this post


Link to post
Share on other sites
Just now, SpannerMonkey(smce) said:

In that case did you install it correctly,?  it's difficult to tell from your awesome bug report . See first post for bug reporting details

I mean the website didn't work

Share this post


Link to post
Share on other sites
39 minutes ago, DoctorDavinci said:

Here is the link to BDAc v0.11.1.6 https://github.com/PapaJoesSoup/BDArmory/releases

Be advised that it is ONLY for KSP version 1.2.2 .... this means if you are trying to use it on the 1.2.9 pre-release then your out of luck for the time being

The team has been working feverishly to bring new features and squash bugs over the past few months, however the likelihood of a release before KSP v1.3 is released is unlikely at this time (subject to change at our discretion)

Brilliant! Thanks so much guys for your hard work and dedication!

Share this post


Link to post
Share on other sites
19 minutes ago, Andrew Hei said:

I mean the website didn't work

The issue lies on your end as I am having no issue with accessing github nor the releases link I provided above

Share this post


Link to post
Share on other sites
9 hours ago, DoctorDavinci said:

Be advised that it is ONLY for KSP version 1.2.2 .... this means if you are trying to use it on the 1.2.9 pre-release then your out of luck for the time being

If you guys (@BDATeam) are ok with it, i could upload a version of the .dll that has been recompiled for those of us so inclined to use BDA in the beta.  No changes to teh code have been made, and the only thing that needed updating was the actual dll itself (guns and all work just like they did).

Share this post


Link to post
Share on other sites

Hi, I was just using BDA Autopilot and I saw it doesn't recognize Firespitter engine as engine, thus throttling down to zero and doing nothing. Is there any fix/patch/MM Patch or somethign I can do about it?

Share this post


Link to post
Share on other sites

Posted (edited)

You may want to change the default GUI location to the top left corner. I changed game resolution today and BDArmory GUI is missing on my screen, and I am assuming that it is out of the screen boundary.

I just figured out that I can change them in setting.cfg.

Edited by damowang2
1 person likes this

Share this post


Link to post
Share on other sites
5 hours ago, damowang2 said:

You may want to change the default GUI location to the top left corner. I changed game resolution today and BDArmory GUI is missing on my screen, and I am assuming that it is out of the screen boundary.

I had the same issue! I will open an issue on GitHub. 

Share this post


Link to post
Share on other sites
33 minutes ago, jrodriguez said:

I had the same issue! I will open an issue on GitHub. 

Open setting.cfg and change BDAWindows setting.

Share this post


Link to post
Share on other sites

Posted (edited)

What weight measurement are bullets? (e.g. Measured in tons? Grams?)

Edited by Murican_Jeb

Share this post


Link to post
Share on other sites

Posted (edited)

11 hours ago, Murican_Jeb said:

What weight measurement are bullets? (e.g. Measured in tons? Grams?)

I think tons because the standard weight for bullets is either 10.xxe-6<-grams or 1.xxxe-5 (tetryds uses this one, i have no clue why)


Edit: another sensible measurement would be kg 1.xxxe-3

Edited by Skyer
1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

@Murican_Jeb@Skyer

Bullet and shell mass is described in metric tonnes . 

The value in the resource definition is the weight of  shell case projectile and charge, so considerably heavier than the actual bullet mass .

The value used in the weapon config for bullet mass is supposed to be a percentage of the resource value.  

The reason most of us use  4.25e-6 for example is that it's a lot tidier and more bug resistant than writing 0.00000425  missing a zero can have a dramatic effect on how a weapons system behaves,

Edited by SpannerMonkey(smce)
1 person likes this

Share this post


Link to post
Share on other sites

Thanks.

I know this gram to metric ton converter and I know how to find weights of bullets (which are mostly measured in grams) and convert the weight measurements.

Speaking of that, @Skyer should I look into your mod and check if the bullet weight is correct?

Share this post


Link to post
Share on other sites
29 minutes ago, Murican_Jeb said:

Speaking of that, @Skyer should I look into your mod and check if the bullet weight is correct?

HI re this I'd advise caution, real world shell values do not work too well when applied to KSP and BDA. @TheDog and i spent a month or so beating the numbers around  and more or less decided that the real numbers are pretty irrelevant, and seriously considered proposing  a fixed range of values for every shell /bullet type, that way it could be assured that mod X's 30mm will perform like mod A's 30 and so on down the line.  It is still something I'm very much in favor of and 90% of SM weapons were tweaked accordingly .

AS a point of reference we looked at ALL the popular weapon packs and the values differed wildly in some cases, and fell way outside what i and others consider "keeping it real for KSP" .  Everything was looked at from range and dispersion to firing rate and heat output both on firing and on target impact, some of the values there are hilarious, in only how far away from any reality be  it this one or the 65% world of Kerbs,

TLDR

real is not balanced!

1 person likes this

Share this post


Link to post
Share on other sites
26 minutes ago, SpannerMonkey(smce) said:

 

real is not balanced!

 

(Installs RO)

Better?

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now