Nertea

[1.3.0] Near Future Technologies (June 19)

805 posts in this topic

44 minutes ago, Dr. Jet said:

0.625m one consumes gas and EC, but does not provide any thrust in Xenon mode. Thrust is OK in Argon mode though. 

Confirmed this on my end. Does not seem to be related to anything involving the Tweak Patch (happens even without it present). Will raise a github issue.

Share this post


Link to post
Share on other sites

Posted (edited)

18 minutes ago, Streetwind said:

Confirmed this on my end. Does not seem to be related to anything involving the Tweak Patch (happens even without it present). Will raise a github issue.

Most possible cause - "ThrustTransform" instead of "thrustTransform" in config. Unity is case-sensitive about object naming.

Edited by Dr. Jet

Share this post


Link to post
Share on other sites
9 hours ago, Gollum1986 said:

Hi,

I have a little question. I made myself a Mining base on a moon using 3 MX-1 Prometheus Fission Reactor and some big radiators. Before the last patch the temperature stopped nicely at 850K (no overheating).  Since the last patch it is always overheating (in atmosphere It still works fine) and more radiators make no difference..  Is this a Bug or has anything changed ??

Nothing has changed in the plugin or in the thermal values in about 4 releases. You'll need to provide much more information in order for there to be any effective troubleshooting, for example a mod list, reproduction steps, a copy of your KSP.log.

16 hours ago, AccidentalDisassembly said:

Continuing my curly braces tour, here's a list of files in NearFutureProps that have missing curly braces somewhere. Dunno if this even matters, but figured maybe it could!

NearFutureProps\Props\Screens\Dummies\MFDLargeBezels\nft_MFD_LargeBezels_DummyScreen02.cfg
NearFutureProps\Props\Screens\Dummies\MFDLargeBezels\nft_MFD_LargeBezels_DummyScreen03.cfg
NearFutureProps\Props\Screens\Dummies\MFDLargeBezels\nft_MFD_LargeBezels_DummyScreen04.cfg
NearFutureProps\Props\Screens\NFTMFD\nft_MFD_Large_Bezels_Type1.cfg
NearFutureProps\Props\Screens\NFTMFD\nft_MFD_Large_Type1.cfg
NearFutureProps\Props\Screens\NFTMFD\nft_MFD_Mini_Type1.cfg
NearFutureProps\Props\Screens\NFTMFD\nft_MFD_Small_Type1.cfg

Were you the one that made like 10 PRs to fix this? If so, you know you can combine many changes into a single PR, right?

4 hours ago, Dr. Jet said:

Most possible cause - "ThrustTransform" instead of "thrustTransform" in config. Unity is case-sensitive about object naming.

If you want to get technical, the case-sensitiveness of this depends entirely on the implementation of the PartLoader :|

Relased NF Propulsion 0.8.7

  • Fixed small typo in VAB VariableIspEngine display
  • Fixed thrust transform typo on 0.625m VASIMR
  • Fixed surface attach node on 0.625m VASIMR
  • Enabled surface attachment on the 0.625/1.25m VASIMR casings
  • New version of NFP Tweak Patch from Streetwind
2 people like this

Share this post


Link to post
Share on other sites
36 minutes ago, Nertea said:

Were you the one that made like 10 PRs to fix this? If so, you know you can combine many changes into a single PR, right?

Nope, couldn't figure out how to make even 1 PR, sadly...

Share this post


Link to post
Share on other sites

Posted (edited)

4 minutes ago, AccidentalDisassembly said:

Nope, couldn't figure out how to make even 1 PR, sadly...

  1. fork Nertea's repository.
  2. clone or download repository to your PC
  3. make code changes and commit them
  4. upload / sync
  5. make pull request
Edited by Three_Pounds

Share this post


Link to post
Share on other sites
1 hour ago, Nertea said:

Were you the one that made like 10 PRs to fix this? If so, you know you can combine many changes into a single PR, right?

That was me, sorry... 

I didn't know you could do that...

Share this post


Link to post
Share on other sites

Posted (edited)

38 minutes ago, AccidentalDisassembly said:

Nope, couldn't figure out how to make even 1 PR, sadly...

2 minutes ago, Benjamin Kerman said:

That was me, sorry... 

I didn't know you could do that...


Guess it's time for a super brief Github tutorial :P

When you edit a file, right at the very bottom where you can submit the edit, Github will ask you whether to commit directly to <branchname> branch, or whether to create a new branch and make a pull request towards the original repository. It looks like this.

Now here's the trick: when you are working on your own repository, it defaults to option 1. But if you go to someone else's repository and press the edit button on the files there, it defaults to option 2. And as a new user, the only thing you know is that you want to make a pull request, so option 2 looks pretty much the right thing, whereas option 1 sounds rather worryingly direct. Would that directly overwrite Nertea's stuff without giving him the choice to review what you were doing?

But that's not it. What actually happened is that the very first time you tried to make any edit to Nertea's stuff, Github created a "fork" of the entire repository in the background and copied it to your account. That fork is now a repository that you own. Therefore, the option "commit directly to branch" actually means "make this change to my fork of the repository instead of sending it directly to the source". This way, instead of making one isolated change and turning it into one isolated pull request ten times in a row, you can make ten changes and all commit them to your fork repository first. Then, you manually make a pull request of that entire branch of your repository you have been committing to, towards the source repository, and it will find and offer for pulling the sum of all changes that you have made. In the end, that means that Nertea sees only one pull request, but it contains ten file changes.

Edited by Streetwind
7 people like this

Share this post


Link to post
Share on other sites
14 hours ago, Nertea said:

Nothing has changed in the plugin or in the thermal values in about 4 releases. You'll need to provide much more information in order for there to be any effective troubleshooting, for example a mod list, reproduction steps, a copy of your KSP.log.

Were you the one that made like 10 PRs to fix this? If so, you know you can combine many changes into a single PR, right?

If you want to get technical, the case-sensitiveness of this depends entirely on the implementation of the PartLoader :|

Relased NF Propulsion 0.8.7

  • Fixed small typo in VAB VariableIspEngine display
  • Fixed thrust transform typo on 0.625m VASIMR
  • Fixed surface attach node on 0.625m VASIMR
  • Enabled surface attachment on the 0.625/1.25m VASIMR casings
  • New version of NFP Tweak Patch from Streetwind

Hi,

Found the problem. It comes with KSP Interstellar Extended 1.12.12. I reinstalled version 1.12.11 again and the radiators are working fine again. So the problem must be somewhere there. Wish I could tell more details. But no clue what to look for... By the way thanks for the great mod´s you do. Thanks     

Share this post


Link to post
Share on other sites

Posted (edited)

2 hours ago, Gollum1986 said:

Hi,

Found the problem. It comes with KSP Interstellar Extended 1.12.12. I reinstalled version 1.12.11 again and the radiators are working fine again. So the problem must be somewhere there. Wish I could tell more details. But no clue what to look for... By the way thanks for the great mod´s you do. Thanks     

Your best bet then is probably to head over to the KSPI development thread with the following in tow:

- An output_log.txt file from when you observed the problem
- A list of mods you have installed, ideally trimmed down as much as you can while still being able to reproduce the issue (e.g. nothing but NF Electrical, KSPI, and their respective dependencies)
- A detailed step by step guide on how to reproduce the problem (even include steps you think are self-explanatory, because they usually aren't to other people)
- Perhaps even a savefile that the author can plug into a test install with the required mods and observe the issue directly

Edited by Streetwind

Share this post


Link to post
Share on other sites

BTW, @Nertea, your "construction" pack is totally amazing ! I'm building a useless Kerbin station, just t play with it !

Share this post


Link to post
Share on other sites

Posted (edited)

@Warzouz

Try with usefull:D

They are great to build something like a switchable tank/supportstation and if you play with USI and CC and have contract with 20k fuel 7k monoprop and 20k EC.... I dont know what it have to look without Nerteas Help!

@Nertea

A great thank you and god speed on your way

Funny Kabooms 

Urses 

 

 

 

 

Edited by Urses
Doublepost?!
1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

@Nertea

Power level slider for VASIMRs is now inverted?

P.S.

VW-10K model is clipped into parent part in the existing designs.

Edited by WildLynx

Share this post


Link to post
Share on other sites

I finished texturing the two reactor models. Probably will release this wednesday or so, plugin needs some fine-tuning

MVNSYDD.pngU1OvMpD.png

Some more pictures in this update album.

1 hour ago, WildLynx said:

@Nertea

Power level slider for VASIMRs is now inverted?

Whatever it is now is the way it is. 

1 hour ago, WildLynx said:

VW-10K model is clipped into parent part in the existing designs.

And I'm not even sorry ;).

 

14 people like this

Share this post


Link to post
Share on other sites

In the update album, what is that attached to the bottom of the 3.75m reactor with all the pipes and stuff. I don't recognize it from any of your mods.

Share this post


Link to post
Share on other sites
1 minute ago, Nertea said:

And I'm not even sorry ;).

Out of likes T_T 

You get a thumb up XD

Realy fine work as ever!

Share this post


Link to post
Share on other sites
17 minutes ago, HoveringKiller said:

In the update album, what is that attached to the bottom of the 3.75m reactor with all the pipes and stuff. I don't recognize it from any of your mods.

That is a fusion pulse engine from the in-development Far Future Tech mod. 

Share this post


Link to post
Share on other sites

Nertea! Your modelling and texturing skills never cease to amaze me!

Share this post


Link to post
Share on other sites

Glad you enjoy :).

I'm pretty close to finishing the Capacitor window and the layout tweaks to the Reactor window. Just a few niggling clip issues to deal with.

fmDjGza.png

8 people like this

Share this post


Link to post
Share on other sites

^^^ What he said. 

What software do you use for modeling?

Share this post


Link to post
Share on other sites
17 hours ago, Benjamin Kerman said:

^^^ What he said. 

What software do you use for modeling?

3D Studio Max, Archaic Edition.

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

On 3/20/2017 at 0:12 PM, WildLynx said:

@Nertea

Power level slider for VASIMRs is now inverted?

P.S.

VW-10K model is clipped into parent part in the existing designs.

There was a warning about this being a possibility a few days (weeks?) ago.  I would retire existing ships before updating.  Or not.

 

@Nertea nice pics!  Amaze-b&lls as always

Edited by smotheredrun

Share this post


Link to post
Share on other sites

Hey @Nertea,

Just wanted to alert you that the 30 degree variants of NFC's octo truss (truss-octo-angled-01.cfg and truss-octo-angled-01.cfg) are snapping to 27 degrees rather than 30. It looks like it's just a precision/rounding issue. If you change the line:

node_stack_top03 = 0.0, 0.665, 0.197, 0.0, 0.86602540378, 0.5, 2

to 

node_stack_top03 = 0.0, 0.665, 0.197, 0.0, 0.86602540378443864676372317075294, 0.5, 2

then it snaps correctly and 3x30 degree adapters = 90 degrees :)

Share this post


Link to post
Share on other sites
3 hours ago, eddiew said:

Hey @Nertea,

Just wanted to alert you that the 30 degree variants of NFC's octo truss (truss-octo-angled-01.cfg and truss-octo-angled-01.cfg) are snapping to 27 degrees rather than 30. It looks like it's just a precision/rounding issue. If you change the line:

node_stack_top03 = 0.0, 0.665, 0.197, 0.0, 0.86602540378, 0.5, 2

to 

node_stack_top03 = 0.0, 0.665, 0.197, 0.0, 0.86602540378443864676372317075294, 0.5, 2

then it snaps correctly and 3x30 degree adapters = 90 degrees :)

Are you sure? This seems correct to me:

bOovK0U.png

 

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

17 hours ago, smotheredrun said:

There was a warning about this being a possibility a few days (weeks?) ago.  I would retire existing ships before updating.  Or not.

Could not find any warnings, except note, that new model will  be longer. May be it means, that it would clip, may be not.

I just reverted to older version.

For me, part is just a box with functions. Clipping may cause problems, not so shiny model is not.

Also, I'm not inclined to retire my ships because of new part model, without any significant benefits. They are pretty big, expensive, and difficult to assemble - I docked big modules with less then 0.5 degree of angular error. Also, I accumulated big pool of experience of their efficient exploitation.

Compatibility is way more important for me then looks.

 

Edited by WildLynx

Share this post


Link to post
Share on other sites
1 hour ago, WildLynx said:

Could not find any warnings, except note, that new model will  be longer. May be it means, that it would clip, may be not.

I just reverted to older version.

For me, part is just a box with functions. Clipping may cause problems, not so shiny model is not.

Also, I'm not inclined to retire my ships because of new part model, without any significant benefits. They are pretty big, expensive, and difficult to assemble - I docked big modules with less then 0.5 degree of angular error. Also, I accumulated big pool of experience of their efficient exploitation.

Compatibility is way more important for me then looks.

Then you are not the target audience for this mod. If you want boxes with functions that never change shape or evolve, suggest you grab blender and make some grey cylinders. Maybe learn to lay out IVAs while you're at it because that seems to bug you inordinately too. 

I never provide any guarantee of stability, content, or state that things will not change. Particularly note that the version #s of all NFT packs are  <1.0.

 

6 people like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now