ProtoJeb21

[1.2.2] [Kopernicus] Interstellar Adventure Revived v1.2.0 - The New TRAPPIST-1 System! [8Mar17]

125 posts in this topic

I installed first Kopernicus and then this mod (Dropped the zip files in the game data folder, like any other mod), but all the Stars are orbiting The Sun "Kerbol". Is this normal or Am I doing something wrong? 

Share this post


Link to post
Share on other sites
16 hours ago, Deltathiago98 said:

I installed first Kopernicus and then this mod (Dropped the zip files in the game data folder, like any other mod), but all the Stars are orbiting The Sun "Kerbol". Is this normal or Am I doing something wrong? 

It is normal, its not really a big deal since they are SO far away they will most likely not move around in their orbit.

Share this post


Link to post
Share on other sites
On 2/4/2017 at 0:45 PM, Piratepete5 said:

It is normal, its not really a big deal since they are SO far away they will most likely not move around in their orbit.

Oh thank you. Still, it would be cool to have some independent systems tough... Love the pack!

Share this post


Link to post
Share on other sites

hxSjrMw.png

Sending a probe to Trappist-1 as we speak. A short 71 year flight. :P

Thank you for the mod ProtoJeb21!

1 person likes this

Share this post


Link to post
Share on other sites
On 3/31/2017 at 3:54 PM, AceCrafted said:

Is this mod suitable for career?

 

That's actually a good question. While the mod is not known to cause spontaneous location-changing for vessels (except when Hyper Edit) is installed, there are no contract patches and the science values may be a tad too high. Also, I don't have any custom science descriptions for the celestial objects....mostly because there's nearly 50 of them and writing so many science defs would kill me :confused:

On 4/1/2017 at 8:55 PM, Deltathiago98 said:

I installed first Kopernicus and then this mod (Dropped the zip files in the game data folder, like any other mod), but all the Stars are orbiting The Sun "Kerbol". Is this normal or Am I doing something wrong? 

It's fine. They're meant to orbit Kerbol, but I'm planning on making a galactic core in a later version:

___________________________________________________________________________________________________________________________________________________________________________________________

DEVELOPMENT UPDATE: Over the last few weeks I've been pretty consumed with schoolwork and SCIENCE, but I have gotten most of version 1.2.1 done. However, there's a bug where I can't remove, cut+paste or delete anything in my GameData folder, so for now development has been halted. Sorry. :( 

On 3/30/2017 at 8:58 PM, Something_Smith said:

Will there be a biomes update at any point? I just downloaded SCANsat and ive been having a lot of fun checking out the biomes of planets from space, but once i got to the new stars none of them had their own biome maps, they were all borrowed from other planets/moons

Only a few have customs biomes ATM. I'm planning on adding more in the future.

1 person likes this

Share this post


Link to post
Share on other sites

I just noticed a problem, whenever i leave Kerbins sphere of influence, I suddenly beeline directly towards Cerventes, I changed the sphere of influence to make it smaller and i also moved all the stars absurdly far away but Cerventes still becomes the dominant body whenever i am supposed to be orbiting the Sun

Share this post


Link to post
Share on other sites
13 hours ago, Something_Smith said:

I just noticed a problem, whenever i leave Kerbins sphere of influence, I suddenly beeline directly towards Cerventes, I changed the sphere of influence to make it smaller and i also moved all the stars absurdly far away but Cerventes still becomes the dominant body whenever i am supposed to be orbiting the Sun

I found a way to fix this, what you have to do Is change the star from orbiting kerbol, to orbiting lich, sadly I could not figure out how to move lich without it effecting the orbits, but this gets all the stars to close, or far distances if you want.

Share this post


Link to post
Share on other sites
2 hours ago, Piratepete5 said:

I found a way to fix this, what you have to do Is change the star from orbiting kerbol, to orbiting lich, sadly I could not figure out how to move lich without it effecting the orbits, but this gets all the stars to close, or far distances if you want.

Yes it worked! Thank you for this, I had just launched an interplanetary craft in career and it didnt go as expected lol

Share this post


Link to post
Share on other sites

Contracts with this mod are currently bugged. I haven't left the kerbal system yet and it's wanting me to go explore the lich and make a station around dragur.

Share this post


Link to post
Share on other sites
8 hours ago, jibidabo said:

Contracts with this mod are currently bugged. I haven't left the kerbal system yet and it's wanting me to go explore the lich and make a station around dragur.

This mod does not yet have custom contracts for the 40-something objects added in. That's something on the to-do list. To try and limit the amount of objects in need of extra features (science defs, clouds, etc.) I may remove the Trappist-1 system and make it its own mod.

Also, @amarius1 I'm unable to work on the mod for some time (stupid computer won't let me cut+paste or delete files in Gamedata), so can you try to help me out with a few things?

Share this post


Link to post
Share on other sites
8 hours ago, ProtoJeb21 said:

This mod does not yet have custom contracts for the 40-something objects added in. That's something on the to-do list. To try and limit the amount of objects in need of extra features (science defs, clouds, etc.) I may remove the Trappist-1 system and make it its own mod.

Also, @amarius1 I'm unable to work on the mod for some time (stupid computer won't let me cut+paste or delete files in Gamedata), so can you try to help me out with a few things?

I will try. My time is also very very slim and I have barelly gotten time to touch my computer last week. The last Kerbol Origins was released on pretty much that one day...

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

 @ProtoJeb21 the cervantes SOI is 49,034,443,037 km and it's SMA is 47,200,000,000km. can you tell me what's wrong?

Edited by Destructogaming

Share this post


Link to post
Share on other sites
19 hours ago, Destructogaming said:

 @ProtoJeb21 the cervantes SOI is 49,034,443,037 km and it's SMA is 47,200,000,000km. can you tell me what's wrong?

I'll take a look at it when I get home. Since all the stars have custom SOI values (not calculated by in-game math using semi major axis and mass) I may have accidentally set it too high.

Share this post


Link to post
Share on other sites

Posted (edited)

@ProtoJeb21when i move cervantes its SOI increases. which means your fixed SOI value is overwrited by another mod

(congratulations on 1000 posts by the way)

Edited by Destructogaming
1 person likes this

Share this post


Link to post
Share on other sites

Tried with OPM and selphar is awesomely positioned riding up on plock. Makes it actually rechable by the ability to gravity assist more than Voyager II en-route.

Share this post


Link to post
Share on other sites

Just released version 1.2.1. It's a hotfix/tweaking update that fixes a few atmospheres, orbits, SOIs, textures, etc. While a new moon is added (Arctus for the planet Carphos), this is not NEARLY large enough of an update to qualify as version 1.3.0. Oh trust me...I've got some big things planned for THAT....:wink:

Share this post


Link to post
Share on other sites

Posted (edited)

2 hours ago, ProtoJeb21 said:

Just released version 1.2.1. It's a hotfix/tweaking update that fixes a few atmospheres, orbits, SOIs, textures, etc. While a new moon is added (Arctus for the planet Carphos), this is not NEARLY large enough of an update to qualify as version 1.3.0. Oh trust me...I've got some big things planned for THAT....:wink:

When I go to load my save, I get an exception from Contract Configurator warning me the contract data wasn't loaded correctly. Here is the error message:


"Exception occured while loading contract 'ScanSatOfficial.SCAN_NarrowBand':
System.ArgumentException: 'Tekto' is not a valid CelestialBody.
  at ContractConfigurator.ConfigNodeUtil.ParseCelestialBodyValue (System.String celestialName) [0x00000] in <filename unknown>:0 
  at ContractConfigurator.ConfigNodeUtil.ParseSingleValue[CelestialBody] (System.String key, System.String stringValue, Boolean allowExpression) [0x00000] in <filename unknown>:0 
  at ContractConfigurator.ConfigNodeUtil.ParseValue[CelestialBody] (.ConfigNode configNode, System.String key, Boolean allowExpression) [0x00000] in <filename unknown>:0 
  at ContractConfigurator.ConfigNodeUtil.ParseValue[CelestialBody] (.ConfigNode configNode, System.String key, .CelestialBody defaultValue) [0x00000] in <filename unknown>:0 
  at ContractConfigurator.ConfiguredContract.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0 "

Should I just ignore the exception and carry on?

*edit* can't enter my save game, just keeps loading and never gets to the Space Center. 
*edit2* Woops, Tekto isn't from this mod, it's from Outer Planets, I assumed this error was from this mod because it occurred right after updating.
 

Cheers on a great mod btw!

Edited by DocRockwell

Share this post


Link to post
Share on other sites

Posted (edited)

1 hour ago, DocRockwell said:

When I go to load my save, I get an exception from Contract Configurator warning me the contract data wasn't loaded correctly. Here is the error message:


"Exception occured while loading contract 'ScanSatOfficial.SCAN_NarrowBand':
System.ArgumentException: 'Tekto' is not a valid CelestialBody.
  at ContractConfigurator.ConfigNodeUtil.ParseCelestialBodyValue (System.String celestialName) [0x00000] in <filename unknown>:0 
  at ContractConfigurator.ConfigNodeUtil.ParseSingleValue[CelestialBody] (System.String key, System.String stringValue, Boolean allowExpression) [0x00000] in <filename unknown>:0 
  at ContractConfigurator.ConfigNodeUtil.ParseValue[CelestialBody] (.ConfigNode configNode, System.String key, Boolean allowExpression) [0x00000] in <filename unknown>:0 
  at ContractConfigurator.ConfigNodeUtil.ParseValue[CelestialBody] (.ConfigNode configNode, System.String key, .CelestialBody defaultValue) [0x00000] in <filename unknown>:0 
  at ContractConfigurator.ConfiguredContract.OnLoad (.ConfigNode node) [0x00000] in <filename unknown>:0 "
 

Yep. Same Error. KSP 1.2.2 on Mac OS X (Sierra).

And a oddly funny startup screen! The green planet has a Bo-Bo. Just one. :wink::D 

And only one Kerbalnaut in the screen.

Also concur with DocRockwell: Excellent mod! All the planets look great!

nMCQ7u4.png

Edited by GDJ
1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

1 minute ago, GDJ said:

Yep. Same Error. KSP 1.2.2 on Mac OS X (Sierra).

And a oddly funny startup screen! The green planet has a Bo-Bo. Just one. :wink::D 

And only one Kerbalnaut in the screen.

nMCQ7u4.png

I got that start up screen to when I uninstalled Environmental Visual Enhancements, Stock Visual EnhaNcements, Stock Visual Terrain, etc. while trying to get my save game to work. Looks normal with those visual mods installed at least. Still can't load my save game.

edit: perhaps I shouldn't say it was "normal" with the visual mods installed, cause normally I don't get clouds on the main screen, but I did once I installed the update (and the cloud shadows flicker).

Edited by DocRockwell

Share this post


Link to post
Share on other sites
Just now, DocRockwell said:

I got that start up screen to when I uninstalled Environmental Visual Enhancements, Stock Visual EnhaNcements, Stock Visual Terrain, etc. while trying to get my save game to work. Looks normal with those visual mods installed at least. Still can't load my save game.

Makes sense. I don't have those mods. Just about every other mod, just not those....

As for loading the game, that part is not impeded on my KSP.

Share this post


Link to post
Share on other sites

I was in the processes of abandoning my career and reinstalling to start fresh with Galileo's Planet Pack (it should be compatible with this right?) and I noticed this in one of the subdirectories of GPP

https://github.com/Galileo88/Galileos-Planet-Pack/tree/master/GPP_CareerSaver

Career Saver: dull moment with Strategia mm cfg, removed scatterer from dll

I'm using contract configurator (the source of the error) to use Strategia. Looks like it resets some globalflightindex values (no idea what that is), perhaps there are some clues to fix this bug in here.

Share this post


Link to post
Share on other sites

@DocRockwell I'm not too sure what's causing the career save issues, mostly because I don't know much about career to begin with. Yes, I've been playing KSP for two years and haven't done a full-fledged career save yet. My best guess is somehow some features of this mod don't act well with OPM.

@GDJ That loading screen is perfectly normal. I didn't realize, however, that any moons of the main menu body are put closer to the planet, so now Carphos has a giant tumor.

Share this post


Link to post
Share on other sites

Posted (edited)

Ever since the most recent update (yesterday, I believe), I cannot get KSP to start at all.  This was the only mod updated... I can load the save but when it gets to the main KSP scene, screen stays black and it just sits there and churns.  I have to kill KSP with the task manager to regain control of my system.  End of the log is filled .. and I mean *filled*, with millions of lines like:

[EXC 21:33:49.966] NullReferenceException: Object reference not set to an instance of an object
    GalaxyCubeControl.Update ()
[EXC 21:33:49.967] NullReferenceException: Object reference not set to an instance of an object
    Kopernicus.Components.KopernicusStar.LateUpdate ()
[EXC 21:33:49.980] InvalidOperationException: Operation is not valid due to the current state of the object
    System.Linq.Enumerable.First[StarComponent] (IEnumerable`1 source)
    Kopernicus.StarLightSwitcher.Update ()
[EXC 21:33:49.982] NullReferenceException: Object reference not set to an instance of an object
    GalaxyCubeControl.Update ()
[EXC 21:33:49.983] NullReferenceException: Object reference not set to an instance of an object
    Kopernicus.Components.KopernicusStar.LateUpdate ()
[EXC 21:33:49.988] InvalidOperationException: Operation is not valid due to the current state of the object
    System.Linq.Enumerable.First[StarComponent] (IEnumerable`1 source)
    Kopernicus.StarLightSwitcher.Update ()
[EXC 21:33:49.990] NullReferenceException: Object reference not set to an instance of an object
    GalaxyCubeControl.Update ()
[EXC 21:33:49.992] NullReferenceException: Object reference not set to an instance of an object
    Kopernicus.Components.KopernicusStar.LateUpdate ()
[EXC 21:33:50.013] InvalidOperationException: Operation is not valid due to the current state of the object
    System.Linq.Enumerable.First[StarComponent] (IEnumerable`1 source)
    Kopernicus.StarLightSwitcher.Update ()
[EXC 21:33:50.015] NullReferenceException: Object reference not set to an instance of an object
    GalaxyCubeControl.Update ()
[EXC 21:33:50.017] NullReferenceException: Object reference not set to an instance of an object
    Kopernicus.Components.KopernicusStar.LateUpdate ()
[EXC 21:33:50.029] InvalidOperationException: Operation is not valid due to the current state of the object
    System.Linq.Enumerable.First[StarComponent] (IEnumerable`1 source)
    Kopernicus.StarLightSwitcher.Update ()
[EXC 21:33:50.032] NullReferenceException: Object reference not set to an instance of an object
    GalaxyCubeControl.Update ()
[EXC 21:33:50.033] NullReferenceException: Object reference not set to an instance of an object
    Kopernicus.Components.KopernicusStar.LateUpdate ()

 

I tried a brand new save since I had some craft on Thallo, I thought that might be part of the problem, but... no luck, same behavior.

 

UPDATE:  It's a confilct with Stock Visual Enhancements/stock visual terrain.  If I remove those, the problem goes away.  However, this is a new conflict since the last update to this mod.

Edited by ss8913

Share this post


Link to post
Share on other sites

I managed to get a LOT of work done for version 1.3.0. Darani has been re-added with a better texture, and a bunch of old moons look quite different now. In fact, Galene has become a terra moon like Lamancha! Uninhabited, sure, but still a terra! Currently working on new textures for Kokksaut, then adding in many new bodies to the Niobe system. I hope to (mostly) complete the system in this update - that means adding the final two planets (HR 8832g/Kategi and HR 8832f) and a whole crudload of moons. In the meantime, enjoy some screenshots! (Darani not included)

Also, I've decided that I MIGHT add only more more system in a later update: Kepler-47, which has two confirmed (and possibly one more) ice giants around a binary system similar to that of Tatooine. Even the stars' colors match up with those in Star Wars! I really want to name the planets and moons after deceased members of the New Hope cast and Lucasfilm. Any naming suggestions? I'm already thinking of doing Quarrie (for Ralph McQuarrie) and Fisher (for Carrie Fisher).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now