ProtoJeb21

[1.2.2] [Kopernicus] Interstellar Adventure Revived v1.2.0 - The New TRAPPIST-1 System! [8Mar17]

125 posts in this topic

23 hours ago, ProtoJeb21 said:

I managed to get a LOT of work done for version 1.3.0. Darani has been re-added with a better texture, and a bunch of old moons look quite different now. In fact, Galene has become a terra moon like Lamancha! Uninhabited, sure, but still a terra! Currently working on new textures for Kokksaut, then adding in many new bodies to the Niobe system. I hope to (mostly) complete the system in this update - that means adding the final two planets (HR 8832g/Kategi and HR 8832f) and a whole crudload of moons. In the meantime, enjoy some screenshots! (Darani not included)

Also, I've decided that I MIGHT add only more more system in a later update: Kepler-47, which has two confirmed (and possibly one more) ice giants around a binary system similar to that of Tatooine. Even the stars' colors match up with those in Star Wars! I really want to name the planets and moons after deceased members of the New Hope cast and Lucasfilm. Any naming suggestions? I'm already thinking of doing Quarrie (for Ralph McQuarrie) and Fisher (for Carrie Fisher).

 

so is Lamancha fixed?  Does it look on the ground the way it looks from orbit now?  Last time I went there, the actual ground didn't match up *at all* with either the visuals from orbit nor the scansat scans that I took...

Share this post


Link to post
Share on other sites
16 minutes ago, ss8913 said:

so is Lamancha fixed?  Does it look on the ground the way it looks from orbit now?  Last time I went there, the actual ground didn't match up *at all* with either the visuals from orbit nor the scansat scans that I took...

It should be. I just need to do the regular ocean-lowering when I get the chance. Currently I've been working on Kategi and it's moons in the Niobe system. Although...what's scan sat?

Share this post


Link to post
Share on other sites
1 hour ago, ProtoJeb21 said:

It should be. I just need to do the regular ocean-lowering when I get the chance. Currently I've been working on Kategi and it's moons in the Niobe system. Although...what's scan sat?

scansat is a surface scanning mod that has been around for a while.. predates the stock scanning mechanic, and many, myself included, still feel that it is superior to the stock scanning.

Share this post


Link to post
Share on other sites

@ProtoJeb21, Sorry if someone's asked already, but what happened to that one binary system? Y'know, the one you made a barycenter for that started with 'Kepler-1' that I can't remember the full name of and had 2 red dwarfs, one was almost a K-type and the other one kind of like Amphion?

Why did you kill that system? It had children! (1 orange-green desert planet)

srsly tho, what happened to it? the views were amazing! :'(

1 person likes this

Share this post


Link to post
Share on other sites
19 hours ago, electricpants said:

@ProtoJeb21, Sorry if someone's asked already, but what happened to that one binary system? Y'know, the one you made a barycenter for that started with 'Kepler-1' that I can't remember the full name of and had 2 red dwarfs, one was almost a K-type and the other one kind of like Amphion?

Why did you kill that system? It had children! (1 orange-green desert planet)

srsly tho, what happened to it? the views were amazing! :'(

Well...Kepler-296 wasn't the best designed system. The stars didn't look right and the first planet had a rather poor texture - not the greatest example of SE-Kittopia hybrid textures. It didn't help that I couldn't even figure out what to name all the planets and stars. So with all those things in mind I took it out.

I still think it's a cool system, but I'd rather go with a small circumbinary system to put in the mod - maybe Kepler-16 or Kepler-47.

1 person likes this

Share this post


Link to post
Share on other sites

I am probably just to stupid to install this mod but everytime i do it end up not working. It would be great if someone could help me. Every time I download this ( i did it like 3 times) i try to but IA-Revived v1.2.1 in my gamefolder but when i then run the game all the objects didnt have any texture.so I put the IA_Revived, Kopernicus, ModularflightIntegrator, and the ModuleManager.2.7.5.dll. It seems like it works every time but when i look in the map view and zoom onto the planets the orbital lines start to freak out. Thus the sun Lich is totally buggy for me. The sun has pixels and its texture not on the surface no its floating around it. Every other texture looks fine tho. When i the want to build a rocket or anything like that and want to revert the flight to the hanger or to the launchpad the game will crash.

 

Share this post


Link to post
Share on other sites
10 hours ago, jortack said:

I am probably just to stupid to install this mod but everytime i do it end up not working. It would be great if someone could help me. Every time I download this ( i did it like 3 times) i try to but IA-Revived v1.2.1 in my gamefolder but when i then run the game all the objects didnt have any texture.so I put the IA_Revived, Kopernicus, ModularflightIntegrator, and the ModuleManager.2.7.5.dll. It seems like it works every time but when i look in the map view and zoom onto the planets the orbital lines start to freak out. Thus the sun Lich is totally buggy for me. The sun has pixels and its texture not on the surface no its floating around it. Every other texture looks fine tho. When i the want to build a rocket or anything like that and want to revert the flight to the hanger or to the launchpad the game will crash.

 

The orbit lines wigging out is normal, it's a stock bug made visible by Kopernicus.

The 'pixels' are an unfinished particle stream that just goes off in every direction because Lich is a pulsar so it spins very, very fast.

That last part is normal for lower-end PC's.

Share this post


Link to post
Share on other sites
11 hours ago, electricpants said:

The orbit lines wigging out is normal, it's a stock bug made visible by Kopernicus.

The 'pixels' are an unfinished particle stream that just goes off in every direction because Lich is a pulsar so it spins very, very fast.

That last part is normal for lower-end PC's.

You beat me to it! But yes, @jortack, this is what's happening.

The wiggly orbits are because KSP is not the greatest with such large distances. It's most noticeable with Lich because it's over 2 TRILLION kilometers away from the stock system. Those little pixels flying around Lich are actually meant to be bits of electromagnetic energy caused by the star's rapid rotation (less than one second) and the incredibly cramped magnetic field. Still have to work on them, though. In the future I'm planning on shrinking Lich, as well as adding an accretion disk and particle jets.

Also, Interstellar Adventure Revived works quite a lot better with KSP 64 bit.

1 person likes this

Share this post


Link to post
Share on other sites
16 minutes ago, ProtoJeb21 said:

-snip- The wiggly orbits are because KSP is not the greatest with such large distances. It's most noticeable with Lich because it's over 2 TRILLION kilometers away from the stock system. -snip-

The wiggly orbits are even worse for me because I put ALL the stars 10x closer than they are IRL.

So Lich is 1500 Kerbal lightyears (150 RL Lightyears) away.

1 person likes this

Share this post


Link to post
Share on other sites

I was just on a mun encounter and all of a sudden it became not an encounter. What give?

 

 

this is the only mod I have installed.

Share this post


Link to post
Share on other sites
On 5/15/2017 at 1:09 PM, A_beholder said:

I was just on a mun encounter and all of a sudden it became not an encounter. What give?

 

 

this is the only mod I have installed.

There have been issues with the SOIs of the stars, which have been reported to interfere with spacecrafts in the Kerbol system. I'm planning on fixing that for version 1.3.0. The reason why the update hasn't come out sooner is that I just wanted a bit of a break from modding, since I was developing IAR v1.3 and Upsilon Kandromedae at the same time. Quite a hassle. I'll probably resume development this weekend.

Also...

10,000 DOWNLOADS!

Thank you all for the great support! This is what keeps me developing IA-Revived, even during times when I felt like abandoning it. The huge amount of people interested in the pack has made me realize that giving up the mod would mean giving up on those wishing for more. Plus it would suck if over a year's worth of hard work were to die out like that.

1 person likes this

Share this post


Link to post
Share on other sites

So as "near real life" means this mod will work well with RSS?

Share this post


Link to post
Share on other sites

Posted (edited)

7 hours ago, Karamon said:

So as "near real life" means this mod will work well with RSS?

No.

All planets and moons are scaled to Kerbin, and all stars are scaled to Kerbol (0.395x the size of our sun) except TRAPPIST-1, which is 10x smaller than it is IRL.

 

Speaking of which, can you fix that, @ProtoJeb21?

There's nothing wrong with it, it's just that I have a kind of "All or None" mentality.

Like, why is only TRAPPIST-1 0.1x?

I'd think that you should either make it scaled to Kerbol or make all the other stars (Kerbol included) 0.1x.

Edited by electricpants

Share this post


Link to post
Share on other sites
6 hours ago, electricpants said:

No.

All planets and moons are scaled to Kerbin, and all stars are scaled to Kerbol (0.395x the size of our sun) except TRAPPIST-1, which is 10x smaller than it is IRL.

 

Speaking of which, can you fix that, @ProtoJeb21?

There's nothing wrong with it, it's just that I have a kind of "All or None" mentality.

Like, why is only TRAPPIST-1 0.1x?

I'd think that you should either make it scaled to Kerbol or make all the other stars (Kerbol included) 0.1x.

Trappist-1 is just the first of 10% real-scale stars. I need to figure out how to shrink Kerbol as well.

1 person likes this

Share this post


Link to post
Share on other sites
Just now, ProtoJeb21 said:

Trappist-1 is just the first of 10% real-scale stars. I need to figure out how to shrink Kerbol as well.

Ah.

Well, could you at least keep the stock Kerbol-scaled stars in some sort of 'Optional' folder?

I just prefer Kerbol-scaled stars. nTTYEdB.png

1 person likes this

Share this post


Link to post
Share on other sites
4 minutes ago, electricpants said:

Ah.

Well, could you at least keep the stock Kerbol-scaled stars in some sort of 'Optional' folder?

I just prefer Kerbol-scaled stars. nTTYEdB.png

Maybe. The problem with Kerbol-scale stars is that they conflict with 10%-scale orbits. For example, Niobe is WAY too big in comparison to the orbits of its inner planets, Eotia and Kolasi. In fact, the former is essentially hovering over the star's surface when in real life it's still a good distance away. If I were to add a planet around a Sun-like star with a year of like one day, then it would be INSIDE the star! That's quite an issue if you have any plans of orbiting or landing on that planet. But maybe I'll add it as an optional feature in 1.3 or 1.4.

Also apparently KSP 1.3 came out a few days ago. Dangit! I was going to work on my mods this weekend, but now I have to wait for a new version of Kopernicus to do so!

I really hope 1.3 has some sort of secret planet-busting glitch I can exploit.

1 person likes this

Share this post


Link to post
Share on other sites

Thanks for the great mod. I just have a small problem with solar panels, and I think it is related to your mod: Once I deploy solar arrays in Kerbin orbit some of them try to face Kerbol and once they face it they generate energy, while others try to face one of the stars you added and obvisiouly can't generate energy, as they are to far away. Do you know a way how this could be fixed.

Share this post


Link to post
Share on other sites
21 hours ago, Schetefan said:

Thanks for the great mod. I just have a small problem with solar panels, and I think it is related to your mod: Once I deploy solar arrays in Kerbin orbit some of them try to face Kerbol and once they face it they generate energy, while others try to face one of the stars you added and obvisiouly can't generate energy, as they are to far away. Do you know a way how this could be fixed.

This has been reported on the KSPIE thread as well, it seems there is some kind of compatibility issue currently between KSPIE and Kopernicus.

Share this post


Link to post
Share on other sites

Posted (edited)

On 4/28/2017 at 5:45 PM, ProtoJeb21 said:

It should be. I just need to do the regular ocean-lowering when I get the chance. Currently I've been working on Kategi and it's moons in the Niobe system. Although...what's scan sat?

Update: Lamancha is still not fixed.  I can see the biomes and the continents from orbit, but... everything's below sea level when you get down there.

Update #2: was using an old version.  lamancha is  KIND OF fixed.  The biomes don't really match the terrain still, and as such the surface resources are off - ie, "The Sagen Sea" is the listed biome while I'm in the middle of a continent on the grass.
Other things I've noticed - 1. craft don't cast shadows on the ground on Lamancha.  2. It's very cold - 174K is about -100C.  Intentional?  Seems like green plants wouldn't grow at that temp?  It's definitely green. :)

Edited by ss8913

Share this post


Link to post
Share on other sites

Posted (edited)

I really Want Iona and Natalie From EE here now. I want to land on them. Also, Can we Have 1.3 Support?

Edited by Cabbink
Added Stuff

Share this post


Link to post
Share on other sites
6 hours ago, Cabbink said:

I really Want Iona and Natalie From EE here now. I want to land on them. Also, Can we Have 1.3 Support?

It already works in 1.3.

 

Another update: Thallo seems to have the same "biome map doesn't match actual landmasses" issue that Lamancha does.  Since resources are allocated by biome, this could be an issue.

Share this post


Link to post
Share on other sites

I doesn't work in 1.3 for me, when I click a gamesave it loads forever, I got the new version of Kopernicus installed.... What am I doing wrong ?

Share this post


Link to post
Share on other sites

Posted (edited)

10 hours ago, k0spwn said:

I doesn't work in 1.3 for me, when I click a gamesave it loads forever, I got the new version of Kopernicus installed.... What am I doing wrong ?

not sure; I installed Kopernicus + this mod, using CKAN, in 1.3, and it works for me.  You may want to uninstall/reinstall those mods.  If you have other planet packs installed, it may be conflicting, too.  Not all of them work together, I've found.

Edited by ss8913

Share this post


Link to post
Share on other sites
10 hours ago, ss8913 said:

not sure; I installed Kopernicus + this mod, using CKAN, in 1.3, and it works for me.  You may want to uninstall/reinstall those mods.  If you have other planet packs installed, it may be conflicting, too.  Not all of them work together, I've found.

IAR 1.2.1 is currently in CKAN, but i cannot install it; it says t's for KSP 1.2.2.

Share this post


Link to post
Share on other sites
On 6/11/2017 at 6:08 PM, ss8913 said:

Update: Lamancha is still not fixed.  I can see the biomes and the continents from orbit, but... everything's below sea level when you get down there.

Update #2: was using an old version.  lamancha is  KIND OF fixed.  The biomes don't really match the terrain still, and as such the surface resources are off - ie, "The Sagen Sea" is the listed biome while I'm in the middle of a continent on the grass.
Other things I've noticed - 1. craft don't cast shadows on the ground on Lamancha.  2. It's very cold - 174K is about -100C.  Intentional?  Seems like green plants wouldn't grow at that temp?  It's definitely green. :)

With the new 1.3 texture, 95% of all landmasses are above sea level. I haven't created custom biomes for it yet (going to work on that for 1.4). Also, I kind of suck at atmosphere pressure and temperature curves, which may explain the 174*K environment. Trust me, it's supposed to be WAY warmer - more around 240-250*K.

On 6/13/2017 at 1:16 PM, Cabbink said:

I really Want Iona and Natalie From EE here now. I want to land on them. Also, Can we Have 1.3 Support?

I will be putting them into a mod called ProtoJeb's Planets. I'll probably rename it to Exoplanet Explorers Pack since most of my discoveries have been on that site. Also, this mod can still work with KSP 1.3; you just need the latest version of Kopernicus.

On 6/13/2017 at 7:24 PM, ss8913 said:

It already works in 1.3.

 

Another update: Thallo seems to have the same "biome map doesn't match actual landmasses" issue that Lamancha does.  Since resources are allocated by biome, this could be an issue.

Once again, Thallo (as do most of the planets) does not have custom biomes yet. Its sea level issues are much better fixed than Lamancha, however.

On 6/15/2017 at 6:28 AM, k0spwn said:

I doesn't work in 1.3 for me, when I click a gamesave it loads forever, I got the new version of Kopernicus installed.... What am I doing wrong ?

Sometimes that happens when a certain node or value in the config files is changed, which causes the entire mod to break KSP. Did you happen to edit any files before booting up the game?

15 hours ago, DrScarlett said:

IAR 1.2.1 is currently in CKAN, but i cannot install it; it says t's for KSP 1.2.2.

As I said before, it can still work for 1.3, as long as you use Kopernicus 1.3-1. Also, don't edit any files until I release version 1.3.

 

 

Heads up on development: I'm switching to a new texture style, Space Engine/Kittopia hybrids. Some of the planets will have custom, edited Space Engine height maps. Their color and normal maps are produced by different PQSMods through the use of Kittopia Tech. Thallo (TRAPPIST-1d) is a great example of one. The other objects will have pure Kittopia textures - no Space Engine height map. So far I've finished a few moons, retextured some planets, et cetera. However, because of all my research lately, and because of Upsilon Kandromedae, I've had little opportunity to work on IA-Revived 1.3. Here's an example of the type of research I've been doing for the last few weeks. Thankfully, I may get a break as a new Kepler announcement may actually confirm some of the candidates me and some other users (Vidar, shutcheon, @Cabbink, etc.) have found and analyzed.

2 people like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now