• 0
toric5

[linux] crash on startup, no ksp.log

Question

Posted (edited)

 

crashes whether i run it from steam or not, 32 bit or 64. tried reinstall of game. crashes before ksp.log generates. there is the player.log:

Stacktrace:


Native stacktrace:

	/SSDgames/steam/steamapps/common/Kerbal Space Program/KSP_Data/Mono/x86_64/libmono.so(+0x91a46) [0x7f209afeca46]
	/SSDgames/steam/steamapps/common/Kerbal Space Program/KSP_Data/Mono/x86_64/libmono.so(+0x348e4) [0x7f209af8f8e4]
	/lib/x86_64-linux-gnu/libpthread.so.0(+0x11390) [0x7f20a0760390]
	/SSDgames/steam/steamapps/common/Kerbal Space Program/KSP.x86_64() [0xf2dd3d]
	/lib/x86_64-linux-gnu/libc.so.6(+0x39ff8) [0x7f209ef38ff8]
	/lib/x86_64-linux-gnu/libc.so.6(+0x3a045) [0x7f209ef39045]
	/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf7) [0x7f209ef1f837]
	/SSDgames/steam/steamapps/common/Kerbal Space Program/KSP.x86_64() [0x46f695]

Debug info from gdb:

ERROR: ld.so: object '/home/thetoric/.steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
Could not attach to process.  If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user.  For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Operation not permitted.
No threads.

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

 

all i can think of is that a package updated that ksp relied on and broke it? using KDE neon, no third party ppas for libraries.

Edited by toric5

Share this post


Link to post
Share on other sites

20 answers to this question

  • 0
On 06/03/2017 at 0:20 AM, toric5 said:

crashes whether i run it from steam or not, 32 bit or 64

You confused me with this then,

 

2 minutes ago, toric5 said:

not trying to run the 32 bit version,  would you reccomend i try that?

By all means, see if there is any change.

Also, try resetting KSP's settings, do this by deleting the settings.cfg in the games folder, and to ensure there's no unwanted settings also delete the prefs file from /home/username/.config/unity3d/Squad/Kerbal Space Program/

Share this post


Link to post
Share on other sites
  • 1

deleted settings.cfg and the unity 3d config, seems to work now!

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Hi @toric5, you might need libcursor1.so, I believe it's no longer installed by default.

Try ldd KSP.x86_64 in a terminal while in the KSP directory, it should show any missing libraries as not found.

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

        linux-vdso.so.1 =>  (0x00007fff78887000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f9fe6dab000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f9fe6b8e000)
        librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f9fe6985000)
        libGL.so.1 => /usr/lib/nvidia-367/libGL.so.1 (0x00007f9fe66f6000)
        libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f9fe63bc000)
        libXcursor.so.1 => /usr/lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007f9fe61b1000)
        libXrandr.so.2 => /usr/lib/x86_64-linux-gnu/libXrandr.so.2 (0x00007f9fe5fa6000)
        libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f9fe5c24000)
        libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f9fe591a000)
        libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f9fe5704000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f9fe533b000)
        /lib64/ld-linux-x86-64.so.2 (0x00005632453c7000)
        libGLX.so.0 => /usr/lib/nvidia-367/libGLX.so.0 (0x00007f9fe5109000)
        libGLdispatch.so.0 => /usr/lib/nvidia-367/libGLdispatch.so.0 (0x00007f9fe4e20000)
        libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f9fe4bfe000)
        libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f9fe49f3000)
        libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f9fe47ed000)
        libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f9fe45db000)
        libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f9fe43d6000)
        libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f9fe41d0000)

 

there is a libXcursor.so.1, but no libcursor1.so. libcursor1.so is not on the repositories, do you have a place i can get it? (i can compile from source if i need to, but i am not fully comfortable with it.)

 
Edited by toric5
more info

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, toric5 said:

 

there is a libXcursor.so.1, but no libcursor1.so. libcursor1.so is not on the repositories, do you have a place i can get it? (i can compile from source if i need to, but i am not fully comfortable with it.)

 

Sorry, libXcursor is the one I meant.

Can you please provide more information on your hardware and operating system, the hardinfo package can do this for Linux.

Share this post


Link to post
Share on other sites
  • 0
9 hours ago, toric5 said:

Here you go!

Nothing looks out of place, the hardware should run KSP fine, does anything funky happen when KSP crashes? Like the window manager also crashing?

Can you try starting KSP from the command line, see if there's anything written there that's not in the logs.

Also from the command line, see if it works with KSP.x86_64 -force-glcore

To run the 32bit version you might need to install libgl1-mesa-glx:i386

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, sal_vager said:

Nothing looks out of place, the hardware should run KSP fine, does anything funky happen when KSP crashes? Like the window manager also crashing?

Can you try starting KSP from the command line, see if there's anything written there that's not in the logs.

Also from the command line, see if it works with KSP.x86_64 -force-glcore

To run the 32bit version you might need to install libgl1-mesa-glx:i386

not trying to run the 32 bit version,  would you reccomend i try that?

nothing else significant happens, steam even resets me to not playing a game (something that does not usually happen with hard crashes like this.)

CLI output is this:

Found path: /home/thetoric/Documents/ksp stuff/KSP/KSP.x86_64
Mono path[0] = '/home/thetoric/Documents/ksp stuff/KSP/KSP_Data/Managed'
Mono path[1] = '/home/thetoric/Documents/ksp stuff/KSP/KSP_Data/Mono'
Mono config path = '/home/thetoric/Documents/ksp stuff/KSP/KSP_Data/Mono/etc'
displaymanager : xrandr version warning. 1.5
client has 4 screens
displaymanager screen (0)(DVI-D-0): 1920 x 1080
Using libudev for joystick management


Importing game controller configs

the 4 screens are virtual desktops, not monitors. only one of them is rendered by the compositor at a time.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, toric5 said:

deleted settings.cfg and the unity 3d config, seems to work now!

Great! If it happens again maybe consider making a shortcut to the prefs file folder, to make removing it easier.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, sal_vager said:

Great! If it happens again maybe consider making a shortcut to the prefs file folder, to make removing it easier.

oh, already created a script to do it for me!

Share this post


Link to post
Share on other sites
  • 0

I had the exact same problem. Deleting settings.cfg didn't fix it but deleting the Unity3D prefs did. I compared the previous version  of the file to the version after running the game again and found that the Screenmanager Resolution Height value was set to 0 when it was crashing. So whatever causes that value to be set to 0 is the problem.

Share this post


Link to post
Share on other sites
  • 0

I have this problem and deleting settings.cfg and ~/.config/Unity3D did nothing to fix it.

Running Kerbal Space Program
Set current directory to {home}/bin/kerbal/v1.2.2/game
Found path: {home}/bin/kerbal/v1.2.2/game/KSP.x86_64
Mono path[0] = '{home}/bin/kerbal/v1.2.2/game/KSP_Data/Managed'
Mono path[1] = '{home}/bin/kerbal/v1.2.2/game/KSP_Data/Mono'
Mono config path = '{home}/bin/kerbal/v1.2.2/game/KSP_Data/Mono/etc'
displaymanager : xrandr version warning. 1.5
client has 4 screens
displaymanager screen (0)(DP-4): 1920 x 1200
displaymanager screen (1)(DP-2): 1920 x 1200
Using libudev for joystick management


Importing game controller configs

I have had v1.2.2 running on this system.  I don't know what's changed between then and now other than the usual system updates.

Share this post


Link to post
Share on other sites
  • 0
On 09/03/2017 at 6:45 PM, Kerbidiah said:

I had the exact same problem. Deleting settings.cfg didn't fix it but deleting the Unity3D prefs did. I compared the previous version  of the file to the version after running the game again and found that the Screenmanager Resolution Height value was set to 0 when it was crashing. So whatever causes that value to be set to 0 is the problem.

Unfortunately this is a Unity3D engine bug, and we are waiting on Unity to fix it.

The only workarounds I know is using xfce, always deleting the prefs (unreliable) or making oom killer target KSP.

 

On 10/03/2017 at 2:27 PM, StarStryder said:

I have this problem and deleting settings.cfg and ~/.config/Unity3D did nothing to fix it.


Running Kerbal Space Program
Set current directory to {home}/bin/kerbal/v1.2.2/game
Found path: {home}/bin/kerbal/v1.2.2/game/KSP.x86_64
Mono path[0] = '{home}/bin/kerbal/v1.2.2/game/KSP_Data/Managed'
Mono path[1] = '{home}/bin/kerbal/v1.2.2/game/KSP_Data/Mono'
Mono config path = '{home}/bin/kerbal/v1.2.2/game/KSP_Data/Mono/etc'
displaymanager : xrandr version warning. 1.5
client has 4 screens
displaymanager screen (0)(DP-4): 1920 x 1200
displaymanager screen (1)(DP-2): 1920 x 1200
Using libudev for joystick management


Importing game controller configs

I have had v1.2.2 running on this system.  I don't know what's changed between then and now other than the usual system updates.

Is that all the log you have? Try the 32bit version, KSP.x86

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

9 hours ago, sal_vager said:

Is that all the log you have? Try the 32bit version, KSP.x86

Yes, that is the entire log before the program exits to the terminal.  

Same issue with both KSP.x86 and KSP.x86_64.

oh, and no KSP.log file is generated.

Edited by StarStryder

Share this post


Link to post
Share on other sites
  • 0
10 hours ago, StarStryder said:

Yes, that is the entire log before the program exits to the terminal.  

Are you getting the symptoms in the Unity bug linked above? I.e resizing game window and your window manager crashing?

Are any libraries missing when you use ldd KSP.x86 or ldd KSP.x86_64 in a terminal?

What Linux distribution are you using and which version?

What graphics card are you using and which driver?

KSP is installed to your home folder correct? All the files are writeable?

Share this post


Link to post
Share on other sites
  • 0
22 hours ago, sal_vager said:

Are you getting the symptoms in the Unity bug linked above? I.e resizing game window and your window manager crashing?

Are any libraries missing when you use ldd KSP.x86 or ldd KSP.x86_64 in a terminal?

What Linux distribution are you using and which version?

What graphics card are you using and which driver?

KSP is installed to your home folder correct? All the files are writeable?

 

The game window appears for a fraction of a second and then disappears again.  The window manager doesn't crash though.

No libraries are listed as missing by ldd

I'm using Linux Mint 18.0

I have an Nvidia Geforce 1060 using driver 375.39

Yes, it's installed in my home folder.  All of the files are owned by me and my personal user group.  They are a mixture or rw+u and rw+ug permissions.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, StarStryder said:

The game window appears for a fraction of a second and then disappears again.

This sounds like a different issue to toric5's, your symptoms aren't the same and what you describe is more like Unity failing to find a graphics driver.

The log you posted isn't the log, it's the output from the terminal, for example here's mine.

Spoiler

$ ./KSP.x86
Set current directory to /home/mat/Games/kerbal space program/KSP_linux_122
Found path: /home/mat/Games/kerbal space program/KSP_linux_122/KSP.x86
Mono path[0] = '/home/mat/Games/kerbal space program/KSP_linux_122/KSP_Data/Managed'
Mono path[1] = '/home/mat/Games/kerbal space program/KSP_linux_122/KSP_Data/Mono'
Mono config path = '/home/mat/Games/kerbal space program/KSP_linux_122/KSP_Data/Mono/etc'
displaymanager : xrandr version warning. 1.5
client has 4 screens
displaymanager screen (0)(HDMI-0): 1920 x 1080
Using libudev for joystick management


Importing game controller configs

What I need is the Player.log, which is in the same place as the prefs file, deleting ~/.config/Unity3D just removes all unity game logs not just KSP's but Unity will make a new one every time it starts.

What I'm looking for looks more like this.

Spoiler

Selecting FBConfig
GLX_FBCONFIG_ID=147
GLX_BUFFER_SIZE=32
GLX_DOUBLEBUFFER=1
GLX_RED_SIZE=8
GLX_GREEN_SIZE=8
GLX_BLUE_SIZE=8
GLX_ALPHA_SIZE=8
GLX_DEPTH_SIZE=24
GLX_STENCIL_SIZE=8
GLX_SAMPLES_ARB=0
GLX_SAMPLE_BUFFERS_ARB=0
GLX_STEREO=0
GLX_CONFIG_CAVEAT=NONE

Desktop is 1920 x 1080 @ 60 Hz
Initialize engine version: 5.4.0p4 (b15b5ae035b7)
GfxDevice: creating device client; threaded=1
GPU_MEMORY_INFO_DEDICATED_VIDMEM_NVX: 1048576
OpenGL:
    Version:  OpenGL 3.0 [3.0 Mesa 12.0.6]
    Renderer: Gallium 0.4 on AMD KAVERI (DRM 2.43.0 / 4.4.0-66-generic, LLVM 3.8.0)
    Vendor:   X.Org
    VRAM:     1024 MB

Yours may say "Failed to initialize engine" and should give a clue as to why.

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, sal_vager said:

What I need is the Player.log, which is in the same place as the prefs file, deleting ~/.config/Unity3D just removes all unity game logs not just KSP's but Unity will make a new one every time it starts.

This looks more promising:

Quote

Selecting FBConfig
GLX_FBCONFIG_ID=209
GLX_BUFFER_SIZE=32
GLX_DOUBLEBUFFER=1
GLX_RED_SIZE=8
GLX_GREEN_SIZE=8
GLX_BLUE_SIZE=8
GLX_ALPHA_SIZE=8
GLX_DEPTH_SIZE=24
GLX_STENCIL_SIZE=8
GLX_SAMPLES_ARB=0
GLX_SAMPLE_BUFFERS_ARB=0
GLX_STEREO=0
GLX_CONFIG_CAVEAT=NONE

Desktop is 3840 x 1200 @ 60 Hz
XError: BadValue (integer parameter out of range for operation) (error 2, opcode 154/24, serial 54, XID 00000000, display 0x3fa42a0
XError: BadValue (integer parameter out of range for operation) (error 2, opcode 154/34, serial 60, XID 00000000, display 0x3fa42a0
XError: BadValue (integer parameter out of range for operation) (error 2, opcode 154/34, serial 66, XID 00000000, display 0x3fa42a0
XError: BadValue (integer parameter out of range for operation) (error 2, opcode 154/34, serial 72, XID 00000000, display 0x3fa42a0
XError: BadValue (integer parameter out of range for operation) (error 2, opcode 154/34, serial 78, XID 00000000, display 0x3fa42a0
XError: BadValue (integer parameter out of range for operation) (error 2, opcode 154/34, serial 84, XID 00000000, display 0x3fa42a0
XError: BadValue (integer parameter out of range for operation) (error 2, opcode 154/34, serial 90, XID 00000000, display 0x3fa42a0
XError: BadValue (integer parameter out of range for operation) (error 2, opcode 154/34, serial 96, XID 00000000, display 0x3fa42a0
XError: BadValue (integer parameter out of range for operation) (error 2, opcode 154/34, serial 102, XID 00000000, display 0x3fa42a0
Failed to create valid graphics context: please ensure you meet the minimum requirements
E.g. OpenGL core profile 3.2 or later for OpenGL Core renderer

 

Share this post


Link to post
Share on other sites
  • 0

Okay so there's definitely something wrong here with resolution, from your terminal...

On 10/03/2017 at 2:27 PM, StarStryder said:

displaymanager : xrandr version warning.
1.5 client has 4 screens
displaymanager screen (0)(DP-4):1920 x 1200
displaymanager screen (1)(DP-2): 1920 x 1200


But the log shows it's trying to use this...

On 12/03/2017 at 8:53 PM, StarStryder said:

Desktop is 3840 x 1200 @ 60 Hz


This is obviously too large and I expect on your system that oom killer is seeing KSP as the highest priority process instead of the window manager.

I know that Unity games will read the prefs file (or the registry on Windows) for the last resolution the engine closed with, and assumes this to be "good", I suspect that if you go to the path I gave above...

On 07/03/2017 at 4:14 PM, sal_vager said:

/home/username/.config/unity3d/Squad/Kerbal Space Program/


You'll find a prefs file containing these lines.

Quote

    <pref name="Screenmanager Resolution Height" type="int">1200</pref>
    <pref name="Screenmanager Resolution Width" type="int">3840</pref>


You mentioned deleting the Unity3D folder.

On 10/03/2017 at 2:27 PM, StarStryder said:

deleting settings.cfg and ~/.config/Unity3D did nothing to fix it


But there can be multiple folders as different Unity applications don't all use the same case, and Linux file systems are case sensitive.

So please try specifically deleting the ~/.config/unity3d/Squad/Kerbal Space Program/prefs file, I use a script to start KSP and it uses these lines.

Quote

#! /bin/sh
rm ~/.config/unity3d/Squad/Kerbal\ Space\ Program/prefs
cd ~/.steam/steam/steamapps/common/Kerbal\ Space\ Program/
./KSP.x86_64

Hope this solves it.

Share this post


Link to post
Share on other sites
  • 0
22 hours ago, sal_vager said:

Hope this solves it.

It didn't, but I have solved the problem.  I'd completely forgotten my Windows training and had not turned it off and on again!

That solved the problem although it still breaks if launched from CKAN. Not sure what's going on there.  Launching from cli is fine.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now