• 0
THEM4CHIN3

KSP 1.2.2 wont load completely on MSI Apache pro laptop

Question

Ok so I'm trying to run the current version of KSP on my new laptop. This machine has spunk so I did not forsee any major problems.

Installed Fallout 4- it runs with not even a hair of trouble or lag at full video settings. The 6 gig GTX 1060 in this thing chugs along, with no problems.

I have tried both x86 and x64 versions with no success. I have tried a clean delete and re-install between boots and no improvement.

I had seen on a different post others have had this problem as well. Seems to be an asset loading issue. Included in this post is the log file copied and pasted over.

Kerbal Space Program - 1.2.2.1622 (WindowsPlayer x64)


OS: Windows 10  (10.0.0) 64bit
CPU: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz (8)
RAM: 32644
GPU: NVIDIA GeForce GTX 1060 (6100MB)
SM: 30 (Direct3D 9.0c [nvd3dumx.dll 21.21.13.7654])
RT Formats: ARGB32, Depth, ARGBHalf, Shadowmap, RGB565, Default, ARGB2101010, DefaultHDR, ARGBFloat, RGFloat, RGHalf, RFloat, RHalf, R8


Log started: Sun, Mar 12, 2017 09:53:30


[WRN 09:53:31.952] [SpaceNavigatorWindows]: Could not initialize device.

[LOG 09:53:31.956] MainCanvas MASK: 3458764513820540928
[LOG 09:53:31.986] AssemblyLoader: Loading assemblies
[LOG 09:53:32.029] VesselModules: Found VesselModule of type CommNetVessel with order 999
[LOG 09:53:32.031] VesselModules: Found VesselModule of type FlightIntegrator with order 0
[LOG 09:53:32.033] VesselModules: Found 2 VesselModule types
[LOG 09:53:32.039]
************************************************************************

Environment Info
Win32NT 7FFFFFFFFFFFFFFF  Args: KSP_x64.exe

Mod DLLs found:
Stock assembly: Assembly-CSharp v1.0.0.0

Folders and files in GameData:

************************************************************************

[LOG 09:53:32.094] PhysicsGlobals: Loading database
[LOG 09:53:32.111] AppCanvas MASK: 3458764513820540928
[LOG 09:53:32.113] ActionCanvas MASK: 3458764513820540928
[LOG 09:53:32.247] Loading Asset Bundle Definitions
[LOG 09:53:32.250] AssetLoader: Loading bundle definitions
[EXC 09:53:32.256] DirectoryNotFoundException: Directory 'D:\#############\Right Hemisphere\Frontal Lobe\GAMES\KSP 1.2.2\GameData\Squad' not found.
    System.IO.Directory.GetFileSystemEntries (System.String path, System.String searchPattern, FileAttributes mask, FileAttributes attrs)
    System.IO.Directory.GetFiles (System.String path, System.String searchPattern)
    System.IO.DirectoryInfo.GetFiles (System.String searchPattern)
    System.IO.DirectoryInfo.GetFilesSubdirs (System.Collections.ArrayList l, System.String pattern)
    System.IO.DirectoryInfo.GetFiles (System.String searchPattern, SearchOption searchOption)
    (wrapper remoting-invoke-with-check) System.IO.DirectoryInfo:GetFiles (string,System.IO.SearchOption)
    KSPAssets.Loaders.AssetLoader+<LoadDefinitionsAsync>d__30.MoveNext ()
    UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress)
    UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
    <LoadAssetBundleObjects>c__Iterator4B:MoveNext()
    UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
    <CreateDatabase>c__Iterator49:MoveNext()
    UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
[LOG 09:53:32.283] GameDatabase: Assets loaded in 0.323s
[LOG 09:53:32.289] PartLoader: Version strings do not match. Creating part database.
[EXC 09:53:32.296] NullReferenceException: Object reference not set to an instance of an object
    PartUpgradeHandler.LinkUpgrades ()
    PartLoader+<CompileAll>c__Iterator61.MoveNext ()
    UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress)

 

Really bums me out having bought a nice machine for Mechanical Engineering school with the capability to do some pretty awesome gaming as well and one of my favorite games ever wont load.

First world problems I guess.

 

 

Share this post


Link to post
Share on other sites

9 answers to this question

  • 1
6 minutes ago, THEM4CHIN3 said:

[EXC 09:53:32.256] DirectoryNotFoundException: Directory 'D:\#############\Right Hemisphere\Frontal Lobe\GAMES\KSP 1.2.2\GameData\Squad' not found.

This looks like the problem, KSP can't find the game assets.

Possibly it's a folder name that can't be parsed, "#############" doesn't look normal to me so I think you need to move KSP to something like D:\Games\

Share this post


Link to post
Share on other sites
  • 1
11 minutes ago, THEM4CHIN3 said:

Is it a file name issue then? is the path too long? I think that'd be solved by just re-locating the files and folders to the desktop.

Could also be an unusual character in your username. In that case putting the files on the desktop wouldn't help because the file path to the desktop does still contain your username.

Share this post


Link to post
Share on other sites
  • 1
26 minutes ago, THEM4CHIN3 said:

Tried it again after relocating the whole game folder to the desktop.

It should work there assuming you're admin.

There's been a lot of reports lately of KSP folders and files being set to read only on Windows 10, this prevents KSP from working correctly, there should be the option in the folder properties to make it and all subfolders and files read-write.

If that doesn't work do you have any other Unity games that you can check?

Share this post


Link to post
Share on other sites
  • 0

perhaps a bunch of ##### symbols wasnt the best way to omit any personal information on my system.

I do not understand the issue of the game not finding it's assets. It's all in one location on my system. Not spread out or anything. I am not trying to load the KSP.exe from a folder separate from the game data folder and others.

Is it a file name issue then? is the path too long? I think that'd be solved by just re-locating the files and folders to the desktop.

Share this post


Link to post
Share on other sites
  • 0

Tried it again after relocating the whole game folder to the desktop. No change in performance. Log file still throwing out the same stuff.

So if it isn't finding the assets then how do I get it to find them? How was I reasonably able to play KSP despite needing to abandon saved progress every month or two as the game would eventually fall apart and not be able to account for all the probes and stuff I had sent into space. If not that issue then I'd get this weird bug  where it would just stare off into space and not ever be able to focus on the actual craft I was piloting. I had these problems on a pretty poopy machine, like I'm talking about 8 gigs ram on an integrated chipset.  Drop mad coin on a legit machine and somehow my problems only intensify.

Share this post


Link to post
Share on other sites
  • 0

Ran it again from a clean unzip on the desktop using compatibility mode in XP service pack 3, Vista service pack 2 and Windows 7 and 8 and 10 with just the "run as admin" box checked. Run as admin on all attempts.

No dice. Nothing changed, Log file says the same no matter the OS chosen- It's not finding Gamedata/Squad or -\Desktop\GameData\Squad' not found.

Looked over the files and folders and no limitations have been set on em', all boxes unchecked from "Read only" and "hidden".

I do not own any other Unity games.

Share this post


Link to post
Share on other sites
  • 0

Running KSP from the desktop is usually something we recommend you avoid, as Windows can prevent software from running if it doesn't have a registry entry, which is why I mentioned D:\Games\ (Guess your C drive is the OS)

Are you running the KSP.exe and KSP_x64.exe directly or via a shortcut? And do the Launchers work?

Maybe there's a clue in your dxdiag, please put it on pastebin for us, you say you've tried several versions of Windows, was this in a virtual machine? And have you tried older graphics drivers?

Share this post


Link to post
Share on other sites
  • 0

Ok, I understand you on the desktop thinger.

I have tried both 32 bit and 64 bit directly from the .exe. The launcher loads up no problems. I tried playing it through that but no improvement.

the other windows versions I tried were with the compatibility options in windows.

Share this post


Link to post
Share on other sites
  • 0

Silly question, but there is a Squad folder in GameData, right?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now