• 0
Excl

Docked Stations and Bases becoming really unstable

Question

This may already be a topic, but after a quick search I couldn't find anything related.  Is anyone else having a problem with extreme instability with docked space-stations and bases?  Much more so than any previous version?  I currently have a space station around Duna and am trying to piece together bases on Ike and Duna.  I first really started seeing this issue with the Space station.  If I try to use SAS to hold the station in a specific position, the base would soon start to oscillate back and forth until it eventually ripped itself apart.  I tried to disable most of the SAS modules on the various remote guidance units I had on each station piece, but it still seems to wobble out of control.

I then built a base on Ike.  Put down a ISU converter piece and a driller piece and docked them with a few fuel pipes and a main communication battery.  It seemed stable at first, but when I returned to the base after a few days, the station wobbled completely out of control and ripped itself apart in about 3 seconds.  I was able to "fast-forward" and resume over and over to keep the station long enough for me to disable all the drills, retract them and undock the drill unit from the rest of the station, but it was a really frustrating process.

Is anyone else having problems with really unstable docked stations?  Any way of avoiding/getting around this?  Thanks! 

Share this post


Link to post
Share on other sites

14 answers to this question

  • 0

My current career's second ring station (for Mun) developed destructive oscillations after installing the final, mining module. I assume it was because of a bad collision somewhere (the Mk3 short cargo bay is just a smidgen too short to easily hold a perpendicular Sr. Docking Port).

Time warp would cause modules to snap to original positions, but oscillations would start shortly after leaving time warp. The issue resolved itself when I auto-strutted the new modules (using time warp to snap them back before every toggle).

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Auto-strutted?  What do you mean by that?

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

11 minutes ago, Excl said:

Auto-strutted?  What do you mean by that?

In options you can enable advanced tweakables and after that you can autostrut (it holds your creations together without mass and drag) almost every part
it is explained a lot better here 

 

Edited by Numerlor

Share this post


Link to post
Share on other sites
  • 0

Try turning off all but one SAS Unit. I've found SAS units and pods mounted at different angles on different docked sections can "fight" each other, leading to the oscillations.

2 people like this

Share this post


Link to post
Share on other sites
  • 0

One thing I've found is that heavy parts that are far away from the center of mass of the whole craft is bad. I.e. don't put a processing lab as the last module far away from the center of mass of the station. 

Share this post


Link to post
Share on other sites
  • 0

One caveat about autostrutting, it is not a silver bullet.  If your station gets too big it will still shake apart.  Too many parts autostrutted to Root or Heaviest will cause the same problem as if you use Rigid Attachment, i.e. it all starts to feed back on itself and rips the station apart.  Apparently this is a Unity joint bug/issue.  There's a thread on it somewhere but I can't recall it offhand.

My solution was to autostrut everything to Grandparent - that way there is no feedback because the autostruts are spread out.  This Included docked craft.  If I docked a new craft and it started to misbehave I hand-edited the save file to fix the autostrutting on all parts.

It did make my stations behave like links of sausages, which made docking extra-tricky (even after timewarping to stabilize), but better that than a bunch of shrapnel.

 

3 hours ago, SelectHalfling0 said:

Try turning off all but one SAS Unit. I've found SAS units and pods mounted at different angles on different docked sections can "fight" each other, leading to the oscillations.

This sounds like a fabulous idea!  I'd always just left SAS turned off... except for short periods after bumps to stop spinning.  Only problem is enabling/disabling will get a little cumbersome when there are several docked craft.

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

Overuse of autostrut can make this worse too. there's an autostrut visualization tool in the debug console - you can see that one ends up with circular flows of forces that can lead to wild oscillations. 

I find it kind of fun to roleplay it, and have rescue and cleanup missions ready to fly

Edited by fourfa

Share this post


Link to post
Share on other sites
  • 0

This seems like a support-style question. And so, moved to Support. 

Share this post


Link to post
Share on other sites
  • 0

That's why USI MKS provides "proxy logistics" and WBI Pathfinder provides "distributed bases".
Both are to avoid the docking of station modules together, replacing this with resource "teleportation" in specific range.

Share this post


Link to post
Share on other sites
  • 0

There's two things that cause this, depending on the design of your base.

First is a PhysX bug in the joints that can cause them to feed back into each other increasing the force each time, this can be worked around using struts as they prevent the parts from moving enough for the forces to get out of control, though it helps to strut parts in a way that prevents movement on 3 axis.

Autostruts can help here, it's possible to fix a station by setting all the autostruts in the save file to True, perhaps a modder could make a plugin that lets us do this for a specific vessel.

Second is the wheels, if there's too many rover wheels, aircraft gear or landing legs (they are all the same thing) they can start to jump around, they are already autostrutted so struts won't help, the only workaround I know is to use fewer wheels.

The modular girder segments have been overlooked as supports for surface bases for too long...

Share this post


Link to post
Share on other sites
  • 0

Adding some more to this ...

So here's my base:

e4rp8KH.png

 

I'm trying to add the half on the left to the main part on the right.  I've got a number of auto-guidance units, but I've turned all of the Reaction Wheels to "Pilot-Only", the Reaction Wheels to "0" and the Toggle Torque to "disabled".  I've also put most of the units into Hibernation, except a select few.  There's also several legs and such, but I've activated only 10 legs so that most of the base is off of the wheels and not using many of the legs.

I plug the left into the right and BOOM, Instant Tacoma Narrows Bridge:

ZMlqPvb.png

I tried auto-strutting a bit too, but that didn't help.

The more irritating part is that this was working fine in previous version, but now if you get too big, your station goes into auto-destruct mode.

Share this post


Link to post
Share on other sites
  • 0

Your solar panels seems to start flapping ?

I had similar issue on a space station. The top of it had a non I-beam with 4 gigantors on it. As soon as I extend them, they start flapping. I solved the probme by using 2 small I-beam instead of 1.

On space station I tend to disable reactions wheels except on one place, especially on parts docked on small ports.

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, Warzouz said:

Your solar panels seems to start flapping ?

I had similar issue on a space station. The top of it had a non I-beam with 4 gigantors on it. As soon as I extend them, they start flapping. I solved the probme by using 2 small I-beam instead of 1.

On space station I tend to disable reactions wheels except on one place, especially on parts docked on small ports.

No, the whole station starts violently shaking and it rips itself apart.  You can see in the bottom left part of the last image, one of the modules has already torn off.

Unfortunately, I haven't found a solution to this.  The best thing I can do is make separate smaller stations, and they will generally keep together.

Share this post


Link to post
Share on other sites
  • 0

I am also experiencing this problem with large bases and stations. It cannot be fixed by turning the SAS off; I'm confident this is a bug that needs to be fixed in a patch.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now