Question

Posted (edited)

Do something add a setting, delta barely works, maybe make delta have a more extreme limit, I can barely land with this freezing and the 5fps I get with a decent computer

Edited by Abstract223

Share this post


Link to post
Share on other sites

8 answers to this question

  • 0

I am unsure of you're asking for. What is delta? What is the setting you want? Do you have any mods installed? Those tend to make your game laggy. What computer do you have? There's a lot of things you need to specify here, as of right now no one is sure what you have requested here.

Share this post


Link to post
Share on other sites
  • 0

I think he's talking about the physics stepping delta, and appears to believe that it's the best/the only thing he can change to improve performance.

 

@Abstract223 - what are you changing it to? It's normally 0.04. Are you setting it to 0.03, or to 0.05? Because if it's the former, you're not improving performance, but are making it worse. A smaller physics delta means more calculations per second, which costs more performance.

Apart from that: computer performance is a far more complex topic than you think it is. Your computer consists of many different parts, each of which can individually become a bottleneck in different cases. Adjusting physics delta will only give you more performance if your CPU clock speed is low. It will not do anything if you are running out of memory. It will also not do anything if you have a poor video card, or you are on a laptop with switchable graphics and your graphics driver software doesn't properly switch when KSP is started. It also won't help if your computer's internals are a solid block of age-old dust and grime, and one ore more of the parts in the system throttles itself because it cannot get enough cooling.

Without a proper, in-depth description of what's happening to you, where the worst performance drops happen, what mods you have installed, and what components you have in your computer, we won't be able to help you.

Share this post


Link to post
Share on other sites
  • 0
27 minutes ago, Streetwind said:

@Abstract223 - what are you changing it to? It's normally 0.04. Are you setting it to 0.03, or to 0.05? Because if it's the former, you're not improving performance, but are making it worse. A smaller physics delta means more calculations per second, which costs more performance.

Actually, it's a maximum time (Unity doc reference), so lower will in theory mean less physics calculations and thus a higher visual FPS (but also more GPU usage).  Raising it will lower the FPS but make the physics calculations better (more CPU/less GPU).

But the rest of your post is spot on.  That setting is for fine-tuning on systems running normally.  (e.g. I run it raised to 0.12 because it helps keep my big stations stable.)  On a system is running slow, lowering this setting is indeed going to make the problem worse, because a) it will push the (possibly already overloaded) GPU more and b) KSP won't likely have enough time to simulate vessel physics properly.

In the absense of more info, all I can suggest is to go to the Graphics tab of Settings and slide the Terrain Detail, Render Quality, and Texture Quality sliders all to the left, and turn off Terrain Scatters and all the FX buttons if any of them are green.  But that's blind advice... as has already been said, way more info is needed to properly diagnose the problem.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Really? I thought it was a setting that said "put a physics step every 0.0x seconds". Guess I thought wrong...

Share this post


Link to post
Share on other sites
  • 0
6 hours ago, Abstract223 said:

Do something add a setting, delta barely works, maybe make delta have a more extreme limit, I can barely land with this freezing and the 5fps I get with a decent computer

Often people will say "My computer specs are so high!" but will neglect to mention the 350 seperate programs they have running in the background, the 15 films they are downloading and 40bajillion megapixel monitor they are expecting to run at max FPS whilst they try and fly a 3000-part spacecraft through an atmosphere.

You're gonna have to A) give more detail about your computer and the situations that behave poorly, and B) accept that there might be something wrong other than poor coding by the devs, since this game has been around for many years now and has been running well on what was considered "decent" computers back then, so its unlikely that the software is fundamentally flawed in this respect.

3 people like this

Share this post


Link to post
Share on other sites
  • 0

Moved to tech support but we can't begin to help without info, and sometimes the only way to improve performance is with a better PC...

Please see here.

We'll need your dxdiag hardware report, and I suggest you turn off any other programs while running KSP.

Share this post


Link to post
Share on other sites
  • 0

@Abstract223, well if you have a decent PC, you could run a unmodded install of KSP easily run with 60 FPS. Unless you have way too much programs on the background.
But even in that case, you can run it smoothly by going into you task manager -> right-click on the KSP process -> details -> right-click on the KSP process in the details tab -> set priority to high (not to realtime, that will mess up your sound) 

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

went into the ksp folders and went to setting and set the delta to 5

Edited by Abstract223

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now