• 0
Sign in to follow this  
Followers 0
JMS1959

MechJeb not docking

Question

Recently MechJeb has been unable to dock successfully. Instead, it will get almost to the docking port and then just stops, leaving the thrusters alternatively pushing the ship forwards and backwards whilst the target port goes further off-axis. This has only started happening recently, so I replaced MechJeb with the latest version but still no joy.

Any ideas?

Share this post


Link to post
Share on other sites

11 answers to this question

  • 0

I had a similar problem when I put a docking port close to a large deployable heat radiator. The bounding box extends to far past the docking port. I added a fuselage piece with docking ports at either end, had no issues after

Share this post


Link to post
Share on other sites
  • 0

Will move the docking ports further from the vessels, thank you :)

 

Share this post


Link to post
Share on other sites
  • 0

Tick the Show Bounding Box in Docking Autopilot window. It will drop your framerate badly but will give you an idea and help you verify what Maxamillion-x72 said.If the boundaries of the box cross anything that stick out from the target vessel, MechJeb will dock.

Share this post


Link to post
Share on other sites
  • 0

I moved the docking ports further apart on both vessels but they still stop a metre or two from docking. The bounding boxes stop right on the forward edge of the docking ports to that isn't a problem. I did find (in a test) that if I undock the two vessels and move one away from the other but keep them both pointing at each other they will dock normally, but if I turn the vessel that is performing the docking, it will not dock, again stopping just a metre or two away. At that point, the docking ports start to slowly move off-centre.

Share this post


Link to post
Share on other sites
  • 0

If you have the MJ module on both vessels select control from here on both relevant ports, use SmartA.S.S and select TGT+ on both craft.

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

3 hours ago, dangerhamster said:

If you have the MJ module on both vessels select control from here on both relevant ports, use SmartA.S.S and select TGT+ on both craft.

I never had to do that. I just select Control from Here on the docking vessel and set a docking port on the destination as a target.

JMS, pay attention to the status of RCS. I noticed that MechJeb would sometimes turn RSC off too early which might result in what you're describing. If that happens indeed then quickly toggle RCS and it should finish docking.Or just try to nudge the ship towards the port manually.

I also found that the latest dev version is problematic so I'm using the latest release build 2.6.0.0.

Edited by Kerbital

Share this post


Link to post
Share on other sites
  • 0

I have this problem too.  I found that at the 2m mark, disable MJ, activate RCS, Docking mode, and push it those excruuuuciating two meters.

Share this post


Link to post
Share on other sites
  • 0

Have you guys tried deleting the MechJeb settings?

Kerbal Space Program\GameData\MechJeb2\Plugins\PluginData\MechJeb2

Share this post


Link to post
Share on other sites
  • 0
On 4/17/2017 at 4:39 AM, dangerhamster said:

If you have the MJ module on both vessels select control from here on both relevant ports, use SmartA.S.S and select TGT+ on both craft.

Just do that to line them up, if you leave the passive craft set to TGT+ mode they will dance around each other as each craft tries to follow the other.

 

48 minutes ago, Kerbital said:

Have you guys tried deleting the MechJeb settings?

Kerbal Space Program\GameData\MechJeb2\Plugins\PluginData\MechJeb2

You don't need to do that, in MJ's settings window there is an option to restore MJ to factory settings.

Share this post


Link to post
Share on other sites
  • 0

AFAIK that only resets the global setting file, not the numerous files created for each ship.

Share this post


Link to post
Share on other sites
  • 0

Thanks for all the replies :)

The problem still persists however, though I haven't yet tried deleting MJ settings or restoring it to the factory settings. The ship that is doing the docking will get to within 1 metre of the target vessel and then the RCS thrusters will alternatively fire towards and away from the target, and in the meantime the axis will slowly drift off-centre. The only way I can get them to dock is by turning off MJ and nudging the ship forward myself.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0