• 0
Lo Var Lachland

KSP display is too large. (NEED AN ANSWER)

Question

Posted (edited)

Okay. This is weird. I have an iMac, with a 5120 x 2880 resolution display. KSP has always looked normal on my screen, but today it looks like this:

Screen Shot 2017-05-09 at 10.49.57 AM

This is very squished and low res for my computer. 

 

It used to look like this:

Screen Shot 2016-10-23 at 3.40.37 PM copy

As you can see, a LOT larger. 

 

Any help?

Edited by Lo Var Lachland
1 person likes this

Share this post


Link to post
Share on other sites

8 answers to this question

  • 2

For what I know, the operating system may force a low but safe screen resolution when the one required by an application isn't supported (something alike a control panel should list all supported resolutions with your display).

KSP stores the resolution in the settings.cfg (lines "SCREEN_RESOLUTION_WIDTH = " and "SCREEN_RESOLUTION_HEIGHT = "). Of course those can be changed via the settings (Graphics) in game, but better check what really is stored. It should also work directly editing those two lines with values supported by your display.

Therefore, check what the values stored are; if they don't both match one of the supported resolutions, change them to one supported you like. Maybe do some experiments with lower resolution first, I've heard of some crazy high resolution being working in KSP but can't tell if the one you wish would. Also, did you change any other graphical settings before having this issue? Not having a Mac can't tell, but could be possible not all combinations of settings like V-sync or Frame Limit work at such resolution (Frame Limit in particular, its frequency by Width by Height by 4 defines the number of bytes your GFX must send to the display each second, with a Frame Limit = 120 that would amount to ~7.1 GB/s which is pretty high and may not be supported).

1 person likes this

Share this post


Link to post
Share on other sites
  • 1
6 hours ago, Lo Var Lachland said:

Okay. This is weird. I have an iMac, with a 5120 x 2880 resolution display. KSP has always looked normal on my screen, but today it looks like this:

Screen Shot 2017-05-09 at 10.49.57 AM

This is very squished and low res for my computer. 

 

It used to look like this:

Screen Shot 2016-10-23 at 3.40.37 PM copy

As you can see, a LOT larger. 

 

Any help?

Sorry I can't help but....

NYAN CAT!!! (April Fools)

1 person likes this

Share this post


Link to post
Share on other sites
  • 1

Try in the settings scaling down the UI size. Also, is your resolution running at the native resolution?

Share this post


Link to post
Share on other sites
  • 0

Also, evertime I manually edit the settings.cfg., it always comes up like this. 

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, Shadow Wolf56 said:

Sorry I can't help but....

NYAN CAT!!! (April Fools)

lol I know. :D

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Hey, I could really use some help here. Anyone?

Share this post


Link to post
Share on other sites
  • 0

If you would be Running Windows you could go to the registry and change the resolution of ksp there.

For Mac? No clue 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now