• 0
Gordon Dry

No pods existing

Question

Actually I have the issue that no pods are available, neither stock nor from mods.

ModuleManager.ConfigCache includes them, but PartDatabase.cfg does not.

The full log with everything regarded:

https://www.dropbox.com/s/c6g5ouxgv8a1a2c/2017-05-18-1 KSP.log.zip?dl=1

 

I just replaced the PartDatabase.cfg with the one from the Steam synchro (I use a copy in another folder), deleted the MM caches and try it again.

 

---

 

Nope.

Some mod (of course the log does not say which one ...) creates this:

PartLoader: Compiling Part 'Squad/Parts/Command/mk1pod/mk1Pod/mk1pod'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

PartLoader: Encountered exception during compilation. System.NullReferenceException: Object reference not set to an instance of an object
  at PartResourceDefinitionList.get_Item (System.String name) [0x00000] in <filename unknown>:0 
  at PartResourceLibrary.GetDefinition (System.String name) [0x00000] in <filename unknown>:0 
  at ShipConstruction.GetPartCostsAndMass (.ConfigNode partNode, .AvailablePart aP, System.Single& dryCost, System.Single& fuelCost, System.Single& dryMass, System.Single& fuelMass) [0x00000] in <filename unknown>:0 
  at ShipConstruction.SanitizePartCosts (.AvailablePart aP, .ConfigNode partNode) [0x00000] in <filename unknown>:0 
  at PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node) [0x00000] in <filename unknown>:0 
  at PartLoader+<CompileParts>c__Iterator62.MoveNext () [0x00000] in <filename unknown>:0 
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

and this:

NullReferenceException: Object reference not set to an instance of an object
  at PartLoader.GetDatabaseConfig (.Part p) [0x00000] in <filename unknown>:0 
  at PartLoader.GetDatabaseConfig (.Part p, System.String nodeName) [0x00000] in <filename unknown>:0 
  at DragCubeSystem.LoadDragCubes (.Part p) [0x00000] in <filename unknown>:0 
  at Part+<Start>c__Iterator38.MoveNext () [0x00000] in <filename unknown>:0 
  at UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress) [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)

Could it be FAR?

Edited by Gordon Dry

Share this post


Link to post
Share on other sites

1 answer to this question

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now