• 0
KerBlitz Kerman

Patchy Mods, Korrupted KSP, HELP!!!!!!!!!!!!!!

Question

Posted (edited)

I believe my KSP is corrupted. Almost every mod I install is patchy (list in hidden area below), I have resorted to pasting sooooooooooo many in just to test. Yeah, I'm desperate

Spoiler

Near Future Systems: 

 Electrical: Works well minus the reactor menu button image not loading, every part works.

Space Craft: Only crew storage works

Construction: Doesn't work at all 

Solar: Same as Construction

Propulsion: Most if not all engines, no fuel tanks ;.;. Now it's teasing me...

HyperEdit: First Mod, works perfectly!!! :) (for testing purposes only)

BDArmoury: a bit sketchy, you can only get to them through manufacturers tab and all action groups don't work, nor does the menu icon show up (or even a white square)

Kerbinside: Works perfectly, but like NFE is missing the in-flight and VAB/SPH Icon and all other Icons

Kurrikane: Works perfectly! :)

Here is my system stats: 

Latest version of Windows 10 x64 bit 

KSP x64

v1.2.2.1622

My suggestion: Can on new update you have the option of having an automatic installer replace your old KSP upon corruption????

Edited by KerBlitz Kerman

Share this post


Link to post
Share on other sites

21 answers to this question

  • 2

1 - Wrong section

2 - 

 

4 people like this

Share this post


Link to post
Share on other sites
  • 2

If the problem isn't a mod that isn't updated to 1.3, I'll eat my socks.

If a stock game misbehaves, maybe it's time to either reinstall KSP, or, if you have Steam, have Steam validate the local files.

If a modded game misbehaves... 95% of the time, it's either due to a mod or mis-installation of a mod.

4 people like this

Share this post


Link to post
Share on other sites
  • 1

None of the near future mods are updated to 1.3.

1 person likes this

Share this post


Link to post
Share on other sites
  • 1

Your thread has been moved to the support subforum. Good luck with your issue. 

1 person likes this

Share this post


Link to post
Share on other sites
  • 1

You might need toolbar mod for the icons, I can't remember exactly which mods needed it

1 person likes this

Share this post


Link to post
Share on other sites
  • 1

Posted (edited)

2 hours ago, KerBlitz Kerman said:

I believe my KSP is corrupted.

So reinstall it? Nothing special needed here, just delete averything but your saves/screenshots etc. directories, reinstall KSP, then reinstall your mods. Make sure you also install their dependencies.
If you think you have mod issues, just add mods one at a time until you identify the problem.

Automatically (or otherwise) 'fixing' a modded install is more trouble to do right than it is to just nuke and rebuild. Using CKANs export / import feature can be a time-saver here.

That said, your current list of problems does sound like you're missing some common dependency, you have got ModuleManager and co., right?

Edited by steve_v
1 person likes this

Share this post


Link to post
Share on other sites
  • 1
8 minutes ago, KerBlitz Kerman said:

Sorry, I have already reinstalled. TWICE. Is module manager stock? If not I don't have it sadly. Also I am in 1.2.2.1622 not 1.3, I want to see what the devs think of my suggestion (an automatic KSP replacer that replaces an old version, possibly corrupted COMPLETLy. then you have new version and new game.)

The developers wouldn't think much of your suggestion because it is almost never needed, and tools already exist for the rare occasions that it does happen: reinstall, or have Steam validate local game files.

Again, the overwhelming majority of the time when a modded game misbehaves, it's because of a mod... and we don't even have any logs to try to figure out what the problem might be.

Also, Module Manager is not stock, it is a mod, one of the most widely used ones out there.

2 people like this

Share this post


Link to post
Share on other sites
  • 1
8 hours ago, KerBlitz Kerman said:

How would Module Manager help?

ModuleManager is required by (and bundled with) heaps of mods, and I'm sure NF is one of them. You have ModuleManager.2.8.0.dll in your GameData directory?

Share this post


Link to post
Share on other sites
  • 1

@KerBlitz Kerman If your KSP is from the store, then its provided in compressed archive and archive will validate its contents via checksum function.
If your KSP is not from the store, then its either has validation function elsewhere (Steam) or can be validated manually with md5sum/sha256sum or similar (GOG standalone).

If you get corrupted archive, then you are experiencing network issues (your LAN or your ISP). This can happen anywhere in the chain, from bad Wifi connection, to loose wires somewhere in ISP center. This issue is not related to KSP.

The current KSP version is 1.3 and its the only one targeted by current mods because its latest official version. Any mod that targets previous versions is likely doing it on legacy support-basis.

It is correct that mods may corrupt the savefile, however they do not corrupt KSP installation, because that would be against KSP mod rules.
Please use KVC-ASP to make sure you are running latest version of the mods.

If you have any issues with the mods, please start with no mods in your Gamedata directory. Add one mod, start the career and make sure it does not produce problems.
Then gradually add another mod and keep testing until you find a buggy one, then report this mod - in either dedicated development thread of this mod, or here with pinging back to mod author.
Just observations are usually insufficient for support.

Share this post


Link to post
Share on other sites
  • 0

Sorry, I have already reinstalled. TWICE. Is module manager stock? If not I don't have it sadly. Also I am in 1.2.2.1622 not 1.3, I want to see what the devs think of my suggestion (an automatic KSP replacer that replaces an old version, possibly corrupted COMPLETLy. then you have new version and new game.)

Share this post


Link to post
Share on other sites
  • 0

If anybody has found a good cloud I can put it on there. How would Module Manager help?

Share this post


Link to post
Share on other sites
  • 0

No will add. Thanks!

Share this post


Link to post
Share on other sites
  • 0

Module Manager sadly didn't help me in crisis, what mod helps toolbar?

P.S. Does anyone know if chrome still corrupts KSP Downloads?

Share this post


Link to post
Share on other sites
  • 0

Chrome has never corrupted KSP downloads (I've been playing for 2 years and have always used chrome to download KSP from the kerbalspaceprogram.com store)

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Huh. I once saw a KSP care tips page that said otherwise.

Share this post


Link to post
Share on other sites
  • 0

Do you know of any clouds that accept the KSP filetypes. I know Dropbox is hopeless and Drive plain old doesn't work.

Share this post


Link to post
Share on other sites
  • 0
14 minutes ago, KerBlitz Kerman said:

Do you know of any clouds that accept the KSP filetypes. I know Dropbox is hopeless and Drive plain old doesn't work.

I use both Dropbox and Google Drive for sharing KSP logs, configs and mods so ¯\_(ツ)_/¯

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

When I attempted to use drive it said .cfg file is unreadable as well as others and dropbox won't let you upload folders and I am a very impatient person and as such I don't want to have to recreate every. single. folder..

Any others?

Those are the only clouds I have tested

Share this post


Link to post
Share on other sites
  • 0
On 6/18/2017 at 5:27 PM, KerBlitz Kerman said:

When I attempted to use drive it said .cfg file is unreadable as well as others and dropbox won't let you upload folders and I am a very impatient person and as such I don't want to have to recreate every. single. folder..

Well, have you tried NOT being a very impatient person? That would probably help you in properly isolating your problem and seeking out help from others.

Share this post


Link to post
Share on other sites
  • 0

1) remove all mods. KSP still crashing? Reinstall

 

2) add mods back one by one, until KSP crashes. Now you know what is causing the problem.

Share this post


Link to post
Share on other sites
  • 0

It doesn't crash, simply doesn't work. I think it is in the installer as each mod still does nothing. Does 1.3 act as an reinstallment of KSP? if so I might update to 1.3 just for that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now