• 0
OneSmallStepForKerbal

My game keeps on crashing!

Question

My game keeps on crashing every time it's in the loading files part! Every time I delete the folder/file that supports that mod and another pops up each time!

Someone help me!

Share this post


Link to post
Share on other sites

22 answers to this question

  • 0
20 minutes ago, OneSmallStepForKerbal said:

This is the error file.

Thanks, but I've had to go in and snip it out of your post.

I know you meant well, but please don't post large files (such as log files) in the forum itselfIt causes peoples' browsers to lag, it makes forum pages unreadable, and for folks on mobile devices it can lock up their browsers entirely.

Sharing log files is still a good thing to do... just don't put them in the post.  Instead, post the log file to some third-party file sharing site (there are lots of free ones on the internet), and then post a link to it from here.  Thanks!

Anyway:  It's clear that you've got mods installed.  (The fact that you have a ModuleManager.cache file indicates that you have ModuleManager, at least, installed.  I'm guessing you have others, too.)

So, the first thing to do is uninstall all mods completely.  That is, inside your GameData folder, there should be a "Squad" folder (the one that was installed with KSP), and nothing else, not even any empty folders.  Then try running.  Does it work, or does it crash?

  • If it works then, it means the issue is with one of the mods you have installed, so all you need to do is to narrow it down to which mod is causing the issue.
  • If it doesn't work then, you've got some other issue, but let's cross that bridge when we come to it.

Also, incidentally, deleting ModuleManager.cache is a red herring-- don't bother with it, it's not hurting anything.  It's a symptom rather than a cause.  ModuleManager just creates it for performance optimization each time it runs.  The problem you're encountering may have something to do with a malformed config file somewhere that ModuleManager is reading, or it might not have anything to do with ModuleManager at all-- hard to say at this point.

The main thing to do first is to establish whether it's a mod causing your problem, and if so, which one.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Moving to Technical Support.

Can you provide a bit more detail?  Your current description of the problem is rather vague.  Is the issue that you have a bunch of mods installed, and the game crashes on startup?  What happens if you uninstall all of your mods-- does the game start up okay then?

Are there any error messages in the log file?

Share this post


Link to post
Share on other sites
  • 0

But my game still keeps on crashing and this thing called ModuleManager.Cache and Config crashes my game and i keep deleting it and it pops up in the files and crashes the game on ModuleManager: FINAL

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

Heres all the files.

This is the error file. 

[Large log file contents snipped by moderator]

Edited by Snark
Large log file was included in post

Share this post


Link to post
Share on other sites
  • 0

 

Share this post


Link to post
Share on other sites
  • 0

What operating system is your computer?

Share this post


Link to post
Share on other sites
  • 0

YAY! Finally fixed problem.A couple of mods may have been outdated and caused it! Thank you!

Share this post


Link to post
Share on other sites
  • 0

But my game isn't giving the start screen when it finishes... Help?

Share this post


Link to post
Share on other sites
  • 0

logs please

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, OneSmallStepForKerbal said:

Here's proof from an image of the game not loading.

https://twitter.com/TheGamingEmrld

And that is absolutely useless information. You have to upload your logs to pastebin or dropbox or whatever. Just don't paste megabytes of text directly into the forum.

Share this post


Link to post
Share on other sites
  • 0

No, the problem is that it does not crash, but does not bring up the start/play menu. What I mean is that the menu doesn't pop up after loading.

 

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, OneSmallStepForKerbal said:

No, the problem is that it does not crash, but does not bring up the start/play menu. What I mean is that the menu doesn't pop up after loading.

 

Did you happen to delete the Squad folder inside GameData when you were removing your mods? KSP needs the contents of the folder called "Squad" since that is where the default game data is stored.

Share this post


Link to post
Share on other sites
  • 0

Hmm, I have the Stock KSP, but not the squad folder when i open up GameDATA

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

1 hour ago, OneSmallStepForKerbal said:

Hmm, I have the Stock KSP, but not the squad folder when i open up GameDATA

Your game can't run without the Squad folder and all its contents in place. Did you delete it? Can you recover it from your recycle bin?

1 hour ago, OneSmallStepForKerbal said:

I did the thing, and it still doesn't launch.

Do you mean that you put the Squad folder and all of the files and folders within it back in the GameData folder and it still doesn't work? Using an old version of Modulemanager can also cause a game to crash or freeze. Remove anything that says ModuleManager from your GameData folder and try again.

If KSP still doesn't run then I think you may have accidentally corrupted your installation. Are you running the game on Steam? On Steam you can verify your game files by right clicking the name of the game in your Steam library and going to Properties. Then select the "Local files" tab and click "Verify integrity of game files."

If you installed without Steam then you may have to download and reinstall the game again. It would be a good idea to make a back up copy of your "Saves" folder so you can transfer them back over to your new install, but be aware that anything you built that used modded parts cannot load if you don't have that mod installed. In the future always check to see that a mod has been tested to run on the version of KSP that you are using.

Edited by HvP

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

What I mean is that it runs, but still doesn't start up the menu. This menu.

97119F14E0C30E653A1FC5163D3665833CA1B64D

Edited by OneSmallStepForKerbal
Wanted to.

Share this post


Link to post
Share on other sites
  • 0

Posted (edited)

3 hours ago, OneSmallStepForKerbal said:

What I mean is that it runs, but still doesn't start up the menu. This menu.

I understand.

You know when you see that yellow bar at the bottom of the screen before it would go to the menu? That is the part where the game is loading in all of the files it needs to operate. But if it doesn't find some of the files it needs then it might not be able to go any further or load the menu. Since it isn't loading the menu that means some files are corrupt, missing or in the wrong place. The game can't find what it needs to go further. Or something is trying to load that is interfering with the normal operation of the game. Old or incompatible mods might do that.

I know it's no fun when your game won't work, but it's hard for us to help you because we don't know what files have been changed or where they are at. Can you give us a list of everything that is in your GameData folder? And can you be sure that you haven't moved or changed any other files outside of the GameData folder?

Did you try any of the steps I mentioned in my last post? If so. What did you try? It looks like you are playing on Steam, so it would really be a good idea to verify the integrity of your game files as I explained in the previous post. Make sure to make a backup copy of your "Saves" folder first.

And just to be sure, what version of KSP are you running and where did you get the picture of the screen that you uploaded? The version number shows that to be a very old copy of Kerbal Space Program. The most current version of KSP is 1.3.0.1804

Edited by HvP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now