Sign in to follow this  
Followers 0
MineOfTheCrafts

MechJeb No Worky!

13 posts in this topic

Hello. So im going to get straight to the point, MechJeb doesnt work for me. Iv tried uninstalling every mod, JUST the MechJeb. And when I first start KSP, MechJeb works just fine. But when I restart the flight, or make a new rocket, the second time I fly it, MechJeb is not there. It just disapears. Im not sure if there is a toggle key for it or something. But please if someone knows how to fix this, please tell me. :( Is Anyone there? Iv been hoping for replies. Can anyone ven see this... D: Wtf Idk dont ask me. Im talking to myself again. :( Darn. Which rymes with barn. Potato

Edited by MineOfTheCrafts
because potato

Share this post


Link to post
Share on other sites

Potato indeed! I wish I could be super helpful and tell you exactly what is going wrong, but anything I say is generally guesswork and almost consistently wrong.... That being said, are you 100% sure that you have your craft saved with the mechjeb intact? As far as a toggle key, I know that the main Mechjeb window can slide in and out from the side of the screen, so maybe it is just in and you have to click the tab to pull it back out?

Sorry if this isn't very helpful, but I'm trying!

Share this post


Link to post
Share on other sites

Mechjeb sometime disappears for me too. Only when I exit the Kerbin SOI.

Here are some things to try:

Download the latest mechjeb (http://www.kerbal.net/mod.php?id=20)

Turn all the mechjeb stuff off before unloading a ship.

place only one mechjeb on a ship.

delete the file where mechjeb stores it's state. (it's in recources or plugin data, sry I don't exactly remember)

Share this post


Link to post
Share on other sites

Hmm, never had this before. when you make new rocket, do you put the mechjeb pod or a mechjeb unit on your rocket? if you didnt, its not gonna work, if you dont put it actually ON the rocket. Secondly, if you cant see mechjeb, try looking to the right (again, assuming you have a mecheb module actually ON it, not just a rocket.) and you should see the panel named "mechjeb" clicking on that will open it up, if you cant see it, maybe wrong screen resouloution?

Share this post


Link to post
Share on other sites

I've closed the mechjeb panel a few times and couldn't open it back up without reinstalling. So I don't ever close it now.

Share this post


Link to post
Share on other sites

When you leave the planet Kerbin system, the Kraken will often eat your MechJeb. Mechanical Jeb Modules are it's favorite afternoon snack.

Share this post


Link to post
Share on other sites

The kraken issue is actually a result of the Mechjeb unfortunately. At the moment, mechjeb is warping from 1x to 10000x and back to 1x so fast that it literally rips the ship apart.

every time ive tried to use the 1.9.1 and even with the new 1.9.2 it has done this. Hopefully it gets a thorough update soon.

Share this post


Link to post
Share on other sites

mechjeb should be edited, to use highest warp possible, but activate it slowly

Share this post


Link to post
Share on other sites

Hi all, im not sure if this will help but i was having major problems for days with mechjeb in both 0.20 and 0.21. After many many hours i found the culprit myself. Now it may not be exactly the same problem but could be a lead in the right direction. I used to have the control part to attach to ship but no menu tabs ever appeared. This is a copy of my post from a different thread that worked for me.

Ok, problem solved. Here is what i did. After days of messing around with this thing i finally found the culprit. COMODO Anti Virus blocks certain applications if it does not recognise its certificates. I tried telling it that KSP can go do what it wants with no restrictions but still didnt work so i just uninstalled COMODO, Uninstalled KSP 0.20 and reinstalled KSP 0.21 with mechjeb 2.0.9 in the gamedata folder. I then gave it a test and all works perfectly. I then installed B9 parts and NovaPunch2 and tested again succesfully.

Share this post


Link to post
Share on other sites

I also can't get MechJeb to work. I copied the Parts and Plugins folder into my Kerbal directory in Steam, but I see no evidence of any change. There are no new windows, no new crew options and no new parts. Unfortunately the manual doesn't explain any of this.

Edit: Ah, never mind. For some reason the first time I copied the files over, it didn't put anything in the Plugins folder, only the Parts one.

Edited by RocketBlam

Share this post


Link to post
Share on other sites

A) Why did you reply to a august 2013 thread ?

B) You installed it wrong. You need to unzip MJ in the Gamedata folder so you get :


KSP
+- GameData
+-MechJeb2
+-Part
+-Plugin
+-Squad

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0