Sign in to follow this  
Followers 0
skykooler

[0.22] Extraplanetary Launchpads Legacy Thread

1525 posts in this topic

Orbital Consruction uses "spare parts" as a resource. So there should not be a conflict.

Orbital Construction became non-functional with the release of KSP 0.17, as the anti-Kraken measures implemented at the time catastrophically broke the transporting mechanism it was using to move vessels.

At the time I had tried to repair it without sucess, and the original author has since dissappeared.

There will be no conflicts, as this plugin is designed for a much newer version than that was ever functional for.

I am actually glad to see this working, as i had originally gotten into Orbital Construction precisely because I wanted this kind of capability.

Currently putting a Kethane probe in Minimus orbit to scan overnight, tomorrow I'll build an actual base with a launch pad and kethane processing equipment.

Share this post


Link to post
Share on other sites

Just for fun... what happens when you combine balloons and this mod...

I will be editing it, annotating and putting it on youtube some time later tomorrow [i had already done so but youtube ate my video...] but thought I would share the raw vid now ;)

EDIT: youtube resurrected the annotated version... sort of youtube link is up annotations might or might not work...

Edited by elfindreams

Share this post


Link to post
Share on other sites
Orbital Construction became non-functional with the release of KSP 0.17, as the anti-Kraken measures implemented at the time catastrophically broke the transporting mechanism it was using to move vessels.

At the time I had tried to repair it without sucess, and the original author has since dissappeared.

There will be no conflicts, as this plugin is designed for a much newer version than that was ever functional for.

I am actually glad to see this working, as i had originally gotten into Orbital Construction precisely because I wanted this kind of capability.

Currently putting a Kethane probe in Minimus orbit to scan overnight, tomorrow I'll build an actual base with a launch pad and kethane processing equipment.

Yeah, well, some awesome guy (evilC possibly) updated it to 0.20. So now we can have both. :)

Share this post


Link to post
Share on other sites

by the way not sure if anyone has said this, but congrats on your official mention in the current weekly update.

I am not sure if you remember skycooler, but you had be alpha test your original build. I am pleased to see you stuck with this. This is an incredible work of coding, and am proud to have helped even a tiny bit with it!

Share this post


Link to post
Share on other sites
look through your dev thread, someone made an awesome looking launchpad model with animation out of excitement but you weren't there at the time so the reply sank deep into the thread, i'll link it here if I find it

EDIT: here I found it, probably a great a idea to work with this guy

That looks like a good model.

Share this post


Link to post
Share on other sites

Great mod. Having a problem. I set up a rover-skycrane combo with a Kethane detector before setting up the launchpad on the Mun. As soon as the skycrane took off back into Mun orbit, everything exploded. A base with at least 7 kerbals (using the HOME Module from Bobcat) disapeared off the mun. No debris field. So I sent up a second one. As soon as the second skycrane was about 1000 meters away, the rover's physics went asdfghjkl and every part went in every direction. Not sure whats going on, but something with your mod and the original kethane mod is going crazy, or something with another mod is reacting with the others. Never had a problem with any mods not meshing together before.

Share this post


Link to post
Share on other sites
That looks like a good model.

It is a great model. I was looking forward to it being in game!

Great mod. Having a problem. I set up a rover-skycrane combo with a Kethane detector before setting up the launchpad on the Mun. As soon as the skycrane took off back into Mun orbit, everything exploded. A base with at least 7 kerbals (using the HOME Module from Bobcat) disapeared off the mun. No debris field. So I sent up a second one. As soon as the second skycrane was about 1000 meters away, the rover's physics went asdfghjkl and every part went in every direction. Not sure whats going on, but something with your mod and the original kethane mod is going crazy, or something with another mod is reacting with the others. Never had a problem with any mods not meshing together before.

Hit Alt-F12 before you launch and watch the debug log

Share this post


Link to post
Share on other sites
It is a great model. I was looking forward to it being in game!

Hit Alt-F12 before you launch and watch the debug log

And that'll tell me what exactly?

Share this post


Link to post
Share on other sites

i've always wanted this, but i thought of it as you choose where to launch, and there was a proper space center on every planet and moon. but otherwise good job.

Share this post


Link to post
Share on other sites

i just cried tears of happiness thank you so much :D:::::*O

Share this post


Link to post
Share on other sites
look through your dev thread, someone made an awesome looking launchpad model with animation out of excitement but you weren't there at the time so the reply sank deep into the thread, i'll link it here if I find it

EDIT: here I found it, probably a great a idea to work with this guy

Someone.

Please.

Make this happen, it looks so good, it will totally do until this is officially in the stock game (a while).

Share this post


Link to post
Share on other sites
look through your dev thread, someone made an awesome looking launchpad model with animation out of excitement but you weren't there at the time so the reply sank deep into the thread, i'll link it here if I find it

EDIT: here I found it, probably a great a idea to work with this guy

That is one nice looking launchpad!

I think it should be a very heavy beast to put into orbit and land thou... Establishing a construction facility offworld should be hard!

In my opinion: 50+ tonnes atleast!

I haven't tested the mod yet, but 5 t for a mobile launchpad feels a bit too easy to move around.

Share this post


Link to post
Share on other sites
FVqu8Im.png

QLPE9aV.jpg

6ebLpNA.png

iUYsF0z.png

Confirmed working with hooligans mods, the kerbal launching is in my iva cage and has an minisrb on the back.

This was at ca 17km altitude

ox9mqJm.png

Nice burning effect, would it be okey if i used it in my kerballog mod ?^^ WOuld give a nice warm feeling to it

Haha i had forgotten about deadly re-entry plugin so the smelter got really hot really fast and well, there was some accidents

I just realized what these were screenshots of.... I posted a vid a bit later where i launched from atmo... how did you get everything to stay stable, I had a dickens of a time keeping the platform stable enough (the ships kept sliding off)? Also that green "pod" what mod is that? Same questions with the asteroids... I really like your airbase.

Share this post


Link to post
Share on other sites

Ha! That is an easy enough fix. Can you share the code you used to put it on there?

Share this post


Link to post
Share on other sites
Ha! That is an easy enough fix. Can you share the code you used to put it on there?

Sure! I just added this to the part.cfg:

MODULE
{
name = ExLaunchPad
debug = true
}

Share this post


Link to post
Share on other sites

im having an issue with the holder cans for ores and metals not having any texture mesh. Anyone else having this issue and how to fix it?

Share this post


Link to post
Share on other sites

So now that I have everything working I am redoing my scan of Kerbin.

A couple things I see, not so sure about...Map has only Yellow(I assume is ore) and white (I assume that's kethane now?)

I'm wondering why the deposits seem so sparse? Even if everything on my map was green it would be about 1/2 the amount that's normaly on Kerbin with Kethane 0.5. Is that right? Or is it possible Im still having issues....

Also a universal debug tool would be nice, as the kethane one does not work with your MMI.dll replacement....not sure if it would work for ore n such anyway? Having debug is nice for testing though.

Share this post


Link to post
Share on other sites

Haha i also tried with the platforms, cool to hear you can fix it easy hoolligan ^^

@ elfindreams The asteroid is from http://kerbalspaceprogram.com/20-asteroids-from-fasa-2/, the green dome is one of my unfinished products :P Hmm to make it stable i used asases(sounds like another word haha) and the strong ropes from http://forum.kerbalspaceprogram.com/showthread.php/27283-InfiniteDice-Strong-Struts-Pack-BONUS-SUPER-JETPACK-KSP-0-19-1 plugin

Share this post


Link to post
Share on other sites

Seems awesome, I just want to check if I got things right: when you click on load ship on the lauchpad, it should open a window or something even if it is in debug mode, right?

Share this post


Link to post
Share on other sites

Hey what if I have a save game, will the ore generate in my world? or do I need to do something for it to generate?

Share this post


Link to post
Share on other sites
Hey what if I have a save game, will the ore generate in my world? or do I need to do something for it to generate?

You need to delete the kethane.cfg from your save folder.

Share this post


Link to post
Share on other sites

:confused:Thanks, also my game causes the world to disappear when I load with the parts on my ship -_-

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0