NathanKell

[1.2] Real Solar System v12.0 Dec 8

7499 posts in this topic

Yes, renaming references in RSSVE-Lite was not a good idea, alone re-enabling cbNameLater did the job.

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

Good day guys

I am a bit lost and need your help. >.<
Just recently i went back playing some KSP after 1.3 was released, but because my favorite mods are not supported i went back to KSP 1.2.2 via clean install.
I then installed CKAN and installed a couple of mods including of course RSS.

Now everything seems to be working fine, no glitches etc.. BUT... after building a rocket with about 11000 m/s deltaV and launching it, i realised that the solar system is not the real size. I reached orbit with just above 2000m/s instead, and had enough fuel to get basically anywhere in the solar system. (boring) :( 
All i did in CKAN was checking "Real Solar System", "Real Solar System Textures - 8192 x 4096" and "Realism Overhaul" and clicked "Apply changes" to install all dependencies/recommendations(Kopernicus, FAR etc). 
Now does anybody here know how to quickfix this anyhow? Is there a folder in the gamedata location that i can simply replace in order to get all bodies to real size(and distance)?

Just for testing i downloaded the 10x Kerbol System modification, but before placing it in the gamedata folder i checked its contents and it does not contain the files for all of Sol's planetary bodies.. only for Kerbol.
In the installation path within the RSS folder i found the .cfg files for earth, mars, venus, sun etc.. containing values such as their radius, inclination etc... so i guess if i find the proper .cfgs somewhere, and just replace them, it will work!? Not sure, because of dependencies such as EVE, clouds etc tho..
Anyone can give me a hint where to start from to get this fixed? Im just a bit confused because in CKAN there is a ability to download half and quarter size RSS, which i didnt... i just downloaded the normal one and expected it to be the real size.



Thaaaanks guys & have a good week
Basti
 

Edited by EagleDeMoN

Share this post


Link to post
Share on other sites
31 minutes ago, EagleDeMoN said:

Good day guys

I am a bit lost and need your help. >.<
Just recently i went back playing some KSP after 1.3 was released, but because my favorite mods are not supported i went back to KSP 1.2.2 via clean install.
I then installed CKAN and installed a couple of mods including of course RSS.

Now everything seems to be working fine, no glitches etc.. BUT... after building a rocket with about 11000 m/s deltaV and launching it, i realised that the solar system is not the real size. I reached orbit with just above 2000m/s instead, and had enough fuel to get basically anywhere in the solar system. (boring) :( 
All i did in CKAN was checking "Real Solar System", "Real Solar System Textures - 8192 x 4096" and "Realism Overhaul" and clicked "Apply changes" to install all dependencies/recommendations(Kopernicus, FAR etc). 
Now does anybody here know how to quickfix this anyhow? Is there a folder in the gamedata location that i can simply replace in order to get all bodies to real size(and distance)?

Just for testing i downloaded the 10x Kerbol System modification, but before placing it in the gamedata folder i checked its contents and it does not contain the files for all of Sol's planetary bodies.. only for Kerbol.
In the installation path within the RSS folder i found the .cfg files for earth, mars, venus, sun etc.. containing values such as their radius, inclination etc... so i guess if i find the proper .cfgs somewhere, and just replace them, it will work!? Not sure, because of dependencies such as EVE, clouds etc tho..
Anyone can give me a hint where to start from to get this fixed? Im just a bit confused because in CKAN there is a ability to download half and quarter size RSS, which i didnt... i just downloaded the normal one and expected it to be the real size.



Thaaaanks guys & have a good week
Basti
 

Sounds like you downloaded Stock Size Real Solar System.

Share this post


Link to post
Share on other sites

Posted (edited)

Yea, indeed it does. But where do i get the real solar system from? Because in CKAN there is only 3 options, quarter size, half size and plain simple "Real Solar System"(i downloaded the latter).. i guess i have to download it manually because it is not showing in CKAN or CKAN is downloading the wrong one?

But hah... sorry, i think i found the cure here:
https://github.com/KSP-RO/RealSolarSystem/releases/tag/v12.0.0

Im currently not at home, but i guess if i download this "RealSolarSystem_v12.0.zip", and use it to replace all the folders in my gamedata folders then it should be working.... i guess? :)



Thanks anyway & bests
 

Edited by EagleDeMoN

Share this post


Link to post
Share on other sites

 

On 5.5.2017 at 4:16 AM, Albman said:

the runway is broken in 4 places

On 5.5.2017 at 4:37 AM, Galileo said:

It's a stock issue. Will be fixed in 1.3

This is true for stock. But on rescaled planets the pieces of the runway move - on bigger planets like earth the gaps are back.

So it's plane crash time again ... unfortunately.

Is there anything we could do manually meanwhile?

Share this post


Link to post
Share on other sites
11 minutes ago, Gordon Dry said:

 

This is true for stock. But on rescaled planets the pieces of the runway move - on bigger planets like earth the gaps are back.

So it's plane crash time again ... unfortunately.

Is there anything we could do manually meanwhile?

Get Kerbal Konstructs/ Kerbinside and build your own runways. That's what I did. The default runway is my rover testing site now. 

1 person likes this

Share this post


Link to post
Share on other sites

I'll give it a try.

And another mod ...

Quote

Get lost of some mods. You got way too much mods.

You know ...

Share this post


Link to post
Share on other sites

KK/KS are totally worth it. The ability to build useable facilities and improve KSC makes the game tons better, especially with how large the Earth is compared to Kerbin.  One of my first projects in RSS now is trying to do incremental staging fields extending south until I can establish an equatorial launch site. So I'll have a trail of airfield down through the Caribbean and Central America and usually set up a launch site somewhere in Brazil or Peru around the equator. My rule of thumb is that establishing airbases can't be a suicide mission, I can't use more than half of my useful fuel load, and I can't use drones. I have to fly a team of Kerbals to each site and I have to leave something - a rover, a science pod, something behind. Each airlift has to start at KSC and refuel at the airbases along the way. It's time consuming, but I like the challenge. 

Share this post


Link to post
Share on other sites

Hmm. I just installed it and now KK itself throws massive exceptions and other mods started, too.

So actually either I don't know how to use KK or I just can't because it's bugging around...

I placed a 2nd runway next to the default one in Cape Canaveral. But I can't choose it - no matter what.

This is getting too much. More mods. More bugs.

I decide again - as so often before - no more planes. Basta.

Share this post


Link to post
Share on other sites

Posted (edited)

Is anyone else experiencing issues with biomes? I'm running the latest versions of RSS, Kopernicus, and ScanSAT, the 8k texture pack, and Gallileo's 1.3 RSS patch. I'm only getting a few moon biomes compared to RSS-textures/PluginData/MoonBiomes.png, and biome names aren't showing up. 

Disregard, I got it sorted out. Turns out I didn't have the right texture pack installed.

Edited by DocRockwell

Share this post


Link to post
Share on other sites

Posted (edited)

GameData\RealSolarSystem\LaunchSites.cfg

US Cape Canaveral = reorientFinalAngle = -9.395667

RWY heading = 90° / 270°

so, add 80.604333 to the reorientFinalAngle values, that SHOULD give the runway headings?

Example (testing): FR - Kourou
reorientFinalAngle = -37.231513

RWY heading = 117.835846 = 118° / 298°

Is this correct?

Edit:

nope, it seems that it's just so simple that every runway is headed 90° ... :o

Edited by Gordon Dry

Share this post


Link to post
Share on other sites

Posted (edited)

I recently installed this along with RO in my new ksp install and problems happened. I installed RO and all of its required and recommended mods plus a few extras. I ran in to a few memory problems but I killed a few mods so that I could load to the menu. I thought I was all good to go until I tried to start a game. I was stuck on the black loading screen with the planets (still spinning) for a good 15mins until I gave up. This has happened evertime I try to start a game and also when I try to go to the settings menu. I am using the lowest resolution textures. KSP.log here and output log here. Below is a screenshot of my GameData folder.

Spoiler

CSXvWqY.png

I am running an i7@2.6ghz (always runs at 3.2 for some reason though) with 16gb RAM and GTX960m. I am running KSP x64 off of an SSD. Any ideas? I will be trying a fresh install with just RSS in a few minutes to see if it's that or a conflict. I know that someone is going to go straight for the 50/50 suggestion but I want to save that as a last resort option as it seems that everything depends on everything to work. Thanks.

 

Ok, update: I tried to run a fresh version of KSP with just RSS installed and nothing happened. It loaded fine but it was just stock in game. Here is the log file for that install. Here is a screenshot of that GameData folder. Am I missing something really simple here? I'm pretty sure that I followed all the instructions. I've got no idea what's going on. Any help would be much appreciated. Thanks.

Edited by Benji13

Share this post


Link to post
Share on other sites

@Benji13 You have a badly corrupted base KSP installation, on top of using some KSP 1.3-only mods with KSP 1.2. Delete your current installation, get a clean copy of KSP and reinstall carefully all the mods.

Share this post


Link to post
Share on other sites
2 minutes ago, Phineas Freak said:

@Benji13 You have a badly corrupted base KSP installation, on top of using some KSP 1.3-only mods with KSP 1.2. Delete your current installation, get a clean copy of KSP and reinstall carefully all the mods.

KSP AVC says that all mods are compatible except for a few that are for 1.2. And what makes you say that my ksp is corrupted? I'm not saying that you are wrong and I will try what you said but what's makes you think this?

Share this post


Link to post
Share on other sites

Posted (edited)

6 minutes ago, Benji13 said:

KSP AVC says that all mods are compatible except for a few that are for 1.2.

[LOG 18:18:21.904] Load(Assembly): /ModuleManager.2.8.0
[LOG 18:18:21.907] AssemblyLoader: Loading assembly at C:\Program Files\KSP_win64\GameData\ModuleManager.2.8.0.dll

MM 2.8.0 is KSP 1.3 only. This is enough for the rest of the mods that depend on it to break.

Also, SSTU Tools?

[ERR 18:18:24.218] AssemblyLoader: Exception loading 'Microsoft.DirectX.Direct3D': System.BadImageFormatException: Could not load file or assembly 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\Debug\Microsoft.DirectX.Direct3D.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\Debug\Microsoft.DirectX.Direct3D.dll'
  at (wrapper managed-to-native) System.Reflection.Assembly:LoadFrom (string,bool)
  at System.Reflection.Assembly.LoadFrom (System.String assemblyFile) [0x00000] in <filename unknown>:0 
  at AssemblyLoader+LoadedAssembly.Load () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

[ERR 18:18:24.235] AssemblyLoader: Exception loading 'Microsoft.DirectX.Direct3DX': System.BadImageFormatException: Could not load file or assembly 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\Debug\Microsoft.DirectX.Direct3DX.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\Debug\Microsoft.DirectX.Direct3DX.dll'
  at (wrapper managed-to-native) System.Reflection.Assembly:LoadFrom (string,bool)
  at System.Reflection.Assembly.LoadFrom (System.String assemblyFile) [0x00000] in <filename unknown>:0 
  at AssemblyLoader+LoadedAssembly.Load () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

[ERR 18:18:24.252] AssemblyLoader: Exception loading 'Microsoft.DirectX': System.BadImageFormatException: Could not load file or assembly 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\Debug\Microsoft.DirectX.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\Debug\Microsoft.DirectX.dll'
  at (wrapper managed-to-native) System.Reflection.Assembly:LoadFrom (string,bool)
  at System.Reflection.Assembly.LoadFrom (System.String assemblyFile) [0x00000] in <filename unknown>:0 
  at AssemblyLoader+LoadedAssembly.Load () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

[ERR 18:18:24.269] AssemblyLoader: Exception loading 'Microsoft.DirectX.Direct3D': System.BadImageFormatException: Could not load file or assembly 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\x86\Release\Microsoft.DirectX.Direct3D.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\x86\Release\Microsoft.DirectX.Direct3D.dll'
  at (wrapper managed-to-native) System.Reflection.Assembly:LoadFrom (string,bool)
  at System.Reflection.Assembly.LoadFrom (System.String assemblyFile) [0x00000] in <filename unknown>:0 
  at AssemblyLoader+LoadedAssembly.Load () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

[ERR 18:18:24.287] AssemblyLoader: Exception loading 'Microsoft.DirectX.Direct3DX': System.BadImageFormatException: Could not load file or assembly 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\x86\Release\Microsoft.DirectX.Direct3DX.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\x86\Release\Microsoft.DirectX.Direct3DX.dll'
  at (wrapper managed-to-native) System.Reflection.Assembly:LoadFrom (string,bool)
  at System.Reflection.Assembly.LoadFrom (System.String assemblyFile) [0x00000] in <filename unknown>:0 
  at AssemblyLoader+LoadedAssembly.Load () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

[ERR 18:18:24.304] AssemblyLoader: Exception loading 'Microsoft.DirectX': System.BadImageFormatException: Could not load file or assembly 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\x86\Release\Microsoft.DirectX.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\x86\Release\Microsoft.DirectX.dll'
  at (wrapper managed-to-native) System.Reflection.Assembly:LoadFrom (string,bool)
  at System.Reflection.Assembly.LoadFrom (System.String assemblyFile) [0x00000] in <filename unknown>:0 
  at AssemblyLoader+LoadedAssembly.Load () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

And:

Assembly-CSharp-firstpass v0.0.0.0
Stock assembly: Assembly-CSharp v1.0.0.0
Assembly-UnityScript-firstpass v0.0.0.0 / v
Assembly-UnityScript v0.0.0.0 / v
KSPAssets v1.0.0.0
SSTUTools v0.0.0.0
UnityEngine v0.0.0.0
UnityEngine.UI v1.0.0.0
UnityScript.Lang v1.0.0.0 / v
Assembly-CSharp-firstpass v0.0.0.0
Stock assembly: Assembly-CSharp v1.0.0.0
Assembly-UnityScript-firstpass v0.0.0.0 / v
Assembly-UnityScript v0.0.0.0 / v
KSPAssets v1.0.0.0
SSTUTools v0.0.0.0
UnityEngine v0.0.0.0
UnityEngine.UI v1.0.0.0
UnityScript.Lang v1.0.0.0 / v
Assembly-CSharp-firstpass v0.0.0.0
Stock assembly: Assembly-CSharp v1.0.0.0
Assembly-UnityScript-firstpass v0.0.0.0 / v
Assembly-UnityScript v0.0.0.0 / v

The KSP base assemblies are installed/loaded 3 times via SSTUTools (?)

Edit: OK, not a corrupted KSP installation but a very weird GameData folder.

Edited by Phineas Freak

Share this post


Link to post
Share on other sites
4 minutes ago, Phineas Freak said:

[LOG 18:18:21.904] Load(Assembly): /ModuleManager.2.8.0
[LOG 18:18:21.907] AssemblyLoader: Loading assembly at C:\Program Files\KSP_win64\GameData\ModuleManager.2.8.0.dll

MM 2.8.0 is KSP 1.3 only. This is enough for the rest of the mods that depend on it to break.

Also, SSTU Tools?


[ERR 18:18:24.218] AssemblyLoader: Exception loading 'Microsoft.DirectX.Direct3D': System.BadImageFormatException: Could not load file or assembly 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\Debug\Microsoft.DirectX.Direct3D.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\Debug\Microsoft.DirectX.Direct3D.dll'
  at (wrapper managed-to-native) System.Reflection.Assembly:LoadFrom (string,bool)
  at System.Reflection.Assembly.LoadFrom (System.String assemblyFile) [0x00000] in <filename unknown>:0 
  at AssemblyLoader+LoadedAssembly.Load () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

[ERR 18:18:24.235] AssemblyLoader: Exception loading 'Microsoft.DirectX.Direct3DX': System.BadImageFormatException: Could not load file or assembly 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\Debug\Microsoft.DirectX.Direct3DX.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\Debug\Microsoft.DirectX.Direct3DX.dll'
  at (wrapper managed-to-native) System.Reflection.Assembly:LoadFrom (string,bool)
  at System.Reflection.Assembly.LoadFrom (System.String assemblyFile) [0x00000] in <filename unknown>:0 
  at AssemblyLoader+LoadedAssembly.Load () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

[ERR 18:18:24.252] AssemblyLoader: Exception loading 'Microsoft.DirectX': System.BadImageFormatException: Could not load file or assembly 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\Debug\Microsoft.DirectX.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\Debug\Microsoft.DirectX.dll'
  at (wrapper managed-to-native) System.Reflection.Assembly:LoadFrom (string,bool)
  at System.Reflection.Assembly.LoadFrom (System.String assemblyFile) [0x00000] in <filename unknown>:0 
  at AssemblyLoader+LoadedAssembly.Load () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

[ERR 18:18:24.269] AssemblyLoader: Exception loading 'Microsoft.DirectX.Direct3D': System.BadImageFormatException: Could not load file or assembly 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\x86\Release\Microsoft.DirectX.Direct3D.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\x86\Release\Microsoft.DirectX.Direct3D.dll'
  at (wrapper managed-to-native) System.Reflection.Assembly:LoadFrom (string,bool)
  at System.Reflection.Assembly.LoadFrom (System.String assemblyFile) [0x00000] in <filename unknown>:0 
  at AssemblyLoader+LoadedAssembly.Load () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

[ERR 18:18:24.287] AssemblyLoader: Exception loading 'Microsoft.DirectX.Direct3DX': System.BadImageFormatException: Could not load file or assembly 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\x86\Release\Microsoft.DirectX.Direct3DX.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\x86\Release\Microsoft.DirectX.Direct3DX.dll'
  at (wrapper managed-to-native) System.Reflection.Assembly:LoadFrom (string,bool)
  at System.Reflection.Assembly.LoadFrom (System.String assemblyFile) [0x00000] in <filename unknown>:0 
  at AssemblyLoader+LoadedAssembly.Load () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

[ERR 18:18:24.304] AssemblyLoader: Exception loading 'Microsoft.DirectX': System.BadImageFormatException: Could not load file or assembly 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\x86\Release\Microsoft.DirectX.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'C:\Program Files\KSP_win64\GameData\Plugin\SSTUTools\SSTUUtilDDS\bin\x86\Release\Microsoft.DirectX.dll'
  at (wrapper managed-to-native) System.Reflection.Assembly:LoadFrom (string,bool)
  at System.Reflection.Assembly.LoadFrom (System.String assemblyFile) [0x00000] in <filename unknown>:0 
  at AssemblyLoader+LoadedAssembly.Load () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

And:


Assembly-CSharp-firstpass v0.0.0.0
Stock assembly: Assembly-CSharp v1.0.0.0
Assembly-UnityScript-firstpass v0.0.0.0 / v
Assembly-UnityScript v0.0.0.0 / v
KSPAssets v1.0.0.0
SSTUTools v0.0.0.0
UnityEngine v0.0.0.0
UnityEngine.UI v1.0.0.0
UnityScript.Lang v1.0.0.0 / v
Assembly-CSharp-firstpass v0.0.0.0
Stock assembly: Assembly-CSharp v1.0.0.0
Assembly-UnityScript-firstpass v0.0.0.0 / v
Assembly-UnityScript v0.0.0.0 / v
KSPAssets v1.0.0.0
SSTUTools v0.0.0.0
UnityEngine v0.0.0.0
UnityEngine.UI v1.0.0.0
UnityScript.Lang v1.0.0.0 / v
Assembly-CSharp-firstpass v0.0.0.0
Stock assembly: Assembly-CSharp v1.0.0.0
Assembly-UnityScript-firstpass v0.0.0.0 / v
Assembly-UnityScript v0.0.0.0 / v

The KSP base assemblies are installed/loaded 3 times via SSTUTools (?)

Edit: OK, not a corrupted KSP installation but a very weird GameData folder.

Ah ok. I will try a fresh install and make sure I get the right mm this time, thanks. 

Share this post


Link to post
Share on other sites

@Phineas Freak I tried it with the latest version of Module Manager intended for 1.2.x (2.7.6) and I got the same result. I then tried it with the version of MM that comes with RSS (2.7.5) and it worked perfectly. I didn't think that the difference between the two would make a difference but apparently it does. Strange. Anyway, thanks for your help.

Share this post


Link to post
Share on other sites
43 minutes ago, Benji13 said:

@Phineas Freak I tried it with the latest version of Module Manager intended for 1.2.x (2.7.6) and I got the same result. I then tried it with the version of MM that comes with RSS (2.7.5) and it worked perfectly. I didn't think that the difference between the two would make a difference but apparently it does. Strange. Anyway, thanks for your help.

I doubt that switching from MM 2.7.6 to 2.7.5 is what made a difference. Something else happened there and you should make sure your mod directories are clean of stray dlls. 

Share this post


Link to post
Share on other sites

Does anyone have the textures for RSS 8.6.1?

Share this post


Link to post
Share on other sites

What is the correct inclination and LAN for a probe in Earth orbit to be aligned with the ecliptic? I remember reading that it was fixed at 23.5° and 0° respectively but I can't find the reference. My current probe is off by a small amount and it's driving me mad.

Share this post


Link to post
Share on other sites
2 hours ago, Gaarst said:

What is the correct inclination and LAN for a probe in Earth orbit to be aligned with the ecliptic? I remember reading that it was fixed at 23.5° and 0° respectively but I can't find the reference. My current probe is off by a small amount and it's driving me mad.

The Moon's orbital plane is close enough to the ecliptic for most purposes.

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

How do you change the lighting parameters in the newest version? With the default settings it feels like I'm wearing sunglasses while watching a slasher movie.

According to this page: https://github.com/NathanKell/RealSolarSystem/wiki/Lighting-Parameters

-I should be able to change the sunlight intensity in a "RealSolarSystemSettings.cfg", but that file doesn't exist in the latest version and none of the other configuration files have anything relevant.

 

Also, anyone know of some workarounds for the ksc "seams" in the runway and whatnot being amplified by RSS? I love experimenting with aircraft design but currently have to taxi the vessel into the grass to launch.

Edited by FierySwordswoman
1 person likes this

Share this post


Link to post
Share on other sites

@Gaarst just a few days ago i was searching for the same information. i can point you to the RSS github wiki:

https://github.com/NathanKell/RealSolarSystem/wiki/Launching-into-the-Ecliptic
also the LAN - longitude of ascending node is important

@Aelfhe1m the moon is 5.1° of the ecliptic it is close but you have to correct that. And during an escape burn to Venus or Mars the normal/antinormal has quite a high percentage...

1 person likes this

Share this post


Link to post
Share on other sites
2 hours ago, KroShan said:

@Gaarst just a few days ago i was searching for the same information. i can point you to the RSS github wiki:

https://github.com/NathanKell/RealSolarSystem/wiki/Launching-into-the-Ecliptic
also the LAN - longitude of ascending node is important

@Aelfhe1m the moon is 5.1° of the ecliptic it is close but you have to correct that. And during an escape burn to Venus or Mars the normal/antinormal has quite a high percentage...

Yes, the Moon isn't in the plane of the ecliptic but neither are any of the planets. Venus is 3.4°, Mars 1.9° and Mercury 7° relative to the ecliptic. Of the outer planets Uranus is least inclined at only 0.8° and Saturn the most inclined at 2.5°.

Launching to the Moon's orbital plane is easy to do by eye or with MechJeb and is a reasonable "eyeball approximation" of an initial parking orbit for an interplanetary transfer. (The pre-positioned  satellite in the wiki link can also act as a launch target but requires editing orbital parameters either directly in your save file or with hyperedit). 

To work out what the ideal parking orbit is for any given transfer window (which may be nowhere near the ecliptic) requires solving for the specific orbital alignments at that time - best done with a tool like KSPTOT or by looking up mission parameters if you're recreating an actual mission.

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

delete

Edited by Ciko

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now