NathanKell

[1.2.2] Real Fuels v12.2.1 July 8

3772 posts in this topic

Posted (edited)

1 hour ago, Relitto said:

this is the first forum ive used, couldnt find out if there was a function on here or not but here are the logs

http://www.mediafire.com/file/v3d2jl3lk3yafh2/KSP.log

http://www.mediafire.com/file/zh9s2128ecdf7xd/ModuleManager.ConfigCache

 
 
 

Don't worry about it. There's a first time for everyone and you're doing great! I'll have a look into the problem now.

 

By the way, you have "turn down engine when unstable" as true. You would want it to be false

Edit: Unfortunately I cannot replicate the problem. Does the issue still persist after you've chaned the above to false?

Edited by MaxZhao

Share this post


Link to post
Share on other sites

RealFuels v12.1.0 for KSP 1.2.2 has been released!

  • Reinstate analytic boiloff with improvements
  • Set specific heat to zero for cryogenic resources (assumption that part and resource temperature are the same doesn't make sense here)
  • Disable ferociousBoilOff since changing cryogenic resource specific heat makes it unnecessary
  • Add the ability for ignitions to be allowed only when attached to launch clamps
  • Make sure cost only gets multiplied by scale once
  • Fix issue where engines would explode after being decoupled (due to KSP reporting the wrong ambient temperature for a couple of frames)
  • Fix resource mix buttons not showing up when a ship is first loaded
  • Fix fuel tank related NRE in flight
  • Make burn time formatting consistent
  • Fix vacuum thrust displaying the same as sea level thrust
1 person likes this

Share this post


Link to post
Share on other sites

THANK YOU. Ugh, I was wondering why my engines would explode on decouple.

 

 

Share this post


Link to post
Share on other sites

Posted (edited)

1 hour ago, Sovek said:

THANK YOU. Ugh, I was wondering why my engines would explode on decouple.

It was a feature to cut down on space junk :P

Now your Kerbals will have to keep an eye out while on EVA or they might catch a 2 ton engine in the small of the back. (an engine is one hell of a thing to catch in the small of the back, trust me)

Edited by Starwaster

Share this post


Link to post
Share on other sites

Posted (edited)

Hi, I have been using Real Fuels with Stockalike Configs, but my engines still have an infinite number of ignitions, don't need ullage, AND can throttle down. Why?

EDIT: I did go into the Stockalike enginesRF and did change the Ullage at moduleRF. But the ullage is still not working.

Edited by LordOfMinecraft99

Share this post


Link to post
Share on other sites

Hello guys!

This is a general question - I'm not hunting down bugs or reporting errors.

The Balloon tanks + SMURFF + Procedural Parts mods allow for extremely lightweight propellant tanks. I'm talking mass ratios of 300+. Are these realistic? Or are these the result of SMURFF acting upon the procedural part masses after RealFuels has already modded their masses?

Thanks!

Share this post


Link to post
Share on other sites

Posted (edited)

3 hours ago, LordOfMinecraft99 said:

Hi, I have been using Real Fuels with Stockalike Configs, but my engines still have an infinite number of ignitions, don't need ullage, AND can throttle down. Why?

EDIT: I did go into the Stockalike enginesRF and did change the Ullage at moduleRF. But the ullage is still not working.

edit your RealSettings.cfg file

make sure the following are true

		simulateUllage = true
		limitedIgnitions = true
1 hour ago, MatterBeam said:

Hello guys!

This is a general question - I'm not hunting down bugs or reporting errors.

The Balloon tanks + SMURFF + Procedural Parts mods allow for extremely lightweight propellant tanks. I'm talking mass ratios of 300+. Are these realistic? Or are these the result of SMURFF acting upon the procedural part masses after RealFuels has already modded their masses?

Thanks!

no that's not realistic but I thought SMURFF doesn't operate on RF tanks either. The mod's author also has said that you don't need SMURFF if you're using Real Fuels. I think it was created for use with RSS and stock parts which don't have efficient or realistic mass ratios, which RF does.

Edit: Check your ModuleManager.ConfigCache file and look for name = proceduralTankRealFuels. That's the actual procedural tank part so then search for SMURFFExclude = true in the PART node. If it's not there then you probably need that inserted by way of a MM patch. But you should probably also ask in the SMURFF thread instead. I don't use it myself so I could be giving you wrong advice.

Edited by Starwaster

Share this post


Link to post
Share on other sites

I dont know why but this mod had made that the engines dont have exaust:o

Share this post


Link to post
Share on other sites
2 minutes ago, KerbolExplorer said:

I dont know why but this mod had made that the engines dont have exaust:o

A few of the stock effects are incompatible with RF.  Solution is to install RealPlume.

Share this post


Link to post
Share on other sites
Just now, blowfish said:

A few of the stock effects are incompatible with RF.  Solution is to install RealPlume.

ok.And this is a great mod.I m gonna use it in my real solar sistem save:D

Share this post


Link to post
Share on other sites

Hi! This is a great mod but unfortunately despite I have installed manually and through CKAN every time I time warp over x100 my spacecraft overheats and exploded.

I don't have tons of mods installed, mainly graphics effects, KIS/KAS and few extra parts. Help :)

Share this post


Link to post
Share on other sites
2 hours ago, potter63 said:

Hi! This is a great mod but unfortunately despite I have installed manually and through CKAN every time I time warp over x100 my spacecraft overheats and exploded.

I don't have tons of mods installed, mainly graphics effects, KIS/KAS and few extra parts. Help :)

Need your output_log.txt file and ModuleManager.ConfigCache (the cache is in your GameData folder)

And what kinds of propellants were in the craft? Were they cryogenic? (LH2, LOX, methane)

Share this post


Link to post
Share on other sites

Posted (edited)

2 hours ago, Starwaster said:

Need your output_log.txt file and ModuleManager.ConfigCache (the cache is in your GameData folder)

And what kinds of propellants were in the craft? Were they cryogenic? (LH2, LOX, methane)

I don't have the log at the moment but I am going o attach it soon

The error occurred with Kerosene and  Liquid Hydrogen, the spacecraft was composed by Stock, Tantares and Contares parts. Every single piece was overheating as soon it reached x1000 warp timing

 

edit. I have the log, how do I attach it?

Edited by potter63

Share this post


Link to post
Share on other sites
1 hour ago, potter63 said:

I don't have the log at the moment but I am going o attach it soon

The error occurred with Kerosene and  Liquid Hydrogen, the spacecraft was composed by Stock, Tantares and Contares parts. Every single piece was overheating as soon it reached x1000 warp timing

 

edit. I have the log, how do I attach it?

Preferably by uploading it to Dropbox and then sharing the link to it. You can even sync your Dropbox to your computer (or multiple computers) so you just drop the log in your Dropbox folder, wait for it to sync then right click and grab the link.

Get a Dropbox account. Really.

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

3 minutes ago, Starwaster said:

Preferably by uploading it to Dropbox and then sharing the link to it. You can even sync your Dropbox to your computer (or multiple computers) so you just drop the log in your Dropbox folder, wait for it to sync then right click and grab the link.

Get a Dropbox account. Really.

Many thanks! here's the log:

https://dl.dropboxusercontent.com/content_link/NN3sr1ZaRcKY8QrtuivTMTmlVE9inKSYLR6Oh8P2WsusJJEwy002t4vd3fce7LSW/file 

Edited by potter63

Share this post


Link to post
Share on other sites
3 hours ago, potter63 said:

Looks like you copied the wrong link. There's two ways of getting a link other people can see. One is right clicking the file in your Dropbpox folder on your computer (assuming you downloaded the Dropbox client and synced it) and clicking 'Copy Dropbox Link' and it will look like this: (that dl=0 at the end means that if they click it then they will be taken to the dropbox site to see the file. If it says dl=1 then clicking it starts an immediate download)

https://www.dropbox.com/s/n7og7ixn50dh0ix/Atmospheric_Re-Entry_Vehicle_Mechanics_-_Patrick_Gallais.pdf?dl=0

The other way of doing it is if you are viewing it on the Dropbox site you click the Share button and then from the pop up window click 'Copy Link'

1 person likes this

Share this post


Link to post
Share on other sites
7 hours ago, Starwaster said:

Looks like you copied the wrong link. There's two ways of getting a link other people can see. One is right clicking the file in your Dropbpox folder on your computer (assuming you downloaded the Dropbox client and synced it) and clicking 'Copy Dropbox Link' and it will look like this: (that dl=0 at the end means that if they click it then they will be taken to the dropbox site to see the file. If it says dl=1 then clicking it starts an immediate download)

https://www.dropbox.com/s/n7og7ixn50dh0ix/Atmospheric_Re-Entry_Vehicle_Mechanics_-_Patrick_Gallais.pdf?dl=0

The other way of doing it is if you are viewing it on the Dropbox site you click the Share button and then from the pop up window click 'Copy Link'

Got it!

https://www.dropbox.com/s/99t2egpwf2wvipu/ModuleManager.ConfigCache?dl=0

Thank you for the patience. Hopefully is something we can fix, cause I really feel like I don't wanna play without this mod :)

Share this post


Link to post
Share on other sites
11 hours ago, potter63 said:

Got it!

https://www.dropbox.com/s/99t2egpwf2wvipu/ModuleManager.ConfigCache?dl=0

Thank you for the patience. Hopefully is something we can fix, cause I really feel like I don't wanna play without this mod :)

No luck here so far. I need more information. What parts overheat and explode? Can you duplicate it just with stock tanks and give me a craft file and save file? Also, need that log file. preferably from a game where you just start the game, load up the craft and timewarp until destructions. Then quit the game and present the resulting log file from that session.

Share this post


Link to post
Share on other sites

Hello, I am new to the forum and just created this account to point out an easy fix for a problem that I haven't found anywhere else.

After installing Real Scale Boosters and Real Fuels through CKAN for 1.2.2 I realized some second stage boosters like Delta II-K were incorectly treated by the game, not using the liquid fuel values but instead only the RCS volumes as they were catalogued as "service modules", and therefore having a small fraction of their overall thrust capability. I fixed this problem by going to the Real Scale Boosters folder, then Parts and into every booster folder changing each second stage "tank" text file; you will need to delete every resource line below the main information but electricity, monopropellant, liquid fuel and oxidizer. Then Real Fuels will treat the part in a correct way.

Greetings.

Share this post


Link to post
Share on other sites

The RealFuels-Stockalike config for CryogenicEngines crash the game on loading with this:
 

PartLoader: Compiling Part 'CryoEngines/Parts/Engine/cryoengine-125/cryoengine-125-1/cryoengine-125-1'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

*U* Ullage constructor called on cryoengine-125-1
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

FloatCurve: Invalid line. Requires two values, 'time' and 'value'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

PartLoader: Part 'CryoEngines/Parts/Engine/cryoengine-125/cryoengine-125-1/cryoengine-125-1' has no database record. Creating.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

DragCubeSystem: Creating drag cubes for part 'cryoengine-125-1'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

PartLoader: Compiling Part 'CryoEngines/Parts/Engine/cryoengine-125/cryoengine-125-2/cryoengine-125-2'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

*U* Ullage constructor called on cryoengine-125-2
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

*RFMEC* ERROR: could not find configs definition for cryoengine-125-2-1
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

*RFMEC* ERROR: could not find configs definition for cryoengine-125-2-1
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

*RFMEC* ERROR Can't find configuration LqdHydrogen+LqdOxygen, falling back to first tech-available config.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

*RFMEC* ERROR could not find configuration of name LqdHydrogen+LqdOxygen and could find no fallback config.
For part cryoengine-125-2, Current nodes:

 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

FloatCurve: Invalid line. Requires two values, 'time' and 'value'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

PartLoader: Part 'CryoEngines/Parts/Engine/cryoengine-125/cryoengine-125-2/cryoengine-125-2' has no database record. Creating.
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

DragCubeSystem: Creating drag cubes for part 'cryoengine-125-2'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

NullReferenceException: Object reference not set to an instance of an object
  at RealFuels.ModuleEngineConfigs.TLTInfo () [0x00000] in <filename unknown>:0 
  at RealFuels.ModuleEngineConfigs.GetInfo () [0x00000] in <filename unknown>:0 
  at PartLoader.CompilePartInfo (.AvailablePart newPartInfo, .Part part) [0x00000] in <filename unknown>:0 
  at PartLoader+<CompileParts>c__Iterator62.MoveNext () [0x00000] in <filename unknown>:0 
  at UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress) [0x00000] in <filename unknown>:0 
 
(Filename:  Line: -1)

Crosspost:

 

Share this post


Link to post
Share on other sites

@Gordon Dry The entire log might be more illuminating.  Those few lines definitely say that something is wrong, but don't provide any clue as to what might be causing it.  Maybe include ModuleManager.ConfigCache as well.

Share this post


Link to post
Share on other sites

Actually I got rid off CryoEngines and CryoTanks, but now I got this spamming the log:

getting ullage from RealFuels casted to null, ullage status likely broken

It seems that it's only spamming the log when reverting to VAB, but way too much of it.

If it helps for this case:
https://www.dropbox.com/s/v68jrpqisgl6imz/2017-05-09-1 KSP.log.7z?dl=1

Share this post


Link to post
Share on other sites

Okay, I added CryoEngines again and removed the RealFuel-Stockalike and RealPlume-RFStockalike configs ... my bad.

I guess that was the issue.

Share this post


Link to post
Share on other sites

Posted (edited)

I should mention that:

Edit:

There is really something borked between RealFuels, SolverEngines, MechJeb regarding ullage and what, like the log spamming with

ArgumentOutOfRangeException: Argument is out of range.
Parameter name: index
  at System.Collections.Generic.List`1[Propellant].get_Item (Int32 index) [0x00000] in <filename unknown>:0 
  at RealFuels.ModuleEnginesRF.UpdateSolver (EngineThermodynamics ambientTherm, Double altitude, Vector3d vel, Double mach, Boolean sIgnited, Boolean oxygen, Boolean underwater) [0x00000] in <filename unknown>:0 
  at SolverEngines.ModuleEnginesSolver.FixedUpdate () [0x00000] in <filename unknown>:0 
  at RealFuels.ModuleEnginesRF.FixedUpdate () [0x00000] in <filename unknown>:0 

Full log:
https://www.dropbox.com/s/9xp3z52fa2qmpo9/2017-05-10-1 KSP.log.7z?dl=1

Edited by Gordon Dry

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now