Sign in to follow this  
Followers 0
NathanKell

[1.0.4] ModuleRCSFX v4.2 Aug 23 OBSOLETE IN 1.0.5

121 posts in this topic

Updated version of ialdabaoth's (who is awesome) ModuleRCSFX.

ModuleRCSFX

*fixes the major known issues with the stock RCS Module (ModuleRCS)

*Supports some advanced features (axis restriction, full thrust, scaling).

*Supports EFFECTS (well, it will--currently broken)

Installation: Extract to GameData (creating a ModuleRCSFX folder, and inside that, Plugins and the readme.

Download

GitHub

License: CC-BY-SA (with the ialdabaoth proviso, that all forkers must remark upon his awesomeness...which I'd do anyway).

From the readme:

ModuleRCSFX is a fixed version of the stock RCS module.

It is derived from ModuleRCSFX by ialdabaoth (who is awesome).

It supports a lot of configuration, as well as fixing stock bugs.

** RCS Part Controls **

useZaxis defaults to false. If you set it to true, the RCS will fire along the Z axis of the given transform(s). This means you can use engine part models as RCS parts (like using the ion engine model as an RCS part).

** RCS Axis Control **

enablePitch

enableYaw

enableRoll

enableX

enableY

enableZ

All these default to true, but if one is set to false in the MODULE, the RCS part will not fire for that input. These can be toggled in the VAB/SPH.

useThrottle

which, when set to true, means that RCS will fire forwards with the throttle.

** RCS Thrust Control **

fullThrust defaults to false. Set it to true and if the thrust ratio is > fullThrustMin (default: 0.2) RCS will fire at full thrust (or 10% thrust in precision mode), rather than the less-than-full-thrust, dependent-on-angle they do stock.

useLever defaults to false. When it's false, fine controls will make RCS fire at 10% (default) power only. When it's set to true, stock behavior returns (i.e. fine controls means lever arm compensation).

precisionFactor is the multiplier to use when useLever is false (as it is by default). precisionFactor defaults to 0.1 (10%).

** RCS Input Controls **

EPSILON defaults to 0.05. That means a control actuation of less than 5% is ignored. This is because Unity is bad at joysticks and ignores deadzones.

** RCS Effects **

Currently disabled pending rework.

Changelog:

v4.2

* Fixed bug where inputs were being improperly normalized (thanks Starwaster!)

* Fixed a bug in applying useThrottle (was being done in global Y not local Y; ditto).

v4.1

* Fixed bug in thrust calculation (was 2% what it should be...)

* When in fullThrust mode, don't switch to full thrust unless thrust ratio already starts out at fullThrustMin (configurable).

Edited by NathanKell
1 person likes this

Share this post


Link to post
Share on other sites
*fixes the major known issues with the stock RCS Module (ModuleRCS)

Can you eloborate, I've been playing for a while, and maybe this is like near/far, where I learn that I've been learning to count to 10 by 2s instead of 1s, losing half the data....

Share this post


Link to post
Share on other sites

I remember that there's a bug that for a multi-nozzle RCS thruster using MRFX, if one nozzle has emitted some particles, it will keep emitting until I release all my keystrokes. e.g. I'm pressing H key for RCS forward, and then I pressed A/S/D/W for direction adjustment, later i release the A/S/D/W key but some nozzles still emit although the direction of them are totally not necessary for RCS forward.

It seems like it's only a graphic glitch though.

Share this post


Link to post
Share on other sites

HoneyFox: if that's still true, I'll try to fix. I don't use EFFECTS for RCS so I haven't run into it.

fathed: the stock module will only use one thruster nozzle if you use PROPELLANT nodes, even if the part has lots of thruster nozzles. I.e. only pressing W results in thrust.

Share this post


Link to post
Share on other sites
HoneyFox: if that's still true, I'll try to fix. I don't use EFFECTS for RCS so I haven't run into it.

fathed: the stock module will only use one thruster nozzle if you use PROPELLANT nodes, even if the part has lots of thruster nozzles. I.e. only pressing W results in thrust.

Nope.

1. I'm not sure if this thread is for a newer version release, if so i will need to download it and test again.

2. The RCS port i mentioned doesn't seem to be using EFFECTS because the effect is same as the stock one. but I will check that later.

EDIT: Tested with latest version. the small glitch still exists, but it's just a visual one.

Edited by HoneyFox

Share this post


Link to post
Share on other sites

could you perhaps post an example, id love to try and turn an ion engine into an rcs engine and run the ion effect but really dont know how to use this, or if its even possible

Share this post


Link to post
Share on other sites

Hello!

I am running into a problem that I believe to be related to this mod.

As you know Realism overhaul uses this plugin extensively and one of the most recent changes to it is the attitude control thrusters built into the command pods by default.

The problem with this design is that for some reason thrusters do not produce any audible and visual effects in some cases however they seem to produce thrust.

For example visually one thruster will respond to its respective controls but the other one will only respond to controls on the other axis of the pod or only respond to control inputs on a few axes at the same time or to a specific combination of keys however physically they seem to work as expected.

I am not sure whether all of them work with autopilot plugins that apply inputs to all the three axes.

Sometimes it seems that I did not see some of the thrusters working at all as they require some sort of a strange combination.

Any ideas what can the reason for this be? It looks very very weird. Can this be fixed somehow?

It would be very nice to see them working properly.

Thank you.

Share this post


Link to post
Share on other sites

I will look into this, but it may be a stock bug; FX is tied to thrust power, and if the thruster is producing very little thrust (but a fair amount of torque, given location) you won't get visual FX.

Share this post


Link to post
Share on other sites

Thank you Nathan!

I do not think that it is a thrust related thing because there are thrusters that do not fire at full power with some of the control inputs and they produce effects that are hardly visible because they are very weak but in this case the thrusters are supposed to fire at their full power or close to that but they produce no effects at all unless some conditions are met for them to produce their full power completely normal effects.

I will get more details when I get to the game. Please tell me if any logs or settings or any other stuff of that sort will help.

Share this post


Link to post
Share on other sites

Just tell me everything you have installed, *exactly* the control inputs (and craft) used to reproduce, and I'll try to replicate.

Oh, and note that RO *always* has the latest version of this mod, because my build script pushes it to the RO repository whenever I build this mod. :)

Share this post


Link to post
Share on other sites

This question is gonna roll eyes... how do I add sfx to all my rcs engines using this mod? I'm hoping to use the sfx from rcssound mod and use them in my RO install but I can't seem to figure out how to do so.

Share this post


Link to post
Share on other sites

I believe you can do the same thing you would for a ModuleEnginesFX engine. You'll need to create an EFFECTS node in the cfg, create various states (running, etc), and add visual and auditory FX to them, then add hooks to them in the ModuleRCSFX module.

Share this post


Link to post
Share on other sites

I'm missing something in the config I think

EFFECTS
{
running
{
AUDIO
{
channel = Ship
clip = sound_rocket_spurts
volume = 0.0 0.0
volume = 1.0 1.0
pitch = 0.0 0.2
pitch = 1.0 1.0
loop = true
}
MODEL_MULTI_PARTICLE
{
modelName = Squad/FX/shockExhaust_red_small
transformName = RCSthruster
emission = 0.0 0.0
emission = 0.05 0.0
emission = 0.075 0.25
emission = 1.0 1.25
speed = 0.0 0.5
speed = 1.0 1.2
}
}
engage
{
AUDIO
{
channel = Ship
clip = sound_vent_soft
volume = 1.0
pitch = 2.0
loop = false
}
}
flameout
{
PREFAB_PARTICLE
{
prefabName = fx_exhaustSparks_flameout_2
transformName = RCSthruster
oneShot = true
}
AUDIO
{
channel = Ship
clip = sound_explosion_low
volume = 1.0
pitch = 2.0
loop = false
}
}
}


MODULE
{
name = ModuleRCSFX
thrusterTransformName = RCSthruster
thrusterPower = 1
resourceName = MonoPropellant
resourceFlowMode = STAGE_PRIORITY_FLOW
useThrottle = false
runningEffectName = running
engageEfffectName = engage
flameoutEffectName = flameout
atmosphereCurve
{
key = 0 260
key = 1 100
}
}

in game the FX plays, no audio, and FX doesn't respond to input. position and orientations are correct. adding "name = " inside the PARTICLE{} doesn't appear to make any difference. No errors in the logs.

Edited by nli2work

Share this post


Link to post
Share on other sites

Here is the complete list of the mods installed.

My actions filmed live from the game are in the video on the link below and it is clearly visible that sometimes the effects fail to appear when expected and sometimes fail to stop when expected. The small pod behaves in a similar fashion.

image.png

https://www.sendspace.com/file/jmit7i

Edited by Kitspace

Share this post


Link to post
Share on other sites

Apologies, with .25 I haven't had a chance to investigate. I still plan to. Meanwhile, updated for 0.25

Share this post


Link to post
Share on other sites

Thanks to Taverius (again) I have fixed my link. Oops.

Share this post


Link to post
Share on other sites

This might be (probably is) a stupid question. But what exact does this mod do?

Share this post


Link to post
Share on other sites

lets you assign custom FX for RCS thrusters like you can with Engines.

Share this post


Link to post
Share on other sites
This might be (probably is) a stupid question. But what exact does this mod do?
lets you assign custom FX for RCS thrusters like you can with Engines.

More importantly it fixes some major issues with stock RCS function like having a stackable RCS pod.

Share this post


Link to post
Share on other sites

Nathan are you still going to investigate the bug with exhausts?

Sorry if I missed something here.

Share this post


Link to post
Share on other sites
Apologies, with .25 I haven't had a chance to investigate. I still plan to. Meanwhile, updated for 0.25

Any progress on this one yet?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0