Ven

[1.2.2] Stock Part Revamp, Update 1.9.6. Released Source Files!

3572 posts in this topic

@Ven

I think I found a solution for the disappearing engine extensions, by using the B9PartSwitchModule to choose the typ of structure in the VAB/SPH. The parts persist even after unloading an reloading the craft.

This is a code example from the engine.cfg for the LVT 30 "Reliant" and how it looks ingame ("Poodle engine")

	MODULE
	{
		name = ModuleB9PartSwitch
		moduleID = meshSwitch
		switcherDescription = Structure
		SUBTYPE
		{
			name = Compact
		}
		SUBTYPE
		{
			name = Extended
			transform = Size2A  
			transform = Collider.001
			node = top2 
		}
	}

I have reworked all engines like above. I can upload the .cfg's if it's ok.

2 people like this

Share this post


Link to post
Share on other sites
On 4/3/2017 at 0:00 PM, Siminator said:

@Ven

I think I found a solution for the disappearing engine extensions, by using the B9PartSwitchModule to choose the typ of structure in the VAB/SPH. The parts persist even after unloading an reloading the craft.

This is a code example from the engine.cfg for the LVT 30 "Reliant" and how it looks ingame ("Poodle engine")


	MODULE
	{
		name = ModuleB9PartSwitch
		moduleID = meshSwitch
		switcherDescription = Structure
		SUBTYPE
		{
			name = Compact
		}
		SUBTYPE
		{
			name = Extended
			transform = Size2A  
			transform = Collider.001
			node = top2 
		}
	}

I have reworked all engines like above. I can upload the .cfg's if it's ok.

if it's small, paste it into a code block, if big, provide a link to a file

Share this post


Link to post
Share on other sites
16 hours ago, Siminator said:

(Replaces original files from Ven with partially altered versions, requires B9PartSwitch)

I placed these configs in their respective folders and overwrote the original configs, and now the engines (the "Flea" SRB, anyway) do not report any thrust at all, and as a consequence, mods such as Kerbal Engineer do not calculate any values for the engine. I will upload a link to my output_log.

https://www.dropbox.com/s/0zor0a3ab2rf6e5/output_log.zip?dl=0

If you require anymore logs or files to review, just let me know and I'll get them to you.

Share this post


Link to post
Share on other sites

Hi, I'm starting a new career mode game with Ven's, SETIctt, and a few other parts mods. I noticed an issue that with Ven's installed, I can't attach any decouplers to the bottoms of any engine. If I uninstall Ven's revamp, everything works fine again.

Has anyone else experienced a similar problem?

Share this post


Link to post
Share on other sites

Posted (edited)

19 hours ago, Siminator said:

(Replaces original files from Ven with partially altered versions, requires B9PartSwitch)

Have you considered creating a MM patch instead of overwriting the config files? That would also solve the part switch dependency.

EDIT: I tried this out on the LV-T15 and it seemed to work fine.

Spoiler

@PART[LVT15]:NEEDS[B9PartSwitch]
{
    MODULE
    {
        name = ModuleB9PartSwitch
        moduleID = meshSwitch
        switcherDescription = Structure
        SUBTYPE
        {
            name = Compact
        }
        SUBTYPE
        {
            name = Extended
            transform = Size2A  
            transform = Collider.001
            node = top2 
        }
    }
}

Cheers,

Edited by Stratickus
3 people like this

Share this post


Link to post
Share on other sites

@fallout2077

If I understand your problem correctly, this bug only prevents the thrust from being displayed in Kerbal Engineer, but engines itself work.

Do you use any mods that alter stock parts, especially engines, other than Stock Part Revamp?

Have you tried to reinstall Kerbal Engineer?

@Stratickus

Great idea :). Thanks. I probably have time to work on a MM patch over the weekend. 

Share this post


Link to post
Share on other sites
1 minute ago, Siminator said:

@fallout2077

If I understand your problem correctly, this bug only prevents the thrust from being displayed in Kerbal Engineer, but engines itself work.

Do you use any mods that alter stock parts, especially engines, other than Stock Part Revamp?

Have you tried to reinstall Kerbal Engineer?

@Stratickus

Great idea :). Thanks. I probably have time to work on a MM patch over the weekend. 

Could the patch be generic enough that It could be applied to non-VSR engines? 

Share this post


Link to post
Share on other sites

@eberkain 

3 minutes ago, eberkain said:

Could the patch be generic enough that It could be applied to non-VSR engines? 

I don't think so, because it will need the exact name of the optional meshes. But if the engines are similar to those from VSR, it might be relatively simple to adapt the patch.

Share this post


Link to post
Share on other sites

So, the tank butt meshes are part of the models?  I guess I had just assumed they were separate meshes. 

Share this post


Link to post
Share on other sites
46 minutes ago, eberkain said:

I guess I had just assumed they were separate meshes. 

They COULD be... If someone "revamped" them...lol

Share this post


Link to post
Share on other sites

Posted (edited)

Thanks, going to give this a try.  It looks great. 

Edited by klesh

Share this post


Link to post
Share on other sites

Thanks for releasing the textures! This stuff really is like finding the book on black magic

1 person likes this

Share this post


Link to post
Share on other sites
22 hours ago, Siminator said:

Great idea :). Thanks. I probably have time to work on a MM patch over the weekend. 

I could probably help with this over the weekend, but no point in duplicating work if you're already doing it. Plus I'd have to hunt through all the config files to find all the changes you've made, where as you already know where they are. Let me know.

Cheers,

Share this post


Link to post
Share on other sites

Posted (edited)

@Stratickus

The work on most of the engines is nearly complete, but seven still have some bugs(Ant, Nerv, Dachshund, Thunder, Vector, Shiba and Dawn)

I could send you a link to a development version of the patch with a list of known bug  if you want to help. 

EDIT: After some additional changes the Dachshund, Thunder and Shiba now properly react to the patch.

Edited by Siminator

Share this post


Link to post
Share on other sites

Does the update fix the weird Survey Scanner?

Share this post


Link to post
Share on other sites

I just tried this mod for the first time.  I am shocked at how awesome it is.  Stunned.  Its gorgeous.  I was expecting reskins only. :o

Immediately into the must-have mod category for me.

Share this post


Link to post
Share on other sites

Hey there, I love this mod and have used it for a long time, but there is one part which has bothered me ever since you modified it. It's the hatches on the cupola module. Not only because when you open them, the ship becomes asymmetrical, but because the IVA looks like this:

jb7ZtaY.jpg

When you move the camera around it clips through the closed hatches, and it's just ugly. Now, rather than ask you to make a version without the hatches (which would be greatly appreciated BTW) is it possible for me to modify the mod so it doesn't touch the cupola?

Share this post


Link to post
Share on other sites
On 02/04/2017 at 6:16 PM, Senex said:

yeah its not a lining up issues when you put them in even in isolation they always have the joining shroud and the one surrounding the engin

2

The same issue happened to me. Deleting and redownloading the mod fixed the issue

Share this post


Link to post
Share on other sites

Posted (edited)

On 02/04/2017 at 2:37 PM, Stone Blue said:

Dang it... neither link for the textures is working for me... Anyone else have any alternatives? :P

The models website is down.

I'll re-host them soon. However the textures are working fine as of now.

Edit: As of now, if you go to the "Textures" website you can download both the model and the textures.

Edited by MaxZhao
1 person likes this

Share this post


Link to post
Share on other sites

Okay. Someone explain to me why this mod reduces the details on some objects rather than adding them? Like take the inline batteries. Here they are in vanilla:

h5st7kv.png

And here they are after this mod has been at them:

mfXIfd7.png

I mean, you do see this right? I'm not crazy?

Share this post


Link to post
Share on other sites
43 minutes ago, NomenNescio said:

Okay. Someone explain to me why this mod reduces the details on some objects rather than adding them? Like take the inline batteries. Here they are in vanilla:

h5st7kv.png

And here they are after this mod has been at them:

mfXIfd7.png

I mean, you do see this right? I'm not crazy?

Mainly because VSR was made before the updates that made the stock textures look better. Also, appreciate the work the author spent on a mod. 

2 people like this

Share this post


Link to post
Share on other sites
4 minutes ago, MaxZhao said:

Mainly because VSR was made before the updates that made the stock textures look better. Also, appreciate the work the author spent on a mod. 

Don't get me wrong, most of his work is great, far better than the stock textures/models, but if something seems stupid I'm going to point it out (or at least ask for an explanation).

1 person likes this

Share this post


Link to post
Share on other sites
1 minute ago, NomenNescio said:

Don't get me wrong, most of his work is great, far better than the stock textures/models, but if something seems stupid I'm going to point it out (or at least ask for an explanation).

That's alright, I've mistaken it as complaining, my bad. Since the mod hasn't seen too much development recently perhaps stock is slowly catching up in a few cases. 

Share this post


Link to post
Share on other sites

is there a way to just individually strike out particular textures (ie the batteries)?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now