MOARdV

[1.3.0] Distant Object Enhancement bis v1.9.1 (8 July 2017)

518 posts in this topic

Is it intended behavior that I must change settings in the space center every time I launch the game? Any way to set the skybox brightness to a desired level and just keep that setting, always? Manually editing the config file doesn't work; it always returns to default settings.

Share this post


Link to post
Share on other sites
Is it intended behavior that I must change settings in the space center every time I launch the game? Any way to set the skybox brightness to a desired level and just keep that setting, always? Manually editing the config file doesn't work; it always returns to default settings.

It's a bug that was pointed out a couple pages back. I've made the code change, but I haven't released it yet since there are some other fixes I'd like to make, too.

Share this post


Link to post
Share on other sites

Distant Object Enhancement bis v1.4.1 released. Fix for max skybox brightness being ignored. Get it on GitHub.

Share this post


Link to post
Share on other sites

I installed it but there's been no visible change. The distant object flares don't appear. As far as I know, I installed it correctly - I copied what was in the Gamedata folder to the Gamedata folder in the KSP directory. Pls halp :(

Share this post


Link to post
Share on other sites

@Bartybum - have you enabled them?

Anywho, noticed a little quirk - mouseover labels can be seen when the flare is hidden by the planet. Is this fixable or no? I don't mind either way, it's not exactly a common occurrence, I'm just wondering.

Yi7H4ny.jpg

Share this post


Link to post
Share on other sites
Anywho, noticed a little quirk - mouseover labels can be seen when the flare is hidden by the planet. Is this fixable or no? I don't mind either way, it's not exactly a common occurrence, I'm just wondering.

It's a feature, so you don't get lost. Yeah, that's it... :)

I haven't looked at hiding them yet - I want to get the flares positioned correctly, first (particularly for map view). Then I'll work on hiding labels on hidden flares.

Share this post


Link to post
Share on other sites
@Bartybum - have you enabled them?

I'm not sure what you mean. What exactly entails enabling them?

Edited by Bartybum

Share this post


Link to post
Share on other sites
I installed it but there's been no visible change. The distant object flares don't appear. As far as I know, I installed it correctly - I copied what was in the Gamedata folder to the Gamedata folder in the KSP directory. Pls halp :(

Do you have Blizzy's Toolbar installed? It's required for 1.4.0, and I assume it still is for 1.4.1 because there's no fix for this mentioned in the changelog.

Share this post


Link to post
Share on other sites
The original thread has much nicer pictures.

So, uh... why not put those pictures in this thread? Just cut and paste:

[noparse][img=http://i.imgur.com/i6muyiI.png]
[img=http://i.imgur.com/8090EYq.png]
[img=http://i.imgur.com/mYIBwXw.png]
[img=http://i.imgur.com/VYMvQjd.png]
[img=http://i.imgur.com/Yc16ybb.png][/noparse]

Share this post


Link to post
Share on other sites

Version 1.4.2 is now available. I reverted the camera layer change for vessel / debris flares, since they're drawing in the wrong place when on layer 10. Planets remain on L10 so they aren't affected by other mods that light the active vessel (ie. Planet Shine). 1.4.2 also includes Raven45's compatibility fix for the CactEye Orbital Telescope (although that mod might need updated as well to use the fix).

Available on GitHub, and now also on KerbalStuff.

3 people like this

Share this post


Link to post
Share on other sites

Oh nice update, thanks a lot !

Can't play KSP without this mod ^^

Share this post


Link to post
Share on other sites

This plugin is working on 0.90, but needs the toolbar to work... thanks for the mod!!!

Share this post


Link to post
Share on other sites
This plugin is working on 0.90, but needs the toolbar to work... thanks for the mod!!!

Toolbar is working despite the warning it puts up (it did for me, at least). I plan on adding DOE to the AppLauncher so that Toolbar is optional.

Share this post


Link to post
Share on other sites

So I don't think is actually working that well in 0.90..

In map view, the flares are drawn in the wrong place (and get further away the further out you zoom) and in flight view, they jump around a fair bit.

Example of the first problem (left to right: Moho, Duna, Eve):

ZIaks8o.png

I'll see if I can get a video of the second problem along with reproducing it on a clean install (though, all mods are 0.90 compatible).

Share this post


Link to post
Share on other sites
So I don't think is actually working that well in 0.90..

In map view, the flares are drawn in the wrong place (and get further away the further out you zoom) and in flight view, they jump around a fair bit.

That's a side-effect of moving the flares to a different camera layer. I'd intended to disable them in map view, since they weren't previously visible (from what I recall), but I missed that on the last update. The flares should be closer to correct in flight - the planets are far enough away that they usually are close / close enough to where they need to be. The craft flares should have improved with the last update I released, but they may still be off.

Share this post


Link to post
Share on other sites

0.90.0 compatibility?

Share this post


Link to post
Share on other sites
0.90.0 compatibility?

Take (literally) 5 seconds to read the posts above you to see where this mod is at.

Share this post


Link to post
Share on other sites
Toolbar is working despite the warning it puts up (it did for me, at least). I plan on adding DOE to the AppLauncher so that Toolbar is optional.

Thank you so much! I hate having to use toolbar!

Share this post


Link to post
Share on other sites
0.90.0 compatibility?

Thread title is currently: "[0.90] Distant Object Enhancement bis v1.4.2 (11 Dec 2014)"

Hmm.

Share this post


Link to post
Share on other sites
Thread title is currently: "[0.90] Distant Object Enhancement bis v1.4.2 (11 Dec 2014)"

Hmm.

I updated that after GregroxMun asked - it was still [0.25] prior to that (forgot to update).

Share this post


Link to post
Share on other sites

I don't know who needs to fix it, but in the ckan repository your mod is still listed as only 0.25 compatible :(

Share this post


Link to post
Share on other sites

Thank you for keeping this up to date :)

c6oWVHe.jpg

1Xc14ti.jpg

Edited by MalfunctionM1Ke

Share this post


Link to post
Share on other sites

PLEASE PLEASE PLEASE Remove the Toolbar dependency. We have the stock App Launcher.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now