RoverDude

parts
[1.2] Sounding Rockets! Start small. Dream big! [0.5.0]

893 posts in this topic

Javascript is disabled. View full album

I expect a lot of us will be starting new career saves after the release of 0.90. So in anticipation of that day, and because the idea of grinding science on the launchpad makes me sad, I give you Sounding Rockets!

This mod adds a series of very simple 0.35m parts to the start node, including:

 

  • Two SRB engines. One with high thrust, one with high efficiency. Neither have decouplers, but will instead automatically jettison when out of fuel (this is especially handy for the upper stage below your payload).
  • A nosecone containing a basic parachute, gyro system, and control module. Note: These run off of StoredCharge not ElectricCharge, and by design cannot be recharged. You will have enough juice for a short mission, but don't expect to get to the Mun with it.
  • Four new science experiments to serve as payloads for your sounding rocket. Note, that trying to stack more than one will likely exceed the parachute's capacity.

 

Enjoy! Go forth and find bees, feedback rocks.

Configuration files and code are licensed under the GPL v3 license.

Assets, including Models (*.mu) and Textures *.png/*.dds) are All Rights Reserved. If you wish to use any of these assets in your project, just ask nicely :)

Pick it up on GitHub!

https://github.com/BobPalmer/SoundingRockets/releases

Edited by RoverDude
19 people like this

Share this post


Link to post
Share on other sites

Looks good. Will be useful to get past the first few boring nodes. Are the science packages stock experiments?

Share this post


Link to post
Share on other sites
Looks good. Will be useful to get past the first few boring nodes. Are the science packages stock experiments?

They are new experiments.

Share this post


Link to post
Share on other sites

Wow! Roverdude, you are quite the prolific KSP modder! I love the variety and new gameplay your mods bring to KSP! I will definitely give this one a try.

Share this post


Link to post
Share on other sites

saweet! Now I can do that V2 launch ive always wanted to do !

Share this post


Link to post
Share on other sites

The cool little parachute from the nosecone might be neat for other applications as well... I have no idea what those would be, but.. you know, for stuff.

Share this post


Link to post
Share on other sites

Trust me it's severely nerfed ;) But as long as you are using it on exceptionally light loads you would be ok

Share this post


Link to post
Share on other sites

Thanks for this, this is a good tiny mod, I like it :P

And the idea of grinding science on the launchpad makes me sad too ;)

Share this post


Link to post
Share on other sites

Something about the sounding rockets is preventing me from loading KSP on a very heavily modded copy, but (apparently) not on a mostly-fresh one with just a couple mods, like PartCatalog/MM/couple others.

I was able to load twice on the copy with lots of mods. When I did:

1) First load: PartCatalog (or something) borked, parts don't display in VAB/SPH - not a question of autotagging, that did nothing (same with rebuild of catalog).

2) Second load: no parts listed in VAB.

After that, KSP wouldn't load. First time I tried, this was at the very end of the log when it hung near the end of the loading process:

NullReferenceException: Object reference not set to an instance of an object

at System.Collections.Generic.GenericEqualityComparer`1[system.String].GetHashCode (System.String obj) [0x00000] in <filename unknown>:0

at System.Collections.Generic.Dictionary`2[system.String,System.Int32].TryGetValue (System.String key, System.Int32& value) [0x00000] in <filename unknown>:0

at PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node) [0x00000] in <filename unknown>:0

at PartLoader+.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Second time, it was this instead:

NullReferenceException: Object reference not set to an instance of an object

at (wrapper stelemref) object:stelemref (object,intptr,object)

at PartLoader.ParsePart (.UrlConfig urlConfig, .ConfigNode node) [0x00000] in <filename unknown>:0

at PartLoader+.MoveNext () [0x00000] in <filename unknown>:0

(Filename: Line: -1)

Third time, same as first time. Stopped on a different part every time, though, at least according to the loading screen.

Removing SoundingRockets directory solved the problem, could load once again and see things in the VAB/SPH.

This thread: http://forum.kerbalspaceprogram.com/threads/101122-KSP-Keeps-Freezing-while-Loading

suggests that maybe it has something to do with resources, I only link it because I thought "hey, there's this new StoredCharge resource, maybe there's a connection." I have no clue, I'm just guessing based on superficial similarities between words, possibly useless! =(

EDIT: seems maybe Community Resource Pack, NearFuture and Sounding Rockets all have cfgs defining StoredCharge - could this be a problem?

Er... copied the configs to my KSP Tests copy so that there were 3 present defining the same resource.. that didn't seem to break the clean copy...

Edited by AccidentalDisassembly

Share this post


Link to post
Share on other sites

You are hitting memory pressure most likely.

Granted - this one is small at just one texture for all of the models :P

- - - Updated - - -

Are the chutes RealChute compatible?

Nope, no real need tbh for this one.

Share this post


Link to post
Share on other sites
You are hitting memory pressure most likely.

Granted - this one is small at just one texture for all of the models :P

- - - Updated - - -

Nope, no real need tbh for this one.

Not even close to RAM cap, about 1.5 gigs of RAM used - it is not crashing, it's hanging, I am absolutely certain it's not a memory issue. Game runs happily for hours about about 2.2 gigs when fully loaded. Hangs with the SoundingRockets folder, doesn't without - but not on a clean copy, apparently, so I would just assume there's some sort of weird interaction going on? I have no idea.

Here's the log from the latest attempt at loading: https://dl.dropboxusercontent.com/u/59567837/output_logSoundingRockets.txt

The hanging seems to happen earlier and earlier each load, different part name shown in the loading bar each time.

EDIT: OK, 1.8 gigs of RAM used, to be precise (this most recent attempt)...

Edited by AccidentalDisassembly

Share this post


Link to post
Share on other sites

hmm.. usual deal, clean install, install one mod at a time, try with a clean save, etc.

This is literally just a parts pack and one USI DLL that you probably already had anyway ;)

Share this post


Link to post
Share on other sites
hmm.. usual deal, clean install, install one mod at a time, try with a clean save, etc.

This is literally just a parts pack and one USI DLL that you probably already had anyway ;)

It does load on a clean install, it doesn't load on a clean save on my modded install though - well, one of the times the game loaded, the parts still didn't on a new save, that is. Could it have to do with the resource being used, or it being defined 3 times, or whatever? Or maybe some MODEL{} insanity? Seem to remember finding another thread where the game would not load, and would give similar error messages, that had to do with a combination of MODEL{} being used and something weird going on with the .mu file and textures, or something. I definitely did already have the DLL.

Edited by AccidentalDisassembly

Share this post


Link to post
Share on other sites

Essentially model rockets to start a career with; ridiculously simple and brilliant. Well, there goes another few megabytes of RAM. Thanks, Roverdude!

Share this post


Link to post
Share on other sites

@NWDogg - glad you like it :)

@AccidentalDisassembly - multiple resource defs will not cause what you're seeing. For my own benefit - Mac, PC, Linux, 64 or 32? Try adding your old mods back in one by one into a new save - that usually sorts it.

Share this post


Link to post
Share on other sites
@NWDogg - glad you like it :)

@AccidentalDisassembly - multiple resource defs will not cause what you're seeing. For my own benefit - Mac, PC, Linux, 64 or 32? Try adding your old mods back in one by one into a new save - that usually sorts it.

Windows 8.1 x64, running KSP 32-bit. The really weird thing is that the hanging occurs earlier and earlier every time I load KSP - that's just bizarre. Always on a different part name, always earlier in the loading. Maybe it's a MM thing...? I am really loathe to go through the process of dealing with something like 60 mods =(

Share this post


Link to post
Share on other sites

Awesome, I don't know how you do it! I will definitely try these out on the upcoming re-re-re-boot of the campaign for .90. Kudos!

Share this post


Link to post
Share on other sites

Welp - new working theory. Here goes: multiple resource definitions aren't a problem, but apparently they might be for the Alternate Resource Panel - I removed that (thinking still that maybe the issue had to do with resources, so...) and KSP loaded. Weird.

Share this post


Link to post
Share on other sites
Welp - new working theory. Here goes: multiple resource definitions aren't a problem, but apparently they might be for the Alternate Resource Panel - I removed that (thinking still that maybe the issue had to do with resources, so...) and KSP loaded. Weird.

I'm running the same mods you are except a few more. My game seems to work just fine with these parts with ARP, NearFuture, etc.

Share this post


Link to post
Share on other sites
I'm running the same mods you are except a few more. My game seems to work just fine with these parts with ARP, NearFuture, etc.

Beats me. I run a ton of mods; all I know is that KSP reliably would not load as soon as I put SoundingRockets in. Removed ARP and now it loads - maybe it's coincidence? Maybe it's the number of times StoredCharge was defined somehow interacting with MM and ARP? I have no clue.

Share this post


Link to post
Share on other sites

Btw SRMS motor's description has a spelling error, "with better ISP at the espese". Small little thing, just thought I should point it out :)

Share this post


Link to post
Share on other sites

That is literally what I wanted, well, not for Christmas, but I was thinking about a mini mod that would add a small nosecone probe core with limited capabilities to get that early start.

Of course, not that I could ever hope to make that mod, and this is much more expanded than what I imagined it could be... You just struck the perfect niche for me, RoverDude. Can't wait for my new 0.90 career now!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now