OtherBarry

[1.1.3] Procedural Parts - Parts the way you want 'em - v1.2.5 July 3

1196 posts in this topic

This may have been addressed before but I couldn't find anything on it specifically that wasn't over two years old.

I'm running KSP 1.2.2 with PP version 1.2.10. Whenever a PP part clips with any other part, loading that craft will cause the game to freeze on loading. Clipping a part so that it connects to the same node, IE the bottom node of an adapter and a fuel tank connected to probe's top node, works fine. If either of the clipping parts are a PP part however it causes the game to freeze on loading the craft.

I know this wasn't always an issue because it worked just fine in older versions of the game. So I'm wondering if it's a PP issue or a mod conflict. My output_log.

Share this post


Link to post
Share on other sites
1 hour ago, SwissArmyKnife said:

This may have been addressed before but I couldn't find anything on it specifically that wasn't over two years old.

I'm running KSP 1.2.2 with PP version 1.2.10. Whenever a PP part clips with any other part, loading that craft will cause the game to freeze on loading. Clipping a part so that it connects to the same node, IE the bottom node of an adapter and a fuel tank connected to probe's top node, works fine. If either of the clipping parts are a PP part however it causes the game to freeze on loading the craft.

I know this wasn't always an issue because it worked just fine in older versions of the game. So I'm wondering if it's a PP issue or a mod conflict. My output_log.

Unable to reproduce. I need better instructions. I took a stock 3.75m tank then attached a procedural tank to its top node. Then I used the movement tool to sink the PP tank down inside the stock tank. Then I attached a stock probe core to the procedural tank and used the movement tool to sink THAT down into the procedural tank. I saved it then loaded it back into the VAB then launched it. No freeze, no crash and no errors.

I looked at your log but I found no errors there to be relevant to the bug that you're reporting and none during the time that you were loading any craft. I do see you had Tweakscale installed and there have been reports of that causing issues so you might want to try without that installed and see if you still have that problem.

Share this post


Link to post
Share on other sites
8 hours ago, Starwaster said:

Unable to reproduce.

Yeah I didn't see anything in the log either but figured I might have missed something.

Here are two craft files for example craft. CrashTest_PP_Stock loads fine for me, I didn't have a lot of time to try different parts but the PP LFO cone and stock truss seemed to work fine. CrashTest_PP_PP however did reliably freeze upon loading. If it doesn't freeze on your end I'll try and see if I have any conflicts.

Also give removing TweakScale a try.

Share this post


Link to post
Share on other sites

This is one of the most important mods for KSP, but it's always very slow to update. I wish I could do programming, I'd help with it.

2 people like this

Share this post


Link to post
Share on other sites
2 hours ago, lajoswinkler said:

This is one of the most important mods for KSP, but it's always very slow to update. I wish I could do programming, I'd help with it.

That's because the person who's maintaining it has several other mods that he's involved with. Currently I'm concentrating on finalizing the Deadly Reentry update so I can push final updates for both KSP 1.2.2 and 1.3.0

After that I have several pull requests on Procedural Parts to get to (sorry github contributors :( ) AND two outstanding bugs to look into plus a reworking of a previous bug fix so I can do the same thing. (push updates for 1.2.2 and 1.3)

6 people like this

Share this post


Link to post
Share on other sites
On 6/3/2017 at 7:02 PM, Starwaster said:

That's because the person who's maintaining it has several other mods that he's involved with. Currently I'm concentrating on finalizing the Deadly Reentry update so I can push final updates for both KSP 1.2.2 and 1.3.0

After that I have several pull requests on Procedural Parts to get to (sorry github contributors :( ) AND two outstanding bugs to look into plus a reworking of a previous bug fix so I can do the same thing. (push updates for 1.2.2 and 1.3)

I didn't mean to sound pushy, of course. I just think that Procedural parts are one of those mods that's essential and very important, yet usually people take it for granted and there isn't much feedback, compared to the number of people using it.

It probably wouldn't be an overestimated claim that PP is the most used mod for KSP.

Share this post


Link to post
Share on other sites
2 minutes ago, lajoswinkler said:

I didn't mean to sound pushy, of course. I just think that Procedural parts are one of those mods that's essential and very important, yet usually people take it for granted and there isn't much feedback, compared to the number of people using it.

It probably wouldn't be an overestimated claim that PP is the most used mod for KSP.

I have gone into the PP repository and merged some pull requests, except the ones for things that had been done already. One (1.3 compatibility changes) I'm holding off on so I can do a final 1.2.2 update. So probably sometime this week but after the final update for DRE. (which is still in pre-release status)

3 people like this

Share this post


Link to post
Share on other sites
55 minutes ago, Starwaster said:

I have gone into the PP repository and merged some pull requests, except the ones for things that had been done already. One (1.3 compatibility changes) I'm holding off on so I can do a final 1.2.2 update. So probably sometime this week but after the final update for DRE. (which is still in pre-release status)

I can do localization in Spanish if needed

Share this post


Link to post
Share on other sites
Just now, Rafael acevedo said:

I can do localization in Spanish if needed

If you want to, sure, go ahead. Probably won't get done otherwise. (I mean, I don't know enough spanish to do it)

Share this post


Link to post
Share on other sites

Does anyone know if this works in 1.3 yet?

Share this post


Link to post
Share on other sites
31 minutes ago, Brainpop14 said:

Does anyone know if this works in 1.3 yet?

Yes.....

 

Share this post


Link to post
Share on other sites

I'm trying to use this in 1.3 and none of the parts are showing up

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

1 hour ago, Brainpop14 said:

Does anyone know if this works in 1.3 yet?

Starwaster has been posting status updates, scroll up to read them.

30 minutes ago, V8jester said:

Yes.....

That mod adds wings. This one adds fuel tanks. They're not the same.

Edited by HebaruSan
1 person likes this

Share this post


Link to post
Share on other sites
47 minutes ago, HebaruSan said:

Starwaster has been posting status updates, scroll up to read them.

That mod adds wings. This one adds fuel tanks. They're not the same.

I apologize.... I read the thread title too fast and mis posted my response. Currently there is no "Mainstream" update yet. But I am sure an unofficial fix will pop up.

Share this post


Link to post
Share on other sites

Hopefully sooner rather than later because I can't live without this mod anymore.

2 people like this

Share this post


Link to post
Share on other sites

@Starwaster do you have a donation site? I'd love to send you some coffee/beer money for all your work. 

Share this post


Link to post
Share on other sites
40 minutes ago, Tyko said:

@Starwaster do you have a donation site? I'd love to send you some coffee/beer money for all your work. 

You can paypal.me/Starwaster if you like, I won't say no! Not necessary of course as these are all mods that I need to update if I want them for my own use :P

1 person likes this

Share this post


Link to post
Share on other sites
50 minutes ago, Starwaster said:

You can paypal.me/Starwaster if you like, I won't say no! Not necessary of course as these are all mods that I need to update if I want them for my own use :P

Happy to help keep you caffeinated!

Share this post


Link to post
Share on other sites

How would I create a custom texture I would like to make my own SpaceX texture but I do not know how to config it into the game or what sizes to use any help would be appreciated thank you.

Share this post


Link to post
Share on other sites

Final Procedural Parts update for KSP 1.2.2

https://github.com/Starwaster/ProceduralParts/releases/tag/v1.2.11

  • This is the final update for KSP 1.2.2 (next stop, KSP 1.3.0!)
  • Updated categories for Procedural Batteries and decouplers. (Muppet9876)
  • Updated USI Life Support (Muppet9876)
  • Increased significant figures to 5. (apparently we lost precision with KSP 1.0)

Also, this is the final update I'll post in this thread. From now on I'll post any updates in a new landing thread I created. See link below. That will make it easier to post updates since I can't update the first post on this thread.

5 people like this

Share this post


Link to post
Share on other sites

*twitching increases*

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now