• Kerbal Space Program patch 1.1.1 is now live!


    KasperVld

    1.1 Turbo Charged

     

    Hello everyone!

     

    The 1.1.1 patch is now available! This patch will bring high priority fixes to the game. Although last week’s release of 1.1 went smoothly, there were still a few bugs left to fix. Considering we updated the game’s engine we’re all very pleased with the overall state of the game. Those of you who were around for the switch from Unity 3 to Unity 4 in version 0.18.4 will certainly remember how much impact changing the game engine can have on the game’s stability.

     

    Here's the complete changelog:

    =================================== v1.1.1 ============================================================
    UI:
    * Added FlightUI Element Scaling and Navball Position Slider.
    Wheels:
    * Added auto-struts to every wheel, similar to fairing payload struts. They attach to the most massive part on the vessel. This prevents wheel suspensions from becoming unstable when the wheel is attached to a weaker part. (Attaching legs to pylons no longer causes vessels to bounce and/or break dance.)
    * Fix suspension distance and offset being inversely proportional to the rescaleFactor of a wheel. Fixes LT-1 and LT-2 leg suspensions actually getting smaller despite scale being larger, causing them to visually sink into the ground, and have shorter useful suspensions.
    * Some configuration tweaks suggested by GoSlash27 for the free and fixed landing gears have been integrated, which dramatically improve issues with instability on those gears. Thank you GoSlash27!
    * Fixed some model hierarchy issues with small and medium retractable landing gears, which fixes some odd suspension forces, an animation issue, and the inability to lock the suspension on these gears.
    * Raise the default integration substeps on wheels from 4 to 8, which should dramatically improve the accuracy of the wheel simulation without affecting performance too much.
    * Added separate settings for wheel integrator substep accuracy for active and inactive vessels, which can be tweaked in each wheel's part configuration, or globally from settings.cfg. Inactive vessels get slightly less accuracy to improve performance.
    * "No crash damage" cheat now prevents wheels from blowing up their parts due to gratuitously large impacts. It does not, however, prevent the wheel from entering the damaged state.
    * Halved the deflection magnitude of free and fixed gears, as they are technically much more rigid than other gears, but their lack of suspension travel makes them much more vulnerable to deflection stress, making them twice as tough.
    Editor:
    * Performed significant optimisation of performance intensive areas such as part attaching and dettaching. 
    * Implemented general optimisation throughout editor.
    * Implemented automatic temporary symmetry when the logic expects the symmetry mode or method to be different. I.e when placing engines on tri-couplers in SPH using mirror mode. Fixes part initialization issues. 
    Bug Fixes and Tweaks:
    * Made Kerbal Portrait and ScreenMessage lists public.
    * Show complete cost (base cost + module cost) in part tooltips in editor.
    * Add optional PQS shader using all mappings (for modders).
    * Tweak skin<->internal conduction, slightly increase internal max temps of Mk1 cockpits.
    * No longer spam the log when parsing plugin data.
    * Tweak default exhaust heating upwards slightly.
    * Change building impact damage to be based on kinetic energy by default, not momentum. Make damage configurable in Physics.cfg. Fixes an issue with building damage and wheels.
    * Improve orbit calculation when in 1x warp. Orbit info no longer flickers.
    * Show specified rather than calculated sea level temperature when viewing a planet's page in the knowledge base window in map view.
    * Add more checks (flameout or port disabled) to RCS's Torque Provider.
    * Optimizations to vessel stat-finding and orbital force calculations.
    * Add the missing extension method, uncomment the bits that needed it
    * Admin facility now with vertical scrolling.
    * Adjusted Career Widget Z Pos for higher scaling.
    * Restore part delete sound when deleting parts in editor.
    * Considerable tweaks to building damage to avoid wheels insta-popping them.
    * Renamed the editor filter for Surface Attach to Surface Attach Only to avoid confusion.
    * Optimized getGeeForceAtPosition to not recalculate things it shouldn't.
    * Increased stability in orbital calculation when off rails.
    * Added UI Element scaling for all in-flight UI elements.
    * Removed a fix for a 5.1.1 unity bug which had a unefficient complexity.
    * Check if the body has an ocean before checking if we're under water!
    * Removed text length on input device name.
    * Fixed NRE from Underwater Fog.
    * Fixed gigantor solar panel showing through the main craft.
    * Fixed a bug with science lab science/day display.
    * Fixed where the target could be unset in tutorials.
    * Fixed latitude not displaying in AeroGUI.
    * Fixed an issue where missing directories could break save/load.
    * Fixed an exception in Procedural Fairing interstages.
    * Fixed inability to timewarp near Jool.
    * Fixed some miscellaneous tutorial bugs.
    * Fixed an issue with RequestResource on EVA kerbals.
    * Fixed an issue with the underwater FX applying even if the body does not have an ocean.
    * Fixed issue with decouple action firing jettison in ModuleJettison.
    * Fixed lab display rate to count scientist multiplier.
    * Fixed memory leak in part highlighter and attach node icon destruction.
    * Fixed inability to target things by using map context menu.
    * Fixed targeting being improperly locked in map view.
    * Fixed typo in science tutorial.
    * Fixed an oversight when computing duration/deadline text.
    * Fixed for NRE in UIPartActionController
    * Fixed colour tint on some parts.
    * Fixed multiple docking port joint weakness.
    * Fixed KSPedia page corruption from switching scenes.
    * Fixed issue with decouple action on jettison.
    * Fixed Ap/Pe flickering.
    * Fixed an issue where scientist bonus was counted twice in labs.

     

     



    User Feedback

    Recommended Comments



    1.1.1 is a beeeeeeeeeeeeeeeeeeeeeautiful update. Only thing that makes me bad; after 1.1, shadow cascades option limited to 4 and shadow draw distance bothers me a lot. Do you guys have any suggestions? Not opening a new thread since I think it's a small question.

    Share this comment


    Link to comment
    Share on other sites
    3 hours ago, KerbonautInTraining said:

    That's the stick I was planning on using, so glad it works properly now :D

    Are you sure the inputs aren't interfering with SAS? Try opening the mad catz software and softening the curves.

    Hmm Good call. gonna check that out.

    Share this comment


    Link to comment
    Share on other sites
    12 hours ago, StahnAileron said:

    It makes everything blurry; text hurts to read.

    I'll have to try disabling anti-aliasing, but I was also bothered very much by the blurry text, and didn't notice such a problem in 1.0.5.

    17 hours ago, CaLVin-K said:

    Well 30-40 m/s is between 67 and 90mph so that might not be all that unrealistic.

    Well it's certainly different from before. Even the slightest touch of either wheel steering or just rudder - the shortest and lightest touch I'm capable of with an analog controller - causes an extreme loss of control when it didn't before. If the aircraft would go straight, I wouldn't need corrective steering, but now in the absence of any control inputs an aircraft may turn to the left and then back to the right on the runway... and these are all with stock craft.

    Edited by AdamMil

    Share this comment


    Link to comment
    Share on other sites

    Great Update, so far I personally have only noticed one issue with it.

    In 1.1 the SAS seemed to be working near perfectly.

    Since i updated to 1.1.1 it is continuously over correcting causing bigger and bigger steering issues until the rocket either tears itself apart or i have to shut it down and spend 2 minutes manually re-stabilizing the vessel.

    small single stage rockets tend to survive quite well (because the don't flex as much in the middle) but if you keep an eye on the torque indicators in the bottom left and the thrust vectors on the engine cones you can see that it is still wildly over correcting to keep its heading.

    im running the 64bit client and i have observed this in both atmosphere and in space with no mods.

    as i said above this wasn't occurring in 1.1 so its a little disappointing to find it back in 1.1.1

    Edited by Cheatanct

    Share this comment


    Link to comment
    Share on other sites

    Help!!

     

    Since this update I can't see resources by stage anymore and the administration building is broken, it won't load.

     

    I'm playing on a mac.

    Share this comment


    Link to comment
    Share on other sites
    25 minutes ago, Cheatanct said:

    In 1.1 the SAS seemed to be working near perfectly.

    Since i updated to 1.1.1 it is continuously over correcting causing bigger and bigger steering issues until the rocket either tears itself apart or i have to shut it down...

    I've also had noticeable SAS issues in 1.1.1, although I don't think it was ever perfect. (Even in 1.0.5, certain craft would oscillate like crazy under SAS.)

    Share this comment


    Link to comment
    Share on other sites

    SAS can be made a bit friendlier on taller rockets if more struts are added, connecting big stages separated by decouplers may help... at the expense of drag, of course. Also, aligning reaction wheels on center of mass (actually putting them at, or spaced symmetrically around COM) can help. Reaction wheels act like a big hand grabbing your rocket, and shaking it from where they are placed.

    Share this comment


    Link to comment
    Share on other sites
    * Improve orbit calculation when in 1x warp. Orbit info no longer flickers.

    Emurgurd this!  I have been waiting maybe a year for them to fix this one?  So happy!

    Share this comment


    Link to comment
    Share on other sites
    13 hours ago, TriggerAu said:

    If you hit apply or accept it will save the settings, if you hit close it cancels the changes. Can you confirm which button you are pressing?

    TriggerAu,

    I hit apply and accept but it does not exit the settings menu afterwards.  When I hit close to close the menu it reverts back to default.

     

    Edited by Redleg1

    Share this comment


    Link to comment
    Share on other sites

    Seems like you can't click on an apsis marker to make the apsis altitude stick anymore. Kind of annoying...

    Also seems like cargo bays don't protect their contents against overheating perhaps. I had two Z-100 batteries in a cargo bay that exploded on reeentry at 45km.

    Edited by AdamMil

    Share this comment


    Link to comment
    Share on other sites
    7 hours ago, RandomUser said:

    Temps?  40-50% CPU usage shouldn't cause issue other than noise, which I myself playing KSP hear a LOT of unfortunately (bad cooler).  Perhaps upgrade the cooling system in your case if it's too loud. 

    I've got a H240X liquid cooler, in a H440, 3 120mm fans in and 1 140mm out for static case flow plus the 2 140s on the cooler  it's fine in anything  from  GTAV to rendering system idles at 28c. The temps are not dangerous, I just find it odd that the editor would put that much load on the CPU. I just never noticed it before 1.1  

    Share this comment


    Link to comment
    Share on other sites

    I have a Mk 3 spaceplane that worked fine in 1.0.5, but in 1.1.1 the landing gear go underground on launch half the time, or while I'm traveling down the runway, usually only on one side leading to sudden catastrophic loss of control. After 15 attempts I haven't managed to get safely down the runway yet... Also annoying that on launch the aircraft no longer point straight down the runway. They're at a heading of like 88 degrees, and since the larger landing gear have no steering, this means they run off the side of the runway before you can get them going fast enough to steer with the rudder.

    21 minutes ago, astovall321 said:

    The temps are not dangerous, I just find it odd that the editor would put that much load on the CPU.

    Well, most people don't have a liquid-cooled computer. The game is probably running it a tight loop rather than being event driven as it's supposed to be.

    Edited by AdamMil

    Share this comment


    Link to comment
    Share on other sites

    Did 1.0 have as many critical bugs/crashes/CTDs when it was first released as 1.1 has? The CTDs I experience, especially in the VAB, make it literally impossible to play. I can't help but crash within 5 minutes of entering the VAB.

    Edited by KocLobster

    Share this comment


    Link to comment
    Share on other sites
    25 minutes ago, KocLobster said:

    Did 1.0 have as many critical bugs/crashes/CTDs when it was first released as 1.1 has? The CTDs I experience, especially in the VAB, make it literally impossible to play. I can't help but crash within 5 minutes of entering the VAB.

    I don't know about 1.0, but before 1.1 was 1.0.5, which was quite stable. It crashed only about once every 40 hours for me, unless I was flying very large and heavy craft, in which case it tended to crash if they exploded sometimes.

    Edited by AdamMil

    Share this comment


    Link to comment
    Share on other sites

    Hmm yes, 1.0 was very buggy as was 1.0.1. 1.02 was fairly stable 1.0.3 lasted less than 24 hours and 1.0.4 was very stable.  1.0.5 took up too much memory to be playable with out a lot of lag. at least for me. 1.1.1 seems less stable than 1.1, at least for me it does.  User experience may vary.

    Edited by mcirish3

    Share this comment


    Link to comment
    Share on other sites
    7 minutes ago, mcirish3 said:

    Hmm yes, 1.0 was very buggy as was 1.0.1. 1.02 was fairly stable 1.0.3 lasted less than 24 hours and 1.0.4 was very stable.  1.0.5 took up too much memory to be playable with out a lot of lag. at least for me. 1.1.1 seems less stable than 1.1, at least for me it does.  User experience may vary.

    Im not even going to try any further updates until this gets fixed
     

     

    38 minutes ago, War Eagle 1 said:

    5eii1fr.pngMac users are still suffering from this bug.  Looks like its back to 1.0.5 for me.

     

    Share this comment


    Link to comment
    Share on other sites
    1 hour ago, Redleg1 said:

    TriggerAu,  I hit apply and accept but it does not exit the settings menu afterwards.  When I hit close to close the menu it reverts back to default.

    This almost sounds like a file system permissions issue, when it's trying to save your change. Are you able to make other settings changes, do they save & stick around?

     

    1 hour ago, AdamMil said:

    Seems like you can't click on an apsis marker to make the apsis altitude stick anymore. Kind of annoying...

    Try to right-click on the marker

    Share this comment


    Link to comment
    Share on other sites
    3 hours ago, Cheatanct said:

    Great Update, so far I personally have only noticed one issue with it.

    In 1.1 the SAS seemed to be working near perfectly.

    Since i updated to 1.1.1 it is continuously over correcting causing bigger and bigger steering issues until the rocket either tears itself apart or i have to shut it down and spend 2 minutes manually re-stabilizing the vessel.

    small single stage rockets tend to survive quite well (because the don't flex as much in the middle) but if you keep an eye on the torque indicators in the bottom left and the thrust vectors on the engine cones you can see that it is still wildly over correcting to keep its heading.

    im running the 64bit client and i have observed this in both atmosphere and in space with no mods.

    as i said above this wasn't occurring in 1.1 so its a little disappointing to find it back in 1.1.1

    I am experiencing the same issue as you. After upgrading to 1.1.1, when I enable SAS on launch, the craft begins rotating clockwise and then counterclockwise much like a washing machine during its agitate cycle. The craft then spins out of control. Happened with three different rockets that I launched. I'm sorry to say that KSP was far more playable and bug-free during pre-release. It has gotten progressively worse update after update. Please hotfix this ASAP.

    Share this comment


    Link to comment
    Share on other sites
    6 minutes ago, bigshow281 said:

    It has gotten progressively worse update after update. Please hotfix this ASAP.

    I've also been having trouble with SAS. It makes it much harder to get spaceplanes into orbit since the planes won't hold a course as steadily as they used to. Hopefully they'll fix it soon, but they don't seem to prioritize bug-fixing. I've been watching bugs that would be trivial to fix go unfixed for 3+ years... but here's hoping. :-)

    Edited by AdamMil

    Share this comment


    Link to comment
    Share on other sites
    2 hours ago, KocLobster said:

    Did 1.0 have as many critical bugs/crashes/CTDs when it was first released as 1.1 has? The CTDs I experience, especially in the VAB, make it literally impossible to play. I can't help but crash within 5 minutes of entering the VAB.

    IME: Bugs yes, instability and crashing no.
    Prior to 1.1, I had zero crashes, even pre-beta, at least as far back as 0.21. Now I can expect it to crash hard once every 1-2 hours.
    If you're coming from 32bit out-of-memory crashes on Windows, 1.1 might be a stability improvement.
    For me, coming from a perfectly stable 64bit (GNU/Linux) game, this is rather disappointing TBH.
    Unity minor version upgrade is happening when?

    Share this comment


    Link to comment
    Share on other sites
    4 minutes ago, steve_v said:

    Unity minor version upgrade is happening when?

    That's complex and not likely soon.  Will be much less fateful than the shift between Unity 4 to 5, but will have be deliberately and carefully done by Squad.  Before then, many of the issues are KSP's to fix, and even those it's can't, the quality of the workarounds can be improved.

    KSP 1.1.2 is coming in a few hours.  Hope for the best from it.

     

    Edited by Jacke

    Share this comment


    Link to comment
    Share on other sites
    5 hours ago, Redleg1 said:

    TriggerAu,

    I hit apply and accept but it does not exit the settings menu afterwards.  When I hit close to close the menu it reverts back to default.

     

    Doesnt sound quite right no. Checking permissions and the logs and the usual support and bug stuff would be a good next step I think.

    You could also try editing the settings.cfg file by hand to see if that applies, but if you do decide to go that way then do make a backup

    Share this comment


    Link to comment
    Share on other sites

    x64 1.1.0 was rock-stable for me, how can I get it back (steam version)?

    all options on Beta tab points to 1.1.1

    Share this comment


    Link to comment
    Share on other sites
    21 minutes ago, kokospl said:

    x64 1.1.0 was rock-stable for me, how can I get it back (steam version)?

    all options on Beta tab points to 1.1.1

    I did some testing earlier and found a version of 1.1.0.  If you're quick, you might be able to get a 1.1.0 install before 1.1.2 shows up and things change.  Then copy it out of the Steam directory into a backup directory so you can't lose it again.

    Here's what I found earlier yesterday.  I just tested the "prerelease" verison and it is still 1.1.0.1228 for 32-bit, 64-bit, and apparently the rest of the files.

    2016 Apr 29 Fri
    
    KSP on Steam under Win 8.1 64-bit for different settings of Beta dropdown
    
    NONE		1.1.1.1250
    prerelease	1.1.0.1228
    previous	1.0.5.1028 32-bit .exe	1.1.1.1250 64-bit .exe	1.1.1.1250 Squad parts
    

    Go for the "prerelease" Beta setting and you should get 1.1.0.1228, which is just before the KSP 1.1.0 version, 1.1.0.1230.  Hopefully the changes are trivial.

    I suggest you delete everything in the Steam KSP program directory so it has no cruft.  Set the Beta setting to prerelease, then download it.  When it's finished, I highly suggest you Verity the Integrity of the Game Cache to make the all the KSP files are correct.  THEN take Steam offline or exit its client so it can't update until you've save KSP 1.1.0.1228 elsewhere.

    I suggest following what I posted here about saving an unmodded copy of the KSP verison, then saving another copy to mod and play.  You don't run KSP through Steam.  You use a link to the 64-bit executable KSP_x64.exe of the modded copy.

     

    Share this comment


    Link to comment
    Share on other sites