Jump to content
  • Kerbal Space Program patch 1.1.2 is now live!


    KasperVld
     Share

    1.1 Turbo Charged

     

     

    Hello everyone!

     

    We noticed a number of issues persisted through the 1.1.1 patch earlier this week. We’re releasing patch 1.1.2 to address these issues before we head off to a long overdue vacation for the next couple of weeks. Patch 1.1.2 addresses issues with the user interface and landing legs, amongst others.

     

    Here's the complete changelog:

    =================================== v1.1.2 ============================================================
    * Fixed an issue with triggers and convexity in loading models.
    * Fixed exception in the Stage Only mode of Vessel Resources panel.
    * Fixed for LT-1 and LT-2 landing legs causing a physics jerk when retracting.
    * Fixed an issue where some vessels might explode on go to pad (introduced in 1.1.1).
    * Fixed an issue with PQS shader accessibility.
    * Optimized moment of inertia calculations and some matrix operations.
    * Fixed an issue with an offset in the small landing gear part.
    * Optimized drag calculations.
    * Made wheel autostrutting more configurable.
    * Fixed some display issues in KSPedia.
    * Fixed an issue in FlightLogger regarding reverting / loading saves.
    * Increased brake torque tweakable's upper limit to 200%.
    * Added editor tweakables for spring and damper strength for suspension.
    * Removed non-working "disable suspension" tweakable.
    * Fixed issue with popup dialogs sharing the same title which broke game loading when loading multiple vessels all lacking parts.
    * Removed unneeded image effects on UI camera for increased performance.
    * Fixed issue where IVA field of view changes applied to flight camera on exiting IVA.
    * Remove some garbage creation in Part.Update.
    * Fixed an issue where Kerbals on EVA rescue contracts weren't fully destroyed if the contract was not done. Added a check to clear any 'empty' EVA'd Kerbal vessels in existing saves.
    * Fixed an issue where Kerbals were able to be renamed through KB.

     

     

     Share


    User Feedback

    Recommended Comments



    19 minutes ago, TheTaleteller said:

    Yap, ModuleManager (at least 2.6.20.0) does not work on 1.1.2 - dont upgrade to eagerly people!

     

    2.6.23 - exactly the same situation.

    Trying "Previous stable release" option in Steam with no difference: 350 mb downloaded and installed, but the game show me "v1.1.2.1260" and ModuleManager still does not work.

    UPD: Steam "Verify Integrity of Game Cache" did not help.

    Edited by JtHermit
    Link to comment
    Share on other sites

    1 minute ago, Curveball Anders said:

    Always create a backup before an update.

    This goes for all software.

    Yes, it's a right way, but Steam install all updates without any question or even notification by default.

    Link to comment
    Share on other sites

    8 minutes ago, JtHermit said:

    2.6.23 - exactly the same situation.

    Trying "Previous stable release" option in Steam with no difference: 350 mb downloaded and installed, but the game show me "v1.1.2.1260" and ModuleManager still does not work.

    UPD: Steam "Verify Integrity of Game Cache" did not help.

    Most likely because Steam wants to start the game with KSP_x64.exe instead of the regular KSP.exe. Try again after deleting the x64 file. (the Previous stable release will downgrade you to 1.0.5)

    Link to comment
    Share on other sites

    2 minutes ago, KasperVld said:

    Most likely because Steam wants to start the game with KSP_x64.exe instead of the regular KSP.exe. Try again after deleting the x64 file. (the Previous stable release will downgrade you to 1.0.5)

    Thank you for explanation. As i understand, there are no proper way to roll back on 1.1.1?

    Link to comment
    Share on other sites

    Great thanks. Excellent job everyone. I fiddled with 1.1.1 over the week but i look forward to spending this weekend with 1.1.2.

    In reference to the man having issues with module manager, mine works so far. I am only able to run KSP in 64 bit mode. 32 always crashes for me.

    Edited by Slamnam
    Link to comment
    Share on other sites

    23 minutes ago, JtHermit said:

    Yes, it's a right way, but Steam install all updates without any question or even notification by default.

    Which is why you back up the Steam directory immediately after it updates (as well as stop its download by deleting local files and making sure its directory is empty before telling it to install the new version).  I backed up my Steam copy of KSP this morning.  That's my pristine copy of 1.1.2.1260.  Then I copy it again.  That's the copy I mod and play from using a link to its KSP_x64.exe.  And Steam can't affect either one.  Do the same after hotfixes.

    Edited by Jacke
    Link to comment
    Share on other sites

    1 minute ago, KerbOrbiter said:

    It's good that we have so fast updates. BUT half of the mods are broken now. :mellow:

    I'd say most of mods. Almost all.

    Link to comment
    Share on other sites

    NOOOO! I just updated like 100 Mods and made sure that everything works fine and now they just release that small Update and everything stopped working! 

    Jesus Christ i hope module manager will be updated soon :(

    Link to comment
    Share on other sites

    33 minutes ago, KerbOrbiter said:

    It's good that we have so fast updates. BUT half of the mods are broken now. :mellow:

     

    31 minutes ago, basila said:

    I'd say most of mods. Almost all.

    SOOOO :mad:  Give the mod makers some time to catch up and stop griefing squad for trying to fix the game.

    Edited by mcirish3
    Link to comment
    Share on other sites

    1 minute ago, mcirish3 said:

     

    SOOOO :mad:  Give the mod makers so time to catch up and stop griefing squad for trying to fix the game.

    ^^^ THIS. “Oooh the humanity! The Squad staff seems to be working 24/7 to fix the bugs! Let's complain about updates coming out too fast

    Link to comment
    Share on other sites

    19 minutes ago, Kilof said:

    We have bug in fairings... ;.; in editor mode...

    Just scare them away, bugs are dumb. At least as long as its not a brain bug. In that case, run!

    Link to comment
    Share on other sites

    1 minute ago, Kerbart said:

    ^^^ THIS. “Oooh the humanity! The Squad staff seems to be working 24/7 to fix the bugs! Let's complain about updates coming out too fast

     

    1 minute ago, Kerbart said:

    ^^^ THIS. “Oooh the humanity! The Squad staff seems to be working 24/7 to fix the bugs! Let's complain about updates coming out too fast

    Haha, especially after "OMG, whennnnn is 1.1 coming out! Need 64-bit...."

    2 hours ago, bradwiggo said:

    has the ship drifting away from camera bug in 1.1 been fixed yet.

    This I would like to know.

    Link to comment
    Share on other sites

    Landing gear is still a total wreck. I cant build a single spaceplane (moded or standard) they either explode on launch or bounce all over the runway. I love my spaceplanes please fix the issue with the landing gear

    Link to comment
    Share on other sites

     @sarbian for the win!

    1 minute ago, m-theory said:

    Thanks for the patch, great job Squad, thanks

    ^^^ This-----Yes, @SQUAD thank you very much for all your hard work it is much appreciated!

    Edited by mcirish3
    Link to comment
    Share on other sites



×
×
  • Create New...