Jump to content
  • Kerbal Space Program patch 1.1.3 is now available!


    RSSv71A.jpg

     

    Hello everyone!

     

    The 1.1.3 patch is now available! We’ve taken our time over the past couple of weeks to tackle as many issues as we could in this patch and the results speak for themselves: close to 100 fixes have been logged compared to the previous version of KSP, and we even found time to hide something small in the game that we’re sure a lot of long time fans will appreciate!

     

    Here's the complete changelog:

    =================================== v1.1.3 ============================================================
    
    Editor:
    * Fixed game crashing during deletion of parts under certain conditions.
    * Fixed Gizmos buttons not properly highlighting after loading a craft.
    * Fixed Fuel tank Part Action Window sliders to dynamically update symmetry partners when adjusted in editor.
    * Fixed frozen parts showing up in front of the main vessel.
    * Fixed fairings being see-through when a part inside or behind is highlighted.
    * Fixed certain fairing configurations causing inputlocks.
    * Fixed interstage fairing panels not being properly deleted when an interstage is removed from the ship.
    * Fixed Abnormal lighting and contrast.
    * Fixed Re-rooting and attaching frozen parts causing improper part selection.
    * Fixed an exception in FXModuleAnimateThrottle when in the editor.
    * Fixed inputlock preventing pressing [Delete] key from deleting a part.
    * Subassemblies can now be used as the start of a craft (fixes editor being non-responsive).
    * CoM indicator now accounts for mass of physicsless parts added to parent.
    * "Ground Crew" option now toggles off all animated components of VAB/SPH. Fixes increased CPU Load and Temp.
    * "Place" gizmo now provides onscreen message in editor to be consistent with other gizmos.
    
    Orbit:
    * Fixed Circular Orbit Ap/Pe jump on exiting timewarp.
    * Fixed on-rails SoI transition message to properly report both SoIs.
    * Greatly reduce Apoapsis/Periapsis changing with no input, with thanks to ferram4 and eggrobin. option is toggleable in Settings->Gameplay and tunable in Physics.cfg.
    * Lower the thresholds for floating origin shift and krakensbane when above the inverse rotation threshold, and use doubles when recomputing velocity during change (and do so immediately rather than via PhysxX).
    * GetEccentricAnomaly now correctly returns negative eccentric (hyperbolic) anomaly values when the true anomaly is before the hyperbola's periapsis, and should be more numerically stable.
    * GetEccentricAnomaly no longer spams E is NaN.
    * Conic patch creation is a little more efficient.
    * Ignore G spike on the frame where SoIs switch.
    * Orbit reported position will no longer be a frame ahead of velocity.
    
    Misc. Fixes:
    * [KSPedia] Fixed Bug with KSPedia asset bundle Dependancies.
    * Fixed symmetric part stage icons not expanding in stage manager.
    * Fixed Quicksave filename accessibility.
    * Fixed Multiple core heat producers not being properly cooled by radiator panels.
    * Fixed NRE when trying to overwrite or cancel out of save folder overwrite dialog.
    * Fixed E is NaN! tA: (pi) spam with some generated contracts.
    * Fixed Flags no longer displaying properly in the Tracking Station Info Box..
    * Fixed Flag transparency issues in editor.
    * Fixed Science lab spamming the log with "Updating" warnings whenever right-click menu is open.
    * Fixed funds penalties not being applied when Hiring Kerbals.
    * Fixed being unable to rename vessels via Knowledge Base.
    * Fixed NRE in ModuleGrappleNode.Release when parent is null.
    * Fixed UI_ChooseOption - onFieldChanged being called even when the field value hasn't changed.
    * Fixed Body lift missing when loading the Physics.cfg file.
    * Fixed Parts Tooltip window location being misplaced when changing UI scale.
    * Fixed issue with the sea level pressure display in the Knowledge Base.
    * Fixed an exception in PartModule OnLoad and OnStart causing vessel load failure.
    * Fixed a NaN in FlightIntegrator atmospheric thermo.
    * Fixed issue in Moment of Inertia calculations.
    * Fixed Rocket Exhaust FX not being moved by FloatingOrigin/Krakensbane when emitters are disabled.
    * Fixed missing parachute deployment sound.
    * Fixed VesselModules not being properly destroyed when a vessel object is destroyed.
    * Fixed unit tests from main menu causing every test to be run 4 times.
    * Fixed having an abstract UnitTest type causing TestManager to throw an exception.
    * Fixed regression that was causing global gravity to be non-zero, which should help with phantom drifting, especially with wheels.
    * Fixed a logical issue causing crew rotation objectives to be much rarer than intended on station and outpost contracts.
    * Fixed staging requiring two activation's when resuming in flight mode.
    * Fixed navigation waypoint getting stuck if a survey is killed in the middle of the flight scene.
    * Fixed Waypoint Markers not showing on Navball in IVA view.
    * Fixed potential error from generating if attempting to IVA an EVA kerbal that has just been loaded outside of a vessel.
    * Fixed RCS TorqueProvider implementation to take thrust limiting and alternate precision mode into account.
    * Fixed an issue where the NBS dialog was not resetting its coordinates properly.
    * Fixed reported typos and grammatical issues in various areas of the game.
    * Fixed ITargetable FlightCoMTracker.GetVessel always returning null.
    * Fixed Asteroids all spawning with a mass of 150t, regardless of class.
    * Fixed race condition with map filters causing asteroids to be invisible in new games until they were modified.
    * Fixed asteroids sometimes appearing to be pitch black while being seemingly immune to light when rotated at certain angles.
    * Adjusted science data collection range of Mk1 cabin to match other science options.
    * Kerbals can no longer "Take surface sample" while in command seat.
    * Fairing base purchase and entry costs adjusted to vary by size.
    * Part Action Window for symmetric parts no longer needs modkey to open when a sibling window is open.
    
    Misc. Tweaks:
    * [Modding] Additional access to fields in Mission Control.
    * [EVA, Gameplay] R&D upgrade text adjusted.
    * Added onVesselCrewWasModified, which consolidates many events in which crew changes on a specific vessel. Use this to fix a few issues with crew rotation objectives.
    * Added ITargetable.GetActiveTargetable, which allows us to specify if a target should be allowed on something that is part of the active vessel.
    * Added AeroFXIgnore layer so some parts (Gigantor e.g.) can have parts of their model ignored by AeroFX. Fixes an issue with odd Aero FX streamers.
    * Added "EVA" layer, added it to various cameras, physics casts, lights, and collision matrices to behave exactly like normal parts, except suspension raycasts ignore it entirely. Prevents violent interactions when kerbals touch wheels.
    * Added alwaysRecomputeLift to ModuleControlSurface so it can be set to not ignore slight actuation.
    * Added wheel weight stress and slip stress multipliers to game settings, allowing players that do not want these stresses to disable them globally.
    * Added onCommandSeatInteraction GameEvent, and deployableSeated to science experiments. Use these to disable scooping up surface samples when seated.
    * Added Felipe to crew name generation.
    * Satellite contract orbit generation made much more modular and maintainable, allowing us to validate generated orbits now. If an orbit parameter becomes corrupt through save manipulation or other means, that parameter can be regenerated without affecting the rest of the orbit.
    * Clarify R&D facility upgrade text to make it clear that Kerbin is still fair game for surface samples without the astronaut complex upgrades.
    * Crew Transfer more moddable.
    * Game is now paused going to MissionControl, AstronautComplex, Admin, R&D and unpaused when closing them.
    * Renamed Telus ladder to Kelus Ladder to avoid naming conflicts.
    * Improvements to flag rendering in KB.   
    * Improvements in Tutorial input locks and Error checking
    * Adjustments to the Repair/Downgrade costs of the Facilities
    * Changed "Cancel warp" to use forward slash instead of Esc.
    * When repaired, wheels become temporarily immune to weight and slip stresses, slowly rising back to normal over a period of between 30 to 90 seconds.
    * Reduction in the creation of Garbage Objects in Flight scene.
    * Reduction in the creation of Garbage Objects in Space Center.
    * Optimize Part.GetConnectedResources and Vessel.GetActiveResources for speed and to not create garbage.
    * Dramatically improve resolution of asteroid textures, while simultaneously improving their shader performance by 400%. New shader can have very subtle desaturated brown/red hues sometimes.

     


    User Feedback

    Recommended Comments



    I've upgraded to 1.1.3

    The Kerbin orbit now is stable - in terms it's not dropping.

    But the orbits are changing when switching focus to Space Center and back.

     

    For a short test made a stable orbit of 74677,7 / 74107,7

    "Without any input" my ship changed orbit to 74677,9 / 74109,3

     

     

    Second try gave me 74678,1 / 74108,9

    Repeating this again resulted 74678,2 / 74108,4

     

    There seems to be a serious loss of precision and the Apoapsis is constantly increasing.

    Whoa, i don't need fuel anymore to escape Kerbin :) 

    Edited by _Astra_
    Link to comment
    Share on other sites

    Performed a clean install of KSP v1.1.3 (Mac version running on early 2008 iMac with El Capitan) using the zipped download file (i.e., not the Mac installer).  Software hangs when I try to start a new game (Start Game --> Start New  -->enter save name, mode Sandbox, click Start!).  Tried to attach the KSP log but couldn't figure out how; unsure how to proceed.  Note, I haven't experienced this issue through 1.1.2. Any help appreciated - thanks.

    Link to comment
    Share on other sites
    6 hours ago, Riton Lafouine said:

    Hi, is it normal that i can't update with the patcher ? Button is greyed out. I might be wrong, but i'm sure i red in comments that a few guys updated with the patcher. Any advice ?

    the patcher hasn't worked in a long time. It shouldn't even be part of install afaic.

    Just do a complete reinstall an transfer your save file/craft files as needed

    Link to comment
    Share on other sites

    After sever mod updates, my launch clamps now work! Yea!
    But I just noticed that the photo cells on my probes and stations all have ZERO energy flow in direct sunlight - I checked several probes and stations, and angled some right at Kerbol.

    Edited by Balrog
    Link to comment
    Share on other sites
    Just now, Balrog said:

    After sever mod updates, my launch clamps now work! Yea!
    But I just noticed that the photo cells on my probes and stations all have ZERO energy flow in direct sunlight - I checked several probes and stations, and angled some a couple right at the Kerbol.

    Any idea which mod was causing the launch clamp thing?

    Link to comment
    Share on other sites
    2 minutes ago, Jim Kernan said:

    Any idea which mod was causing the launch clamp thing?

    The ones that were updated are:

    KerbalEngineer, Kopernicus, TarsierSapceTech, b9PartSwitch,[X] Science!, WildBlueIndustries, DMagicOrbitalScience, BetterBurnTime, UmbraSpaceIndustries, SCANsat, CommunityResourcePack, ContractConfigurator, KIS, MechJeb2 - DEV, WaypointManager

    Link to comment
    Share on other sites
    Quote

    Just do a complete reinstall an transfer your save file/craft files as needed

    Thanks,

     

    that's what i finally did, Working fine but landing gears still messing as i see ... after the 90s on runway, they explode ... fast takeoffs and landing absolutly necessary

    Link to comment
    Share on other sites
    4 hours ago, Denko666 said:

    strange, cause i can run KSP 1.1.3 on my MacOS X el capitan just fine.... 

    Are you starting the 64bit version or the 32bit?

    I'm using the Launcher to start the game, so I'm assuming it starts the proper version.  Also just checked the download page and there is no choice to download 32-bit or 64-bit versions; just 1.1.3 for OS X.

    Link to comment
    Share on other sites
    7 minutes ago, Riton Lafouine said:

    you can choose 32 bits and 64 bits in launcher settings ... at least for Microsoft OS ... i dunno for others.

    That does not appear to be an option in the OS X version.  Launcher contains graphics, audio and advanced options.  The only advanced options are to enable AMD compatibility mode and to not show the launcher.  The radio button for the other advanced options are filled red and the text states that the options are not available for this platform.  Also, KSP actually starts from the Launcher; I can get to the main menu and make selections.  I assume if there were an incompatibility such as 32-bit vs. 64-bit, KSP would crash immediately.

    Link to comment
    Share on other sites
    1 minute ago, Balrog said:

    now to find which mod isn't cooperating....

    Solar panels not working will probably be you need Kopernicus 1.1.2 and/or ModularFlightIntegrator 1.1.5.

    Link to comment
    Share on other sites
    17 hours ago, decimal-simplex said:

    Elevons deploy up by default now, since 1.1.3 - or at least I didn't notice it until after 1.1.3? Pretty sure they were deploying down by default with 1.1.2.

    What do you mean by elevons deploy? Are you turning them into flaps or spoilers? By default elevons should not deploy as they are a flight control surface and move with pitch/roll input, but if you are using them as a flap or spoiler then ya they will deploy with the. Could be an issue with the patch, so first, is this a saved craft from 1.1.2 or a newly built craft for this version? If the first, then go in an verify the elevon settings, if they have Flaps checked then they should deploy downward. Maybe the patch reset or changed their tweakable configuration you set. If this is a new craft, maybe the wrong button got selected, or in both situations maybe they got put on upside down by you or the patch flipped them.

     

    So ya check the tweakable settings in SPH/VAB and verify their settings.

    Link to comment
    Share on other sites
    8 hours ago, WildLynx said:

    Sentinel telescope is still non functioning. It neither updated as mod nor added as stock part.

     

    The Sentinel and the rest of the Asteroid Day pack will probably come in 1.2, but nothing has been confirmed yet.

     

     

     

     

    Link to comment
    Share on other sites
    * Added wheel weight stress and slip stress multipliers to game settings, allowing players that do not want these stresses to disable them globally.

    Where are the settings for this?

    Link to comment
    Share on other sites


×
×
  • Create New...