tjsnh

Members
  • Content Count

    913
  • Joined

  • Last visited

Everything posted by tjsnh

  1. When in doubt, make a backup of your existing tantares install - put the new one in, fire up a sandbox game and try stuff out.
  2. I always have to manually tweak the position of the LK ladder by tiny increments etc etc. Consider, making a 2nd version of the part that's custom aligned for radial attachment to the tantares LK pod. Like, the actual ladder and mesh are offset from the attachment point by an amount that makes it placed correctly if radially attached to the LK pod on the correct side, if you know what I mean.
  3. THANK YOU for this. I've been duct-tape-patching a 2-piece LK frame/tank from an old abandoned-in-2016 mod for several years now, and they kraken out half the time when i stage into them. It'll be REALLY nice to have a fresh, reliably working, LK tank&frame. I give you the highest of fives.
  4. When I get home from the office I'll post a .craft file. Just VERY simple sputnik-1 style crafts, I tried a few slight variations in the combination of bulge tanks. It seems that unless the payload is VERY heavy (tens of tons), the launch profile slips to blackflips a few seconds after starting the gravity turn. Increasing the weight of the bulge tanks seems to resolve the issue completely.
  5. The flipping problem is back for the Soyuz/R7 booster. Gravity turn around 300 m/s as usual, starts doing flips at about 30-40degrees off vertical. The following MM patch resolves the issue (increases the weight of the bulge tanks to move the center of gravity up): @PART[tantares_lv_fuel_tank_s1p5_s1_1] { @mass = 2.5 } @PART[tantares_lv_fuel_tank_s1p5_s1_2] { @mass = 2.65 } @PART[tantares_lv_fuel_tank_s1p5_s1_3] { @mass = 2.75 } @PART[tantares_lv_fuel_tank_s1p5_s1_4] { @mass = 2.85 }
  6. If you mean this part, LET it be abused as a heatshield. It's almost the right form factor anyway. :-)
  7. As a thought, this already happens with decouplers, fairings, and some of the structural parts like those engine plates from the MH expansion. These wouldnt be the only two parts that look similar in the VAB ;-)
  8. Option 6 : Just include them normally alongside the others ? If the parts already exist, it sounds like the work is already done.
  9. Is that 1.875m/etc R7 bulge tank and 2nd stage still in the works?
  10. I always use autostrut on almost everything. Seriously, at least 80% of parts in a craft. I usually autostrut to "root part" , and almost never have problems. Rigid attach, however, almost always turns my stuff into kraken food. :-(
  11. You have no idea how much I am looking forward to this.
  12. I usually put an extra decoupler below the fairing, and have abort just activate that decoupler, and the LES. From that point, the staging takes care of itself and you can just spacebar into a normal-ish recovery.
  13. Thankyouthankyouthankyouthankyouthankyouthankyou!
  14. I absolutely love this. I've tried, using a similar 2.5m part from another mod, to make a closable "docking bay module" like this that a Tantares soyuz could fit inside, but haven't had a lot of luck.
  15. You can make a pretty convincing TMK out of existing parts, dedicated parts would mostly be close duplicates of existing stuff in the Tantares pack. The only tricky bit is balancing the weight to keep the center of thrust aligned with the center of mass.
  16. Its listed in the tantares resources.cfg I think, but I believe I removed it as a troubleshooting step. I couldnt find it either. @Beale ??
  17. Whatever that update did, it seems to have fixed the problem. Window came right up with normal behavior. Logs just for good measure ; https://www.dropbox.com/s/0r6ko5gtqxnakbl/logs.zip?dl=0
  18. Still can't get the window to pop up when clicking the menu button. **shrugs** Not sure what to troubleshoot.
  19. I strongly suspect this had more to do with how difficult those particular parts are to model, with the engine fairings and such, rather than how they're intended to be used in-game.
  20. I'm having the same problem as the others, with the window not popping up. What exactly is causing that? Should I just add every "agent" in any mods to the excludedmanufactureres.cfg? I think this (below) is the error from my ksp.log. I've added the Tantares manufacturer to the exluded list, and added this experiment to the excluded list. Same error in ksp.log each tim e [LOG 17:12:50.371] [UIMasterController]: ShowUI [WRN 17:12:51.645] [R&D]: No Experiment definition found with id tantaresTelemetryReport [EXC 17:12:51.654] NullReferenceException: Object reference not set to an instance of an object KEI.KEI.<GainScience>m__8 (.ScienceExperiment x) System.Linq.Enumerable+<CreateWhereIterator>c__Iterator1D`1[ScienceExperiment].MoveNext () KEI.KEI.GainScience (System.Collections.Generic.List`1 experiments, Boolean analyze) KEI.KEI.ShowMainWindow () ToolbarControl_NS.ToolbarControl.SetButtonActive () ToolbarControl_NS.ToolbarControl.doOnTrue () KSP.UI.Screens.ApplicationLauncherButton.OnTrue (UnityEngine.EventSystems.PointerEventData data, CallType callType) UnityEngine.Events.InvokableCall`2[UnityEngine.EventSystems.PointerEventData,KSP.UI.UIRadioButton+CallType].Invoke (UnityEngine.EventSystems.PointerEventData args0, CallType args1) UnityEngine.Events.UnityEvent`2[UnityEngine.EventSystems.PointerEventData,KSP.UI.UIRadioButton+CallType].Invoke (UnityEngine.EventSystems.PointerEventData arg0, CallType arg1) KSP.UI.UIRadioButton.SetState (State state, CallType callType, UnityEngine.EventSystems.PointerEventData data, Boolean popButtonsInGroup) KSP.UI.UIRadioButton.ToggleState (CallType callType, UnityEngine.EventSystems.PointerEventData data) KSP.UI.UIRadioButton.UnityEngine.EventSystems.IPointerClickHandler.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData) UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData) UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor) UnityEngine.EventSystems.EventSystem:Update() [LOG 17:12:55.504] ocean node ondestroy Also in ksp.log: [LOG 17:23:29.303] [UIMasterController]: ShowUI [ERR 17:23:29.724] ToolbarControl: WARNING: RegisterMod, LoadedScene: MAINMENU, called too late for: KEI_NS, Kerbin Environmental Institute, button may not be registered properly
  21. I've played around with this on my own for .. quite a while now .. and read, and re-read, the documentation (though I may be blind). I'm trying to remove some requirements from a tech node and can't figure out how. Specifically, I want to remove the requirements from generalConstruction and replace them with only needing "start" tech. Here is the stock code out of the tech tree: RDNode { id = generalConstruction title = #autoLOC_501040 //#autoLOC_501040 = General Construction description = #autoLOC_501041 //#autoLOC_501041 = New equipment to help out in keeping things stable, especially useful when the size of the spacecraft defies the current bounds of sanity. cost = 45 hideEmpty = False nodeName = node3_generalConstruction anyToUnlock = True icon = RDicon_construction-general pos = -1946,1355,0 scale = 0.6 Parent { parentID = stability lineFrom = RIGHT lineTo = LEFT } Parent { parentID = generalRocketry lineFrom = RIGHT lineTo = LEFT } } I've been able to ADD a requirement no problem, but I can't figure out how to REMOVE those existing "parents". Using the same syntax to remove modules from a part didn't work. Before anyone suggests it, I can't just leave them in and leave "anyToUnlock = True" because it won't show up correctly on the tech tree and breaks other things since I've removed stability and generalRocketry from the tree with another patch. So rather than go through the 50 things I tried and how they all didn't work, I'll just ask straight up - what is the normal syntax to remove those parents from generalconstruction?
  22. I have regular struts unlocked with "start" , still nothing.