ExavierMacbeth

Members
  • Content Count

    202
  • Joined

  • Last visited

Everything posted by ExavierMacbeth

  1. Should be fine. I am using MKS, LS, Konstruction, FTT, & Warp Drive. So far the only problem I ran into on 1.7 is that the above mentioned flex tubes don't work with the 1.7 release version of KIS. KIS depreciated the code that Rover used for the flex tubes. Everything else seems to be working fine for me.
  2. Could you help me with an issue? Been trying to determine why the part list isn't displaying correctly within the 3D Printer Lab. It shows some parts (mostly the tiny grabbables from Universal Storage) but nothing else. I am playing on v1.7 so I don't know if thats actually supported yet so figured I would ask. This is what I am seeing in the logs when I open the workshop to try and select a part to create. Lots and Lots of these. Any ideas? [OSE] - Part USHexcore could not be added to available parts list (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51) MissingMethodException: Method not found: 'KISAPIv1.PartUtilsImpl.GetPartVolume'. at Workshop.WorkshopUtils.GetPackedPartVolume (.AvailablePart part) [0x00000] in <filename unknown>:0 at Workshop.OseModuleWorkshop.IsValid (.AvailablePart loadedPart) [0x00000] in <filename unknown>:0 at Workshop.OseModuleWorkshop.LoadAvailableParts () [0x00000] in <filename unknown>:0 UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object) UnityEngine.DebugLogHandler:LogException(Exception, Object) UnityEngine.Logger:LogException(Exception, Object) UnityEngine.Debug:LogException(Exception) Workshop.WorkshopUtils:LogError(String, Exception) Workshop.OseModuleWorkshop:LoadAvailableParts() Workshop.OseModuleWorkshop:ContextMenuOpenWorkbench() BaseEvent:Invoke() UIPartActionButton:OnClick() UnityEngine.Events.InvokableCall:Invoke() UnityEngine.Events.UnityEvent:Invoke() UnityEngine.UI.Button:Press() UnityEngine.UI.Button:OnPointerClick(PointerEventData) UnityEngine.EventSystems.ExecuteEvents:Execute(IPointerClickHandler, BaseEventData) UnityEngine.EventSystems.ExecuteEvents:Execute(GameObject, BaseEventData, EventFunction`1) UnityEngine.EventSystems.StandaloneInputModule:ProcessMousePress(MouseButtonEventData) UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent(Int32) UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent() UnityEngine.EventSystems.StandaloneInputModule:Process() UnityEngine.EventSystems.EventSystem:Update() (Filename: Line: -1) [OSE] - Part USOctocore could not be added to available parts list (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51) MissingMethodException: Method not found: 'KISAPIv1.PartUtilsImpl.GetPartVolume'. at Workshop.WorkshopUtils.GetPackedPartVolume (.AvailablePart part) [0x00000] in <filename unknown>:0 at Workshop.OseModuleWorkshop.IsValid (.AvailablePart loadedPart) [0x00000] in <filename unknown>:0 at Workshop.OseModuleWorkshop.LoadAvailableParts () [0x00000] in <filename unknown>:0 UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object) UnityEngine.DebugLogHandler:LogException(Exception, Object) UnityEngine.Logger:LogException(Exception, Object) UnityEngine.Debug:LogException(Exception) Workshop.WorkshopUtils:LogError(String, Exception) Workshop.OseModuleWorkshop:LoadAvailableParts() Workshop.OseModuleWorkshop:ContextMenuOpenWorkbench() BaseEvent:Invoke() UIPartActionButton:OnClick() UnityEngine.Events.InvokableCall:Invoke() UnityEngine.Events.UnityEvent:Invoke() UnityEngine.UI.Button:Press() UnityEngine.UI.Button:OnPointerClick(PointerEventData) UnityEngine.EventSystems.ExecuteEvents:Execute(IPointerClickHandler, BaseEventData) UnityEngine.EventSystems.ExecuteEvents:Execute(GameObject, BaseEventData, EventFunction`1) UnityEngine.EventSystems.StandaloneInputModule:ProcessMousePress(MouseButtonEventData) UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent(Int32) UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent() UnityEngine.EventSystems.StandaloneInputModule:Process() UnityEngine.EventSystems.EventSystem:Update() (Filename: Line: -1) EDIT: Both KIS & OSE are the current versions up on CKAN.
  3. My recommendation, Learn to make your own MM Patches I have a mod folder in my gamedata that contains nothing but my own personal MM patch files for each mod I use. If during gameplay I find that I like a mod I have installed but it has components I don't use then I add a line to my personal patch file to disable that part or update that setting. Now everytime a new game version is release (or I reshuffle my installed mods) I just clear the whole gamedata folder as 5thHorseman suggested, use CKAN to download the ones i want to continue to play with, and drop my custom MM patch mod into gamedata. I don't think I have had to directly touch the contents of one of the mods (outside looking at it when making a new patch entry) in several game versions now. And it wouldn't be hard to just keep a copy of the patches set aside if you want to change whole game types (like a set specific to RSS).
  4. Ok one more question. Does KAS no longer physically "dock" ships together when connected? If not i may have to rethink my MKS base building lol.
  5. @Tonka Crash worked perfectly. 30m cable version of the PCB with a slightly increased break reasistance to help keep it from snapping allowed me to tether the ends of the station together. It still wobbles like i would expect but no more exponential increase toward spontaneous disassembly Only need to use 8 of them so it even looks better than using struts would have lol. Thanks again for the tips.
  6. lol thanks. I remember playing EVA thruster drift games trying to move parts around in older version of KAS and wishing i had a tether when i did something that collision launched the kerbal (or part) rapidly away from the station. Part of the fun of assembly in space
  7. Thanks for the info & the patch. I understand the logic of making them realistic but some of the ranges just seem a bit short. Your modified 5m version of the TJ makes sense to me though I think i may use your patch as a guideline to see if i can't make a 30m version of the PCB. I don't mind some flex as long as it doesn't build on itself until it causes spontaneous disassembly (which it tries to now unless i tap time warp). And my part count is a bit high on this station to try and brace every joint like your image. Appreciate the links. I'll try sticking with KAS first though mostly because I don't like adding more mods to my large list if the functionality already exists somewhere else. Less things I need to go back and review when a new game version is released lol
  8. Quick question. I just came back to the game after a while so trying to figure out the new version of KAS. I know the old EVA Struts have been decommissioned & removed, is there a replacement that provides the same/similar functionality or is it just completely gone? Based on the legacy conversion notes on the wiki it sounds like the cable brace may have taken over this role but I can't find any information on what the "Spring Force" and "Break Force" values represent. If the functionality is completely gone, than does anyone know a good replacement? I have a space station that likes to try and tear itself apart if I have to reorient it... usually because i hit it too hard while trying to dock lol.
  9. Which logistics module specifically? You need to have either the "Duna" Logistics Center or the Tundra Pioneer Module with a Pilot in the module plus a warehouse storage module with Planetary Logistics enabled on it (Pretty much any of the USI Kontainer Storage Tab stuff). That will allow you to push/pull just about anything into or out of PL. The recent patch though added some unmanned refineries that will Push stuff into PL without the need of a pilot for remote mining bases but your main base will still need the above to pull anything out of it.
  10. @Nertea I know this might count as a feature request but there is one thing I would like to see. It mostly affects the NFE/Atomics patches but since it would be a change to the NFE reactor control panel I will post it here. Would it be possible to get an option we can set on a reactor to automatically change its power level (or enable/disable it completely) when time warp is engaged? I've lost count of how many times I have burned out the fuel in the Kerbal Atomics Engines (As well as the smaller EXP reactor & the USI patched reactors in bases) where I have accidentally left the things at full power while time warping between maneuver nodes or arbitrary time points (for bases). I realize such a function might not work well with the non-active catch-up functions the game uses if you time warp while focused on another craft. But just having it for when your trying to actively time-warp with the vessel would be extremely useful. Other than that I love your mods and consider them required for any game of KSP I play
  11. @Kobymaru & @Gilph, this was something that came up a few pages back. There is a workaround that is arguably a bug. You can "lock" the machinery & organics in the module by using the right click menu and the little icon on the end of the resource bar. The converters & other functions will no longer pull the resource from that location and instead deplete other storage. Useful for preventing organics from drying up or to hard lock an efficiency level on a machinery based production module. Arguably a bug, but personally I like it functioning like that as its less things i have to keep track of once its set
  12. Is the Pilot IN the Logistics Module? I believe that is one of the "required crew here" functions. It should pull automatically as it is drained. It will not arbitrarily fill storage to full as I think it only pulls in 10% chunks if it gets too low. Also you might want to try switching to another vessel outside physics range & then switching back after everything has been set up. I've noticed that if you try assembling things on site the various functions don't always activate properly until the vessel is reloaded fully.
  13. Lmao true, but at least if something is written there we can just heckle those who can't/won't read instead of being polite until they drive us all insane
  14. True. I've run enough mods for other games myself to know that annoyance. Maybe add an FAQ to the main page about taking up CKAN issues with CKAN? You list it as a download option but don't actually tell people you don't troubleshoot CKAN issues with your mods like many other modders do. Sadly, common sense is not very common on the internet lol
  15. If you go look at the last page of the CKAN sticky, someone opened a git issue for it. Just keep your eye on that till they get it fixed. EDIT: Hehe Rover, I think people prefer using CKAN to help them keep track of alot of mods. I run over 100 and if i get too many (especially the ones with pre-reqs) manually installed I start losing track of the versions. Which just causes me more headaches later
  16. As mentioned over the last couple of pages, there was an update that changed the MKS requirements in reguards to Ground Construction. The problem is that the new Ground COnstruction Core that it requires hasn't been approved and added to the CKAN list yet. We just have to wait.
  17. Ok now its working. Maybe it just didn't initialize right until after I unloaded/loaded the craft when I went back to ship out more organics. I accidentally zeroed them out shortly after that post. I think i am going to have to lock a small container of organics so I don't do that again lol Shouldn't be too hard. I just shipped out a 33 kontainer micro storage pod (3 Karibou flatbeds lined with 1.25m Kontainers & mini liquid spheres) to the base so I could disable PL on specific resources without losing all storage. Realized I have ended up with about 20mil dirt, 3mil fertilizer, and a few other things I probably really don't need to stockpile in PL. On the upside the base has 1.5mil supplies for the kerbals to burn through Think my PC is hitting its limit with this Base, I am up to 430 parts. Need to sit down and strip off all the various landing & surface attach stuff that is redundant now that the base is assembled. My Current Base: http://imgur.com/U2sv7ui (minus the cargo pod I just landed which was out of screenshot range still. One of my crew return pads is disconnected and upside down. That was Vals fault while i was trying to learn how to land on them
  18. Ahh ok, Then I will just have to run it in bursts (or go have bill switch 2 of the converters from colony supplies). I don't actually worry about where resources are pulled from. I use GPO with a universal pump MM to manage most of my resources. I have an inflatable ranger storage bubble for each type set up with max GPO level and to pump resources to the rest of the base. Keeps everything at full before things start getting dumped into PL EDIT: Or not. Organics apparently don't go into PL from the 1.25m Flat Storage I set up for that purpose. Ok Bill get out there and reconfigure the thing.
  19. Oh well will just spam some more inflatables lol. My base still looks pretty neat during the day. Took me almost 6 years to fully construct so far. Quick question, To produce organics you need a seed crop. Is that just to start the process? Or if I burn through the organics down to zero by leaving the Colony Supply production on will it completely shut down organics production? I didn't realize setting all 3 bays in the Assembly Plant didn't give me a button for each bay if they are all the same resource (I had nothing better to set on that module atm) so turning it on outstrips my current organics production massively lol
  20. Hey Rover, I am of the opinion that the Tundra modules need windows. My base is too dark at night which is why I used so many ranger parts in the image i posted on a previous page Finally got all the modules unlocked and expanded the place to be self sufficient. Just need to set up a Urananite mine somewhere within the next 8 years, which is when I will run out of power lol
  21. I actually used the Stations & Bases contract pack to set up my base on minmus. The only side effect of it is that the Karabou Rover parts get flagged as base so can sometimes be picked up by the "expand your base" contracts if its parked too close to the original base location. But you can usually just skip those and it will update to the correct base. EDIT: Also as for funds, Send up a crew of engineers & kolonisis for a while. If you have a Pioneer Module on the base you can use "check for kolony rewards" and generate alot of funds if you set it up right. I didn't even start setting up a base until I had the Tundra Pioneer module handy for Planetary logistics & Kolony Rewards.
  22. Yea USI-LS resources are Supplies, Fertilizer, & Mulch. I think the Greenhouse components only get applied to the configurations if you are using TAC-LS. USI-LS uses Agriculture & Cultivate to create its resources. As for swapping them out during a career... if you have alot of vessels with TAC-LS components I can only say ouch. The two mods use different resources so the moment you switch any ship will probably be starving from the start until you get the new LS resource out to it. But USI-LS doesn't auto-kill unless you turn it on so its a manageable issue since the kerbals will just go on strike until you can supply them. The problem is going to be "Parts" if you have alot of active vessels since it will break any vessel thats already built to remove them. Your best bet would probably be to install USI-LS, delete the TAC-LS dll & configs to disable it (but leave the parts files), and then either ignore that TAC parts until you can recover/remove them from active vessels or write a MM patch that clears the part category so they are hidden from the VAB/SPH parts list. This is how alot of mods handle leaving legacy parts around when they make drastic changes.
  23. Quick Question. Is this mod limited to Orbit only? Or can it be used to dock with a docking port style landing pad for a Minmus surface base? Been trying to find a way to run background supply/delivery missions to my USI MKS base lol
  24. Ok well whatever is going on with my Tundra Hab-Commons I can ignore now. Looks like the Colonization modules I installed kicked in. Was right I had to rotate the kerbals out after I finished KIS/KAs modifications to reset all their timers and now they are maxed at 4 years and staying there. Will have to remember that when I do then ext base expansion and already planning to have return transport waiting for when that time comes. Waiting for my lab to finish processing all the science data so I can unlock the manufacturing modules and think i will need to install more labs before my EVE flyby ship gets back. Thanks for all the help and info, I have to say that comparing the current version to the 0.23 version I played last is one heck of a change. And totally for the better