Jump to content

JPLRepo

KSP Team
  • Posts

    3,125
  • Joined

  • Last visited

Everything posted by JPLRepo

  1. They are not connected to your control station from your screenshot. Try picking the control station up and putting it back down again.
  2. Part Tools has been updated for KSP 1.8.0 Link in the opening post above. NB: Part Tools now requires Unity 2019.2.2f1
  3. The API docs have been updated for KSP 1.8. Link updated in the opening post.
  4. Nope. It is not fixed by Unity. It's a limitation on the way KSP works and has it's cameras setup.
  5. I'm guessing that's a Contract Configurator thing... 'cause this mod uses it for it's contracts.
  6. Instead of if (prl.Contains(ModSegSRBs.SeparatronFuel)) prl.Remove(ModSegSRBs.SeparatronFuel); You should be using part.RemoveResource() However, I don't think that's the problem rather it's: if (HighLogic.LoadedScene != GameScenes.LOADING) { Destroy(this); } you destroy the module. Without telling the part and removing it from the part.Modules list. Hence the NRE. You should be using part.RemoveModule(PartModule module) as this will remove it correctly from the Modules list and destroy the module for you.
  7. Hmm. I’ll have to take a look. Thanks. It’s meant to be played in career mode. But still works in other game modes. You have to point the telescopes at the bodies and keep trying to gather science about them. its definitely a better experience using the contracts in career mode.. Interesting. Thought it had SAS etc. you’re talking about the stock sentinel IR telescope yeah? I’ll have to check it out.
  8. Thanks for your feedback. 1. - How do you send probes to CBs when you don't know their orbit? or where they are? are you guessing? Or you first find them then send a probe to complete the research? 2. - Suggestions for contract costs are always welcome. 3. - The intention is to find them over time. Sounds like this is related to 1. in the way you are finding them without knowing where they are. 4. - Reviewed the observatory and the telescope ranges. Observatory: level 1: 80,000,000km level 2: 184,000,000km With Kopernicus installed: level 1: 700,000,000km level 2: 5,000,000,000km TB-75: 40,000,000km With Kopernicus installed: 540,000,000km Sentinel: 40,000,000km With Kopernicus installed: 324,000,000km This means at level 1 you can see roughly to Jool from kerbin in stock. Upon review, I may change this in the next update, but you can configure these to your liking via the cfg files supplied. 5. - Not sure what you're saying here. Don't do research contracts? just send probes? same as 1? 6. - Sorry you feel that way. 7. - It's a free mod. Built in my free time. 8. - Change coming that fixes this. Thanks.
  9. Change the IGNORELEVELS in the OPM_RsearchBodies.cfg file included with that mod. The format of each line is: <body> = easy normal medium hard where <body> is the body name and then a true or false for each difficulty level if that body is already discovered at the start of a game at that difficulty level.
  10. refer to the opening post. has all the details there on where to locate logs and ask for support.
  11. KSP does not use Unity built-in terrain meshes functionality. It uses its own terrain system - namely PQS.
  12. That is correct. The IVA was never finished. You can transfer the crew by clicking on the hatch of the part.
  13. Performance improvements are hard to quantify because it's always going to be different on each hardware setup and with different settings, etc. Let's say we have observed definite, measurable performance improvements and it is something we have focused on with the Unity engine upgrade and the new features that brings, as well as focusing (as always) on improving the performance of our code.
  14. In the meantime, if you remove the \gamedata\reposofttech\backgroundresources folder from your install the problem should go away for now. you just can't have background/unloaded vessel resource processing.
  15. Be nice not to paste the whole log into a forum post. But yes, you are right. There is a dependency there that was not intended. I'll release a fix in the next couple of days.
  16. The part was designed to be mounted vertically.
  17. This mod supports any mod that supports this mod by meeting its model requirements. Not the other way around. If a mod model has not been created to meet these requirements then it can’t be. As I am not the author of those mods, I can’t change them, nor do I have the time to change them.
  18. That was also in the announcement. https://forum.kerbalspaceprogram.com/index.php?/topic/187834-ksp-loading-the-ksp-franchise-expands/
  19. Well actually KSP 1.8 is being upgraded to Unity 2019.2.2f1 (this was announced yesterday) and a new parttools will be released for it. Part tools works with the Unity version the game runs on. So currently KSP 1.7.3 is unity 2017.1.3p1 and so to use parttools you must use that version.
  20. I will check - but pretty sure if it's not using a KSP part shader there is a part icon shader there now that will work.
×
×
  • Create New...