Jump to content

Unspec

Members
  • Posts

    8
  • Joined

  • Last visited

Posts posted by Unspec

  1. Okay, I too have been having this problem since 1.0 launch. I've played KSP since .18 and used opengl since .23.5. I may have narrowed this down to what I believe is an issue when the game is launched in windowed mode.

    First, my setup is an HDMI monitor running 1920x1080 as monitor 1. Second monitor is running DVI on 1680x1050.

    I use Nvidia 770GTX ver 340.52 drivers. Second monitor is running a basic Nvidia 9500 card.

    I believe this issue stems from the game opening itself right in the middle of the two monitors therefore causing it to try and adjust to the lowest resolution monitor.

    Simple test I ran, was to remove the '-popupwindow' launch option and disable the 'fake full-screen' option from the launcher. Once these options were changed, I was able to run the game in 'windowed' (not borderless) and also in full-screen. However the windowed version started in-between the two monitors.

    Hopefully this will help anyone else in the future. There really isn't a fix that I know if besides starting in full-screen and then changing to windowed (Alt+Enter), until they fix this opening in-between two desktops issue.

    Edit: Apparently windowed mode with '-popupwindow -force-opengl' inherently carries this issue, as Alt+Enter just causes the same crash for me.

    Just tried KSP with one monitor. Still has the issue. Not an issue of KSP starting inbetween monitors.

  2. Wow, i had this issue again so I can back to see how I solved it the first time, not knowing so much conversation had happened since! Anyway, for me, I have learnt to check the registry AND the settings.cfg, resetting both to get over the issue. I used to always run windowed mode, but I tried switching it to fullscreen and back, somehow I couldn't, so I went into the settings.cfg to do it manually.

    When that was done, although it was "windowed", but there was only the picture, no actual window frame was visible, and I couldn't figure out why...

    Even if you set both to the correct resolutions, the game still crashes above a certain resolution.

  3. Same here, my older builds still function normally, just 1.0 and up. GTX970 driver version 350.12.

    How many are using multiple monitors? Also, is the game rendering on the main monitor in Windows, or the secondary?

    I am running dual monitors with the primary connected HDMI (1920*1080) and the second by DVI (1600*900). The game is rendering on my main monitor.

    Running a 1920x1080 and a 1600x900 monitor here.

  4. I always crash before the game loads with the unity error: Couldn't switch to the requested monitor resolution.

    What OS are you running? I am in Win 7 Ultimate and I cannot minimize the application through the task manager or the task bar. I tried using the Windows Borderless Gaming app to force the game into fullscreen after lowering the resolution, but it rescales the image and causes the same error as above.

    Also running windows 7

  5. Interesting--when it doesn't work, what happens? Does it hang on the end of loading? That's what happened for me.

    As an experiment, I tried setting it to a lower resolution (1680x1050), setting it to be windowed in normal DirectX, then tried running through OpenGL--the window briefly was at the correct size, then reverted to a different resolution (it always goes to that size in my case), and then hung in the same place (checking the last asset before the spinning planet load screen). Weird. Looks like this new Unity version will not run OpenGL on my system, bummer.

    EDIT: Okay, I played around with the settings a bit more, and I got OpenGL working, hurrah! Let's see if it keeps up after I restart though.

    What settings did you change?

    I found a funky work around to get OpenGL working on fullscreen windowed borderless. Start the game in 1680x1050 (or lower), once its open, go to task manager and find KSP. Right click it, minimize, then maximize. Puts it into fullscreen windowed borderless.

    Edit: Forgot to mention, the workout is really sub-optimal. You have to go into regedit and manually change the resolution back to 1680x1050 every time you restart KSP.

  6. Apparently, Big Map works if you don't toggle orbits to show up. If you do, you're boned and permanently broke it, as it will cause all buttons to disappear and nothing show up on the map itself. You can't revert it because, as stated, there are no buttons to hide orbits, and there is no config file for you to manually shut off orbit mode. (Hopefully DMagic can easily make one for future reference)

    So, if you broke Big Map(as I foolishly did and learned the hard way), you can kiss MULTI and BTDT scans bye-bye as they don't show up on the still-functioning Small Map. Anything besides this nasty bug works A-OK, though.

    Is this bug present in the dev build (v11)?

×
×
  • Create New...