drdeath

Members
  • Content Count

    43
  • Joined

  • Last visited

Everything posted by drdeath

  1. I think I asked this before, but I'll ask again: Can we get a more independent behaviour for Mechjeb-Equipped vessels without an active connection, like reduced functionality but not a complete shutdown? After all, Mechjeb IS described as a kinda-sorta autonomous system...
  2. I noticed that too, and I noticed they both show author "linuxgurugamer" and are mutually exclusive.
  3. Thankyouthankyouthankyou for bringing one of my favorite mods back from the grave! You're aces! @linuxgurugamer can we expect to see this mod back in ckan?
  4. Well, storing any waste products for recycling would only make sense in the mk1d, and food and water aren't strictly necessities, but I think at least half an hours worth of oxygen should be available in all of them, if just for show. Maybe we also simply need more variants of pods, because especially away from Kerbin, it may be more than a day or two until I can come and pick a downed Kerbal up, and staying in orbit in the mk1d isn't always an option either, especially if I have to bail because I already AM on a suborbital trajectory. I'd also like to point out that the one pod that has supplies is the one least likely to make use of them, because in the mk1c, the inhabitant would be shock frozen. I just saw that post a minute ago. I think either we need a slightly bigger pod with more supplies, or stackable modules that go e.g. between the pod and the chute. It wouldn't even have to be configurable, you could alter the config with module manager depending on which life support flavor is detected. Oh, it's not a HUGE problem, just pop EVA and float to the surface. I still think life pods should be floaty in general. And floatiness on other planets is another question entirely anyways.
  5. I think what this pack could do with is an extended endurance pack for the mk1a. To make the mk1a workable, I almost have to have retro rockets on the bottom and the parachute on top. That leaves nowhere to attach the fuel cell. I ran some trials from higher up, but at anything above 200km, I almost invariably ran into issues with EC depletion before hitting the atmosphere. Also I've noticed that the pods currently sink in water. I think an integration with Comfortable Landing would be a good way to go here. Last but not least, there seems to be something wrong with TacLS integration, at least it looks that way from here. Currently the OTAV and the mk1c pod are the only ones that have a full set of TacLS resources. The mk1a has oxygen, the mk1n and mk1d have none of the resources at all. I'm afraid I can do nothing to help you fix it, except maybe test some stuff for you.
  6. I can confirm that on Ubuntu with Nvidia proprietary drivers, no pink blocks and everything looks fine. All monitor pages seem to work as expected as far as I can tell.
  7. That doesn't sound good at all... Didn't see that before. Great idea though! Thanks!
  8. I have some trouble with the font rendering on Linux. See Screenshots below - I showed each screen in sequence There are also a lot monitor<date><somecode>.png files in the screenshots folder, probably implicating RPM realizes it has a problem. How do I get at the logs to post those too?
  9. You, Sir, are an awesome, lightning-fast bugfixing-machine!
  10. That's true. Learning a bit of MM can let you do most things with a part, provided they have been done before.
  11. To tell the truth, the skycrane stuck a little sideways with me too. Hurra for low part counts, but I'm simply not one for all-in-one solutions. They smack too much of pre-cut paper planes. It's the same thing I criticize about Lego for years now: If all parts are specialized and highly integrated, it takes the creativity out of it. If all I have to do is stick together two or three parts that only fit together one way, where's the fun? To get back to KSP, there is (was?) that moon lander mod, where you can basicly stick together an apollo moonshot from pre-cut, pre-scored parts. Where's the fun in that? When I first went to the Mun, I flew unmanned 37 times, until I had all the ship construction, the engineering, the tanks, the maneuvers, the lander construction etc, etc, figured out. That was where the fun was at! The actual being-on-the-moon? Well, Kerbal gets out, Kerbal plants flag, Kerbal gives EVA report, Kerbal takes surface sample, Kerbal gets in. Boooo-ring!!!
  12. Oh, it's a loooooooong list... However, thanks to a little mod called Kaboom, I cut away all the exotic parts, so you should be able to make do with just Hangar and ART, which are probably the relevant ones anyways. You should get some unloadable ship messages when starting this up, that's OK. The relevant ones are the asteroids at about 1500000m above Kerbin. Here it is, just unzip it into your saves folder: https://filebin.net/xlssae4f6hd4k7z9
  13. I will try. Would it help if I gave you the savegame?
  14. Anything I can do to help you?
  15. Got something strange here: All of a sudden, all stats on the Asteroid hatch read NaN, Volume and size both, and also in the tank editor. It was working fine this afternoon, I built and tested a mono tank in the hatch. some time after I destroyed the tank again, it seems to have gone wahoonie-shaped on me. @allista, have you ever experienced something like that?
  16. That's one risk I'm willing to take , at least for some experiments. Point duly noted though, so I'm not gonna complain to you about any lost asteroid bases. What piqued my interest is the fact that ART obviously correctly interprets that the asteroid is being hollowed out, even though it's being done by an excavator from the Hangar mod, which, as you just pointed out, is not using ART code. Maybe we can get @RoverDude to comment on this? Something interesting is definitely going on here, and I think all kinds of useful things could come from it. Last night for example I attached two hatches to one asteroid and noted the fact that the asteroid hatch has a space stat independent of the one the ART gives the asteroid, and that it is per-hatch. Maybe if a certain percentage of the asteroid mass (say 50%, as ART calculates it) has been mined, the asteroid could be considered hollowed-out and any asteroid hatch where SOME mining was done at some point (gotta mill a hole into the wall) could share that internal space. Now I have no idea what that would do to your code, but it would definitely feel very asteroid-basey. Edit: what I'm also going to try is what happens if I mine ALL of the asteroid as ART calculates it from one hatch and then continue mining from the other
  17. @allista Now I'm curious: when I excavate an asteroid with the asteroid mining factory from the hangars mod, the "available space" stat added by ART starts going up. Do you share any game mechanics with ART after all?
  18. Thanks for the quick work! I wish I were allowed to shoot up hotfixes that fast...
  19. Nonono, that's not it. It's not about the asteroids, it's about the configurable tanks. Technically speaking, ART tanks are part of the fuel hatches, not the asteroid. That compartmentalisation tech looks very similar to the configurable containers mod, so I figured if both are broken, that could indicate some kind of shared problem.
  20. One more point on this: KSP itself seems to think it is quite cool, 300-some K surface temperature. The surface gets hot eventually (and the radiators kick in), but only after it shows 800-something K. I can't make all that much sense from the thermal debug, but I don't see the heat figures provided by the part menu anywhere in the thermal debug.
  21. You know, I love EPL, but it's always been a pain getting the setup in place. I guess I just found the right tool to do that. Also, could you perhaps interface this mod with the Hangars mod in such a way that, when one stuffs a DIY kit into a hangar, it can spew out the finished craft some time later?
  22. Just found this mod... I am SO trying it RIGHT NOW.
  23. So I'm trying to excavate an asteroid, I've got tons of radiators on my asteroid mining factory, but it still gets terribly hot and stops doing anything. Either I'm doing something wrong or the thermal code on this thing is seriously broken. Can anyone give me a few pointers? @Haifi: Having the same Problem here. I'm also using ART, which also has trouble with the tanks, does it perchance have similar dependencies?
  24. Good to hear that. Looking forward to those videos of yours.