Jump to content

charliepryor

Members
  • Posts

    72
  • Joined

  • Last visited

Everything posted by charliepryor

  1. Hey there! I have a very niche need with a video series I'm doing, and would like to know if there is any mod, or really just any way in general, to have all part costs hidden in the VAB/SPH when building crafts. I want the costs to still count towards the total and everything, but I'd like to hide the cost of the parts as I'm hovering over them and seeing new information. Is there any way to get the game to omit that information? Thanks for your time!
  2. It is rather large. Perhaps the idea is that it's visible from Kerbin anyways, and so since they can see it, it's starting visible? IDK just trying to find a lore reason to help ya. Hope somebody answers that for ya.
  3. Don't know if this has been mentioned yet. I don't see it mentioned after searching anyways, but this mod is NOT fully compatible with Kerbalism. I realize that's not necessarily either side's responsibility to do, but I thought I'd mention that There are AddResource processes that fail and spam NREs in the log like crazy if you try to use them. The Life support SabatierH2OPriority, WaterElectrolysisO2Priority, etc. are all spamming lots of NREs. You can see this by opening the log while in the VAB (console) and trying to add, for example, the K&K Planetary ISRU part (just clicking on it will be enough), as well as the Life Support Recycler. -- If you don't want a gargantuan amount of NRE spam in your logs, I don't recommend using any K&K part with Kerbalism that impacts or has anything to do with LS or ISRU related to Life support, until that's somehow patched, if it gets patched. Example image: https://imgur.com/RUbheSa It's far worse with the ISRU. LOG: https://drive.google.com/file/d/1r2Fb7RlN9AOqK7_gQxZ4ow6stSF73gq6/view?usp=sharing [LOG 14:13:47.187] [FAR v0.16.0.4]: Voxelization Time (ms): 424 [LOG 14:13:48.563] KKAOSS.LS.container.sabatier added to ship - part count: 241 [LOG 14:13:48.564] KKAOSS.LS.container.sabatier added to ship - part count: 242 [LOG 14:13:48.565] KKAOSS.LS.container.sabatier added to ship - part count: 243 [ERR 14:13:48.662] [Kerbalism] Lib.AddResource error while adding _SabatierH2OPriority: the resource doesn't exist [EXC 14:13:48.662] NullReferenceException: Object reference not set to an instance of an object KERBALISM.ProcessController.Start () (at <508759cbee33445e8d50142044bd4b10>:0) UnityEngine.DebugLogHandler:LogException(Exception, Object) ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object) UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object) [ERR 14:13:48.662] [Kerbalism] Lib.AddResource error while adding _SabatierH2OPriority: the resource doesn't exist [EXC 14:13:48.663] NullReferenceException: Object reference not set to an instance of an object KERBALISM.ProcessController.Start () (at <508759cbee33445e8d50142044bd4b10>:0) UnityEngine.DebugLogHandler:LogException(Exception, Object) ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object) UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object) [EXC 14:13:48.716] NullReferenceException: Object reference not set to an instance of an object KERBALISM.ProcessController.Update () (at <508759cbee33445e8d50142044bd4b10>:0) UnityEngine.DebugLogHandler:LogException(Exception, Object) ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object) UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object) [EXC 14:13:48.717] NullReferenceException: Object reference not set to an instance of an object KERBALISM.ProcessController.Update () (at <508759cbee33445e8d50142044bd4b10>:0) UnityEngine.DebugLogHandler:LogException(Exception, Object) ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object) UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object) [EXC 14:13:48.717] NullReferenceException: Object reference not set to an instance of an object KERBALISM.ProcessController.Update () (at <508759cbee33445e8d50142044bd4b10>:0) UnityEngine.DebugLogHandler:LogException(Exception, Object) ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object) UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object) That'll continue on and on until you completely remove the part and fully trash it in the editor. It begins again when you select any part with such a process.
  4. I get massive NRE spam in my logs which I believe may be traced to this mod. Here's a log file: https://drive.google.com/file/d/1u4TEFoLFsJPxH6mTmLgSmDWYNCgE6-JI/view?usp=sharing What I did when it happened: 1) Launched a small science rocket out to the ocean like 8km from KSC. Super short distance, no big deal. It continues gathering science with Kerbalism 2) Noticed it was out of range, and it couldn't transmit data. Got brilliant idea to inflate a balloon with an antenna, as I suspected the probe was just a little too far out and the horizon was in the way while it was splashed down. Figured the balloon could act as a relay. 3) I was right. It worked! yay! - but I don't really care to wait around for the balloon now, so I try to go back to space center. Game informs me that I cannot do that mid-flight and that it's going to take me back in time instead. That's annoying, but okay, fine whatever. Not such a brilliant plan after all I guess. 4) I come back to space center, balloon craft icon is on the launchpad, but NREs are spamming me like crazy (I have the error display up in the right corner which caused me to suspect it. It appears to happen after doing something with Balloons. I would then go ahead and retest this exact thing again just to be sure. The log attached is the confirmation attempt. EDIT: Here's the full modlist installed: https://docs.google.com/spreadsheets/d/1xN8rAX_M04w5H-79PLUWc8cdp0z-CpRdRaL1I7-hI14/edit?usp=sharing
  5. Anyone else notice a massive NRE spam whenever these parts are used with FAR installed? I'm on KSP 1.12.2. - Without FAR, no NREs in flight. With FAR, it just spams the log constantly with the following: [EXC 11:46:35.116] NullReferenceException: Object reference not set to an instance of an object FerramAerospaceResearch.FARGUI.FARFlightGUI.PhysicsCalcs.CalculateEngineAndIntakeBasedParameters (System.Double vesselSpeed) (at <5703ae4062a541a09eeee98e1716f5d5>:0) FerramAerospaceResearch.FARGUI.FARFlightGUI.PhysicsCalcs.UpdatePhysicsParameters () (at <5703ae4062a541a09eeee98e1716f5d5>:0) FerramAerospaceResearch.FARGUI.FARFlightGUI.FlightGUI.FixedUpdate () (at <5703ae4062a541a09eeee98e1716f5d5>:0) UnityEngine.DebugLogHandler:LogException(Exception, Object) ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object) UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object) Anyone else notice this? I use all other parts and get none of this, but when OPT is on the runway, this is the case. LOG: https://drive.google.com/file/d/1vdaq0GVyKPtw8RCaNf0t0-auU9RGvZyV/view?usp=sharing
  6. So cool to have a response! I hope it isn't too much work. It's a really cool twist on the solar system I have with OPM installed. Conveniently fits right in there perfectly.
  7. Any chance for a quick update to add stats for Kerbalism? There's currently no radiation or magnetopause at all on these celestial bodies, and it would be so cool to incorporate this into my new series. Thanks!
  8. Have you attempted to do this after completely deleting the folder for this mod, or are you dragging in and overriding? You might have another conflict not associated with DOE, because this is working fine for me with 100+ mods, DOE included.
  9. Update your mod actually. Patch notes suggest the conflict with DOE is resolved. I just tested it in my own KSP 1.12.2 game after posting above, and I needed to update the mod. I have no issues like this anymore.
  10. Same thing here really. Replication steps basically involve having Distant Object Enhancements installed and then trying to use a telescope. The distant objects completely disappear, and eventually even the UI for the telescope will bug out and become unresponsive. KSP 1.12.2 - I don't have a log, as it didn't just happen or anything, but I'm more or less just backing up what the previous guy said.
  11. I'm sorry to hear that, but I understand. Your mods are awesome, but they'll be the only ones in my 100+ list I cannot properly read in the glory of 4K. #FirstWorldProblems
  12. You're using Kerbalism, and the process isn't completed yet. That doesn't sound like a problem with this mod. It looks like you just have to give it time to transmit the data, unless I'm seeing this incorrectly.
  13. I'm know this isn't yet supported in KSP 1.12, but I do feel from reading your posts that you're working on your mods being updated and such. I'd just like to say thank you for your hard work on these mods, and I would hope you are considering UI scaling as a part of the release when you do get around to them. Higher resolution than 1080p makes some mods with KSP, AmpYear included, almost unusable to anyone without really great eye sight. Scaling up the UI with the stock UI would be amazing. Thank you for your time.
  14. Firstly... OH WOW THANK YOU for the scaling. Appreciate that a ton. -- Secondly, I'm noticing something weird, and I'm not sure which mod to blame or whatever, maybe it's nothing... but I just used a balloon from KerBalloons and I noticed the wind direction being listed in the Climate tab was different than the weather tab almost all the time... and I also noticed that my balloon never seemed to drift in the direction the wind stated. Is that showing which way the wind is blowing, or which way the wind is coming from?
  15. Oh god yes. It's the last step to complete the modded series I've always wanted.
  16. Any way to scale this UI larger? Paying higher than 1080p is super small. Even if I have to hard-code font size, that'd be fine.
  17. Is there any way to scale this UI up more? It's super small at anything other than 1080p - and a huge portion of people are playing higher than that now, myself included. Would be nice, even if I had to hard-code it, to change the size of text in the interface. Also, when trying to use Blizzy's toolbar, it's throwing an error (I just have errors display on for testing purposes. You can repro that way). Basically, the icon is too large, and therefore, it shows up as a purple square with Blizzy's bar.
  18. I've had that happen in my testing with time warp. I have way more generation than I need, and sufficient batteries to last twice as long in the dark as my satellite does - and yet with fast enough time warp, while it's the active vessel, it will deplete entirely. At 1X speed, the moment it sees the sun, it's instantly full battery again. I don't believe it's a Kerbalism problem really, but I have no idea how to solve it.
  19. Apologies if this has already been asked, but I'm pretty confused here. I'm on a heavily modded career playthrough with KSP 1.3.1 - and I have TextureReplacerReplaced installed. It said that that mod was replacing this one, but now I'm seeing this one is updated for later versions of KSP. I'm assuming I should be using the one I have already, but am I wrong? Should I be using this one instead? I've got Astronomer's Visual Pack installed, and I'd love to also use suit stuff from @overkill13 as well, but that says it's for the future version as well. I'm gonna assume at this point that I really cannot use updated mods anymore, but at the same time now, I'm getting absolutely no ground textures for Eve -- and I'm just all confused whether it's got something to do with Texture replacer now. Ugh. Thank you for your time... anyone. Is this version of Texture Replacer good to use with KSP 1.3.1, or should I be sticking with Texture Replacer Replaced? Would any of this have to do with having no textures on Eve? [EDIT] I've found the solution. I had AT_Utils updated to 1.6.2, and it should have been 1.6.0. I downgraded it.
  20. Okay, now that this UI factor is in the game, I can see that my productivity is actually quite poor, and after looking into my staff, it seems that the two engineers that are on the base have 80% stupidity. --- I'll cycle new crew to this base and try again. - In the meantime, is there any way to train these kerbals to be less stupid, aside from modifying save files (which I refuse to do for any other purpose than bug mitigation or naming kerbals in game for the video series) - Charlie
  21. I have two engineers though, both stationed in the module with EL survey station installed, and my productivity is above 0. Wouldn't there at least be some sort of progress made here? I'll read the manual as instructed, but it seems to me with my modules having productivity above 0, and their being 6 Kerbal at this station including two Engineers, there would be at least some progress on this construction. Edit: also I'll update the mod to 5.7.3 - since this update has been released.
  22. Trying to get this to work, but I'm running out of options to try out... and by running out, I mean I've exhausted everything I can think of. It's a really heavily modded game, but I've not experienced a total "mod doesn't work at all" yet in the campaign aside from this. My mod list is here: https://hottipsmedia.com/ksp-mods Here's the details. I hope you can shed some light on what I'm missing here: output_log.txt: https://mega.nz/#!ZGQgUBQS!1z4WG3LWC1oVDIbjDS5Z85tRS_pR8Ld-fKwBGn7wcic KSP Version: 1.2.2 EL version: 5.7.1 Installed via: CKAN I'm using this mod with MKS, and I've tried to create a craft from my VAB design here at the Minmus base I have. The Pioneer module has an EL Survey station in it, and should be capable of producing a craft on the surface, as supported by both text in game, as well as this documentation here: https://github.com/UmbraSpaceIndustries/MKS/wiki/Functions-(Extraplanetary-Launchpads) As you can see by the attached screenshot, my survey stake is very close to the base. I have numerous Kerbals on board this vessel, including two decent engineers, two pilots, and a couple others with various other roles. I have all of the supplies I should need to produce this craft from the VAB, and meet all resource requirements. However, upon attempting to build it, my Kerbal Alarm Clock goes off immediately telling me the craft was completed - despite the EL window clearly showing me 0% and 0s remaining. I cannot get this mod to build anything, whether it's this craft or another. It's just not working. Screenshot: https://mega.nz/#!wPpwkCyR!dOmPH5jeGcrXOLxPoxfBQBIV5eHwByZbGbMLAzBHxmM My entire series/mission being produced depends on this mod functioning. I hope I'm missing something simple here, but I've put 3 hours into trying various things from dismantling and replacing stakes, to placing 4 stakes in a square, to changing the crew, changing the craft, changing the craft's design source (VAB or SPH), etc. There's nothing I can do to get this to work. I recently booted up the game and tried to build it, and then shut the game off. I was hoping this would reduce the amount of irrelevant data in the log. I appreciate any help you have to give. Thank you for your time. - Charlie EDIT: Important clarification I forgot to mention: My productivity is 0.3, hence, above 0.
  23. @blowfish Mentioned not knowing how the DRE patch should work in my thread over there. Perhaps you two can talk.
  24. Pretty sure your legacy parts got forgotten about in terms of the Deadly Reentry patch. I've got this going on: This occurs with a craft made almost entirely of the S2 parts and the SH and SW wings. Log is linked in that post there.
  25. Yeah I know. The main NRE I'm trying to diagnose doesn't appear to be related to DRE though, but it comes up EVERY single craft, even new ones, regardless of how many parts or where they are, and regardless of even them being brand new. A single probe core on the launchpad throws hundreds per minute. Deleting parts until I track that down might be all I can do. - I have 4 KSP folders, all pretty much copies, as well as a separate backup of my save folder... so I just gotta take the likely insane amount of time required to do it and track it down. The biggest problem with deleting parts though isn't so much the crafts being deleted, as much as it is the entire career being corrupted entirely because the parts were somehow associated with potential contracts. UGH. KSP... I don't know how you modders do this stuff, but I admire your dedication to solving problems. I'm sure this stuff I have to do is just a small taste of that,
×
×
  • Create New...