SeraphTroy

Members
  • Content Count

    10
  • Joined

  • Last visited

Everything posted by SeraphTroy

  1. @sal_vager It WAS working. Then, as magically as it was working, it stopped working. I think the same issue would be found with a Logitech Extreme 3D pro, as it looks like on most of the forums there's a correlation. The most up to date output log is here (https://www.dropbox.com/sh/1jx0aatrbfda0e3/AAC4myLbD3-ZMT1PHnzxgv5Ta?dl=0)
  2. I might try that out. I won't be able to test until later. Like I said I *think* got this working when I ran the KSP binary rather than the KSP_64 binary, and even the logs output different things when I checked. I'll see if I can recreate the issue, and submit it back to y'all as a bug report.
  3. If I remember correctly, I also tested the MK2 cockpit and it was fine in there, didn't notice anything. I notice it really on the ASET parts, so in this the HUD and some of the other ui elements have the hex code, but not the normal RPM monitor. Have there been any comments about when this (or the underlying ASET parts) will be updated for 1.2?
  4. Nevermind my previous post. I noticed that depending on how you launch, the log is in X:\Steam\steamapps\common\Kerbal Space Program\KSP_Data and not KSP_x64_Data. When I ran KSP.exe instead of the x64 binary it seemed to pick it up, so maybe the problem is with the x86 binary?
  5. Hi @sal_vager I tried to do that but I never get any output to line: X:\Steam\steamapps\common\Kerbal Space Program>dir Volume in drive X is Data Volume Serial Number is A2D3-F13A Directory of X:\Steam\steamapps\common\Kerbal Space Program 31.10.2016 21.43 <DIR> . 31.10.2016 21.43 <DIR> .. 15.10.2016 13.11 60 buildID.txt 15.10.2016 13.13 60 buildID64.txt 15.10.2016 13.16 <DIR> EmptySteamDepot 31.10.2016 18.41 9 312 FAQ.md 31.10.2016 21.43 <DIR> GameData 01.10.2016 06.06 <DIR> Internals 15.10.2016 13.11 17 729 024 KSP.exe 31.10.2016 22.11 632 449 KSP.log 31.10.2016 18.46 <DIR> KSP_Data 15.10.2016 13.14 21 468 672 KSP_x64.exe 30.10.2016 14.01 <DIR> KSP_x64_Data 15.10.2016 13.16 16 180 736 Launcher.exe 15.10.2016 13.16 <DIR> Launcher_Data 31.10.2016 18.41 33 674 LICENSE.md 31.10.2016 22.11 106 357 PartDatabase.cfg 01.10.2016 06.06 <DIR> Parts 15.10.2016 13.16 22 168 Physics.cfg 30.10.2016 14.09 <DIR> PluginData 30.10.2016 12.32 <DIR> Plugins 31.10.2016 18.41 8 894 README.md 15.10.2016 13.16 287 343 readme.txt 01.10.2016 06.06 <DIR> Resources 30.10.2016 12.35 <DIR> saves 30.10.2016 12.34 <DIR> Screenshots 31.10.2016 22.01 29 304 settings.cfg 01.10.2016 06.06 <DIR> Ships 01.10.2016 06.06 <DIR> sounds 15.10.2016 13.16 213 072 steam_api.dll 15.10.2016 13.16 235 600 steam_api64.dll 31.10.2016 21.54 <DIR> thumbs 15 File(s) 56 956 725 bytes 17 Dir(s) 100 546 662 400 bytes free X:\Steam\steamapps\common\Kerbal Space Program>KSP_x64.exe X:\Steam\steamapps\common\Kerbal Space Program>KSP.exe X:\Steam\steamapps\common\Kerbal Space Program>Launcher.exe X:\Steam\steamapps\common\Kerbal Space Program>KSP_x64.exe X:\Steam\steamapps\common\Kerbal Space Program> But I did look through some of different output logs and found this in the KSP_x64_Data Maybe this is what you're looking for? To note is "[InputDevices]: Device #1 has no name." Initialize engine version: 5.4.0p4 (b15b5ae035b7) GfxDevice: creating device client; threaded=1 Direct3D: Version: Direct3D 9.0c [aticfx64.dll 8.17.10.1433] Renderer: AMD Radeon HD 5800 Series Vendor: ATI VRAM: 1010 MB (via DXGI) Caps: Shader=30 DepthRT=1 NativeDepth=1 NativeShadow=1 DF16=1 INTZ=1 NULL=1 RESZ=1 SlowINTZ=1 ATOC=0 Begin MonoManager ReloadAssembly Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\UnityEngine.dll (this message is harmless) Loading X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\UnityEngine.dll into Unity Child Domain Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\Assembly-CSharp-firstpass.dll (this message is harmless) Loading X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\Assembly-CSharp-firstpass.dll into Unity Child Domain Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\Assembly-CSharp.dll (this message is harmless) Loading X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\Assembly-CSharp.dll into Unity Child Domain Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\Assembly-UnityScript-firstpass.dll (this message is harmless) Loading X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\Assembly-UnityScript-firstpass.dll into Unity Child Domain Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\Assembly-UnityScript.dll (this message is harmless) Loading X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\Assembly-UnityScript.dll into Unity Child Domain Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\UnityEngine.UI.dll (this message is harmless) Loading X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\UnityEngine.UI.dll into Unity Child Domain Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\UnityEngine.Networking.dll (this message is harmless) Loading X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\UnityEngine.Networking.dll into Unity Child Domain Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\Mono.Cecil.dll (this message is harmless) Loading X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\Mono.Cecil.dll into Unity Child Domain Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\KSPAssets.dll (this message is harmless) Loading X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\KSPAssets.dll into Unity Child Domain Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\TDx.TDxInput.dll (this message is harmless) Loading X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\TDx.TDxInput.dll into Unity Child Domain Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\TrackIRUnity.dll (this message is harmless) Loading X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\TrackIRUnity.dll into Unity Child Domain Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\xmldiffpatch.dll (this message is harmless) Loading X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\xmldiffpatch.dll into Unity Child Domain Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\XmlDiffPatch.View.dll (this message is harmless) Loading X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\XmlDiffPatch.View.dll into Unity Child Domain - Completed reload, in 0.149 seconds Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\System.Core.dll (this message is harmless) Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\System.dll (this message is harmless) Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\Boo.Lang.dll (this message is harmless) Platform assembly: X:\Steam\steamapps\common\Kerbal Space Program\KSP_x64_Data\Managed\System.Xml.dll (this message is harmless) <RI> Initializing input. <RI> Input initialized. desktop: 1920x1080 60Hz; virtual: 1920x1080 at 0,0 <RI> Initialized touch support. UnloadTime: 3.117644 ms Release Build (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) [KSP Version]: 1.2.0.1586 (WindowsPlayer x64) (x64) ============================== (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) [InputDevices]: Device #1 has no name. (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) [Input Devices]: 0: Saitek ST90 USB Stick (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) [InputDevices]: Device #1 has no name. (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) [Input Devices]: 0: Saitek ST90 USB Stick (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) Launcher Settings File doesn't exist (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) Launcher after checking file: True (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) ******* Log Initiated for Kerbal Space Program - 1.2.0.1586 (WindowsPlayer x64) ******* (Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42) ActionCanvas MASK: 3458764513820540928
  6. This is working for me, after getting ModuleManager (wasn't clear I needed it). But all the labels are screwed up and are in hex. Is this a known issue?
  7. Sure, KSP 1.2.0.1586 https://www.dropbox.com/sh/1jx0aatrbfda0e3/AAC4myLbD3-ZMT1PHnzxgv5Ta?dl=0 For files. Note that this does detect my other joystick which you will see in the settings.cfg, and in the screenshot, you'll see that it detects both, but can only keep/set settings for the saitek. I also delete the settings.cfg at each retry. Lastly, in case you think the Saitek is a problem, I've also tried doing all of this with that joystick unplugged.
  8. Yes, I always have my joystick(s) plugged in. Do you want me to post that information in or in http://forum.kerbalspaceprogram.com/index.php?/topic/83213-stock-support-bug-reporting-guide/
  9. Hi sal, I have tried that to do that. In fact, if I do that, and move the joystick, it will display something in relation to the axis moved (either 0.1 or 1.1 or 1.x 0.x) but the bind won't save, even in the menu.
  10. Tried as I might, my joystick is unable to be recognized in KSP. The buttons can be bound, but not the axis. When attempting to bind, It'll say it's there, but dissappear as soon as I click accept, and it will not work in the game. I've deleted the settings.cfg file multiple times, installed the latest logitech drivers and application, even assigned a profile for KSP. If you run the game and look in the settings.cfg it isn't listed as an input device. This joystick works perfectly find in my other games. I've tested with x64 and x86 binaries. I've run up and down these forums and it looks like there's been some issue with Logitech Extreme and Force 3D joysticks. Have these ever been solved?