scottadges

Members
  • Content Count

    620
  • Joined

  • Last visited

Status Replies posted by scottadges

  1. Hi Allista, I wasn't sure where to post this, since I don't see a KSP forum thread for your AutoLoadGame mod.

    When I quit out of KSP from the main menu, I pretty consistently see the following error in my logs:

    [LOG 03:52:39.833] [AutoLoadGame]: MAINMENU is loaded. Waiting 60 frames and loading the save.
    [ERR 03:52:39.833] Exception handling event onLevelWasLoadedGUIReady in class AutoLoadGame:System.NullReferenceException: 
      at (wrapper managed-to-native) UnityEngine.MonoBehaviour:StartCoroutine_Auto_Internal (System.Collections.IEnumerator)
      at UnityEngine.MonoBehaviour.StartCoroutine (IEnumerator routine) [0x00000] in <filename unknown>:0 
      at AutoLoadGame.AutoLoadGame.onLevelWasLoaded (GameScenes scene) [0x00000] in <filename unknown>:0 
      at EventData`1[GameScenes].Fire (GameScenes data) [0x00000] in <filename unknown>:0 
    
    [EXC 03:52:39.835] NullReferenceException
    	UnityEngine.MonoBehaviour.StartCoroutine (IEnumerator routine)
    	AutoLoadGame.AutoLoadGame.onLevelWasLoaded (GameScenes scene)
    	EventData`1[GameScenes].Fire (GameScenes data)
    	UnityEngine.Debug:LogException(Exception)
    	EventData`1:Fire(GameScenes)
    	<FireLoadedEventGUIReady>c__Iterator2:MoveNext()
    	UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

    I'm wondering, is this anything to be concerned with? or is there perhaps something I haven't configured properly?

    I see GitHub is where you've got issue requests, but I'm not a developer-type KSP player and didn't really want to create a username over there just to post my question. Hopefully you don't mind the public message here.

  2. Hi Allista, I wasn't sure where to post this, since I don't see a KSP forum thread for your AutoLoadGame mod.

    When I quit out of KSP from the main menu, I pretty consistently see the following error in my logs:

    [LOG 03:52:39.833] [AutoLoadGame]: MAINMENU is loaded. Waiting 60 frames and loading the save.
    [ERR 03:52:39.833] Exception handling event onLevelWasLoadedGUIReady in class AutoLoadGame:System.NullReferenceException: 
      at (wrapper managed-to-native) UnityEngine.MonoBehaviour:StartCoroutine_Auto_Internal (System.Collections.IEnumerator)
      at UnityEngine.MonoBehaviour.StartCoroutine (IEnumerator routine) [0x00000] in <filename unknown>:0 
      at AutoLoadGame.AutoLoadGame.onLevelWasLoaded (GameScenes scene) [0x00000] in <filename unknown>:0 
      at EventData`1[GameScenes].Fire (GameScenes data) [0x00000] in <filename unknown>:0 
    
    [EXC 03:52:39.835] NullReferenceException
    	UnityEngine.MonoBehaviour.StartCoroutine (IEnumerator routine)
    	AutoLoadGame.AutoLoadGame.onLevelWasLoaded (GameScenes scene)
    	EventData`1[GameScenes].Fire (GameScenes data)
    	UnityEngine.Debug:LogException(Exception)
    	EventData`1:Fire(GameScenes)
    	<FireLoadedEventGUIReady>c__Iterator2:MoveNext()
    	UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

    I'm wondering, is this anything to be concerned with? or is there perhaps something I haven't configured properly?

    I see GitHub is where you've got issue requests, but I'm not a developer-type KSP player and didn't really want to create a username over there just to post my question. Hopefully you don't mind the public message here.