R4V3N

Members
  • Content Count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

About R4V3N

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Some of my mods are not available or working for 1.2 and i wanted to change my version to 1.1.2 but i do not know how to do this. I am currently using KSP bought off the website not steam