Cooly568

Members
  • Content Count

    1,022
  • Joined

  • Last visited

Everything posted by Cooly568

  1. So I ended up solving it on my own, but I feel like the knowledge could be useful to others. I was running my RAM at 2667 MHz on my Ryzen system. Even with the most recent firmware, this was unstable. But was ONLY unstable in KSP for some reason. All other programs ran just fine. So if anyone is getting odd crashes like this on Ryzen, back down your RAM speed. KSP is a RAM heavy game with a ton of mods after all, so errors in the memory would become more critical. So I ended up solving it on my own, but I feel like the knowledge could be useful to others. I was running my RAM at 2667 MHz on my Ryzen system. Even with the most recent firmware, this was unstable. But was ONLY unstable in KSP for some reason. All other programs ran just fine. So if anyone is getting odd crashes like this on Ryzen, back down your RAM speed. KSP is a RAM heavy game with a ton of mods after all, so errors in the memory would become more critical. Aaaaand I take that back. Still happening. I still think it's a Ryzen issue.
  2. Would make sense, you'd basically be pushing even a system with a healthy amount of RAM to the limit.
  3. Was really bizarre, because removing Making History fixed it for me, give it a shot.
  4. Absolutely. I, I just thought it might be GPO because of the RAM it consumes on it's own but even then, it worked before so... I've no idea. [LOG 06:02:21.976] ******* Log Initiated for Kerbal Space Program - 1.4.3.2152 (WindowsPlayer x64) en-us ******* Kerbal Space Program - 1.4.3.2152 (WindowsPlayer x64) en-us Edit: I still observed this after removing everything except GPO. I'll just nuke Windows and see if that helps. Edit 2: Looks like nuking windows... helped. I think. Edit 3: Ech, might've happened again.
  5. Hey, Gameslinx, sorry for bugging you so much since I've been, doing that a lot as of lately since I've been focusing on your mod, but I've been having weird, issues develop while continuing my career save in your system. I don't know how connected the weird issues I'm having are to your mod, but you were capable of giving some pretty useful insight last time, so, yeah.
  6. Right, here we go. KSP has been getting more and more funky as I've played more and more of my career save. The garbage collection lag spikes aren't so so bad, but after getting out of the remade GPO Kerbin system, and having around 25 ships in flight at once, the game just, started dying. System details: KSP 1.4.3 64-bit CPU: Ryzen 7 1700 GPU: GTX 1070 RAM: 16GB I wish I could detail more exactly as to what's going on, but the game just, dies randomly. Modlist, as covered by the gamedata folder. Folders and files in GameData: 001_ToolbarControl ASET Astrogator AtmosphereAutopilot B9PartSwitch BonVoyage Chatterer ClickThroughBlocker CommNetVisualisation CommunityCategoryKit CommunityResourcePack CommunityTechTree ContractConfigurator ContractPacks CrewRandR CriticalTemperatureGauge CryoTanks CTTP CustomBarnKit DeployableEngines DistantObject DMagicOrbitalScience DMagicUtilities DynamicBatteryStorage EditorExtensionsRedux EnvironmentalVisualEnhancements Firespitter FP_DPSoundFX FShangarExtender GPO GroundConstruction HeatControl HGR HideEmptyTechTreeNodes Impact INSTANTIATOR KAS KerbalAtomics KerbalJointReinforcement KerboKatz KIS Kopernicus MagiCore MechJeb2 MemGraph ModularFlightIntegrator MouseAimFlight MSP3000 NearFutureElectrical NearFutureLaunchVehicles NearFutureProps NearFuturePropulsion NearFutureSolar NearFutureSpacecraft PlanetaryBaseInc QuickMods RealPlume RealPlume-Stock RetractableLiftingSurface SCANsat scatterer Science-Full-reward Sigma SlingShotter SmartStage SmokeScreen spacetux Stock folder: Squad StageRecovery StationPartsExpansionRedux StationScience Strategia SXT ThroughTheEyes TimeControl TriggerTech VanguardTechnologies WaypointManager WernherChecker WetterWingsMM WildBlueIndustries [x] Science! KSPModFileLocalizer.dll ModuleManager.3.0.7.dll ModuleManager.ConfigCache ModuleManager.ConfigSHA ModuleManager.Physics ModuleManager.TechTree I'm not running Making History as it caused issues with GPO. Right, so after around a mission or two, the game simply, truncates. It will lock up, and sometimes regain posture and snap out of it's "program not responding" state, but more often than not, the game will automatically crash without even leaving a crash folder within the game install directory. Viewing the logs... don't help either. [LOG 01:30:23.727] Remaining in Ascent [LOG 01:30:23.750] Remaining in Ascent [LOG 01:30:23.774] Remaining in Ascent [LOG 01:30:23.793] Remaining in Ascent [LOG 01:30:23.819] Remaining in Ascent [LOG 01:30:23.840] Remaining in Ascent [LOG 01:30:23.858] Remaining in Ascent [LOG 01:30:23.881] Remaining in Ascent [LOG 01:30:23.900] Remaining in Ascent [LOG 01:30:23.920] Remaining in Ascent [LOG 01:30:23.938] Remaining in Ascent [LOG 01:30:23.956] Remaining in Ascent [LOG 01:30:23.974] Remaining in Ascent [LOG 01:30:23.993] Remaining in Ascent [LOG 01:30:24.012] Remaining in Ascent [LOG 01:30:24.031] Remaining in Ascent Remaining in ascent is a Mechjeb message generated every frame while ascent autopilot is active. This was, the last recorded thing in the log. Before the log simply, stops. I've never seen KSP go above 8GB of RAM usage, and Windows never goes above 70%. MemGraph reveals nothing weird. Even more bizarre, I run this install off of a hard drive. When I ran it off an SSD, the game started sometimes having the music stutter as if my computer was blue-screening, but the game kept on playing just fine. This was not observed with the hard drive. Meaning I'm only more confused to this all. Is it a save thing? Is it a mod thing? Is it a Windows 10 thing? Edit: Did a lot of looking into it. I think it may be a RAM issue? But there's still 5GB of system RAM open before the game crashes. The game never gets past 10GB ever. I've also found this happening where if I got to the Tracking Station on a new save, the game still gives out. I removed quite a few non-critical mods in order to eliminate possible issues, but that, didn't do anything. What puzzles me is this ran perfectly fine days ago. No mods have been changed when the game worked properly. Edit 2: Attempted to uninstall MSI Afterburner as has been referenced in the past. Lockups and crashes were still observed, even with RAM sucking mods besides GPO uninstalled. The same locking up behavior also manifested still in new saves. The mods have not been changed in a week on this install, and these issues only started as of last night. Even on new saves, with no mods changed in or out, when this install worked perfectly before. Windows issue due to the lack of crash log output? If so, what to do?
  7. Probably. Maybe it has to do with something on Kopernicus's side, who knows. Had an interesting experience trying to get Making History to load without the node editor, and just be the parts, that, doesn't work.
  8. Well, huh, that did it. It's weird that Making History causes that issue. Since I have parts in my save using Making History, I'll try to delete everything about Making History except the parts, and see if that does anything. But, guess it is Making History though.
  9. Odd, I'm flying 1.4.3 right now. Alright, here's the dropbox link. I'll attach a picture after this with my Gamedata folder. The KSP_x64 exe was run as administrator, and I loaded into my sandbox, accidentally blew up the decoupler, launched again, and then popped the decoupler. I then pressed, in the pause menu, return to space center, and return to tracking station. Then I un-paused and pressed Recover Vessel, and Space Center. I then Alt-F4-ed out of the game. Max Persistent Debris was 0 in this test, although I previously used 250 with identical results. The, the decoupler obviously doesn't result in this issue if it's destroyed.
  10. Follow up to the last post since the forums won't let me edit, yeah, I can't get GPO to load with the old linked versions of mods in the Github readme, updating Kopernicus allowed it to run, but with the same bug described above.
  11. Right, so I found a bit of a bug. @AmpCat reported it a while back, but it's not a stock bug, I don't think. I was able to create it in a reliable manner, and I feel like, I'm obviously not an expert here, but I feel like it has to do with the game trying to save debris to a planetary body it doesn't understand. Here's a capsule, that has detached a decoupler. In the top right it's kicked out an error for being unable to save properly. And when I go to try to change to the space center, I'm met with the same error. The error found in verbose logging is as follows. ArgumentOutOfRangeException: Argument is out of range. Parameter name: index at System.Collections.Generic.List`1[LaunchSite].get_Item (Int32 index) [0x00000] in <filename unknown>:0 at Vessel.get_LandedInStockLaunchSite () [0x00000] in <filename unknown>:0 at FlightState..ctor () [0x00000] in <filename unknown>:0 at Game.Updated (GameScenes startSceneOverride) [0x00000] in <filename unknown>:0 at Game.Updated () [0x00000] in <filename unknown>:0 at PauseMenu.<draw>m__7 () [0x00000] in <filename unknown>:0 at DialogGUIButton.OptionSelected () [0x00000] in <filename unknown>:0 at DialogGUIButton.<Create>m__6 () [0x00000] in <filename unknown>:0 at UnityEngine.Events.InvokableCall.Invoke () [0x00000] in <filename unknown>:0 at UnityEngine.Events.UnityEvent.Invoke () [0x00000] in <filename unknown>:0 at UnityEngine.UI.Button.Press () [0x00000] in <filename unknown>:0 at UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData) [0x00000] in <filename unknown>:0 at UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData) [0x00000] in <filename unknown>:0 at UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor) [0x00000] in <filename unknown>:0 UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object) UnityEngine.DebugLogHandler:LogException(Exception, Object) UnityEngine.Logger:LogException(Exception, Object) UnityEngine.Debug:LogException(Exception) UnityEngine.EventSystems.ExecuteEvents:Execute(GameObject, BaseEventData, EventFunction`1) UnityEngine.EventSystems.StandaloneInputModule:ProcessMousePress(MouseButtonEventData) UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent(Int32) UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent() UnityEngine.EventSystems.StandaloneInputModule:Process() UnityEngine.EventSystems.EventSystem:Update() (Filename: Line: -1) The only mods active were CTTP, Environmental Visual Enhancements, INSTANTIATOR, Kopernicus, ModularFlightIntegrator, SigmaSkyboxReplacements, and obviously, GPO. I updated every mod to the latest version I could possibly find. When I removed only GPO, the decoupler was no issue after it was detached, and allowed me to recovery, or return to space center. I have not tried using the exact version of the mods linked in the github post for version 3.3.1, but I will look into trying that and see if anything changes.
  12. I've been playing some of this mod, seeing something like Alternis Kerbol pulled me back into KSP for the first time since 1.0, over two years. It's been a blast playing a heavily modded career mode in the system, and I've not gone to another planet with a probe yet, just Kerbin's moons. I kind of want to write a silly after action report for the playthrough, but for now, I'm basking in the sights.
  13. Okay that's good to hear. What about the other way around, and more specifically custom missions?
  14. Some of the stuff, some of the parts, and the chutes do seem a little, off to be in a DLC. But the "professionally created" missions and the mission editor GUI and the stuff you can't really get from mods sounds a lot more rationalized being in a DLC.
  15. I really want to bring myself to like the idea here, and I love the idea of the node based mission editor, but... everything beyond that sounds, somewhat pointless if your a modder and are willing to deal with mod clunkiness. I know we've had updates in the past, like 1.2, Kerbnet was just a replacement for the RemoteTech mod, but Squad had a cleaner implementation of the mod which functions very well. So I have no issue with them replacing Contract Configurator, because it's clunky for in-experienced creators, but putting it behind a pay-wall is what gets me. Yes, KSP has given me more value than any other game ever, at I think 2500 hours, that means I paid half of a penny for every hour I've spent in this game. 1.2 does feel like a definitive "finished version" of the game, but, I would of liked to see this in an update, and not an expansion, I see it separating the community in a way due to custom contracts being behind a paywall. Would that mean a player with the DLC would be able to make and play contracts, but the DLC-less player wouldn't be able to make or play? Or would they be able to just play? The way they explain the effects of the expansion is abstract. Would it give more to modders at the cost of splitting the community between DLC and DLC-less players? But, the corporate machine runs on funds, and KSP probably isn't getting any more, it's a game past it's release by, a good year or two now, and I'd take a guess that income is drooping. It's either make an update that might get more people to buy the game, or make the fabled expansion packs. And I respect that decision, because it was either this, or hope the modding community can keep the game afloat with no income for the company. So as much as I can sit and whine about this expansion pack not being a free update, I think for the 15 dollars I paid for this game, I got 15 free updates. That's 1 dollar per update. So paying, say, 5 dollars for an expansion pack after all this time is totally fine. On the critical hand though, I can't stop thinking about these new parts, they'll be Squad made, yes, but we have a good few, massive part packs that probably add the same parts, give or take art style. That's, good and all, and I like more stock parts, but, I can't get over that thought. As a longtime KSP player, I'll be purchasing it even if I don't get it for free. When did I buy this game anyways? March of 2012? Holy crap, it's been that long? Five years as of the last couple weeks? Good lord. Also I paid 10$, woops. Didn't even notice. Yeah, Squad, I'll put aside my meager complaints, I was down with The Cyrpt of the Necrodancer's 7$ DLC, don't price this anything above what it's worth like Ubisoft did with Watch_Dog 2's Human Conditions, and we'll be fine. Thanks for keeping the game alive my dudes. My only issue with the DLC would be if players and mods were split between two versions, but with how this game is built, that probably won't happen.
  16. Getting somewhat the same thing too. Boot game up with bunch of mods, game lags and memory leaks up to 12GB. Did a bit of digging, for me at least, it was Sigma Binary.
  17. Hiya, so I run my game with a few mods. To say the least. But I'm on an issue right now I can't seem to track down, the game every, fifteen seconds or so, will just, pause for about half a second. I'm running 1.1.3, and my system definitely isn't being hit anywhere else can causing KSP to lag. The spike doesn't look too bad on this debug menu, but it does go down to zero for a bit. Anyways, I was able to look in the Debug console, and find this absolute spam of plugin errors. I'm running Distant Object, but I don't know what file or mod this is that is requesting Distant Object and causing this spam log. Don't know if the log is causing the random slowdowns, but it certainly is there. So, what does anyone thing is causing the lag spikes? I, have no experience in debugging this stuff, sorry. Edit, I've read a bit about it, it looks like Mono.dll, and there's already a discussion on it, so, whatever.
  18. Breaking News update from, somewhere. I had been talking with someone else on the forum (JPLRepo), and I was able to track down a download of the mod in the old Kerbalstuff torrent. I was testing it with 1.0.5, and it does in fact work. Mostly. Plane parts are borked.
  19. This does in fact work, thank you sir.
  20. He was last active on February 24th. Not too interested in having it updated at the moment, just getting at the current version that had a Kerbalspaceport download, and now does not.
  21. Heya. So I had been getting into making cinematics, videos and the like in KSP, and when it came down to it, I realized I was missing one key mod, Persistent Trails. A mod that's almost required for cinematic creators. So I went to the old forum thread, it's Spaceport link was dead, and I haven't yet been able to track someone down with a 1.0.2 version. And because of that, I wanted to try recompiling the github repository into a working .dll, turns out, I have no idea how to do that in the slightest. So, yeah. https://github.com/GrJo/KSPPersistentTrails I'm a coding moron.
  22. Completely forgot to reply to you, anyways, yeah it would be, and I had another thought. The github for this mod is up, does anyone know how to recompile a mod? If not, I'll look into it.
  23. I mean, does anyone here have another link? (Or, at least the files?) Hey this is my 1000th post. Edit: I tried the 0.90 version in 1.0.5. It did not work.
  24. I feel like this really does need, at least another link to download from. This is a godsend for cinematic creators.