Jump to content

GoAHead

Members
  • Content Count

    15
  • Joined

  • Last visited

Posts posted by GoAHead

  1. 1 hour ago, Tokamak said:

    This mod is massively helpful. Thank you! 

    However, one thing does make it a lot harder to use. A lot of UI elements show whether they are disabled or enabled by displaying either a pale yellow, or a pale yellowish green, which are almost impossible for me to tell apart. I _am_ partly red/green colourblind, so this may not be the case for everyone, but I suppose it's something to be aware of.

    you can change the color as you wish. rightclick the TCA modul Icon

  2. hi there

    i'm experiencing some issues when switching from VAB to flight Mode. I'm setting up TCA with engine Profiles  in VAB but until i'm going to flightmode TCA doesn't load up (stays blue) and the following exceptions are throwing

    [EXC 09:53:53.362] NullReferenceException: Object reference not set to an instance of an object
    	ThrottleControlledAvionics.OnPlanetProps.AddGear (PartModule pm) (at <cc197bb611564a70862493f5aba261ee>:0)
    	ThrottleControlledAvionics.VesselWrapper.UpdateParts () (at <cc197bb611564a70862493f5aba261ee>:0)
    	ThrottleControlledAvionics.VesselWrapper..ctor (ThrottleControlledAvionics.ModuleTCA tca) (at <cc197bb611564a70862493f5aba261ee>:0)
    	ThrottleControlledAvionics.ModuleTCA.init () (at <cc197bb611564a70862493f5aba261ee>:0)
    	ThrottleControlledAvionics.ModuleTCA+<delayed_init>d__62.MoveNext () (at <cc197bb611564a70862493f5aba261ee>:0)
    	UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <5aeafee3fea24f37abd1315553f2cfa6>:0)
    	UnityEngine.DebugLogHandler:LogException(Exception, Object)
    	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
    [LOG 09:53:53.364] FF: situation change for flag
    [LOG 09:53:53.364] FF: situation change for flag
    [LOG 09:53:53.365] FF: situation change for flag
    [LOG 09:53:53.365] FF: situation change for flag
    [LOG 09:53:53.365] FF: situation change for flag
    [LOG 09:53:53.366] FF: situation change for flag
    [LOG 09:53:53.506] [RemoteTech] ModuleRTDataTransmitter::OnLoad
    [LOG 09:53:53.506] [RemoteTech] ModuleRTAntennaPassive: Find TRANSMITTER success.
    [LOG 09:53:53.506] [RemoteTech] ModuleRTAntennaPassive: Add TRANSMITTER success.
    [LOG 09:53:53.507] [RemoteTech] ModuleRTDataTransmitter::OnLoad
    [LOG 09:53:53.507] [RemoteTech] ModuleRTAntennaPassive: Find TRANSMITTER success.
    [LOG 09:53:53.507] [RemoteTech] ModuleRTAntennaPassive: Add TRANSMITTER success.
    [LOG 09:53:53.507] [RemoteTech] ModuleRTDataTransmitter::OnLoad
    [LOG 09:53:53.508] [RemoteTech] ModuleRTAntenna: Find TRANSMITTER success.
    [LOG 09:53:53.508] [RemoteTech] ModuleRTAntenna: Add TRANSMITTER success.
    [ERR 09:53:53.587] Exception handling event onVesselWasModified in class ModuleTCA:System.NullReferenceException: Object reference not set to an instance of an object
      at ThrottleControlledAvionics.OnPlanetProps.AddGear (PartModule pm) [0x0004a] in <cc197bb611564a70862493f5aba261ee>:0 
      at ThrottleControlledAvionics.VesselWrapper.UpdateParts () [0x0011e] in <cc197bb611564a70862493f5aba261ee>:0 
      at ThrottleControlledAvionics.VesselWrapper..ctor (ThrottleControlledAvionics.ModuleTCA tca) [0x00093] in <cc197bb611564a70862493f5aba261ee>:0 
      at ThrottleControlledAvionics.ModuleTCA.init () [0x0000f] in <cc197bb611564a70862493f5aba261ee>:0 
      at ThrottleControlledAvionics.ModuleTCA.onVesselModify (Vessel vsl) [0x000c3] in <cc197bb611564a70862493f5aba261ee>:0 
      at EventData`1[T].Fire (T data) [0x000b0] in <55ba45dc3a43403382024deac8dcd0be>:0 
    
    [EXC 09:53:53.588] NullReferenceException: Object reference not set to an instance of an object
    	ThrottleControlledAvionics.OnPlanetProps.AddGear (PartModule pm) (at <cc197bb611564a70862493f5aba261ee>:0)
    	ThrottleControlledAvionics.VesselWrapper.UpdateParts () (at <cc197bb611564a70862493f5aba261ee>:0)
    	ThrottleControlledAvionics.VesselWrapper..ctor (ThrottleControlledAvionics.ModuleTCA tca) (at <cc197bb611564a70862493f5aba261ee>:0)
    	ThrottleControlledAvionics.ModuleTCA.init () (at <cc197bb611564a70862493f5aba261ee>:0)
    	ThrottleControlledAvionics.ModuleTCA.onVesselModify (Vessel vsl) (at <cc197bb611564a70862493f5aba261ee>:0)
    	EventData`1[T].Fire (T data) (at <55ba45dc3a43403382024deac8dcd0be>:0)
    	UnityEngine.DebugLogHandler:LogException(Exception, Object)
    	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    	UnityEngine.Debug:LogException(Exception)
    	EventData`1:Fire(Vessel)
    	RemoteTech.Modules.ModuleRTAntenna:AddTransmitter()
    	RemoteTech.Modules.ModuleRTAntenna:SetState(Boolean)
    	RemoteTech.Modules.ModuleRTAntenna:OnConnectionRefresh()
    	RemoteTech.VesselSatellite:OnConnectionRefresh(List`1)
    	RemoteTech.NetworkManager:FindPath(ISatellite, IEnumerable`1)
    	RemoteTech.NetworkManager:OnPhysicsUpdate()
    	RemoteTech.RTCore:FixedUpdate()
    [LOG 09:53:53.592] [RemoteTech] ModuleRTDataTransmitter::OnLoad
    [LOG 09:53:53.593] [RemoteTech] ModuleRTAntenna: Find TRANSMITTER success.
    [LOG 09:53:53.593] [RemoteTech] ModuleRTAntenna: Add TRANSMITTER success.
    [ERR 09:53:53.624] Exception handling event onVesselWasModified in class ModuleTCA:System.NullReferenceException: Object reference not set to an instance of an object
      at ThrottleControlledAvionics.OnPlanetProps.AddGear (PartModule pm) [0x0004a] in <cc197bb611564a70862493f5aba261ee>:0 
      at ThrottleControlledAvionics.VesselWrapper.UpdateParts () [0x0011e] in <cc197bb611564a70862493f5aba261ee>:0 
      at ThrottleControlledAvionics.VesselWrapper..ctor (ThrottleControlledAvionics.ModuleTCA tca) [0x00093] in <cc197bb611564a70862493f5aba261ee>:0 
      at ThrottleControlledAvionics.ModuleTCA.init () [0x0000f] in <cc197bb611564a70862493f5aba261ee>:0 
      at ThrottleControlledAvionics.ModuleTCA.onVesselModify (Vessel vsl) [0x000c3] in <cc197bb611564a70862493f5aba261ee>:0 
      at EventData`1[T].Fire (T data) [0x000b0] in <55ba45dc3a43403382024deac8dcd0be>:0 

    any idea what  this means? building up a complete new Vessel works. but something goes wrong with  my big  Ship.
    thx in advance

     

    OK it was the     #LOC_M2X_LandingLeg_title = SPL Heavy-Duty landing System from the MK2 Extension.:confused:

  3. there might be an issue with the controls UI when going to flight mode a second time.  only the modules and main UI is showing up but the controls UI not. there is also an error in the console which states something with an error on redrawing. anyone   with the same issue?

     

    Log:

    [EXC 23:42:21.769] ArgumentException: Getting control 0's position in a group with only 0 controls when doing repaint
    Aborting
        UnityEngine.GUILayoutGroup.GetNext () (at <fa6f9762ac624af092525d37c9d516c4>:0)
        UnityEngine.GUILayoutUtility.BeginLayoutGroup (UnityEngine.GUIStyle style, UnityEngine.GUILayoutOption[] options, System.Type layoutType) (at <fa6f9762ac624af092525d37c9d516c4>:0)
        UnityEngine.GUILayout.BeginVertical (UnityEngine.GUIContent content, UnityEngine.GUIStyle style, UnityEngine.GUILayoutOption[] options) (at <fa6f9762ac624af092525d37c9d516c4>:0)
        UnityEngine.GUILayout.BeginVertical (UnityEngine.GUILayoutOption[] options) (at <fa6f9762ac624af092525d37c9d516c4>:0)
        ThrottleControlledAvionics.TCAGui.DrawMainWindow (System.Int32 windowID) (at <e689ed1085464a36ab2516ad57c1a974>:0)
        UnityEngine.GUILayout+LayoutedWindow.DoWindow (System.Int32 windowID) (at <fa6f9762ac624af092525d37c9d516c4>:0)
        UnityEngine.GUI.CallWindowDelegate (UnityEngine.GUI+WindowFunction func, System.Int32 id, System.Int32 instanceID, UnityEngine.GUISkin _skin, System.Int32 forceRect, System.Single width, System.Single height, UnityEngine.GUIStyle style) (at <fa6f9762ac624af092525d37c9d516c4>:0)
        UnityEngine.DebugLogHandler:LogException(Exception, Object)
        ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
        UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

     

    Also found a second exception. i do not know if related

    [EXC 00:14:41.952] NullReferenceException: Object reference not set to an instance of an object
        AT_Utils.UIBundle+<LoadAsset>d__10.MoveNext () (at <488b8abd490d4610a99c7b87ac625952>:0)
        AT_Utils.UIWindowBase`1+<Show>d__16[T].MoveNext () (at <488b8abd490d4610a99c7b87ac625952>:0)
        UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <5aeafee3fea24f37abd1315553f2cfa6>:0)
        UnityEngine.DebugLogHandler:LogException(Exception, Object)
        ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
        UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
     

  4. hi there. has anyone of you the same problem with  manually extending the legs of the adjustable base gradle? within the VAB it seems to work  but until when going outside and try to extend the legs individually  the legs only extend to its minimum auto level value (10). 
    i'm not able to adjust the minimum autolevel neither adjust the extension manually.
    the only thing which works is deploy retract and autolevel. any advise? thx

  5. 2 hours ago, Shadowmage said:

    Updated dev version is available:

    • Fixes shader references to use the 'LegacyShaders/XXX' shader names.  Will update to use the equivalent newer shaders as time permits.
    • Tested to work under KSP 1.8.1; loads properly without any new/unexpected errors, and dust-effects work while in-flight.

    Updated DLL is available from the dev branch, direct download link:  https://github.com/shadowmage45/KSPWheel/blob/dev/GameData/KSPWheel/Plugin/KSPWheel.dll?raw=true

    I'll be doing some further testing this evening/this week, and package and publish an actual release if it all appears to be working.

    cool. yes it is loading now without stuck together with mechjeb. thx

  6. ok thx.. that worked for me.

    for the people which are not so familiar with  editing cfg files here is the complete change

     

    <?xml version="1.0" encoding="utf-8"?>
    <config>
        <bool name="reinforceAttachNodes">1</bool>
        <bool name="multiPartAttachNodeReinforcement">1</bool>
        <bool name="reinforceDecouplersFurther">1</bool>
        <bool name="reinforceLaunchClampsFurther">1</bool>
        <bool name="clampJointHasInfiniteStrength">1</bool>
        <bool name="useVolumeNotArea">1</bool>
        <bool name="debug">0</bool>

        <float name="angularDriveSpring">5e12</float>
        <float name="angularDriveDamper">25</float>
        <float name="angularMaxForceFactor">-1</float>

        <float name="decouplerAndClampJointStrength">-1</float>

        <float name="breakForceMultiplier">1</float>
        <float name="breakTorqueMultiplier">1</float>
        <float name="breakStrengthPerArea">1500</float>
        <float name="breakTorquePerMOI">6000</float>

        <float name="massForAdjustment">0.01</float>
        <float name="upperMassForLockedJoint">0</float>

        <string name="exemptPartType0">MuMechToggle</string>
        <string name="exemptPartType1">MuMechServo</string>

        <string name="exemptModuleType0">WingManipulator</string>
        <string name="exemptModuleType1">SingleGroupMan</string>
        <string name="exemptModuleType2">KerbalEVA</string>
        <string name="exemptModuleType3">MuMechToggle</string>
        <string name="exemptModuleType4">ModuleKerbetrotterHitch</string>
        <string name="exemptModuleType5">ModuleRoboticServoHinge</string>
        <string name="exemptModuleType6">ModuleRoboticServoPiston</string>
        <string name="exemptModuleType7">ModuleRoboticServoRotor</string>
        <string name="exemptModuleType8">ModuleRoboticRotationServo</string>
        
        


        <string name="decouplerStiffeningExtensionType0">ModuleEngines</string>
        <string name="decouplerStiffeningExtensionType1">ModuleEnginesFX</string>
        <string name="decouplerStiffeningExtensionType2">ModuleHybridEngine</string>
        <string name="decouplerStiffeningExtensionType3">ModuleHybridEngines</string>
        <string name="decouplerStiffeningExtensionType4">ModuleEngineConfigs</string>
        <string name="adecouplerStiffeningExtensionType5">ModuleDecouple</string>
        <string name="adecouplerStiffeningExtensionType6">ModuleAnchoredDecoupler</string>
        <string name="adecouplerStiffeningExtensionType7">ProceduralFairingBase</string>

        <float name="stiffeningExtensionMassRatioThreshold">5</float>

    </config>

  7. there seems to be a bug in conjunction with Universal Storage. Every Experiemnt which is attached as a part of this mod runs only once without storing the data to the configured destination. other experiement which are attached as stock experiment working just fine. i have no glue if this relates to Universal Storage or Automated Science Sample. Anybody out there with the same problem?

×
×
  • Create New...