Ahres

Members
  • Content Count

    51
  • Joined

  • Last visited

Everything posted by Ahres

  1. Weird I missed it too! A Munar launchsite?! Also, I said it for 1.6 and I’ll say it again for 1.7: I think all of these previewed part revamps are excellent. The shiny metallic look of some makes perfect sense to me because their old counterparts were metallic too. Complainers will comment and celebrators won’t, so here’s a celebrator breaking the mold. Keep it up @SQUAD!
  2. I've been trying to research as much as possible before coming onto the forum to ask for help, but now that time has finally come. CC was something I've been wanting to learn so I've been recreating @pap1723's Career Evolution pack piece by piece with my own code and then comparing to pick up on things I might have missed or could have coded better. He (or she) has got a rendezvous contract that I remember worked back in the day. The contract is to simply rendezvous two vessels in orbit. Looking at the original code: PARAMETER { name = Rendezvous type = Rendezvous distance = 100 title = Rendezvous two craft in Orbit hideChildren = true disableOnStateChange = true } You can see there's no "vessel" attribute. So I tried to do the same thing but got an error saying that the "vessel" attribute is required. So did something change there? Because of that error though, I created a contract that asks for launching a target vessel (basically the Agena from the Gemini Program) and gave it a VPG so that I have something to target in follow-up rendezvous contract. I wanted to make it fool proof though and make sure that the Agena was still in orbit so that the rendezvous contract could be fulfilled. I used the VesselValid requirement to see if that'd do the trick but it didn't. The error log says that "VesselValid" is an unknown requirement. Here's the VPG of the target vessel: PARAMETER { name = FirstRendAndDockTargetVesselParameterGroup type = VesselParameterGroup title = Target Vessel define = TargetRendezvousAndDockingVessel dissassociateVesselsOnContractCompletion = false PARAMETER { name = FirstRendAndDockNewTargetVessel type = NewVessel title = Launch New Vessel hideChildren = true } PARAMETER { name = Uncrewed type = HasCrew title = Uncrewed minCrew = 0 maxCrew = 0 hideChildren = true } PARAMETER { name = DockingPortValidation type = PartValidation title = Have A Docking Port partModuleType = Dock hideChildren = true } PARAMETER { name = ReachOrbitState type = ReachState title = Reach Orbit situation = ORBITING disableOnStateChange = false hideChildren = true } } And here's the requirement for the rendezvous contract: REQUIREMENT { name = FirstRendTargetVesselValid type = VesselValid title = Target Vessel Is Still In Orbit vessel = TargetRendezvousAndDockingVessel hideChildren = true } I know I could just ditch the requirement, but I'd really like to keep it in there. The wiki says the vessel attribute in the rendezvous parameter is required, but it appears it didn't used to be. It'd sure make my coding easier if it wasn't required. But if it must be that way, any pointers would be really appreciated.
  3. I know this will get lost in here on the fourth page of this thread but I’ll post it anyway because it needs to be said. I think all the revamps are great, I’m very excited for every single one of them including the Poodle, the Terrier, and the nose cones. And I get the feeling that most of the KSP community feels the same way I do. But @SQUAD is only seeing the negative comments because it’s a law of nature for unhappy people to speak up and happy ones to not say anything. Just look at American policitics. So here I am, deep in the thread where I likely won’t get noticed, but hoping that our beloved developers are aware that many (probably most) of us are very excited for all the revamp that’s been done. Thanks Squad.
  4. That’s interesting to know for those that might come looking through this that have the same problem, but I’ve never touched CKAN. I do manual installs for everything. I could never find a difference between all the failed attempted installs and the one that finally was successful, but this time around on 1.5.1 they’re all failing. You’re the first one I’ve seen that’s mentioned having this problem too, so I’m glad it’s not just me. But if there’s been some new activity showing on github then I better just quiet down and wait for an official 1.5.1 version.
  5. That’s what I thought until I thought about how it’s happened for me for all previous versions I’ve used. Plus I read in earlier posts that it’s working in 1.5.1 anyway.
  6. I try as hard as I can to not bug modders with my troubles but I’ve tried long and hard enough that it’s time I post on here. I’ve used USI-LS since 1.3 and have added it to every version I’ve played since (1.3, 1.3.1, 1.4.1, 1.4.3, and now 1.5.1) and every time without fail the first attempt at its installation in each version would only partially show the mod in the game. By this I mean the parts show up, the MKS customization in the career settings menu shows up, but the USI-LS app doesn’t show up in the toolbar to configure the mod to my liking or to view the status of vessels with life support. Eventually I’d get the mod to install properly but with no apparent rhyme or reason. I’d just delete the folders from GameData and run the game and then reinstall and run the game again and it’d work. I’ve attempted this three times now on 1.5.1 to no avail. I even went so far as pulling my USI-LS folders from my 1.4.3 save where it’s working properly so that I know I’m adding the correct files to GameData, still no success. Searches reveal that this is not a common problem which surprises me since I’ve had it happen every time on every version of KSP that I’ve attempted the initial install. I like to think I know how to install mods since I’ve got a fair number of others and they work just fine. What on Kerbin am I doing wrong here? It’s driving me nuts. I’ll keep uninstalling and installing. But I know it shouldn’t have to be this way.
  7. Thanks Squad for the quick fix. I think I speak for the vast majority of the KSP community when I say that we're excited for the continued updates and support, and how far along you've brought this game. You'll always have a crowd that support you and are thankful for what you've done - made our dreams of flight just a little more real to us.
  8. Huh, that’s a good point. Not that it particularly bothers me, I’m just excited it got revamped at all. But based off of the first picture I’d expect the second one to show it reflecting the blue sky. But thinking about what it’d look like IRL, I’d say the second picture is more realistic. Otherwise it’s more like looking at a mirror than at a spherical piece of metal.
  9. That makes perfect sense. Good explanation. Thanks for all you do @Poodmund.
  10. I hate to be the one that keeps coming back with bugs but it's only because I think this mod is fantastic and I want it to be everything it's supposed to be. As others have mentioned, I'm also having trouble with getting the BaseMoonCore contract to be offered, even with Mission Control telling me I've fulfilled all the requirements.
  11. I'm sorry guys, I've been trying to do some studying before I ask but I'm still not understanding. Say I wanted to do a relay-lander combo mission. If I just had a dinky little Communotron 16 on the lander and left the relay in orbit around Duna using a DSN 3, how could I enter this in the spreadsheet to find what I'd need on the relay to ensure a connection? Or is that not how this sheet works?
  12. @Gidreess, if you read the page before this it says OPM works in 1.4.3.
  13. Figured it out. I finished the six months in space contract by bringing the kerbonauts back home, but doing this left the station empty. The one year in space contract didn't become available until another crew was returned to the station. So this fantastic mod is still working, it just doesn't specify anywhere that a crew needs to be on the station for the next contract to become acceptable.
  14. This is happening to me too, but with the Year In Space contract. This contract pack is fantastic, just wish it worked better. I'm not brave enough to mess with configs to get the contract accepted.
  15. Apologies for not following up sooner. It's the weekend before finals week here. I didn't ever get to look at the logs or check for the celestialbodies config because I just deleted kopernicus, OPM, DOE, and Planetshine, started and quit the game, then put DOE and planetshine back in and now it's working perfectly. So it was kopernicus or OPM that messed it up. But we'll learn more when I try it all again on my new copy of 1.4.3 later this week. Thanks for the help @Valerian! By the way, a couple other things: 1) Cool to see @Valerian helping out in the planetshine thread once again! 2) @Papa_Joe, the planned feature of having sunrise/sunset light is a very exciting one. If I knew anything about modding I'd be all over that. Just watching the live feed of the ISS and seeing the whole structure baked in red-orange light is pretty cool. Just throwing this out there in case you're trying to figure out which feature to get into next.
  16. I'm running 1.4.1 and had the old planetshine running on it perfectly. I updated to the new one just because. But then I got greedy and added kopernicus, OPM, chatterer, and distant object enhancement all at the same time. Now planetshine is screwed up. The bodies being orbited still emit light, but there's no color to it. Minmus and Kerbin were both reflecting white light. So I deleted kopernicus, OPM, and DOE because I'd rather have planetshine than any of those. But now the problem still persists. I started thinking about it, and I had this problem back in 1.3 as well. It's gotta be kopernicus screwing it up right? I'm too bummed to keep messing with it tonight. I'll test it on a fresh install tomorrow. A couple quick google searches makes it seem this isn't a common problem.
  17. Not sure how much changed under the hood, but Planetshine finally got updated after all this time! Has anyone found if OPM is working with this new version?
  18. I just read through all of this in the last couple days! Very nice work! A fun read and it's cool how you're "contracting" out for designs.
  19. Just checked. It's the same in my career persistent.sfs. The Original Four all have the hero trait, none of the other kerbals, even those for hire, have it. Still don't know what it's for though.
  20. @Skystorm, yep I'm asking about the "hero" flag. I know what badS and Veteran do but I don't recall ever hearing about a Hero one. Did you just make that code snippet or is Jeb's Hero really set to True? I didn't look at Jeb's in my file because he died in a plane crash a long time ago already haha. But my current hotshot pilot, Carson Kerman, has his Hero trait set to false. Just curious what it meant.
  21. A couple of quick searches in the last week or so have proven fruitless so I'll ask it here, what is the 'hero' trait for Kerbals in the persistent file? If I remember right, it wasn't there in any of the 1.2 or 1.3 versions which are the earliest I played in. Is it there because of 1.4 or because of MH? Anyone know what it's about?
  22. Yeah once I discovered Career Evolution and started watching it closely, I did the same for a few UbM tech trees. Yemo's looks like the one I'd go with, but like you said it's probably going to be a little while before Yemo or anyone gets one updated because of all the new parts added by MH.
  23. @nightingale - You would know! I wasn't expecting a reply from you. Thanks for that little tidbit. Now I just need an unmanned before manned tech tree and I'm good to go.
  24. I didn't find this mod until after 1.3 and my career was too far along to use it, so I've kept a close watch on it ever since. I'd really like to see this in action in 1.4.1. I'm not posting this to whine about when/if it'll be updated, just want the author to know there is still a demand for this mod and there's probably more like me hoping it'll get a new release.
  25. I'm not sure if I've got an issue or if I'm just missing something. I just launched my Kerbin station core, I didn't add a lab or anything, and I didn't want to launch a Mun or Minmus station because of the problems I've read about so I didn't accept those contracts. They're just sitting there waiting to be accepted. But now I've completed my contract to launch the Kerbin core and nothing is happening after that. I thought there were supposed to be contracts to add power cores and labs and all the Station Science stuff but they haven't shown up. So I looked at the list of contracts under the Bases and Stations tab in Mission Control and for like the "Add a TH-NKR lab to a station" contract it says the condition for having a station WITHOUT a lab is unmet. But it should be met. I've never launched a TH-NKR lab. Ever. Is the mod just waiting for me to launch the Mun and Minmus stations also or what?