<noname>

Members
  • Content Count

    80
  • Joined

  • Last visited

Community Reputation

30 Excellent

About <noname>

  • Rank
    Rocketry Enthusiast

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. All right, I got my wineHQ working again. Apparently, I can have no other applications running and I can not tab out of the game or I lose the mouse. Something is not set right on my wine, but anyway. I can poke through it for now. First this is KSP version 1.9.0.2781 WindowsPlayer x64, no expansions or mods, resolution is FULLSCREEN=True 1920x1080 running under wine-5.0 on Linux Mint 19. I have rx470 as video card and Mesa Vulkan graphics drivers from deb http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu bionic main. As you can see, this is a very blurry texture on that hitchhiker, even though that is a windows version running. I read through this thread : And I am now wondering if the issues seen in this thread are indeed related to the graphics drivers in use. DX9 vs DX11 vs amdgpu vs other. Maybe if the game doesn't specifically see the driver it wants, it falls back to lo-res textures. I wonder if there is a way to override the behavior if that is the case. Also, I may be able to fool the game by changing some stuff in wine - project for another time.
  2. very interesting. I'm trying to poke around some more. Right now I am confused as to why the windows version running under wine would load different textures as to the windows version on windows. When I run KSP under wime, the mouse clicks will not register most of the time. I have to close ksp, change winecfg, open ksp, close ksp change ksp settings, open ksp, close ksp, chang winecfg, on and on until the mouse clicks finally work and I can get into the vab. Anyway, the whole process is a PIA. SO, I am still trying to get screencaptures and stuff. I can without a doubt say my screencapture from the linux version is nowhere as good as your windows machine, I am jealous. So I think it is important to begin eliminating as many other variables as possible. I think our screencaptures should also come with info detailing the game version, the operating system and os version, and the resolution settings of both the game and the os and maybe the resolution of the monitor as well. For example, the above capture is from: Linux Mint 19. KSP Version 1.8.1.2694, 1.8.1 Making History, 1.3.1 Breaking Ground, KSP resolution setting 1920x1080 Fullscreen=True, os resolution = 1920x1080. Elecom Company 40" television HDMI-A-0 1920x1080. In the meantime I will try to get my mouse clicks working again in wineHQ and I also have access to 2 other machines with win10 that I will look at when I can. I suspect there is more to this bug than meets the eye.
  3. that's interesting. Could you post a screencapture of the hitchiker from inside the sph like the other two photos in this thread? Or maybe even from anywhere in game so we can compare?
  4. This looks great. It's important to have a good backstory to go along with game play. But, I am more concerned with nuts and bolts myself, I'm a tinkerer, often call myself a "poker" - I poke things and then see what happens.... I want my landing gear to stay landed - not jump around and explode, I want my wheels to work, I don't want Kerbals falling through the terrain. Please, please, make it as much a priority to have a solid foundation that works as well as the nice cool concepts and visuals.
  5. I did some poking around out of curiosity. I installed the lates vesion of wineHQ, downloaded the windows version fron the KSP store, and loaded up the Hitchhiker in the SPH and zoomed in. The texture looks the same to me. This doesn't appear to be a Linux issue, it does look to be a KSP issue.
  6. Ok, you're right. There is definitely a bug on game startup. I paid attention to the menu screen when I first loaded the game, it is definitely a low resolution texture even though the game is set to full res. So, when I noticed that it loaded a lo-res image, I immediately went into the graphics settings and checked to see what the texture quality was set at, and it showed to be Full Res. So, I think I clicked the apply button, it may have been the accept button, not sure if it matters anyway, but the game locked up for over a minute until it finally went back to the menu screen and now the high res image is there. So, I am thinking this is probably a symptom of the same texture bugs seen on the parts like the Hitchiker Container also. It will be interesting to see if this continues in 1.9. edit : I did some more experimenting. The part texture and this are not the same. It seems the higher res images for the parts like the Hitchiker are just not there to begin with. Honestly, it feels like the Linux version is released as an afterthought, with very little or no testing done at all. And you can shout about bugs at the top of your lungs and it falls on deaf ears for the most part. I'll say it again, it's probably better if we just stop using this version completely, and instead run the windows version under wine or proton. At least with wine and proton, if you complain about performance or bugs in the compatibility layers, someone will eventually try to fix it.
  7. If you mean "graphical option is not being updated in the settings.cfg file" is the same bug as you, then I would say no, I am not seeing the same bug. My settings.cfg is updating as expected. But, if you mean - am I seeing texture bugs in my game on Linux?, then yes, I am seeing texture bugs. Even though I have texture quality set to Full Res I am still seeing low res textures being used in game. Case in point is the Hitchiker Storage container like in this thread - But, as far as the loading menu screen is concerned, no. When I change my texture quality setting, the textures on the loading menu screen are changing. Texture quality set to 1/8 texture quality set to full res texture quality set back to 1/8
  8. Well, Ill repeat what I've said here before. Squad doesn't support Linux. They simply release a Linux version, then run for the hills. It may be better for us to just run the windows version under wine or proton.
  9. Ok, I poked around some more, maybe this will help. First this screenshot from when I set texture quality to 1/8. Notice TEXTURE_QUALITY = 3 in settings.cfg. Next, I changed texture quality to Full Res. The settings.cfg changed to TEXTURE_QUALITY = 0.
  10. I run rx470. I also have a blurry texture on this part. Never really noticed it was this bad before. I still haven't downloaded 1.9, so I;m not sure if it is still like this. One thing I did question is whether or not it looks this bad on Windows also. I have no easy way of verifying that, but if you download the image on the wiki, then zoom in, it looks much, much better than what it does in game on linux. https://imgur.com/3YwlhNq
  11. The launcher has never worked. I've never used the patch. Download the whole game. Make a new install.
  12. Do you use Steam? Have you tried running the game from command line?
  13. I think this might be the same bug I encountered in this thread :
  14. For me, I use the default, then just change my target to fine tune stuff. As far as the original question in the top post, why it looks like a 90 degree change and relating to n-body physics. There are 3 bodies in this problem, not 2 - the mun, Kerbin (home), and Kerbol (the sun). Depending on which frame of reference you are in, the line rendering will change. You can change the frame of reference in some scenarios by changing your target (by double clicking a body in the map view), which will change the way lines are rendered, but the outcome will be the same regardless of how the lines are rendered. The periapsis will not change unless you add or subtract thrust vector.